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Using Help

 

About online Help

 

Adobe Systems, Inc. provides complete documentation in the Adobe PDF Help system. 
The Help system includes information on all the tools, commands, and features for both 
Windows and Mac OS. The PDF format is designed for easy navigation online, and support 
for third-party screen readers compatible with Windows. The Help can also be printed as a 
desktop reference.

 

Navigating in Help

 

The Help will open in an Acrobat window with the bookmark pane open. If the bookmark 
pane is not open choose Window > Bookmarks. You can also navigate using the 
navigation bar, the index, or search the document.

At the top and bottom of each page is a navigation bar. Click Using Help to return to this 
introduction. Clicking Contents, or Index will take you to that section.

The Next Page  and the Previous Page  arrows let you move through the pages 
sequentially. Click Back to return to the last page you viewed. You can also use the 
navigation arrows in the Acrobat toolbar. 

 

Using bookmarks, the table of contents, the index, and Find

 

The contents of Help are shown as bookmarks in the bookmark pane. To view subtopics, 
click the plus sign next to a bookmark. Each bookmark is a hyperlink to the associated 
section of the Help document. 

To go to the information, click its bookmark. As the information is displayed in the 
document pane, its bookmark is highlighted.

You can turn highlighting on or off by selecting the Highlight Current Bookmark option 
from the bookmark pane menu.

 

To find a topic using the table of contents:

1

 

Click Contents in the navigation bar at the top or bottom of any page.

 

2

 

Click a topic on the Contents page to move to the first page of that topic.

 

3

 

In the bookmark pane, expand the topic to see its subtopics.

 

To find a topic using the index:

1

 

Click Index in the navigation bar at the top or bottom of any page.

 

2

 

Click the appropriate letter at the top of the page.

You can also expand the Index bookmark, and click the letter in the bookmark pane.

 

3

 

Locate your entry, and click the page number link to view the information.

 

4

 

To view multiple entries, click Back to return to the same place in the index.
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To find a topic using the Find command:

1

 

Choose Edit > Find.

 

2

 

Enter a word or a phrase in the text box, and click OK.

Acrobat will search the document, starting from the current page, and display the first 
occurrence of the word or phrase you are searching for. 

 

3

 

To find the next occurrence, choose Edit > Find Again.

 

Printing the Help file

 

Although the Help has been optimized for on-screen viewing, you can print pages you 
select, or the entire file.

To print, choose Print from the File menu, or click the printer icon in the Acrobat toolbar.
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Looking at the Work Area

 

Using the tools

 

The first time you start Illustrator, the toolbox appears on the left side of the screen. 
The tools in the toolbox let you create, select, and manipulate objects in Illustrator. 

When you select most tools, the mouse pointer matches the tool’s icon. For example, 
choosing the paintbrush tool changes the pointer to a paintbrush. You can also change a 
tool pointer to a precision pointer, such as a cross hair , for greater precision when 
aligning or working with detailed artwork. 

 

To move the toolbox:

 

Drag the toolbox by the top bar.

 

To show or hide the toolbox:

 

To show or hide the toolbox, choose Window > Tools. When the toolbox is showing, 
a check mark appears before the name.

 

To display hidden tools on-screen:

1

 

Press a tool in the toolbox that has hidden tools underneath it. (Tools that have hidden 
tools are identified by a triangle in the lower right corner.)

 

2

 

When the toolbar of hidden tools appears, hold down the mouse button and drag to 
the arrow at the end of the toolbar. The toolbar detaches from the toolbox. 

 

To close a detached toolbar:

 

Click the close box.

 

To change the pointer to a precision pointer:

 

Do one of the following:

 

•

 

While the tool is selected, press Caps Lock on the keyboard.

 

•

 

Choose Edit > Preferences > General (Windows and Mac OS 9) or Illustrator > 
Preferences > General (Mac OS X), select Use Precise Cursors, and click OK.

 

Using palettes

 

Adobe Illustrator includes a number of palettes to help you monitor and modify your 
work. By default, these palettes appear stacked together in several groups. You can also 
dock palettes so that you can move them together. 

 

Showing and hiding palettes

 

You can display and hide palettes as you work.
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To show or hide a palette:

 

Do one of the following:

 

•

 

Choose Window > (window name). A check mark appears before a window that is 
currently open.

 

•

 

Press Tab to hide or show all palettes and the toolbox.

 

•

 

Press Shift+Tab to hide or show all palettes except for the toolbox.

 

Changing the palette display

 

You can rearrange your palettes to make better use of your work area by using the 
following techniques:

 

•

 

To make a palette appear at the front of its group, click the palette’s tab.

 

•

 

To move an entire palette group, drag its title bar.

 

•

 

To rearrange or separate a palette group, drag a palette’s tab. Dragging a palette 
outside of an existing group creates a new palette window. 

 

•

 

To move a palette to another group, drag the palette’s tab to that group.

 

•

 

To dock palettes so that you can move them together, drag a palette’s tab to the bottom 
of another palette.

 

•

 

To move an entire docked palette group, drag its title bar.

 

•

 

To display a palette menu, position the pointer on the triangle  in the upper right 
corner of the palette and hold down the mouse button. 

 

•

 

To change the size of a resizable palette, drag the lower right corner of the palette 
(Windows) or drag the size box at the lower right corner of the palette (Mac OS). 

 

Note:

 

 A few palettes, such as the Color palette, cannot be resized by dragging.

 

•

 

To collapse a group to the palette titles only, click the minimize/maximize box 
(Windows) or click the zoom box (Mac OS). You can still open the palette menu from a 
collapsed palette.

 

•

 

To cycle through the available sizes for a palette—the default size, size with hidden 
options showing, size as resized by dragging, and palette titles only—double-click the 
palette’s tab.

For maximum performance, hide all palettes except those that are necessary for your 
work.
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Toolbox overview (1 of 5)

 

The selection tool 
(V)

 

 selects entire 
objects.

 

The direct-selection 
tool (A)

 

 selects 
points or path 
segments within 
objects.

 

The group-
selection tool

 

 
selects objects and 
groups within 
groups.

 

The magic wand 
tool (Y)

 

 selects 
objects of similar 
attributes.

 

The direct-select 
lasso tool (Q) 

 

selects 
points or path 
segments within 
objects.

 

The lasso tool 

 

selects entire 
objects.

 

The pen tool (P)

 

 
draws straight and 
curved lines to create 
objects. 

 

The add-anchor- 
point tool (+)

 

 adds 
anchor points to 
paths

 

. 

The delete-anchor- 
point tool (-)

 

 deletes 
anchor points from 
paths. 

 

The convert-
anchor-point tool 
(Shift+C)

 

 changes 
smooth points to 
corner points and 
vice versa. 

 

The type tool (T)

 

 
creates individual 
type and type 
containers and lets 
you enter and edit 
type. 

 

The area type tool

 

 
changes closed 
paths to type 
containers and lets 
you enter and edit 
type within them.
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Toolbox overview (2 of 5)

 

The path-type tool

 

 
changes paths to 
type paths, and lets 
you enter and edit 
type on them.

 

The vertical type 
tool 

 

creates vertical 
type and vertical 
type containers and 
lets you enter and 
edit vertical type.

 

The vertical area-
type tool 

 

changes 
closed paths to 
vertical type 
containers and lets 
you enter and edit 
type within them.

 

The vertical path-
type tool 

 

changes 
paths to vertical type 
paths and lets you 
enter and edit type 
on them.

 

The line tool (\)

 

 
draws individual 
straight line 
segments.

 

The arc tool

 

 draws 
individual concave or 
convex curve 
segments.

 

The spiral tool 

 

draws clockwise and 
counterclockwise 
spirals.

 

The grid tool

 

 draws 
rectangular grids.

 

The polar grid tool

 

 
draws circular chart 
grids.

 

The rectangle 
tool (M)

 

 draws 
squares and 
rectangles.

 

The rounded- 
rectangle tool 

 

draws squares and 
rectangles with 
rounded corners.

 

The ellipse tool (L) 

 

draws circles and 
ovals

 

.
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Toolbox overview (3 of 5)

 

The polygon tool 

 

draws regular, multi-
sided shapes.

 

The star tool 

 

draws 
stars

 

The flare tool

 

 
creates lens-flare or 
solar-flare-like 
effects.

 

The paintbrush 
tool (B) 

 

draws 
freehand and calli-
graphic lines, as well 
as art and patterns 
on paths.

 

The pencil tool (N) 

 

draws and edits 
freehand lines.

 

The smooth tool 

 

smooths bezier 
paths.

 

The erase tool 

 

erases paths and 
anchor points from 
the artwork.

 

The rotate tool (R) 

 

rotates objects 
around a fixed point.

 

The reflect tool (O) 

 

flips objects over a 
fixed axis.

 

The twist tool 

 

twirls 
objects around a 
fixed point.

 

The scale tool (S) 

 

resizes objects 
around a fixed point.

 

The shear tool

 

 
skews objects 
around a fixed point.
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The reshape tool

 

 
smooths or changes 
a path while 
retaining the path’s 
overall shape.

 

The warp tool 
(Shift+R)

 

 molds 
objects with the 
movement of the 
cursor (like molding 
clay, for example).

 

The twirl tool

 

 
creates swirling 
distortions within an 
object.

 

The pucker tool

 

 
deflates an object.

 

The bloat tool

 

 
inflates an object.

 

The scallop tool

 

 
adds many curved 
details to the outline 
of an object.

 

The crystallize tool

 

 
adds many spiked 
details to the outline 
of an object.

 

The wrinkle tool

 

 
adds wrinkle-like 
details to the outline 
of an object.

 

The free transform 
tool (E) 

 

scales, 
rotates, or skews a 
selection.

 

The symbol sprayer 
tool (Shift+S)

 

 places 
multiple symbol 
instances as a set on 
the artboard.

 

The symbol 
shifter tool

 

 
moves symbol 
instances.

 

The symbol 
scruncher tool

 

 
moves symbol 
instances away from 
each other.
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Toolbox overview (4 of 5)

 

The symbol sizer 
tool

 

 resizes symbol 
instances.

 

The symbol spinner 
tool

 

 rotates symbol 
instances.

 

The symbol stainer 
tool

 

 colorizes 
symbol instances.

 

The symbol 
screener tool

 

 
applies opacity to 
symbol instances.

 

The symbol styler 
tool

 

 applies the 
selected style to 
symbol instances.

 

The column graph 
tool (J) 

 

positions 
columns vertically.

 

The stacked column 
graph tool 

 

stacks 
columns on top of 
one another.

 

The bar graph tool 

 

positions columns 
horizontally.

 

The stacked bar 
graph tool 

 

stacks 
columns and 
positions them 
horizontally.

 

The line graph tool 

 

shows the trend of 
one or more subjects 
over time.

 

The area graph tool 

 

emphasizes totals as 
well as changes in 
values.

 

The scatter graph 
tool 

 

plots data as 
paired sets of x and y 
coordinates.
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Toolbox overview (5 of 5)

The pie graph tool 
creates a circle graph 
with wedges 
showing relative 
percentages of the 
compared values.

The radar graph 
tool uses a circle to 
compare sets of 
values at given 
points in time or in 
particular categories.

The mesh tool (U) 
creates and edits 
meshes and mesh 
envelopes.

The gradient 
tool (G) adjusts the 
beginning and 
ending points and 
angle of gradients 
within objects.

The eyedropper 
tool (I) samples color 
or type attributes 
from objects.

The paint bucket 
tool (K) fills objects 
with the current 
paint or type 
attributes.

The measure tool 
measures the 
distance between 
two points.

The blend tool (W) 
creates a blend 
between the color 
and shape of 
multiple objects.

The auto trace tool 
traces the outlines of 
objects in raster 
images.

The slice tool 
(Shift+K) creates 
Web slices.

The slice select tool 
selects Web slices.

The scissors tool (C) 
cuts paths at 
specified points.

�
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Using the Info palette
The Info palette provides information on the area beneath the pointer and on selected 
objects. Depending on the tool you’re using, you can use the Info palette to measure size, 
distance, and angle of rotation. In most cases when a tool is in use, the Info palette displays 
the x and y coordinates of the pointer’s position in the artwork by using the units of 
measurement you specify. The unit of measure is determined by the unit of measure set in 
the Document Setup or Units & Undo Preferences dialog box.

The Info palette also displays color information for the fill and stroke of selected objects, 
and the names of patterns, gradients, or tints applied to the objects.

To display the Info palette:

Choose Window > Info. The Info palette displays the following information, depending on 
the tool or command you select:

• When using a selection tool, the x and y coordinates of the pointer are displayed. If an 
object is selected, the width (W), height (H), and x, y coordinates of the object are also 
displayed.

• When using a zoom tool, the magnification factor and the x and y coordinates are 
displayed after you release the mouse button.

• When using a pen tool or gradient tool, or when you move a selection, the change in 
x (W), the change in y (H), the distance (D), and the angle  as you drag are displayed. 

• When using the scale tool, the percentage change in width (W) and height (H) and the 
new width (W) and height (H) are displayed after the scale is finished.

• When using the rotate or reflect tools, the coordinates of the object’s center and the 
angle of rotation  or reflection  are displayed.

• When using the shear tool, the coordinates of the object’s center, the angle of shear 
axis , and the amount of shear  are displayed.

• When using the paintbrush tool, the x and y coordinates and the name of the current 
brush are displayed.

The knife tool cuts 
objects and paths.

The hand tool (H) 
moves the Illustrator 
artboard within the 
illustration window.

The page tool 
adjusts the page grid 
to control where 
artwork appears on 
the printed page.

The zoom tool (Z) 
increases and 
decreases the view 
magnification in the 
illustration window.
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To show or hide options in the Info palette:

Choose Show Options or Hide Options from the Info palette menu. When you show 
options, the following information appears:

• Values for the fill and stroke colors of the selected object.

• Hexadecimal values for the fill and stroke colors of the selected object, if the color mode 
is RGB or Web safe.

• The name of any pattern, gradient, or tint applied to the selected object.

Note: If you select multiple objects, the Info palette displays only the information that is 
the same for all selected objects.

Using context menus
In addition to the menus that appear at the top of your screen, Adobe Illustrator contains a 
number of context-sensitive menus that relate to the document or the selection. You can 
use context menus as a quick way to choose commonly used commands.

To display context menus:

1 Position the pointer over the document or an object in the document.

2 Do one of the following:

• In Windows, click with the right mouse button.

• In Mac OS, press Control and hold down the mouse button.

Viewing artwork
Adobe Illustrator gives you great flexibility in viewing your artwork. You can view different 
areas of the artwork at different magnifications, use simplified views for tasks such as 
editing paths, and preview how your artwork will appear in a Web browser or in print.

If you are using Illustrator’s color management features, you can also display an online 
preview of how your document’s colors will appear on a particular type of monitor or 
output device. (See “Soft-proofing colors” on page 185.)

Setting up windows and views
You can open additional windows to display several views at once, so that you can quickly 
switch between view modes or magnifications. For example, you can set one view highly 
magnified for doing close-up work on some objects and create another view less 
magnified for laying out those objects on the page. 

To change the screen mode for illustration windows:

Click a screen mode button in the toolbox:

• The left button  displays artwork in a standard window, with a menu bar at the top and 
scroll bars on the sides. 

• The center button  displays artwork in a full-screen window with a menu bar but with 
no title bar or scroll bars.

• The right button  displays artwork in a full-screen window, but with no title bar, menu 
bar, or scroll bars.
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To open a new window: 

Choose Window > New Window. 

A new window of the same size appears on top of the previously active window. The two 
windows are identical except for their window numbers. The new window is now the 
active window.

To close windows:

Do one of the following:

• Choose File > Close to close the active window.

• Press Alt (Windows) or Option (Mac OS) and choose File > Close to close all document 
windows.

To arrange multiple windows (Windows only):

Do one of the following:

• Choose Window > Cascade to display windows stacked and cascading from the top left 
to the bottom right of the screen.

• Choose Window > Tile to display windows edge to edge.

• Choose Window > Arrange Icons to arrange minimized windows within the program 
window.

To create a view:

1 Set up the view that you want.

2 Choose View > New View.

3 Enter a name for the new view, and click OK.

The view names, along with keyboard shortcuts for choosing them, appear at the bottom 
of the View menu. To retrieve a view, select the name of the view you want to use. It is 
possible to create and store up to 25 views for each document.

To rename or delete a view:

1 Choose View > Edit Views.

2 Select the view you want to edit, and rename it or click Delete.

To scroll the view with the hand tool: 

1 Select the hand tool .

2 Move the pointer onto the artwork, and drag in the direction in which you want the 
artwork to move.

To switch to the hand tool when using another tool, hold down the spacebar.

Viewing artwork as paths
Adobe Illustrator sets the view so that all artwork is previewed in color. You can also set the 
view so that your artwork is displayed only as paths with all paint attributes hidden. 
Viewing artwork without paint attributes speeds up the time it takes to redraw the screen 
when working with complex artwork. 
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To view the artwork in color or as path outlines:

Choose a viewing option:

• Choose View > Preview to display the artwork as close as possible to how it will be 
printed, drawn with as much color, shading, and detail as your monitor is capable of 
displaying. 

• Choose View > Outline to display the artwork as paths, hiding each object’s paint 
attributes. Working in this view speeds up the redraw time when working with complex 
artwork.

Use the New Window command to preview in one window while editing in Outline 
view in another.

Viewing artwork as pixels
In Pixel Preview mode, you can preview how your artwork will appear when it is rasterized 
and viewed in a Web browser. (For more information, see “Working in pixel preview mode” 
on page 292.)

Viewing how colors will overprint
Overprint Preview mode provides an “ink preview” that approximates how blending, 
transparency, and overprinting will appear in color-separated output. (For more infor-
mation on overprinting, see “Step 2: Select overprint options for overlapping colors” on 
page 346.)

To preview how colors will overprint and blend:

Choose View > Overprint Preview.

Magnifying and reducing the view
The zoom-in and zoom-out tools and commands let you magnify or reduce the display of 
any area in the file up to 64 times actual size. Zooming in and out does not change the 
actual size of the file, only the magnification at which you see it. See “Scaling” on 
page 115.

You see the current magnification level at the top and the bottom left of the window.

To zoom in:

Do one of the following:

• Select the zoom tool . The pointer becomes a magnifying glass with a plus sign in its 
center. Click at the center of the area you want to magnify. Each click magnifies the view 
to the next preset percentage. When the file has reached its maximum magnification 
level of 6400%, the magnifying glass appears blank.

• Choose View > Zoom In. Each click magnifies the view to the next preset percentage. 
When the file has reached its maximum magnification level of 6400%, the command is 
dimmed.

• When no objects are selected, click the right mouse button (Windows) or Ctrl-click 
(Mac OS) and select the Zoom In command from the context menu.

• Enter a magnification level in the Zoom text box at the lower left of the window.

• Select a magnification level from the Zoom pop-up menu at the lower left of the 
window.
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To zoom out:

Do one of the following:

• Select the zoom tool while holding down Alt (Windows) or Option (Mac OS). The 
pointer becomes a magnifying glass with a minus sign in its center. Click the center of 
the area you want to reduce. Each click reduces the view to the previous preset 
percentage. When the file has reached its maximum reduction level of 3.13%, the 
magnifying glass appears blank.

• Choose View > Zoom Out. Each click reduces the view to the previous preset 
percentage. When the file reaches its maximum reduction level of 3.13%, the command 
is dimmed.

• When no objects are selected, click the right mouse button (Windows) or Ctrl-click 
(Mac OS) and select the Zoom Out command from the context menu.

• Enter a reduction level in the Zoom text box at the lower left of the window.

• Select a magnification level from the Zoom pop-up menu at the lower left of the 
window.

To choose the zoom-in tool while using another tool, press Ctrl+spacebar (Windows) 
or Command+spacebar (Mac OS). To choose the zoom-out tool while using another 

tool, press Ctrl+Alt+spacebar (Windows) or Command+Option+spacebar (Mac OS).

To magnify by dragging:

1 Select the zoom-in tool .

2 Drag a dotted rectangle, called a marquee, around the area you want to magnify. 
To move the marquee around the artwork, begin dragging a marquee and then hold 
down the spacebar while dragging the marquee to a new location.

To display a file at 100%:

Choose View > Actual Size, or double-click the zoom tool.

To change the view to fit the screen:

Choose View > Fit In Window, or double-click the hand tool.

Using the Navigator palette
The Navigator palette lets you quickly change the view of your artwork using a thumbnail 
display.

To display the Navigator palette:

Choose Window > Navigator.

Note: The Navigator palette may take a long time to display when the document contains 
a large quantity of artwork.

To display only artwork inside the boundaries of the Artboard:

1 Choose Window > Navigator.

2 Choose View Artboard Only from the pop-up menu in the Navigator palette. Any 
objects outside the border of the Artboard are removed from the Navigator palette 
thumbnail display. (See “Viewing artwork” on page 13.)
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To magnify or reduce the view using the Navigator palette:

Do one of the following:

• Click the zoom in or zoom out button at the bottom of the Navigator palette.

• Drag the zoom slider at the bottom of the palette.

• Enter the percentage of magnification or reduction you want in the zoom text box of 
the Navigator palette, and press Enter or Return.

• Hold down Ctrl (Windows) or Command (Mac OS), and drag over the area of the 
Navigator palette’s thumbnail that you want to magnify.

To move the view of an image using the Navigator palette:

Do one of the following:

• Drag the view box, which represents the boundaries of the illustration window.

• Click in the thumbnail of the image. The new view includes the area you click. 

To change the color of the Navigator palette view box:

1 Choose Palette Options from the Navigator palette menu.

2 Choose a color:

• To use a preset color, choose an option for Color.

• To specify a different color, double-click the color box or choose Custom, and choose a 
color.

3 Click OK.

Using the status bar
At the bottom left edge of the Illustrator window is the status bar. The status bar contains 
the Zoom pop-up menu and the Status pop-up menu. The Status menu can display infor-
mation about any of the following topics:

• The current tool in use.

• The date and time.

• The amount of virtual memory (Windows) or free RAM memory (Mac OS) available for 
your open file.

• The number of undos and redos available.

• The document color profile. For information on color profiles, see “About color 
management” on page 174.

To specify the type of information to display in the Status pop-up menu:

Select the type of information from the pop-up menu.

Previewing placed EPS images
Placing images from other applications can slow previewing and printing operations in 
Illustrator. You can improve performance by turning off the Show Transparency Interac-
tions option in the Links Palette Options dialog box.
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You can turn off previewing of placed images when you need to work quickly. You can 
then turn previewing back on when you want to view the finished art. 

To determine how placed EPS images appear:

1 Choose Edit > Preferences > Files & Clipboard.

2 Select the Use Low Resolution Proxy for Linked EPS option to view a bitmap proxy of 
the placed image. Deselect the option to view a high-resolution vector image.

To set Outline view for placed EPS images:

1 Choose File > Document Setup. Choose Artboard from the pop-up menu at the top left 
of the Document Setup dialog box. 

2 Select Show Images in Outline to specify that placed images should display a preview 
image when seen in Outline view and click OK. (See “Opening and placing artwork” on 
page 33.)

To display transparency interactions with linked images:

1 If necessary, choose Window > Links.

2 From the Links palette menu, choose Palette Options.

3 Select Show Transparency Interactions and click OK.

Using plug-in modules
Plug-in modules are software programs developed by Adobe Systems, and by other 
software developers in conjunction with Adobe Systems, to add features to Adobe 
Illustrator. A number of special effects plug-ins come with your program and are automat-
ically installed in the Plug-ins folder. 

If you change the location of the Plug-ins folder, or if you want to use a different folder as 
your plug-ins folder, you must use the Plug-ins Preferences command to tell Illustrator 
about the new location of the plug-ins.

You can also use plug-ins from Adobe Photoshop versions 3.0 to 5.5. In addition, you can 
use any commercial plug-in designed for use with Photoshop or Illustrator. 

To avoid duplicating your plug-in filters between the two programs, make a shortcut 
(Windows) or an alias (Mac OS) to your Photoshop plug-in filters in your Illustrator 

Plug-ins folder. Note that Illustrator 10.0 does not support plug-ins from Photoshop 6.0.

To specify the location of plug-in modules:

1 Do one of the following: 

• In Windows or Mac OS, choose Edit > Preferences > Plug-ins & Scratch Disks.

• In Mac OS X, choose Illustrator > Preferences > Plug-ins & Scratch Disks.

2 Click Choose and select the folder containing the plug-in modules, then click OK.

3 Quit Illustrator, and then start it again for the plug-in modules to take effect.

To install an Adobe Systems plug-in module:

If an installer is provided, use it to install the plug-in module. Otherwise, drag a copy of the 
module to the Plug-ins folder inside the Adobe Illustrator folder. 
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To install a third-party plug-in module:

Follow the installation instructions that came with the plug-in module.

Developing plug-in modules for Adobe Illustrator
The open architecture of the Adobe Illustrator program allows developers outside of 
Adobe to create features that are accessible from within Adobe Illustrator. If you are inter-
ested in creating plug-in modules compatible with Adobe Illustrator, see the Adobe 
Systems U.S. Web site at http://www.adobe.com. 

Customizing shortcuts
Illustrator provides a set of standard keyboard shortcuts for commands and tools. 
Illustrator also ships with alternative sets of keyboard shortcuts, including shortcuts for 
previous versions and for other programs.

You can switch between sets of shortcuts, change individual shortcuts within a set, and 
define your own sets of shortcuts. 

To view, manage, or print sets of keyboard shortcuts:

1 Choose Edit > Keyboard Shortcuts.

2 Choose a set of shortcuts from the Set menu at the top of the Keyboard Shortcuts 
dialog box.

3 Choose a shortcut type (Menu Commands or Tools) from the menu above the shortcut 
display.

4 Do any of the following:

• To apply the displayed set of shortcuts, click OK. 

• To delete the displayed set of shortcuts, click Delete. You can’t delete the set named 
Illustrator Factory Defaults.

• To export the displayed set of shortcuts into a text file, click Export Text. In the Save 
Keyset File dialog box, enter a file name for the current keyset that you are saving, and 
click Save. You can use this text file to print out a copy of your keyboard shortcuts.

To define new shortcuts or sets of shortcuts:

1 Choose Edit > Keyboard Shortcuts.

2 Choose a set of shortcuts from the Set menu at the top of the Keyboard Shortcuts 
dialog box.

3 Choose a shortcut type (Menu Commands or Tools) from the menu above the shortcut 
display.

4 In the Shortcut column of the scroll list, select the shortcut you want to modify (palette 
shortcuts are at the end of the scroll list).

5 Enter a new shortcut. When you begin entering changes, the name in the Set menu 
changes to [Custom].

http://www.adobe.com
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If the shortcut is already assigned to another command or tool in the set, an alert informs 
you that another command or tool has the shortcut. Click away from the selection to 
assign the shortcut to the new command or tool, and to erase the previously assigned 
shortcut. Once you have reassigned a shortcut, you can click Undo to undo the change, 
or click Go To to go to the other command or tool and assign it a new shortcut.

6 In the Symbol column, enter the symbol that will appear on the menu or tool tip for the 
command or tool. You can use any of the characters that are allowed in the Shortcut 
column.

7 When you have finished changing shortcuts and symbols, do one of the following:

• To create a new set that includes the modifications, click OK or Save, and then save the 
shortcuts as a file. Enter a name for the new set in the Name text box, and click OK. The 
new file set will appear in the pop-up menu under the new name.

• To discard all changes and exit the dialog box, click Cancel.

• To discard the last saved change without closing the dialog box, click Undo.

To clear shortcuts and symbols from a command or tool:

1 In the Keyboard Shortcuts dialog box, select the command or tool name whose 
shortcut and symbol you want to delete.

2 Click Clear. 

To delete an entire set of shortcuts:

1 Choose Edit > Keyboard Shortcuts.

2 In the Set pop-up menu, choose the shortcut set that you want to delete. 

3 Click Delete and then OK to exit the dialog box.

Setting preferences
Numerous program settings are stored in the Adobe Illustrator preference file:

• In Windows, this file is called AI Prefs. In Windows 98 and ME, it is located in the 
Windows\Application Data\Adobe\Adobe Illustrator 10 folder. In Windows NT, this file 
is located in WinNT\Profiles\user name\Application Data\Adobe Illustrator 10 folder. 
In Windows 2000 and XP it is in the Documents and Settings\username\Application 
Data\Adobe\Adobe Illustrator 10 folder.

• In Mac OS, the preferences file is called Adobe Illustrator 10.0 Prefs. In Mac OS 9.x, it is 
located in the System Folder\Preferences\Adobe Illustrator 10.0 folder. In Mac OS X, it is 
located in the Mac OS X\Users\Home\Library\Preferences\Adobe Illustrator 10 folder.

The settings stored in the preference file include display options, separation setup infor-
mation, tool options, ruler units, and options for exporting information. Most of these 
options are set in panels of the Preferences dialog box.

To find an explanation of a particular preference option or set of options, refer to the 
index.

To open the Preferences dialog box:

Choose the desired preference panel from the Edit > Preferences submenu or the 
Illustrator 10 menu (Mac OS X only).
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To switch to a different preference panel:

Choose an option from the menu at the top left of the Preferences dialog box. You can also 
click Next to display the next panel, or click Prev to display the previous panel.

Using tool tips
The tool tips feature lets you display the name of tools, or buttons and controls in palettes.

To identify a tool or control:

Position the pointer over a tool or control and pause. A tool tip appears showing the name 
and keyboard shortcut (if any) for the item.

If tool tips don’t appear, the preference for displaying them may be turned off.

To display tool tips:

1 Choose Edit > Preferences > General (Windows and Mac OS 9) or Illustrator > 
Preferences > General (Mac OS X).

2 Select Show Tool Tips, and click OK.

Note: Tool tips are not available in most dialog boxes.

Using Web resources
If you have an Internet connection, you can access additional resources for learning 
Illustrator located on the Adobe Systems home page on the World Wide Web. These 
resources are continually updated.

To access Adobe’s home page for your region:

1 Open Adobe’s U.S. home page at www.adobe.com.

2 From the Adobe worldwide menu, choose your geographical region. Adobe’s home 
page is customized for 20 different geographical regions.

Using the Illustrator product section of the Adobe Web site
The Illustrator product section of the Adobe Web site provides a central source for regis-
tered Illustrator users to access the latest Web content for Illustrator. Here you’ll find the 
following:

• Step-by-step tutorials

• Quick tips that provide fast answers to common problems

• Updates, patches, and plug-ins

• Illustrator Top Issues, containing the latest Illustrator technical support solutions

• Technical guides

• A searchable database of answers to technical questions

• Links to user forums

To use the Illustrator product section of the Adobe Web site:

1 Go to the Adobe home page and search for Illustrator.

2 Register your copy of Illustrator.

http://www.adobe.com
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3 Once you have completed the registration process, follow the link back to Illustrator.

Using Adobe Online
Adobe Online provides access to the latest tutorials, quicktips and other Web content for 
Illustrator and other Adobe products. Using Adobe Online, you can also download and 
view the current version of the Illustrator Top Issues document containing the latest 
Illustrator technical support solutions. 

When you set up an Internet connection to Adobe Online, Adobe can either notify you 
whenever new information is available through the Downloadables feature or automati-
cally download that information to your hard disk. If you choose not to use Adobe’s 
automatic download feature, you can still view and download new files whenever they are 
available using the Downloadables command in the Help menu. 

To use Adobe Online:

1 In Illustrator, choose Help > Adobe Online, or click the icon at the top of the toolbox.

Adobe Online icon

Note: You must have an Internet connection to access Adobe Online. Adobe Online will 
launch your browser using your default Internet configuration.

2 If prompted, set preferences, and then click Go Online. General preferences affect how 
Adobe Online interacts with all Adobe products installed on your system, and Application 
preferences affect how Adobe Online interacts with Illustrator. To see an explanation of 
each preference option, click Setup and follow the prompts. You also can set up an 
automatic refresh using the Update Options.

Note: You can also set Adobe Online preferences by choosing Edit > Preferences > Online 
Settings (Windows and Mac OS 9) or Illustrator > Preferences > Online Settings (Mac OS X).

To view Illustrator customer support and technical issues:

Choose Help > Top Issues. The customer support page within the Adobe Web site opens.

To view and download information:

1 In Illustrator, choose Help > Downloadables.

2 Select a View Option:

• Select Show Only New Files to view only the files that are new since the last time you 
viewed downloadable files or were notified of them.

• Select Show All Files to view all the files on Adobe’s Web site that are currently available 
for download.

3 Select Download Options:

• Select Auto Install Downloaded Components if you want Adobe to start the 
component’s installer (if available) as soon as the download is complete. You can then 
follow the prompts to install the files.
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• Select Download in Background if you want to continue working in Illustrator and other 
applications while the file downloads.

• Select Notify When Download Complete if you want Adobe to display a message when 
the files have been transferred to your computer.

4 To view a list of files, open the Downloadables folder and any other folder listed.

5 To see a description of a file, position the mouse cursor over a filename and view its 
description in the Item Description section.

6 To see the location where a file will be installed if downloaded, select a file and view its 
location in the Download Directory section. To change the location, click the Folder 
button .

7 To download a file, select it and click Download.

8 To close the Downloadables dialog box, click Done.

To view Adobe press releases and announcements:

Choose Help > Corporate News. The press and announcements page within the Adobe 
Web site opens.

To register your copy of Adobe Illustrator:

1 Choose Help > Registration.

2 Select a registration option and click Continue; then follow the prompts to register.

To open other sites within the Adobe Web site:

Choose Help > Adobe Links, and choose a link topic from the menu. The associated Web 
page opens.

Other learning resources
Other learning resources are available but are not included with your application.

Classroom in a Book Is the official training series for Adobe graphics and publishing 
software. This book is developed by experts at Adobe and published by Adobe Press. 
The Adobe Illustrator Classroom in a Book includes lessons about using Illustrator. For infor-
mation on purchasing Adobe Illustrator Classroom in a Book, visit the Adobe Web site at 
www.adobe.com, or contact your local book distributor.

Adobe Press books Adobe Press provides a variety of books for beginners and profes-
sionals alike. Topics covered include color management, commercial printing, and 
creating quality online publications in HTML and PDF. For a list of available publications, 
visit the Adobe Web site at www.adobe.com, or contact your local book distributor.

The Adobe Certified Training Provider Program Offers users, instructors, and training 
centers the opportunity to demonstrate their product proficiency and promote their 
software skills as Adobe Certified Training Providers. Certification is available for several 
different geographical regions. Visit the Adobe Solutions Network: Certified Training 
Provider Program Web site at www.adobe.com to learn how you can become certified.

http://www.adobe.com
http://www.adobe.com
http://www.adobe.com
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Customer Support
When you register your product, you may be entitled to technical support for up to 90 
days from the date of your first call. Terms may vary depending on the country of 
residence. For more information, refer to the technical support card provided with the 
Illustrator documentation.

Customer Support on Adobe Online
Adobe Online provides access to FAQs (Frequently Asked Questions) and troubleshooting 
information that provides solutions to common problems.

Additional customer support resources
Adobe Systems provides several forms of automated technical support:

• See the ReadMe and ReadMe First! files installed with the program for information that 
became available after this guide went to press.

• Explore the extensive customer support information on Adobe’s World Wide Web site 
(www.adobe.com). To access Adobe’s Web site from Illustrator, choose Help > Adobe 
Online or click the icon at the top of the toolbox. See “Using Web resources” on 
page 21.

• Read the Top Issues PDF that is available from the Help menu.

http://www.adobe.com
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Setting Up Artwork in Illustrator

About vector graphics and bitmap images
Computer graphics fall into two main categories—vector graphics and bitmap images. 
Understanding the difference between the two helps as you create, edit, and import 
artwork. 

In Illustrator the type of graphic image can have important effects on your workflow. 
For example, some file formats only support bitmap images and others only vector 
graphics. Graphic image types are particularly important when importing or exporting 
graphic images to and from Illustrator. Linked bitmap images cannot be edited in 
Illustrator. Graphic formats also affect how commands and filters can be applied to 
images; some filters in Illustrator will only work with bitmap images. 

Vector graphics
Drawing programs such as Adobe Illustrator create vector graphics, made of lines and 
curves defined by mathematical objects called vectors. Vectors describe graphics 
according to their geometric characteristics. For example, a bicycle tire in a vector graphic 
is made up of a mathematical definition of a circle drawn with a certain radius, set at a 
specific location, and filled with a specific color. You can move, resize, or change the color 
of the tire without losing the quality of the graphic. 

A vector graphic is resolution-independent—that is, it can be scaled to any size and 
printed on any output device at any resolution without losing its detail or clarity. As a 
result, vector graphics are the best choice for type (especially small type) and bold 
graphics that must retain crisp lines when scaled to various sizes—for example, logos.

Because computer monitors represent images by displaying them on a grid, both vector 
and bitmap images are displayed as pixels on-screen.

Vector graphics are good for reproducing crisp outlines, as in logos or illustrations. They can be 
printed or displayed at any resolution without losing detail.

24:1
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Bitmap images
Paint and image-editing software, such as Adobe Photoshop, generate bitmap images, 
also called raster images. The images use a grid (also known as a bitmap or raster) of small 
squares, known as pixels, to represent graphics. Each pixel in a bitmap image has a specific 
location and color value assigned to it. For example, a bicycle tire in a bitmap image is 
made up of a collection of pixels in that location, with each pixel part of a mosaic that 
gives the appearance of a tire. When working with bitmap images, you edit pixels rather 
than objects or shapes. 

Bitmap images are the most common electronic medium for continuous-tone images, 
such as photographs or images created in painting programs, because they can represent 
subtle gradations of shades and color. Bitmap images are resolution dependent—that is, 
they represent a fixed number of pixels. As a result, they can appear jagged and lose detail 
if they are scaled on-screen or if they are printed at a higher resolution than they were 
created for.

Bitmap images are good for reproducing subtle gradations of color, as in photographs. They can 
have jagged edges when printed at too large a size or displayed at too high a magnification.

About resolution in bitmap images
Resolution is the number of dots or pixels per linear unit used to reproduce artwork and 
images. Output devices display images as groups of pixels. The resolution of vector 
graphics, such as Illustrator artwork, depends on the device used to display the artwork. 
The resolution of bitmap images, such as digital photographs, depends on both the 
display device and the inherent resolution of the bitmap image.

Pixel dimensions The number of pixels along the height and width of a bitmap image. 
The display size of an image on-screen is determined by the pixel dimensions of the image 
plus the size and setting of the monitor. The file size of an image is proportional to its pixel 
dimensions.

A typical 21-inch monitor displays 1152 pixels horizontally and 870 vertically. An image 
with pixel dimensions of 1152 by 870 would fill this small screen.

Image resolution The number of pixels displayed per unit of printed length in an image, 
usually measured in pixels per inch (ppi). An image with a high resolution contains more, 
and therefore smaller, pixels than an image of the same printed dimensions with a low 
resolution. For example, a 1-inch-by-1-inch image with a resolution of 72 ppi contains a 
total of 5184 pixels (72 pixels wide x 72 pixels high = 5184). The same 1-inch-by-1-inch 
image with a resolution of 300 ppi would contain a total of 90,000 pixels. 

24:1
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Because they use more pixels to represent each unit of area, higher-resolution images 
usually reproduce more detail and subtler color transitions than lower-resolution images 
when printed. However, increasing the resolution of an image scanned or created at a 
lower resolution only spreads the original pixel information across a greater number of 
pixels and rarely improves image quality. 

To determine the image resolution to use, consider the medium of final distribution for 
the image. If you’re producing an image for online display, the image resolution only 
needs to match the typical monitor resolution (72 or 96 ppi). However, using too low a 
resolution for a printed image results in pixelation—output with large, coarse-looking 
pixels. Using too high a resolution (pixels smaller than what the output device can 
produce) increases the file size and slows the printing of the image. 

Note: The Printing & Export panel of the Document Setup dialog box lets you define the 
output resolution for vector drawings. In Illustrator, output resolution refers to the number 
of line segments the PostScript® interpreter uses to approximate a curve (it is not the same 
as image resolution). (See “Changing the path output resolution” on page 337.)

Monitor resolution The number of pixels or dots displayed per unit of length on the 
monitor, usually measured in dots per inch (dpi). Monitor resolution depends on the size 
of the monitor plus its pixel setting. A PC or Mac OS monitor can range from 60 to 133 dpi. 
Understanding monitor resolution helps explain why the display size of an image on-
screen often differs from its printed size.

Printer resolution The number of ink dots per inch (dpi) produced by an imagesetter or 
laser printer. For best results, use an image resolution that is proportional to, but not the 
same as, printer resolution. Most laser printers have output resolutions of 600 dpi to 
1200 dpi and produce good results with images from 72 ppi to 185 ppi.

High-end imagesetters can print at 1200 dpi or higher and produce good results with 
images from 200 ppi to 350 ppi.

Screen frequency The number of printer dots or halftone cells per inch used to print 
grayscale images or color separations. Also known as screen ruling or line screen, screen 
frequency is measured in lines per inch (lpi)—or lines of cells per inch in a halftone screen.

The relationship between image resolution and screen frequency determines the quality 
of detail in the printed image. To produce a halftone image of the highest quality, you 
generally use an image resolution that is from 1.5 to at most 2 times the screen frequency. 
But with some images and output devices, a lower resolution can produce good results.

Note: Some imagesetters and 600-dpi laser printers use screening technologies other than 
halftoning. If you are printing an image on a nonhalftone printer, consult your service 
provider or your printer documentation for the recommended image resolutions.

About the work area
In Adobe Illustrator, the work area occupies the entire space within the Illustrator window 
and includes more than just the printable page containing your artwork. The printable 
and non-printable areas are represented by a series of solid and dotted lines between the 
outermost edge of the window and the printable area of the page.

Imageable area The imageable area is bounded by the innermost dotted lines and 
represents the portion of the page on which the selected printer can print. Many printers 
cannot print to the edge of the paper. 
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Nonimageable area The nonimageable area is between the two sets of dotted lines 
representing any nonprintable margin of the page. 

Edge of the page The page edge is indicated by the outermost set of dotted lines.

Artboard The artboard is bounded by solid lines and represents the entire region that 
can contain printable artwork. By default, the artboard is the same size as the page, but it 
can be enlarged or reduced. The U.S. default artboard is 8.5" x 11", but it can be set as large 
as 227" x 227". You can choose to show or hide the artboard.

Scratch area The scratch area is the area outside the artboard that extends to the edge 
of the 227-inch square window. The scratch area represents a space on which you can 
create, edit, and store elements of artwork before moving them onto the artboard. 
Objects placed onto the scratch area are visible on-screen, but they do not print.

Illustrator’s work area 
A. Imageable area B. Nonimageable area C. Edge of the page D. Artboard E. Scratch area

Setting up the work area
Once you have created a document, you can then set up your work area to organize your 
work and streamline the workflow. For example, you can change the size of the artboard, 
tile your workspace, or move your page boundaries.

To open a new file:

1 Choose File > New, and then enter a name in the Name text box.

2 Select the CMYK or RGB color mode. (See “Color modes and models” on page 152.)

3 If necessary, specify a height and width for the artboard.

To create a new document without opening the New Document dialog box, press 
Ctrl+Alt+N (Windows) or Command+Option+N (Mac OS). The new, untitled 

document has the settings last used.

To open an existing file:

1 Choose File > Open.

2 Select the name of the file you want to open, and click Open. 

To close a file and quit Illustrator:

1 Choose File > Exit (Windows) or File > Quit (Mac OS). 

2 If the file has not yet been saved or named, the Save dialog box appears. To save the file, 
enter a name in the Name text box (if necessary) and then click OK.
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To show or hide the artboard:

To show the artboard, choose View > Show Artboard; to hide the artboard, choose View > 
Hide Artboard.

To change the size of the artboard:

1 Choose File > Document Setup. Then choose Artboard from the pop-up menu at the 
top left of the Document Setup dialog box.

2 Do one of the following:

• Choose a preset size from the Size pop-up menu.

• Choose Custom from the Size pop-up menu, and enter the dimensions you want in the 
text boxes, up to 227 inches by 227 inches. You can change the units in the document 
(and therefore of the artboard size) by choosing a different unit from the Edit > 
Preferences > Units & Undo dialog box (Windows and Mac OS 9) or the Illustrator > 
Preferences > Units & Undo dialog box (Mac OS X).

• Select Use Print Setup (Windows) or Use Page Setup (Mac OS) to set the size of the 
artboard to match the page size set in the Print Setup (Windows) or Page Setup 
(Mac OS) dialog box. The size of the artboard then changes anytime you choose a new 
page size in the Print/Page Setup dialog box.

3 Click OK.

Note: The artboard displays the maximum printable area but does not define the size of 
the printed page. The printable area of the page is derived from the printer driver and ppd 
of the printing device. You can only change page size settings if your printer will accept 
custom page sizes.

To change the size of the page:

Choose File > Print Setup (Windows) or File > Page Setup (Mac OS) and select a page type 
in the dialog box. 

Note: The imageable area and page size are not limitations when printing to imagesetters 
that handle large media. Imagesetters can typically print to the edge of the page. The 
page size used by an imagesetter may be larger than the page size specified in Illustrator, 
enabling you to print bleeds, for example, that run past the edge of the page.

To change the color of the page:

1 Choose File > Document Setup.

2 Select Transparency from the pop-up menu.

3 Select Simulate Paper, and then click the top color swatch and select a new color from 
the color picker.

4 Click OK.

Tiling artwork and adjusting page boundaries
The artboard’s dimensions do not necessarily match the paper sizes used by printers. As a 
result, when you print a file, the program divides the artboard into one or more rectangles 
that correspond to the page size available on your printer. Dividing the artboard to fit a 
printer’s available page size is called tiling. Tiling is also used when you set up your file to 
view and print multiple pages.
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You can also adjust the placement of the printable area of the page to control how 
artwork is printed. 

Working with tiled artwork
As you work with tiled artwork, be sure to consider how the artwork relates to the bound-
aries of the page grid and to the total dimensions of the artboard. For example, if the 
artwork is tiled onto six pages, part of the artwork will print on a separate sheet of paper 
that corresponds to page 6. If you specify printing only from pages 1 to 5, the part of the 
artwork that is on page 6 won’t print.

If you have set up the file to view and print multiple pages, the file is tiled onto pages 
numbered from left to right and from top to bottom, starting with page 1. (The first page 
is always page 1; there is no way to change the page 1 designation in Adobe Illustrator.) 
These page numbers appear on-screen for your reference only; they do not print. The 
numbers enable you to print all of the pages in the file or specify particular pages to print.

The page or set of pages is aligned with the upper left corner of the artboard by default. 
However, you can reposition pages on the artboard by using the page tool. (See “Moving 
the page boundaries” on page 31.)

To see whether the tiling format is visible on-screen:

Choose View > Show Page Tiling or View > Hide Page Tiling.

To change the page tiling options:

1 Choose File > Document Setup. Then choose Artboard from the pop-up menu at the 
top left of the Document Setup dialog box.

2 Choose from the following options:

• Single Full Page (the default) to view and print one page.

• Tile Full Pages to view and print multiple pages containing separate pieces of artwork. 
For example, you can use this option to print a two-page brochure.

To view and print multiple pages, the artboard size set in the Document Setup dialog box 
must be large enough to fit more than one full page at a time. 

Note: With the Tile Full Pages option, any artwork that extends past the imageable area of 
a given page is not printed.

• Tile Imageable Areas to view and print a single piece of artwork that is too large to fit on 
one page. For example, you could use this option to print artwork for a large poster 
onto several sheets of standard-size paper for proofing.

When you print a file by using this option, the artwork is divided among the imageable 
areas of the pages. 

3 Click OK.

Adjusting the bounding box when tiling pages 
The program may print blank pages if the artwork is tiled so that the editing bounding box 
intersects pages that do not contain any artwork. The bounding box is a border that 
defines the boundaries of your artwork, and can be used to move and transform the 
artwork. For information about editing artwork with the bounding box, see “Using the 
bounding box” on page 99.
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In the following illustration, the bounding box surrounds the artwork, not its direction 
lines. (See  “About direction lines and direction points” on page 51.)

Tile Imageable Areas; bounding box surrounds artwork

Moving the page boundaries
You can adjust the placement of the printable area of the page to control how artwork is 
printed. This is a good way to avoid having the artwork extend past the boundaries of the 
current page.

You can adjust the page from any view. You may find it easiest to choose View > Fit in 
Window so you can see all of your artwork while you adjust the pages.

To adjust a page by using the page tool: 

1 Select the page tool . The pointer becomes a dotted cross when you move it to the 
active window. 

2 Drag the page to the new location. As you drag, the page tool responds as if you were 
moving the page from its lower left corner. Two gray rectangles are displayed. The outer 
rectangle represents the page size, and the inner rectangle represents the printable area 
of a page. 

Note: You can move the page anywhere on the artboard; however, any part of a page that 
extends past the printable area boundary is not printed.

To adjust the placement of artwork by moving it in the printable area: 

1 Unlock any locked objects, and display any hidden objects. (See “Locking and hiding 
objects” on page 112, “Locking artwork” on page 225, and “Hiding or displaying artwork” 
on page 224.)

2 Click the selection tool .

3 Choose Select > All. 

Drag the artwork to the new position within the printable page boundaries.

About imported artwork
Placing artwork from other applications, such as Adobe Photoshop, into Adobe Illustrator 
is easily performed using various Adobe Illustrator commands. 
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Illustrator can import many common graphic file formats, including EPS, CorelDRAW™, 
FreeHand™, GIF, JPEG, PICT, TIFF, SVG, DXF, Adobe PDF, and PostScript Level 1. In addition to 
these common graphic file formats, Illustrator can use artwork in any file format 
supported by an Adobe Photoshop-compatible file format plug-in filter, including Kodak 
Photo CD™, PNG, and TGA.

File 
Format

Import 
Methods Considerations

AI Open Opens all Illustrator format files.

EPS Open, Place Placed files may be linked or 
embedded.

Adobe PDF Open, Place Specify which page of file you want 
to use. Placed files may be linked or 
embedded.

Photoshop Open, Place Supports Photoshop 2.5 and later. 
Placed files may be linked or embed-
ded. Drag and drop artwork directly 
from Photoshop.

SVG/SVGZ Open, Place Illustrator does not support all types 
of SVG data; therefore, some data 
may be modified during import. For 
example, primitives are flattened to 
paths, transformations become 
transformed paths, and paths with 
multiple attributes are converted to 
multiple objects. 

PICT Open, Place Placed files may be linked or 
embedded.

WMF/EMF Open, Place Placed files will be embedded. Drag 
and drop artwork directly from 
Microsoft Office.

DXF/DWG Open, Place Supports DXF releases 13, 14, and 
2000. Placed files will be embedded.

FreeHand Open, Place Supports FreeHand versions 4.0, 5.0, 
5.5, 7.0, 8.0, and 9.0 (Japanese ver-
sion supported to version 5.5). 
Placed files will be embedded.

CorelDRAW Open, Place Supports CorelDRAW versions 5.0, 
6.0, 7.0, 8.0, 9.0, and 10.0 of 
Windows; and versions 5.0, 6.0, 7.0, 
and 8.0 of Mac OS. Placed files will be 
embedded.

CGM Open, Place Supports CGM versions 1, 2, and 3. 
Placed files will be embedded.
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Opening and placing artwork
You can use the Clipboard and drag-and-drop importing to bring images into Illustrator. 
(See “Moving, copying, and deleting objects” on page 102.) However, two commands are 
most commonly used when importing artwork created by other applications:

• The Open command opens a file created by another application as a new Adobe 
Illustrator file.

• The Place command places an image in an existing Illustrator file in one of two ways. 
Depending on the file format, the Place command creates a link to an external file by 
default and does not include a copy of the file in the Illustrator file. You can also 
deselect the Link option in the Place dialog box, which embeds (includes) a copy of the 
file in the Illustrator file. 

Your document’s color mode (CMYK or RGB) does not change when you place a file that 
uses a different color mode. Colors in the imported file convert to the document’s color 
mode when you export or print the file.

Note: Adobe Illustrator does not color-manage imported grayscale images. If you import 
a grayscale image that had a color profile in Adobe Photoshop, for example, the profile is 
discarded when the image is imported into Illustrator.

Opening files 
When you open a file created by another application, it becomes a new Adobe Illustrator 
file. Vector artwork in the file you open is converted to Illustrator paths, which can be 
modified using any Illustrator tool; bitmap images can be modified using transformation 
tools, such as scale and rotate, and using image filters from the Illustrator Filter menu. 
(See “About vector graphics and bitmap images” on page 25.) For information about 
opening shared files from a server, see “Managing files with WebDAV” on page 41.

Files that have been saved in Portable Document Format (PDF) can be opened as Adobe 
Illustrator documents, without losing the ability to edit artwork with Illustrator tools and 
commands. Artwork stored in PDF format can also be placed into Illustrator files, as 
described in “Importing EPS and PDF files into Illustrator” on page 36.

All raster for-
mats supported 
by Photoshop-
compatible 
filters

Open, Place Supports the following formats: 
Amiga IFF, BMP, Filmstrip, GIF 89a, 
Kodak Photo CD, JPEG, PCX, Pixar, 
PNG, TIFF, and TGA.

Text formats Open, Place Supports the following formats: 
plain text, MS RTF, MS Word 97, 98, 
and 2000. Vertical Japanese text in 
RTF and Word files will be imported 
as horizontal text. Placed files will be 
embedded.

File 
Format

Import 
Methods Considerations
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To open a file created by another application:

1 Choose File > Open.

2 Locate and select the file you want to open. If you don’t see the name of the file you 
want, the file is stored in a format that Illustrator can’t read. See “About imported artwork” 
on page 31 for a complete list of all the file formats you can open.

3 Click Open. 

Note: If you open an EPS file that contains fonts not installed on your system, font substi-
tution will occur when you open and print.

To open a file that has recently been used:

Choose File > Open Recent Files, and select the filename from the list.

Opening Photoshop files in Illustrator
When opening a Photoshop file in Illustrator, you can preserve masks, blending modes, 
and transparency, and convert layers to separate Illustrator objects. When exporting an 
Illustrator file to Photoshop format, you can preserve layers, opacity masks, transparency 
(including blending modes), slices, image maps, compound shapes, and editable type. 
(See “Exporting artwork in Photoshop format” on page 326.)

Illustrator does not support some Photoshop features such as adjustment layers and layer 
effects. To maintain the effects in Illustrator, select Convert Photoshop Layers to Objects in 
the Photoshop Import dialog box, or flatten individual layers in Photoshop to embed the 
effects before importing the file into Illustrator.

Layer mask in Photoshop (top) converts to opacity mask in Illustrator (bottom), with preserved 
blending mode and transparency.

To open a file created by Photoshop:

1 Choose File > Open.

2 Locate and select a Photoshop file, and click Open.

3 In the Photoshop Import dialog box, choose a method to import Photoshop layers to 
Illustrator:

• Select the Convert Photoshop Layers to Objects option to create a single layer in 
Illustrator containing objects that correspond to each Photoshop layer or clipping path 
(Illustrator only imports one clipping path per Photoshop file). If the Photoshop 
document contains layer sets, you can create corresponding sublayers. Any opacity 
masks that were applied to the Photoshop layers appear in the Transparency palette 
when you select the corresponding objects or sublayers. 
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When you use the Convert Photoshop Layers to Objects option, Illustrator uses an 
automatic selective merging (of layers) feature to maintain appearance. If you don’t 
require access to layers and objects, you can choose the Flatten Photoshop Layers to a 
Single Image option instead. 

• Select the Flatten Photoshop Layers to a Single Image option to flatten all Photoshop 
layers into a single image, and place the image on Layer 1 in the Illustrator file. The 
converted file retains clipping paths but no individual objects. Transparency is retained 
as part of the main image, but is not editable. 

4 If you want to import image maps or slices that are included in the Photoshop file, 
select Import Image Maps or Import Slices.

5 Click OK.

Placing files
The Place command places files from other applications into Illustrator. Files can be 
embedded, or included in, the Illustrator file, or they can be linked to the Illustrator file. 
Linked files remain independent of the Illustrator file, resulting in a smaller Illustrator file. 
Depending on a preference you set for updating links, the linked image in the Illustrator 
file may change when the artwork in the linked file changes.

By default, the Link option is selected in the Place dialog box. If you deselect the Link 
option, the artwork is embedded in the Adobe Illustrator file, resulting in a larger 
Illustrator file. The Links palette lets you identify, select, monitor, and update objects in the 
Illustrator artwork that are linked to external files. (See “Managing linked and embedded 
images” on page 37.)

Placed bitmap images can be modified using transformation tools and image filters; 
placed vector artwork is converted to Illustrator paths (embedded images only).

If you place a Photoshop file and deselect the Link option, the Photoshop Import dialog 
box appears. For information on options in the Photoshop Import dialog box, 
see “Opening Photoshop files in Illustrator” on page 34. 

Note: Do not place EPS files containing mesh objects or transparency objects if it was 
created in an application other than Illustrator. Instead, open the EPS file, copy all objects 
and then paste in Illustrator.

To place and link files created by other applications:

1 Open the Illustrator file into which you want to place the artwork.

2 Choose File > Place.

3 Locate and select the file you want to place. If you don’t see the name of the file you 
want, the file has been saved in a format that Illustrator cannot read. 

4 Do one of the following: 

• To create a link between the artwork file and the Illustrator file, make sure the Link 
option is selected in the Place dialog box. 

• To embed the artwork in the file deselect the Link option in the Place dialog box. 

• To create a template layer using the file, select Template.

• To replace an existing placed file, select Replace. (This option is only available if you 
select the file to be replaced before choosing File > Place.)
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5 Click Place. The artwork is placed into the Illustrator file as either a linked or an 
embedded image, depending on the option you selected in the Place dialog box. 

Importing EPS and PDF files into Illustrator
You can use Adobe Illustrator to edit artwork that was imported as Encapsulated 
PostScript (EPS) and Adobe Portable Document Format (PDF) file types.

You can import PDF and EPS files using these commands:

• The Open command to open a PDF or EPS file as a new Illustrator file.

• The Place command to place a PDF or EPS file in the current layer in an existing 
Illustrator file. 

Important: To place an EPS image containing a mesh object as an embedded file (that is, 
the Link option is deselected in the Place dialog box), the file should be saved as an EPS 
Level 1 PostScript file.

To open a PDF or EPS file as a new Adobe Illustrator file:

1 Choose File > Open. 

2 Select the file you want to open, and click Open. If the file does not appear, for Files of 
Type, choose All Formats (Windows) or Show All Documents (Mac OS).

To place PDF or EPS artwork into an Adobe Illustrator file:

1 Open the Adobe Illustrator file into which you want to place the artwork.

2 Choose File > Place, select the file you want to place, and click Place.

Placing EPS or PDF files in Illustrator with the Link option selected in the Place dialog box 
does not allow you to modify the linked object within the Illustrator file. To convert the 
elements in an EPS or PDF file to Illustrator objects that can be modified, deselect the Link 
option in the Place dialog box. Deselecting the Link option when you place the EPS or PDF 
file embeds the file and lets you edit each part of the artwork as a discrete object. 
(See “Editing artwork contained in linked files” on page 41.)

3 If you are placing a page from a PDF file that contains multiple pages, select the page 
you want to place, and click OK. 

4 Adjust the placed artwork as needed.

Important: If you import an EPS color that has the same name as a color in your 
document but with a different definition, Illustrator displays an alert. Choose Use Linked 
file’s color to replace the color in your document with the EPS color in the linked file. All 
objects using this color in your document will get updated appropriately. Choose Use 
document’s color to leave the swatch as is and resolve all color conflicts using the 
document’s color. The EPS preview cannot be changed, so the preview may be incorrect, 
but it will print to the correct plates. Checking “Apply to All” will resolve all color conflicts, 
using the definition either of the document or the linked file, depending on which option 
you choose.
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Turning preview images on or off
If a placed file with the Link option selected was not saved with a preview image in the 
application that created it, it will not be visible in Adobe Illustrator when it is placed. 
Instead, an outlined box containing two diagonal lines appears and defines the artwork’s 
dimensions. The box is placed into the center of the active window, in front of all other 
artwork in the file, and is selected. 

If a placed file was saved with a preview image in the application that created it, you can 
see it in Preview view, and you can choose to display a preview image in Outline view. 

To turn on and off the display of preview images in Outline view:

1 Choose File > Document Setup. Then choose Artboard from the pop-up menu at the 
top left of the Document Setup dialog box.

2 Click Show Images in Outline, and then click OK.

Note: Placed images with the appropriate resource always display in Preview view, 
regardless of the Show Images in Outline setting.

Managing linked and embedded images
The Links palette lets you identify, select, monitor, and update, and replace images that are 
linked to external files, or images that are embedded in the Illustrator file. In addition, you 
can determine if an image’s link to an external file is broken or missing, get information 
about linked or embedded image characteristics, and open a linked image’s original file 
and application to edit the image.

If you are color-managing artwork in a document, embedded EPS images are part of the 
document and therefore color-managed when sent to a printing device. In contrast, linked 
images are not color-managed, even if color management is turned on for the rest of the 
document. (See “About color management” on page 174.)

Important: Occasionally you may encounter a warning when printing an Illustrator 
document containing embedded EPS images. If the application cannot find the original 
EPS image, you will be prompted to extract the EPS image. Select the Extract option in the 
dialog box; the image will be extracted into the same directory as the current document. 
Although the embedded file does not preview in the document, the file will now print 
correctly. 

Specifying how to update links
You can set a preference to specify how to update linked images when the original files 
change.

To specify how to update links:

1 Choose Edit > Preferences > Files & Clipboard (Windows and Mac OS 9) or Illustrator > 
Preferences > Files & Clipboard (Mac OS X).

2 Choose an update method from the Update Links pop-up menu:

• Automatically to have Illustrator update linked images automatically when the original 
files are modified.
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• Manually to leave linked images unchanged when the original files are modified. 
You can use the Links palette to identify linked images whose originals have been 
modified and to update these images. (See “Using the Links palette” on page 38.)

• Ask When Modified to display a dialog box when the original files are modified. In the 
dialog box, click Yes to update the linked image or click No to leave it unchanged. 

Specifying how proxies display
By default, Illustrator displays proxies in full resolution, with vectors in full color. However, 
if you want to increase performance when you’re working with many linked files, you can 
turn off this option in the Preferences dialog box. 

To turn off high resolution proxy display:

1 Choose Edit > Preferences > Files & Clipboard (Windows and Mac OS 9) or Illustrator > 
Preferences > Files & Clipboard (Mac OS X).

2 Select Use Low Resolution Proxy for Linked EPS.

Using the Links palette
All linked or embedded images in the file are listed in the Links palette. Linked images 
whose originals have been modified since the image was placed (and which have not 
been updated) are identified with an exclamation point icon ; linked images whose 
original files are missing are identified with a stop sign icon . 

You can use the Links palette to quickly convert linked images into embedded images, 
using the Embed Image command. 

To display the Links palette:

Choose Window > Links. Each linked or embedded image is identified by name and by a 
thumbnail display. 

To select one or more links:

Choose from the following options:

• Click a link to select it.

• Shift-click to select a continuous range of links.

• Ctrl-click (Windows) or Command-click (Mac OS) to select a noncontinuous range 
of links.

• Ctrl+Alt (Windows) or Command+Option (Mac OS) and then click in the palette 
window to select a link by typing its name.

To display link information:

Do one of the following:

• Double-click a link to bring up the Link Information dialog box.

• Select a link, and choose Information from the Links palette menu.

To go to a linked object and select it:

1 Select a link in the Links palette.

2 Choose one of the following:

• Click the Go to Link button  at the bottom of the palette.
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• Choose Go to Link from the Links palette menu.

The link is displayed, and the linked image is selected.

To update a link with the most recent data from the linked file:

1 Select one or more links in the Links palette.

2 Choose one of the following to refresh the link with the most current version of the 
original file:

• Click the Update Link button  at the bottom of the palette.

• Choose Update Link from the Links palette menu.

You can set a preference to automatically update links. See “Specifying how to update 
links” on page 37.

To change a linked image into an embedded image:

1 Select a linked image in the Links palette.

2 Choose Embed Image from the Links palette menu.

Replacing linked images
You use the Links palette to replace a linked image with another linked image. By default, 
the new image adopts the size, placement, and transformation status of the original linked 
image. Using the Placement Options dialog box, you can change the placement options 
for any link you place or replace. For example, you can specify that the new image resets 
the original image’s bounding box so that the new image’s shape and alignment are not 
altered. 

To replace a link with a new linked image:

1 Select a link in the Links palette.

2 Choose one of the following:

• Click the Replace Link button  at the bottom of the palette.

• Choose Replace from the Links palette menu.

3 Select the file to replace the linked image in the Place dialog box, and click OK. The new 
image retains the size, placement, and transformation characteristics of the image that it 
replaced. 

To change the placement of the linked image:

1 Choose Placement Options from the Links palette menu.

2 Choose one of the following from the Preserve pop-up menu:

• Transforms resizes the bounding box for the new image upon placement, while 
preserving transformations. 

• Proportions (Fit) uniformly scales the image to fit in the bounding box. This option 
preserves the aspect ratio of the image, filling the bounding box in one direction, but 
possibly not the other.

• Proportions (Fill) uniformly scales the image to fill the bounding box. This option 
preserves the aspect ratio and may cause the image to overlap the bounding box in 
one direction.
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• File Dimensions places the image without scaling. The image may fit within the 
bounding box or overlap it.

• Bounds resizes the image to fit in the bounding box; in most cases the image will be 
stretched.

3 Select a point on the Alignment icon from where you want to align the image, relative 
to the bounding box.

4 If you want to keep the image from overlapping the bounding box, select Clip to 
Bounding Box. This option is not available for all Methods.

Modifying the Links palette display
You can change the way that links are displayed in the Links palette using commands in 
the Links palette menu. 

The palette can display icons of the links, or show different sized thumbnail images of the 
links. In addition, you can sort the display to show only those links that have missing or 
broken links with the original file, or those links that have been modified since the last 
update. 

To change the links display icons or thumbnails:

1 Choose Palette Options from the Links palette menu.

2 In the Palette Options dialog box, select the type of icon or thumbnail you want 
displayed.

3 Select Show Transparency Interactions if you want to view the interaction of trans-
parent objects with solid objects.

Note: Selecting the Show Transparency Interactions option may slow performance.

To sort the links display by name, kind, or status:

1 Select all or some of the links to sort in the Links palette.

2 Choose one of the following from the Links palette menu to customize the links display 
by sorting:

• Sort by Name to alphabetize the links display.

• Sort by Kind to sort the display according to the type of file (for example, all JPEG files, 
all GIF files, all EPS files, and so on).

• Sort by Status to sort the display according to the linked or embedded status. 
Embedded images are listed first, followed by linked images.

To display links according to link type:

Choose one of the following from the Links palette menu:

• Show All to display all links in the file.

• Show Missing to display only links with missing or broken connections with the original 
file.

• Show Modified to display only links that have been changed after the last time the link 
was updated. 

• Show Embedded to display only embedded images.
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Editing artwork contained in linked files
When you make changes to a linked image using the application that created it, the 
changes are applied to the Illustrator file when the link is updated. (See “Specifying how to 
update links” on page 37.)

Note that if you replace a linked image with another image, any transformation attributes 
applied to it, such as scaling, rotating, or shearing, are retained and applied to the new 
image.

To edit a linked object from within the original file:

Do one of the following:

• Select the linked object, and choose Edit > Edit Original.

• Select a link in the Links palette display, and click the Edit Original button  at the 
bottom of the palette.

• Select a link in the Links palette display, and choose Edit Original from the Links 
palette menu.

Managing files with WebDAV
Illustrator supports the Web Distributed Authoring and Versioning (WebDAV) server 
technology. Using this technology, you can connect to a WebDAV server, download and 
upload files, lock files so others cannot work on them at the same time as you, and add 
(upload) additional files (called assets) to the server. Use a WebDAV server to work in a 
collaborative environment without fear that files will be accidentally overwritten or 
updates lost.

About workgroup management
When working in a collaborative environment, users must share files. The process of 
passing files from one collaborator to another involves working with a workgroup. 
Controlling the hand-off—so that only one person can edit a file at any given time—
is called workgroup management. 

A WebDAV server provides workgroup management via the Web. When a file is managed 
by a WebDAV server, multiple users can download copies of the file, but only one user at a 
time can check out the file. The user who checks out the file can share his or her work with 
other users by updating the file on the server; however, other users can’t make changes to 
the managed file until it is checked in. This check out/check in system allows multiple 
users to access the same file but prevents users from overwriting each other’s work. 

Getting started with workgroup management
To use the workgroup management features in Illustrator, you must be able to connect to 
a WebDAV server. You can find detailed information and the latest news about WebDAV at 
www.webdav.org.

Important: Firewall software can interfere with the process of connecting to a WebDAV 
server. Check with your system administrator or refer to your firewall software documen-
tation for information about setting options to access outside servers.

http://www.webdav.org
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Different WebDAV servers have different authentication requirements. Some servers 
require you to enter a user name and password for every transaction; other servers require 
authentication only the first time you check out a managed file. When the Authentication 
dialog box appears, enter your user name and password, and click OK.

When adding a new server to the workgroup, you will need to provide a unique server 
nickname (this will appear in the Workgroup Servers list) and a URL for the server.

To set up a server for use with Illustrator:

1 Choose File > Manage Workgroup > Workgroup Servers.

2 Specify a folder in which you want to store local copies of managed files. To change the 
default location, click Choose, and specify a different folder.

Note: The path you choose here is used for all servers you want to add. Changing this path 
does not change the location of files on existing servers. 

3 Specify the WebDAV servers you want to use, or do one of the following:

• To add a new server to the list, click New Server, specify a server nickname and URL, and 
click OK.

• To remove a server from the list, click Remove, and then click OK to the warning 
message.

4 Click OK, or click Advanced Options to specify additional information about the server.

5 In the Advanced Options dialog box, select Use a Custom Workgroup Files Location for 
This Server to set up a custom workgroup file repository for this collection of files; then 
click Choose or Select and specify a folder.

Note: This option is only available for adding a new server, not for existing servers. 

6 To specify additional URLs by which you can access this server, type the alternate URL 
under Alternate Server URLs for This Server, and click Add. Currently, Illustrator stores the 
URL information, but does not use it to locate files.

7 To remove previously entered alternate URLs, select the URL and click Remove.

8 Click OK.

Opening managed files
To view a managed file, open a copy of the file from a WebDAV server. The File > Manage 
Workgroup > Open command creates a local copy of the file on your hard drive.

After you have a local copy of a file, you can update it with changes from the managed file 
on the server by using the Revert command (for checked out files), the Update command 
(for non-checked out files), or by setting an automatic update option in the Workgroup 
preferences (see “Setting preferences for managed files” on page 45).

To open a managed file:

1 Choose File > Manage Workgroup > Open.

2 Select a server, a directory, and the file you want to open.

3 Do one of the following:

• Click Check Out if you want to open and check out at the same time. (See “Checking 
files out and in” on page 43.)

• Click Open if you want to open a local copy without checking it out.
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To update or revert a local file to the version on the server:

1 Open your local copy of the file.

2 Do one of the following:

• If the file is checked out, choose File > Manage Workgroup > Revert.

• If the file is not checked out, choose File > Manage Workgroup > Update.

Checking files out and in
Checking out a file prevents other users from making changes to it on the WebDAV server. 
When you’re finished making edits, check in the file to update your changes to the server 
and release your lock on the managed file. 

You can save changes to managed files that you have checked out. To save changes to 
managed files that you have not checked out, use the Save As command and add that 
new file to the workgroup server.

To check out a file:

Do one of the following:

• To check out the file that you already have open, choose File > Manage Workgroup > 
Check Out.

• To open and check out a file at the same time, choose File > Manage Workgroup > 
Open. Then, locate and select the file and click Check Out. (See “Opening managed 
files” on page 42.)

To check in a file:

Do one of the following:

• To check in the file and update changes to the server, choose File > Manage 
Workgroup > Check In.

• To check in the file without updating changes to the server, choose File > Manage 
Workgroup > Cancel Check Out.

Placing managed files
Use the File > Manage Workgroup > Place command to place a single, managed 
document as a link in a checked out managed file. You can place documents from the 
current workgroup server only. To manage links for managed files, see “Managing links on 
a WebDAV server” on page 43.

To place a managed file:

1 Make sure you are connected to the network and have access to the managed server.

2 Open the checked out version of a managed file. 

3 Choose File > Manage Workgroup > Place; then select a file, and click Open. 

Managing links on a WebDAV server
The Links palette contains information on both local (located on your hard disk) and 
managed links (located on a server). 
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When you upload a local file to a managed server, you must also upload any linked files 
that it references. If you do not save the links to the same server, others who open the file 
will not have access to the links. 

Important: To work with managed links, you must first connect to the network and set up 
your workgroup server. (See “Getting started with workgroup management” on page 41.)

To save links to a WebDAV server: 

1 Select the link in the Links palette.

2 Choose Save Workgroup Link As from the Links palette menu. The links are saved to the 
same server as the file in which they are placed.

To update or revert managed links to the latest version on the server:

1 Select the link in the Links palette.

2 Choose Update Link from the Links palette menu.

To determine if the local copy of a link matches the server version: 

1 Select the link in the Links palette.

2 Choose Verify Workgroup Link from the Links palette menu. One of the following icons 
appears next to the link in the Links palette:

•  The local copy of the managed, linked file matches the version on the server.

•  The local copy of the managed, linked file does not match the version on the server.

•  Cannot find a local copy of the managed file.

Uploading changes to the server
While you have a file checked out, you can upload changes to the managed file on the 
server. This allows you to share your work with other users without giving up your lock on 
the file.

To upload changes to the server:

1 Open your local copy of the file.

2 Choose File > Manage Workgroup > Upload to Server.

Adding files to the server
Adding a file to a WebDAV server initiates workgroup management for the file; in other 
words, you create a managed file by adding it to a server. You can add files to a server 
using the File > Manage Workgroup > Save or Save As commands. The Save command 
adds to the server a managed file that has been altered; the Save As command adds a 
previously unmanaged file to the server. 

To add a file to a WebDAV server:

1 Open the file you want to add to the server.

2 Do one of the following:

• To add a managed, but currently checked out file to the server, choose File > Manage 
Workgroup > Save.

• To add a file to a managed workgroup, choose File > Manage Workgroup > Save As.
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3 Choose a server from the pop-up menu; then locate the directory to which you want to 
save the file. 

4 Type in a file name in the Name text box, and choose a format from the Format pop-up 
menu.

Note: Be sure to specify a file extension if the file will be downloaded to a computer 
running a Windows operating system.

5 To check out the file, select Keep This File Checked Out for Editing.

6 Click Save.

Setting preferences for managed files
You can set preferences for opening managed files, including how they are checked out, 
how they are updated, and how links are updated. You can also set preferences for placing 
managed links. 

To set preferences for opening managed files:

1 Choose Edit > Preferences > Workgroup (Windows and Mac OS 9) or Illustrator > 
Preferences > Workgroup (Mac OS X).

2 Select one of the following options for Check Out from Server:

• Ask to display a dialog box when you open a file that is not checked out.

• Never to open the local copy of the file without displaying a dialog box and without 
checking it out.

• Always to automatically check out the file when you open it.

3 Select one of the following options for Update from Server, and click OK: 

• Ask to display a dialog box asking if you want to download the latest version.

• Never to open the local copy of the file without displaying a dialog box and without 
downloading the latest version of the file from the server.

• Always to automatically download the latest version of the file from the server.

4 Select one of the following options for Update Links from Server:

• Ask to display a dialog box asking if you want to download the latest versions of the 
linked files.

• Never to open the local copy of the file without displaying a dialog box and without 
updating links.

• Always to automatically update links when you open a file.

• Verify Only to check if links are broken or not the current version, and if so, display icons 
next to the broken links in the Links palette.

To set preferences for placing managed links:

1 Choose Edit > Preferences > Workgroup (Windows and Mac OS 9) or Illustrator > 
Preferences > Workgroup (Mac OS X).

2 Select one of the following options for Update Links from Server:

• Always to automatically update links when you place a file.

• Ask to display a dialog box when you place a file that contains links.
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• Never to place the local copy of the file without displaying a dialog box and without 
updating links.

To turn off workgroup functionality for this copy of Adobe Illustrator:

Choose Edit > Preferences > Workgroup (Windows and Mac OS 9) or Illustrator > 
Preferences > Workgroup (Mac OS X), and deselect Enable Workgroup Functionality.

Adding metadata to documents
Metadata, or file information, is descriptive information that can be searched and 
processed by a computer. Use it to provide information about the contents of a document 
and to preserve information about a document that will be opened in other Adobe 
applications.

You can add metadata to AI, PDF, or SVG file formats.

To add metadata to a document:

1 Choose File > File Info.

2 Select a category from the list on the left side of the dialog box, enter the desired 
information, and click OK. 

• General specifies information about the document, such as title, author, and 
description. To specify copyright information, select Yes from the Copyrighted pop-up 
menu. Then enter the copyright notice string and the URL of the person or company 
who owns the copyright. 

• Keywords specifies words that can be used to search for the document. To add a word 
to the list, enter text in the Keyword text box and click Add. To edit or replace a word in 
the list, select the word, change the text in the Keyword text box, and click 
Replace.To delete a word from the list, select the word and click Delete.

• Summary specifies status information for the document, including its creation data, 
modification data, and location. If the document is a managed file, the server location 
and checkout status also appears. You cannot edit Summary metadata.
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Drawing

About paths
A path is made up of one or more straight or curved segments. The beginning and end of 
each segment is marked by anchor points, which work like pins holding wire in place. 
You change the shape of a path by editing its anchor points. You can control curves by 
dragging the direction points at the end of direction lines that appear at anchor points.

A path is either open, like an arc, or closed, like a circle. For an open path, the starting and 
ending anchor points for the path are called endpoints. 

Components of a path 
A. Selected (solid) endpoint B. Selected anchor point  C. Curved path segment D. Direction 
line E. Direction point

Paths can have two kinds of anchor points—corner points and smooth points. At a corner 
point, a path abruptly changes direction. At a smooth point, path segments are connected 
as a continuous curve. You can draw a path using any combination of corner and smooth 
points. If you draw the wrong kind of point, you can always change it.

Points on a path 
A. Four corner points B. Four smooth points C. Combination of corner and smooth points

A

B

C

D

E

A B C
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A corner point can connect any two straight or curved segments, while a smooth point 
always connects two curved segments.

A corner point can connect both straight segments and curved segments.

Changing a tool pointer
You can change the appearance of the pointer from the tool pointer to a cross hair for 
more precise control. When the pointer is a cross hair, more of your artwork is visible. 
This is convenient when you’re doing detailed drawing and editing.

To make a drawing tool pointer appear as a cross hair:

Do one of the following:

• Choose Edit > Preferences > General (Windows and Mac OS 9) or Illustrator > 
Preferences > General (Mac OS X). Select Use Precise Cursors, and click OK. 

• Press Caps Lock before you begin drawing with the tool.

Drawing and editing freeform paths
When you want to draw and edit freeform paths, use the pencil tool. You can also smooth 
out and erase segments of a freeform path with the smooth tool and erase tool.

Anchor points are set down as you draw with the pencil tool; you do not determine where 
they are positioned. However, you can adjust them once the path is complete. The number 
of anchor points set down is determined by the length and complexity of the path and by 
the tolerance values set in the Pencil Tool Preferences or Smooth Tool Preferences dialog 
box for either tool. 

Drawing and editing with the pencil tool
The pencil tool lets you draw open and closed paths as if you were drawing with a pencil 
on paper. It is most useful for fast sketching or creating a hand-drawn look. Once you draw 
a path, you can immediately change it if needed.

Note: You can use these same methods to draw and edit brushed paths with the paint-
brush tool.

To draw a freeform path with the pencil tool: 

1 Select the pencil tool . 

2 Position the pointer where you want the path to begin, and drag to draw a path. 
The pencil tool displays a small x to indicate drawing a freeform path.

As you drag, a dotted line follows the pointer. Anchor points appear at both ends of the 
path and at various points along it. The path takes on the current paint attributes, and the 
path remains selected by default.
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3 To continue the existing freeform path, make sure the path is selected, and then 
position the pencil tip on an endpoint of the path and drag.

To draw a closed path with the pencil tool:

1 Select the pencil tool. 

2 Position the pointer where you want the path to begin, and start dragging to draw 
a path.

3 As you drag, hold down Alt (Windows) or Option (Mac OS). The pencil tool displays with 
stripes to indicate drawing a closed path.

4 When the path is the size and shape you want, release the mouse button (but not the 
Alt or Option key). After the path closes, release the Alt or Option key.

To connect a new path to an existing path:

Select both paths; then Ctrl-drag (Windows) or Command-drag (Mac OS) from the current 
path onto the endpoint of the other path.

To change a path with the pencil tool:

1 If the path you want to change is not selected, select it with the selection tool . Or 
Ctrl-click (Windows) or Command-click (Mac OS) the path to select it.

2 Position the pencil tool on or near the path to redraw, and drag the tool until the path is 
the desired shape.

Using the pencil tool to edit a closed shape

Note: Depending on where you begin to redraw the path and in which direction you drag, 
you may get unexpected results. For example, you may unintentionally change a closed 
path to an open path, change an open path to a closed path, or lose a portion of a shape.

Smoothing the path with the smooth tool
The smooth tool lets you smooth out an existing stroke or section of a path. The smooth 
tool retains the original shape of the path as much as possible. 

To use the smooth tool:

1 If the path to smooth is not selected, select it with the selection tool . Or Ctrl-click 
(Windows) or Command-click (Mac OS) the path to select it.

2 Do one of the following:

• Select the smooth tool .

• When the pencil or paintbrush tool is selected, hold down Alt (Windows) or Option 
(Mac OS) to change the pencil to the smooth tool.

3 Drag the tool along the length of the path segment you want to smooth out. 
The modified stroke or path may have fewer anchor points than the original.
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4 Continue smoothing until the stroke or path is the desired smoothness.

Erasing the path with the erase tool
The erase tool lets you remove a portion of an existing path or stroke. You can use the 
erase tool on paths (including brushed paths), but not on text or meshes. 

To use the erase tool:

1 Select the erase tool .

2 Drag the tool along the length of the path segment you want to erase (not across the 
path). For best results, use a single, smooth, dragging motion.

Anchor points are added to the ends of the new paths.

Setting preferences for the pencil and smooth tools
You can set preferences for the pencil tool and smooth tool. The preferences include 
tolerances that control how sensitive the pencil and smooth tools are to the movement of 
your mouse or graphics-tablet stylus, and whether you want the path to remain selected 
after you draw it.

The tolerance is calculated in number of pixels. The larger the number of pixels you 
specify, the smoother and less complex are the paths.

Note: You can also set preferences for the paintbrush tool (see “Drawing and editing 
brushed paths” on page 79), the pen tool (see “Drawing with the pen tool” on page 50), 
the segment tools (see “Drawing line and arc segments” on page 67), and flare tool 
(see “Drawing flares” on page 65), and the grid tools (see “Drawing grids” on page 69),

To set preferences for the pencil tool and smooth tool:

1 Double-click the pencil tool  or smooth tool .

2 Use the Fidelity and Smoothness sliders or enter values in the text boxes:

• Fidelity controls the distance (in pixels) in which curves can stray from the smoothed 
mouse or tablet data when using the tool. The lower the fidelity value, the more 
angular the curves; the higher the value, the smoother the curves. 

• Smoothness controls the amount of smoothing (by percentage) applied when you use 
the tool. The lower the smoothness value, the coarser the path appears; the higher the 
value, the smoother the path.

3 To keep the path selected after you draw it, select Keep Selected. This option is selected 
by default.

4 To edit a path only when you are within a certain distance of it, select Edit Selected 
Paths, and enter a distance.

5 Click OK.

Drawing with the pen tool
Use the pen tool to draw a path that you can’t draw using the simpler drawing tools. 
The pen tool lets you create straight lines and smooth, flowing curves with great precision.
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Drawing straight segments with the pen tool
The simplest path you can draw with the pen tool is a straight line, made by clicking the 
pen tool to create two anchor points. By continuing to click, you create a path made of 
straight line segments connected by corner points. To create independent line segments, 
see “Drawing line and arc segments” on page 67.

To draw straight segments with the pen tool: 

1 Select the pen tool .

2 Position the tip of the pen point where you want the straight segment to begin, and 
click to define the first anchor point (do not drag). The anchor point remains selected 
(solid) until you add the next point. 

Note: The first segment you draw will not be visible until you click a second anchor point. 
Also, if direction lines appear, you’ve accidentally dragged the pen tool; choose Edit > 
Undo and click again.

3 Click again where you want the segment to end. (Shift-click to constrain the segment’s 
angle to multiples of 45 degrees.) This creates another anchor point. 

4 Continue clicking the pen tool to create additional straight segments.

The last anchor point you add appears as a solid square, indicating that it is selected. 
Existing anchor points become deselected as you add more anchor points.

5 Complete the path by doing one of the following:

• To close a path, position the pen pointer over the first (hollow) anchor point. A small 
loop appears next to the pen tool  when it is positioned correctly. Click to close the 
path.

• To leave the path open, Ctrl-click (Windows) or Command-click (Mac OS) anywhere 
away from all objects, or choose Select > Deselect, or select a different tool in the 
toolbox.

About direction lines and direction points
Before you draw and modify curved segments with the pen tool, it’s important to under-
stand two elements that are associated with anchor points on curves. When you use the 
direct-selection tool to select an anchor point connecting curved segments, the segments 
display direction lines which end in direction points. The angle and length of the direction 
lines determine the shape and size of the curved segments. Moving the direction points 
reshapes the curves. Direction lines don’t print.

After selecting an anchor point (left), direction lines appear on any curved segments connected by 
the anchor point (right).
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A smooth point always has two direction lines which move together as a single, straight 
unit. When you drag the direction point of either direction line on a smooth point, both 
direction lines move simultaneously, maintaining a continuous curve at that anchor point.

In comparison, a corner point can have two, one, or no direction lines, depending on 
whether it joins two, one, or no curved segments, respectively. Corner point direction lines 
maintain the corner by using different angles. When you drag a direction point on a corner 
point’s direction line, the other direction line, if present, does not move.

Adjusting direction lines on a smooth point (left) and a corner point (right)

Direction lines are always tangent to (perpendicular to the radius of ) the curve at the 
anchor points. The angle of each direction line determines the slope of the curve, and the 
length of each direction line determines the height, or depth, of the curve.

Moving and resizing direction lines changes the slopes of curves.

Drawing curved segments
You create curves by using the pen tool to add anchor points where a curve changes 
direction, and to drag the direction points that shape the curves. To draw individual curve 
segments, see “Drawing line and arc segments” on page 67.

Curves are easier to edit and your system can display and print them faster if you draw 
them using as few anchor points as possible. Using too many points can also introduce 
unwanted bumps in a curve. Instead, draw widely spaced anchor points, and practice 
shaping curves by adjusting the length and angles of the direction lines. 

To draw a curved segment:

1 Select the pen tool .

2 Position the pen tip where you want the curve to begin. Hold down the mouse button. 
The first anchor point appears, and the pen tip changes to an arrowhead .
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3 Drag to set the slope of the curve segment you’re creating. In general, extend the 
direction line about one third of the distance to the next anchor point you plan to draw. 
Shift-drag to constrain the direction line to multiples of 45 degrees.

Drawing the first point in a curve 
A. Positioning pen tool B. Starting to drag (mouse button pressed) C. Dragging to extend 
direction lines

4 Release the mouse button.

Note: The first segment will not be visible until you draw the second anchor point.

5 Position the pen tool where you want the curve segment to end, and then do one of the 
following:

• To create a “C”-shaped curve, drag in a direction opposite to the previous direction line.

Drawing the second point in a curve 
A. Starting to drag second smooth point B. Dragging away from previous direction line, creating a 
“C” curve C. Result after releasing mouse button

• To create an “S”-shaped curve, drag in the same direction as the previous direction line.

Drawing an S curve 
A. Starting to drag new smooth point B. Dragging in same direction as previous direction line, 
creating an “S” curve C. Result after releasing mouse button

6 Continue dragging the pen tool from different locations to create additional smooth 
points.

7 Complete the path by doing one of the following:

• To close the path, position the pen tool over the first (hollow) anchor point. A small 
loop appears next to the pen tip when it is positioned correctly. Click or drag to close 
the path.

A B C

B CA

A B C
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• To leave the path open, Ctrl-click (Windows) or Command-click (Mac OS) anywhere 
away from all objects, or choose Select > Deselect, or select a different tool in the 
toolbox.

Mixing curves, corners, and straight segments as you draw
You can freely alter point types and direction lines as you draw a path. This is useful for 
interactively drawing straight and curved segments on a single path, or when you want to 
draw two curved segments that are connected by a corner point.

To draw a straight segment followed by a curved segment:

1 Using the pen tool , click corner points in two locations to create a straight segment.

2 Position the pen tool over the selected endpoint. A convert-anchor-point icon  
appears next to the pen tool when it is positioned correctly. Drag a direction point at an 
end of the direction line that appears, to set the slope of the curved segment you’ll 
create next.

Drawing a mixed segment (part 1) 
A. Straight segment completed B. Positioning pen tool over endpoint C. Beginning to drag
D. Dragging direction point

3 Click or drag the third anchor point to complete the curve.

Drawing a mixed segment (part 2) 
A. Holding pen tool down B. Dragging direction point  C. New curve segment completed

To draw a curved segment followed by a straight segment:

1 Using the pen tool, drag to create the first smooth point of the curved segment.

A CB D

A B C
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2 Reposition the pen tool where you want the curved segment to end, drag to complete 
the curve, and release the mouse button. 

Drawing a curved segment

3 Position the pen tool over the selected endpoint. A convert-anchor-point icon  
appears next to the pen tool when it is positioned correctly. Click the anchor point to 
convert the smooth point to a corner point.

Drawing a mixed segment (part 1) 
A. Positioning pen tool over existing endpoint B. Clicking endpoint C. Result after clicking

4 Click the next corner point to complete the straight segment.

Drawing a mixed segment (part 2)

To draw two curved segments connected by a corner:

1 Using the pen tool, drag to create the first smooth point of a curved segment.

A B C
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2 Reposition the pen tool, drag to create a curve with a second smooth point, and then 
press Alt (Windows) or Option (Mac OS) as you drag the direction point to set the slope of 
the next curve. Then release the key and the mouse button. This converts the smooth 
point to a corner point by splitting the direction lines.

Drawing two curves 
A. Dragging a new smooth point B. Pressing Alt/Option to split direction lines while dragging, 
and swinging direction point up C. Result after releasing mouse button

3 Reposition the pen tool where you want the second curved segment to end, and drag a 
new smooth point to complete the second curved segment.

Dragging a new smooth point (left) to complete the second segment (right)

Adjusting path segments
You can change the shape of a path by adding, deleting, or moving the path’s anchor 
points. To adjust a curved segment, you move one or more of its anchor points or direction 
points. You can also adjust a path by converting smooth points to corner points and 
vice versa.

Adding, deleting, and converting anchor points 
You can add or delete anchor points on any path. Additional anchor points can give you 
more control over the path, or extend an open path. You can also connect two open paths. 
Similarly, you can delete anchor points to change the shape of a path or to simplify the 
path. It’s a good idea to delete any unnecessary points to reduce the complexity of 
the path.

You can use the Path Simplify command to remove extra anchor points on a path 
without changing the path’s shape. (See “Simplifying paths” on page 61.) 

The pen tool automatically changes to the add-anchor-point tool or the delete-anchor-
point tool as you position it over a selected path. The add-anchor-point tool adds the 
necessary type of point (corner or smooth) to preserve the existing shape of the path.

Note: You must delete anchor points by using the delete-anchor-point tool or the Path 
Simplify command. The Delete, Backspace, and Clear keys and the Edit > Cut or Edit > 
Clear commands always delete the entire path even if you select an anchor point on 
the path.

A B C
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To add or delete an anchor point: 

1 Using the direct-selection tool , select the paths to which you want to add or delete 
anchor points.

2 Select the pen tool , add-anchor-point tool , or delete-anchor-point tool . All of 
these tools share the same location in the toolbox; if necessary, position the pointer over 
the pen tool and drag to choose the tool you want.

3 Do one of the following:

• To add an anchor point using either the pen tool or the add-anchor-point tool , 
position the pointer over a path segment and click.

• To delete an anchor point using either the pen tool or the delete-anchor-point tool, 
position the pointer over an anchor point and click.

To extend an open path or connect two open paths:

1 Using the pen tool, position the pointer over the endpoint of the open path you want 
to extend. A small slash appears next to the pointer  when it’s precisely positioned over 
the endpoint.

2 Click the endpoint.

3 Do one of the following:

• To create a corner point, position the pen tool where you want to end the new segment, 
and click. If you are extending a path that ends at a smooth point, the new segment will 
be curved by the existing direction line.

• To create a smooth point, position the pen tool where you want to end the new curved 
segment, and drag.

• To connect the path to another open path, click an endpoint on the other path. When 
you position the pen tool over the other path’s endpoint, a small hollow point  
appears next to the pointer when it’s precisely positioned.

To override automatic switching to the add- or delete-anchor-point tools:

Hold down Shift as you position the pen tool over the selected path or an anchor point. 
This is useful when you want to start a new path on top of an existing path. To prevent 
Shift from constraining the pen tool, release Shift before you release the mouse button.

To turn off automatic adding or deleting of anchor points:

1 Choose Edit > Preferences > General (Windows and Mac OS 9) or Illustrator > 
Preferences > General (Mac OS X).

2 Under General Options, click Disable Auto Add/Delete to turn off the option. Then 
click OK.

To add anchor points using the Add Anchor Points command:

With the selection tool , select the object and choose Object > Path > Add Anchor Points. 
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To convert between smooth points and corner points using the convert-anchor-
point tool:

1 Using the direct-selection tool, select the path you want to modify.

To switch to the convert-anchor-point tool while the pen tool is selected, hold down 
Alt (Windows) or Option (Mac OS). 

2 Select the convert-anchor-point tool.

3 Position the convert-anchor-point tool over the anchor point you want to convert, and 
do one of the following:

• To convert a corner point to a smooth point, drag a direction point out of the corner 
point.

Dragging direction point out of a corner point to create a smooth point

• To convert a smooth point to a corner point without direction lines, click a smooth 
point.

Clicking a smooth point to create a corner point

• To convert a corner point without direction lines to a corner point with independent 
direction lines, first drag a direction point out of a corner point (making it a smooth 
point with direction lines). Release the mouse button only (don’t release any keys you 
may have pressed to activate the convert-anchor-point tool), and then drag either 
direction point.
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• To convert a smooth point to a corner point with independent direction lines, drag 
either direction point.

Converting a smooth point to a corner point

To temporarily switch from the convert-anchor-point tool to the last used selection 
tool, press Ctrl (Windows) or Command (Mac OS).

Adjusting straight and curved segments
You can modify the shape of a path by moving any of its anchor points or by moving the 
direction points of direction lines attached to a curve segment. Editing existing segments 
is slightly different from drawing them. Keep the following guidelines in mind as you 
adjust existing segments:

• If an anchor point connects two segments, moving that anchor point always changes 
both segments.

• When drawing with the pen tool, you can temporarily activate the last used selection 
tool by holding down Ctrl (Windows) or Command (Mac OS) so that you can adjust 
segments you’ve already drawn.

• When you draw a smooth point with the pen tool, dragging the direction point 
changes the length of the direction line on both sides of the point. However, when you 
edit an existing smooth point with the direct-selection tool, you change the length of 
the direction line only on the side you’re dragging.

To adjust a straight segment:

With the direct-selection tool , drag the anchor point on either end of a segment. 
Shift-drag to constrain the adjustment to multiples of 45 degrees.

If you’re simply trying to make a rectangle wider or narrower, it’s easier to select it 
with the selection tool and resize it using one of the handles on the sides of its 

bounding box.

To adjust a curved segment: 

1 Using the direct-selection tool , select the anchor point on either end of a curved 
segment. Direction lines appear on the anchor point and on the adjacent anchor points, 
if present (some curved segments use just one direction line).

2 Do one of the following:

• Drag the anchor point. Shift-drag to constrain movement to multiples of 45 degrees.
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• Drag a direction point. If you’re adjusting a smooth point’s direction lines, both 
direction lines revolve around the anchor point. Shift-drag to constrain the direction 
line angle to multiples of 45 degrees.

To split the direction lines of a smooth point, use the convert-anchor-point tool to 
drag them.

Using the reshape tool
The reshape tool lets you select one or more anchor points and sections of paths and then 
lets you adjust the selected points and paths globally. You can use the reshape tool to 
adjust paths containing many points while keeping the overall detail of the path intact. 
For example, if you have a drawing of a leaf with scallops along both edges, the reshape 
tool allows you to bend the leaf, keeping its overall smoothness, while retaining the 
scallops.

Points selected by the reshape tool  are highlighted with small squares. When you drag 
anchor points, any paths containing regularly selected anchor points are smoothly 
distorted as if they were being pulled by the highlighted anchor points. Unselected 
anchor points remain in place. 

To adjust a path using the reshape tool:

1 Use any selection tool or drag a marquee to select the anchor points of the paths that 
you want to reshape. Deselect any points that you want to remain in place. (See “Selecting 
objects” on page 97.)

2 Select the reshape tool .

3 Position the cursor over the anchor point or path segment that you want to act as a 
focal point (that is, a point that pulls selected path segments), and click the anchor point. If 
you click a path segment, a highlighted anchor point is added to the path. 

4 Shift-click more anchor points or path segments to act as focal points. You can highlight 
an unlimited number of anchor points or path segments.

5 Drag the highlighted anchor points to adjust the path. The amount of movement of a 
given path segment is in proportion to its distance from a highlighted point:

• Selected points that act as the focal point move with the selection tool during 
dragging.

• Selected points that aren’t the focal point move in proportion to the dragged focal 
point.

• Unselected anchor points are not affected by reshaping.
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Simplifying paths
The Path Simplify command removes extra anchor points from a path without changing 
the shape of the path.

Original (left) and simplified (right) path

To simplify a path: 

1 Select the path.

2 Choose Object > Path > Simplify. 

3 For Curve Precision, enter a value between 0% and 100% to set how closely the 
simplified path should follow the original path. A higher percentage creates more points 
and a closer fit. Any existing anchor points are ignored except for endpoints of a curve and 
corner points (unless you enter a value for Angle Threshold).

4 For Angle Threshold, enter a value between 0 and 180 degrees to control the 
smoothness of corners. If the angle of a corner point is less than the angle threshold, the 
corner point is not changed. This option helps keep corners sharp, even if the value for 
Curve Precision is low.

5 Select any of the following options:

• Select Straight Lines to create straight lines between the object’s original anchor points. 
Corner points are removed if they have an angle greater than the value set in Angle 
Threshold.

• Select Show Original to show the original path behind the simplified path.

• Select Preview to show a preview of the simplified path and list the number of points in 
the original and simplified paths.

Splitting paths with the scissors tool
You may want to split paths that you have already created or that were created using the 
auto trace tool. Using the scissors tool, you can split an open path into two paths and split 
a closed path so that it becomes one or more open paths. You cannot split a type path. 

To split a path and adjust it: 

1 Select the path to see its current anchor points. (See “Selecting objects” on page 97.)

2 Select the scissors tool .

3 Click the path where you want to split it. 

When you split the path in the middle of a segment, two new endpoints are coincident 
(one on top of the other), and one endpoint is selected. 

When you split the path at an anchor point, a new anchor point appears on top of the 
original anchor point, and one anchor point is selected.

4 Use the direct-selection tool  to adjust the new anchor point or path segment.



Using Help | Contents | Index Back 62  

Adobe Illustrator Help Drawing 

Using Help | Contents | Index Back 62  

Averaging anchor points
The Average command lets you move two or more anchor points (on the same path or on 
different paths) to a position that is the average of their current locations. 

To average anchor points: 

1 Use the direct-selection tool  to select two or more anchor points. (See “Selecting 
objects” on page 97.)

2 Choose Object > Path > Average.

3 Choose to average along both axes, or the horizontal (x) axis only, or the vertical (y) axis 
only, and click OK. 

Joining endpoints
The Join command connects the endpoints of an open path to create a closed path or 
joins the endpoints of two open paths. 

If you join two coincident endpoints (endpoints on top of each other), they are replaced 
with a single anchor point. If you join two noncoincident endpoints, a path is drawn 
between the two points.

To join two endpoints: 

1 Use the direct-selection tool  to select the endpoints. (See “Selecting objects” on 
page 97.) If the endpoints are coincident (on top of each other), drag a marquee through 
both endpoints to select them. 

2 Choose Object > Path > Join. A line is drawn, joining the two endpoints.

3 If the endpoints are coincident, select the Corner option (the default) or the Smooth 
option to specify the type of join you want.

4 Click OK. 

Drag a marquee through the coincident anchor points to select them (left), and choose the Join 
command (right).

Drawing shapes 
You can create many objects in Adobe Illustrator by starting with basic shapes. The tools in 
Illustrator let you easily create rectangles, ellipses, polygons, spirals, and stars.

Drawing rectangles and ellipses
Adobe Illustrator provides two rectangle tools and one ellipse tool that let you quickly 
create these common graphic objects:

• The rectangle, rounded-rectangle, and ellipse tools let you draw rectangles (including 
squares) and ellipses (including circles) by dragging from one corner of the rectangle or 
edge of the ellipse to the opposite corner or edge.
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• When a rectangle tool or the ellipse tool is selected, hold down Alt (Windows) or Option 
(Mac OS) to draw rectangles and ellipses by dragging from the center of the rectangle 
or ellipse outward.

When you create an object with a rectangle or the ellipse tool, a center point appears in the 
object. You can use this point to drag the object or to align the object with other elements 
in your artwork. The center point can be made visible or invisible, but it cannot be deleted. 

To create a rectangle or ellipse by dragging from an edge: 

1 Select the rectangle tool , the rounded-rectangle tool , or the ellipse tool .

2 Position the pointer at one corner or edge of the shape you want to create, and drag 
diagonally until the shape is the desired size. 

3 As you drag, you can do either of the following:

• To constrain the tool to multiples of 45 degrees, creating squares with the rectangle 
tool and circles with the ellipse tool, Shift-drag.

• To move a rectangle or ellipse as you draw it, hold down the spacebar.

• To create multiple rectangles or ellipses, hold down ~ (tilde).

To adjust corners of a rounded rectangle as you draw:

1 Select the rounded-rectangle tool.

2 Position the pointer where you want the rectangle to begin, and start dragging 
diagonally.

3 As you drag, you can do any of the following:

• Press or hold down Up Arrow or Down Arrow to change the corner radius. When the 
corners are the desired roundness, release Up Arrow or Down Arrow.

• Press Left Arrow to change to the minimum radius (most angular corners).

• Press Right Arrow to change to the maximum radius (most rounded corners).

4 Continue dragging with the rectangle tool until the rectangle is the desired size.

To create a rectangle or ellipse by dragging from the center:

1 Press Alt (Windows) or Option (Mac OS) with the rectangle tool, rounded-rectangle 
tool, or ellipse tool selected.

2 Position the pointer where you want the center of the shape to be, and drag diagonally 
to any corner or edge until the shape is the desired size. Shift-drag to constrain the tool to 
multiples of 45 degrees.

To draw a rectangle or ellipse by specifying dimensions: 

1 Select a rectangle tool or the ellipse tool.

2 Click in the artwork to set the origin from which you want to create the shape. To draw 
rectangles and ellipses from the center of the point of origin, Alt-click (Windows) or 
Option-click (Mac OS).

By default, the Rectangle and Ellipse dialog boxes display the dimensions of the last 
rectangle or ellipse drawn. The unit of measure is determined by the unit of measure set in 
the Document Setup or Units & Undo Preferences dialog box.

3 In the Width text box, enter the width you want the shape to be.
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4 In the Height text box, enter the height you want the shape to be, and click OK.

To create a square or circle, enter a value in the Width text box and then click the word 
Height; this copies the width value to the Height text box.

If you are drawing a rounded rectangle, enter the corner radius value you want the 
rectangle to have. The corner radius value represents the radius of a hypothetical circle 
drawn in the corner of the rectangle or square. The default corner radius is 12 points. 
A corner radius of 0 creates square corners. 

Note: The corner style of the rectangle or square you draw is determined by the corner 
radius value you specify in either the Rectangle or General Preferences dialog box. Speci-
fying a corner radius value in either dialog box updates the value in the other dialog box. 

To display or hide the center points:

1 Choose Window > Attributes.

2 In the Attributes palette, click either the Show Center button  or the Don’t Show 
Center button .

Drawing polygons
The polygon tool draws an object with a specified number of sides of equal length, 
each side being the same distance from the center of the object. 

To draw a polygon by dragging:

1 Select the polygon tool .

2 Position the pointer at the center of the polygon you want to create, and drag until the 
polygon is the desired size. 

3 As you drag, do any of the following:

• Drag the pointer in an arc to rotate the polygon.

• Shift-drag to constrain the tool to multiples of 45 degrees or to the angle specified in 
the Constrain Angle text box in the General Preferences dialog box.

• Hold down the spacebar to move the polygon.

• Press or hold down Up Arrow or Down Arrow to add or delete sides to the polygon.

• Hold down ~ (tilde) to create multiple polygons.

To draw a polygon by specifying dimensions: 

1 Select the polygon tool.

2 Click where you want to place the center of the polygon.

By default, the Polygon dialog box displays the dimensions of the last polygon you drew. 
The unit of measure is determined by the unit of measure set in the Document Setup or 
Units & Undo Preferences dialog box.

3 In the Radius text box, enter the distance from the center point to each line’s endpoint.

4 Click the arrows or enter the number of sides in the Sides text box, and click OK.

Drawing stars
The star tool creates a star-shaped object with a given number of points and size.
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To draw a star by dragging:

1 Select the star tool .

2 Position the pointer at the center of the star you want to create, and drag until the star 
is the desired size. 

3 As you drag, you can do any of the following:

• Drag the pointer in an arc to rotate the star. 

• Shift-drag to constrain the tool to multiples of 45 degrees.

• Hold down Ctrl (Windows) or Command (Mac OS) to hold the inner radius constant. 

• Hold down Alt (Windows) or Option (Mac OS) to keep the sides of the star straight.

• Hold down the spacebar to move the star.

• Press or hold down Up Arrow or Down Arrow to add or delete sides to the star.

• Hold down ~ (tilde) to create multiple stars.

To draw a star by specifying dimensions: 

1 Select the star tool.

2 Click where you want to place the center of the star. By default, the Star dialog box 
displays the dimensions of the last star you drew. The unit of measure is determined by the 
unit of measure set in the Document Setup or Units & Undo Preferences dialog box.

3 In the Radius 1 text box, enter the distance from the center to the innermost points.

4 In the Radius 2 text box, enter the distance from the center to the outermost points.

5 Click the arrows or enter the number of sides to the star in the Points text box, and 
click OK.

Drawing flares
The flare tool creates flare objects with a bright center, a halo, and rays and rings. Use this 
tool to create an effect similar to a lens flare in a photograph.

Flares include a center handle and an end handle. Use the handles to position the flare 
and its rings. The center handle is in the bright center of the flare—the flare path begins 
from this point. 

Flares look best when drawn over existing objects.

Components of a flare 
A. Rays B. Halo C. Center handle D. Rings E. End handle

B C D EA
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To create a flare using default settings:

1 Select the flare tool .

2 Press Alt (Windows) or Option (Mac OS), and click where you want the flare to appear.

To create a flare using the Flare Options dialog box:

1 Select the flare tool, and click where you want the flare to appear.

2 Specify the options you want in the Flare Options dialog box, and click OK. 

To reset a flare to the default values:

1 Select the flare, and double-click the flare tool icon to open the Flare Options 
dialog box.

2 Hold down Alt (Windows) or Option (Mac OS), and click Reset.

To draw a flare:

1 Select the flare tool.

2 Click to place the center handle of the flare. Then drag to set the size of the center, 
the size of the halo, and to rotate the angle of the rays.

3 Before releasing the mouse, do any of the following:

• Press Shift to constrain the rays to a set angle.

• Press Up Arrow to add rings.

• Press Down Arrow to remove rings.

• Press Ctrl (Windows) or Command (Mac OS) as you drag to hold the center of the flare 
constant.

• Press Ctrl (Windows) or Command (Mac OS) as you drag to hold the center of the flare 
constant.

• Press ~ (tilde) as you drag to redraw the rings in a different random arrangement.

Each element (center, halo, rings, and rays) in the flare is filled with color at different 
opacity settings. 

To edit a flare:

Do any of the following:

• Select the flare, and double-click the flare tool icon to open the Flare Options dialog 
box. Change settings in the dialog box.

• Select the flare and the flare tool. Drag an end point—from either the center handle or 
the end handle—to change the length or direction of the flare.

• Select the flare, and choose Object > Expand. This makes the elements of the flare 
editable, like elements of blends.

To specify flare tool options:

1 Double-click the flare tool.

2 Specify the overall diameter, opacity, and brightness of the flare’s center:

3 Specify the Growth of the halo as a percentage of the overall size, and specify the 
fuzziness (0 is crisp and 100 is fuzzy) of the halo.
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4 If you want the flare to contain rays, select Rays and specify the number of rays, the 
longest ray (as a percentage of the average ray), and the fuzziness (0 is crisp and 100 is 
fuzzy) of the rays. 

5 If you want the flare to contain rings, select Rings and specify the distance of the path 
between the halo’s center point (center handle) and the center point of the furthest ring 
(end handle), the number of rings, the largest ring (as a percentage of the average ring), 
and the direction or angle of the rings. 

6 When setting options to edit an existing flare, select Preview to view the final effect on 
the selected flare using the current settings. 

7 Click OK.

Drawing line and arc segments
Use the line and arc segment tools to quickly and easily create individual lines and arcs by 
dragging. The Line and Arc Segment dialog boxes display the values of the last segment 
created. You can reset to the default values in the dialog box by pressing Alt (Windows) or 
Option (Mac OS) and clicking Reset. 

To draw a line segment:

1 Select the line segment tool , click where you want the line to begin, and drag to 
where you want the line to end. 

2 As you drag, do any of the following:

• Press Alt (Windows) or Option (Mac OS) to extend the line from both sides of the origin 
point.

• Press the spacebar to move the line as you draw. 

• Press `(grave accent) to create multiple line segments as you move the mouse.

• Press ~ (tilde) to constrain multiple lines to 45˚ angles.

• Press Shift to constrain a single line to 45˚.

To draw a line segment by specifying properties:

1 Select the line segment tool, and click where you want to place the segment.

2 In the Line Segment dialog box, enter the length and angle you want. 

3 Select Fill Line if you want the line to use the current fill color (otherwise the fill is set 
to none).

4 Click OK.

To draw an arc segment:

1 Select the arc segment tool , click where you want the arc to begin, and drag to create 
an arc.

2 As you drag, do any of the following:

• Press Alt (Windows) or Option (Mac OS) to extend the arc from both sides of the origin 
point.

• Press the spacebar to move the arc as you draw. 

• Press `(grave accent) to create multiple arc segments as you move the mouse.
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• Press C to switch between an open and closed arc.

• Press F to flip the arc, keeping the origin point constant.

• Press Up Arrow or Down Arrow to increase or decrease the arc’s angle.

To draw an arc segment by specifying properties:

1 Select the arc segment tool, and click where you want to place the segment.

2 In the Arc Segment dialog box, enter the options you want.

3 Select Fill Line if you want the line to use the current fill color (otherwise the fill is set 
to none).

4 Click OK.

Note: The square icon to the right of the Length X-Axis option sets the origin point for the 
arc. To change the origin point, click the square on any of the four corners.

Drawing spirals
The spiral tool creates a spiral-shaped object of a given radius and number of winds; 
that is, the number of turns that the spiral completes from start to finish.

To draw a spiral by dragging:

1 Select the spiral tool .

2 Position the pointer at the center of the spiral you want to create, and drag until the 
spiral is the desired size. 

3 As you drag, you can do any of the following:

• Drag the pointer in an arc to rotate the spiral.

• Shift-drag to constrain the tool to multiples of 45 degrees or to the angle specified in 
the Constrain Angle text box in the General Preferences dialog box.

• Hold down the spacebar to move the spiral.

• Press or hold down Up Arrow or Down Arrow to add or delete winds.

• Press ~ (tilde) to create multiple spirals.

To draw a spiral by specifying dimensions: 

1 Select the spiral tool, and click where you want to place the center of the spiral.

By default, the Spiral dialog box displays the dimensions of the last spiral you drew. 
The unit of measure is determined by the unit of measure set in the Document Setup or 
Units & Undo Preferences dialog box.

2 In the Radius text box, enter the distance from the center to the outermost point in the 
spiral.

3 In the Decay text box, enter the amount by which each wind of the spiral should 
decrease relative to the previous wind.

4 Click the arrows or enter the number of segments in the Segments text box. Each full 
wind of the spiral consists of four segments.

5 For Style, select the counterclockwise or clockwise option to specify the direction of the 
spiral, and click OK.
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Drawing grids
Use the grid tools to quickly draw rectangular or polar grids. Specify the grid size and the 
number of dividers, and then drag to create the grid anywhere on the artboard. The 
rectangular grid tool creates rectangular grids of a specified size with a specified number 
of dividers. The polar grid tool creates concentric circles of a specified size and a specified 
number of dividers.

Drawing rectangular grids
You can draw rectangular grids by dragging or by setting specific grid parameters in the 
Rectangular Grid Tool Options dialog box.

To draw a rectangular grid:

1 Select the rectangular grid tool , and drag diagonally.

2 As you drag, do any of the following:

• Press Shift to constrain the grid to a square.

• Press Alt (Windows) or Option (Mac OS) to extend the grid from all sides of the origin 
point.

• Press Shift + Alt (Windows) or Shift + Option (Mac OS) to constrain the grid to a square 
as it extends from the origin point.

• Press the spacebar to move the grid as you draw. 

• Hold down ~ (tilde) to create multiple grids.

3 To adjust the grid’s dividers, do any of the following as you drag:

• Press Up Arrow or Down Arrow to add or remove horizontal lines.

• Press Right Arrow or Left Arrow to add or remove vertical lines.

• Press F to decrease the logarithmic skew value for the horizontal dividers by 10%.

• Press V to increase the logarithmic skew value for the horizontal dividers by 10%.

• Press X to decrease the logarithmic skew value for the vertical dividers by 10%.

• Press C to increase the logarithmic skew value for the vertical dividers by 10%.

To create a rectangular grid by specifying properties:

1 Select the rectangular grid tool , and click in the artboard to set the grid’s origin point 
and display the Rectangular Grid Tool Options dialog box. 

2 In the Rectangular Grid Tool Options dialog box, do any of the following and then 
click OK:

• For Default Size, enter Width and Height values for the entire grid. Then click a corner of 
the Origin Point icon to determine the point from where the grid is drawn.

• For Horizontal Dividers, enter the number of horizontal dividers you want to appear 
between the top and bottom of the grid. Then enter a Skew value to determine how 
the horizontal dividers are weighted to one side or the other.

• For Vertical Dividers, enter the number of dividers you want to appear between the left 
and right sides of the grid. Then enter a Skew value to determine how the vertical 
dividers are weighted toward the top or bottom of the grid.
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• Select Use Outside Rectangle As A Frame to replace the top, bottom, left, and right 
segments with a separate rectangular object.

• Select Fill Grid to fill the grid with the current fill color (otherwise, the fill is set to none).

Drawing polar grids
You draw polar grids by dragging or by setting specific grid parameters in the Polar Grid 
Tool Options dialog box.

To draw a polar grid:

1 Select the polar grid tool , and drag diagonally.

2 As you drag, do any of the following:

• Press Shift to constrain the grid to a circle.

• Press Alt (Windows) or Option (Mac OS) to extend the grid from all sides of the origin 
point.

• Press Shift + Alt (Windows) or Shift + Option (Mac OS) to constrain it to a circle as it 
extends from the origin point.

• Press the spacebar to move the grid as you draw. 

• Hold down ~ (tilde) to create multiple polar grids.

3 To adjust the grid’s dividers, do any of the following as you drag:

• Press Up Arrow or Down Arrow to add or remove concentric circles.

• Press Right Arrow or Left Arrow to add or remove radial lines.

• Press X to change the logarithmic skew value for the concentric dividers inward by 10%.

• Press C to change the logarithmic skew value for the concentric dividers outward 
by 10%.

• Press F to change the logarithmic skew value for the radial dividers counterclockwise 
by 10%.

• Press V to change the logarithmic skew value for the radial dividers clockwise by 10%.

To create a polar grid by specifying properties:

1 Select the polar grid tool , and click where you want to create the grid’s origin point 
and open the Polar Grid Tool Options dialog box. 

2 In the Polar Grid Tool Options dialog box, do any of the following and then click OK:

• For Default Size, enter Width and Height values for the entire grid. Then click a corner of 
the Origin Point icon to determine the point from where the grid is drawn.

• For Concentric Dividers, enter the number of circular concentric dividers you want to 
appear in the grid. Then enter a Skew value to determine how the concentric dividers 
are weighted toward the inside or outside of the grid. 

• For Radial Dividers, enter the number of radial dividers you want to appear between the 
center and the circumference of the grid. Then enter a Skew value to determine how 
the radial dividers are weighted counterclockwise or clockwise on the grid.

• Select Create Compound Path From Ellipses to convert the concentric circles into a 
separate compound path and fill every other circle.

• Select Fill Grid to fill the grid with the current fill color (otherwise, the fill is set to none).
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Working with symbols
A symbol is an art object that you store in the Symbols palette and reuse in a document. 
For example, if you create a symbol from a flower, you can then add instances of that 
symbol multiple times to your artwork without actually adding the complex art multiple 
times. Each symbol instance is linked to the symbol in the palette. If you use the same 
artwork multiple times within a document, symbols can save time and greatly reduce file 
size. Symbols also provide excellent support for SWF and SVG export.

After you create a symbol, you can edit the symbol’s instances on the artboard and, if you 
want, redefine the original symbol with the edits. Symbolism tools let you add and manip-
ulate multiple symbol instances at once. (See “Using symbolism tools” on page 73.)

Using the Symbols palette
Use the Symbols palette to store, manage, and place symbols.

To open the Symbols palette:

Choose Window > Symbols.

To display the Symbols palette menu:

Click the triangle at the upper right corner of the palette.

To change the view of symbols in the Symbols palette:

Choose one of the following from the Symbols palette menu: Thumbnail View, Small List 
View, or Large List View.

Note: You can arrange the listings alphabetically by choosing Sort by Name.

Creating symbols
You can create symbols from any Illustrator art object, including paths, compound paths, 
text, raster images, mesh objects, and groups of objects. (However, you cannot use 
nonembedded placed art as a symbol, nor can you use some groups, such as groups of 
graphs.) Symbols may also include active objects, such as brush strokes, blends, effects, 
or other symbol instances in a symbol. You can use the Symbols palette as a database for 
your artwork—to recover the original definition with all of its active elements, simply 
expand a symbol instance.

You can modify the symbol instances and automatically update the original symbol art 
with your edits. To create new symbols from existing symbols, duplicate a symbol and 
edit it. 

To create a symbol:

1 Select the artwork you want to use as a symbol.

2 Do one of the following:

• Drag the artwork to the Symbols palette. Press Shift as you drag if you want the selected 
artwork to become an instance of the newly created symbol.

• Click the New Symbol button  in the Symbols palette.

• Choose New Symbol from the Symbols palette menu.
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To duplicate a symbol in the Symbols palette:

In the Symbols palette, do one of the following:

• Drag a symbol to the New Symbol button.

• Select a symbol, and choose Duplicate Symbol from the Symbols palette menu.

Placing symbol instances
You place instances of symbols in your document in one of two ways: using the Symbols 
palette to place individual instances of a symbol, or using the symbol sprayer tool to 
create multiple symbol instances as a set. When you use the symbol sprayer, all of the 
symbols that appear from each spray become one instance set that you manipulate and 
edit as a whole. (See “Using symbolism tools” on page 73.) 

Symbol instances placed using the Symbols palette are exact replicas of the original. 
When selected in the artboard, symbol instances have a bounding box around them, 
similar to grouped artwork.

To place a symbol instance using the Symbols palette:

1 Select a symbol from the palette.

2 Do one of the following:

• Click the Place Symbol Instance button  in the Symbols palette to place the instance in 
the center of the artboard.

• Drag the symbol to the artboard where you want it to appear.

• Choose Place Symbol Instance from the Symbols palette menu.

To duplicate a symbol instance:

1 Select the instance on the artboard.

2 Alt-drag (Windows) or Option-drag (Mac OS) the symbol instance to another location 
on the artboard.

Deleting symbols and symbol instances
You can easily delete the symbol from the palette. You can also choose to delete or expand 
any instances of the symbol.

To delete a symbol in the Symbols palette:

1 In the Symbols palette, do one of the following:

• Select a symbol and click the Delete Symbol button .

• Drag a symbol icon to the Delete Symbol button.

• Select a symbol and choose Delete Symbol from the Symbols palette menu.

2 To avoid deleting existing symbol instances (if any were created), select Expand 
Instances in the message that appears.

To select all instances of a symbol in the document:

Select a symbol in the Symbols palette, and then choose Select All Instances in the 
palette menu.
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To select all unused symbols in the Symbols palette:

Choose Select All Unused in the Symbols palette menu.

Modifying and redefining symbols and symbol instances
You can move, scale, rotate, shear (or skew), or reflect a symbol instance using commands 
in the Object menu or in the Transform or Align palettes. You can also perform any 
operation from the Transparency, Appearance, and Styles palettes and apply any effect 
from the Effect menu.

After you modify an instance, you can redefine the original symbol in the Symbols palette 
using the modified artwork. When you redefine a symbol, all existing symbol instances 
take on the new definition. If you don’t want a symbol instance to take on the new 
definition, break the link between the symbol and that particular symbol instance.

To modify and redefine a symbol:

1 Select an instance of the symbol on the artboard.

2 Click the Break Link button  in the Symbols palette.

3 Edit the artwork.

4 Do one of the following:

• Make sure the symbol you want to redefine is selected in the Symbols palette, and 
choose Redefine from the Symbols palette menu.

• Alt-drag (Windows) or Option-drag (Mac OS) the modified symbol on top of the old 
symbol in the Symbols palette. The symbol is replaced in the Symbols palette and is 
updated in the current file.

To modify one symbol instance:

Select the symbol instance on the artboard, and edit it.

Associating a new symbol with an instance:

1 Select the symbol instance on the artboard.

2 Select a new symbol in the Symbols palette.

3 Do one of the following:

• Click the Replace Symbol button .

• Choose Replace Symbol from the Symbols palette menu.

Using symbolism tools
Symbols are art objects you create and store in the Symbols palette (see “Working with 
symbols” on page 71). Use symbolism tools to create and edit symbol instances or sets of 
symbol instances. Sets of instances are created using the symbol sprayer tool (see “Using 
the symbol sprayer tool” on page 75). You can create mixed sets of symbol instances by 
using the symbol sprayer tool with one symbol and then using it again with another 
symbol.
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Symbolism tools affect only the symbol or symbols selected in the Symbols palette. 
For example, if you create a mixed symbol instance set that represents a meadow with 
grass and flowers, you can change the orientation of just the grass by selecting the grass 
symbol in the Symbols palette and then using the symbol spinner tool. To change the size 
of both the grass and the flowers, select both symbols in the Symbols palette and then use 
the symbol sizer tool.

Note: When you select a mixed symbol instance set on the artboard, the symbol instance 
most recently added to the set is automatically selected in the Symbols palette.

You can use symbolism tools to change the density, color, location, size, rotation, 
transparency, or style of symbol sets. 

Symbol features 
A. Symbols palette B. Symbol instance C. Symbol instance set

After you select one symbolism tool, you can quickly switch between tools using the inter-
active tool menu. You can also switch between symbolism tools and set options for 
different symbolism tools within the Symbolism Tool Options dialog box.

Setting options for symbolism tools
Symbolism tools have many options in common with each other, such as diameter, 
intensity, and density. Tool options specify the setting for symbols that are currently 
selected or that will be created or edited.

To set options for symbolism tools:

1 Double-click a symbolism tool in the toolbox.

You can click the other tool icons in the Symbolism Tools Options dialog box and set 
options for those tools without leaving the dialog box. 

2 For Diameter, enter a value for the tool’s brush size.

At any time while using a symbolism tool, press [ to decrease the diameter or ] to 
increase it.

BA C
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3 For Intensity, enter a value to specify the rate of change (higher values equal faster 
changes), or select Use Pressure Pen to use the input from a tablet or pen instead of the 
Intensity value.

At any time while using a symbolism tool, press Shift+[ to decrease the intensity or 
Shift+] to increase it. 

4 For Symbol Set Density, enter an attraction value for the symbol set (higher values 
result in more densely packed symbol instances).

Note: The Density setting applies to an entire symbol set. If a symbol set is selected, the 
density changes for all symbol instances in the set, not just newly created instances. 

5 Select Show Brush Size and Intensity to see the size as you use the tool. 

6 Select Preview Bounding Boxes of Symbol Instances to see the oriented bounding 
boxes of the symbol instances as you add them. Selecting this option may increase perfor-
mance speed. Deselect this option to see the actual outline of each symbol instance. 

7 For Method, see each individual tool description.

Using the symbol sprayer tool
Use the symbol sprayer tool to create a set of symbol instances or add more instances to 
an existing set. 

You can specify the following options from each of the tool pop-up menus in the Symbol 
Sprayer Options dialog box:

Average adds a new symbol with the average value of existing symbol instances within 
the brush radius. For example, an instance added to an area where the average existing 
symbol instance is 50% transparent will be 50% transparent; an instance added to an area 
with no instances will be opaque. 

Note: The Average setting only takes into account other instances within the symbol 
sprayer tool’s brush radius, which you set using the Diameter option. To see the radius as 
you work, select Show Brush Size and Intensity.

User Defined applies specific preset values for each parameter:

• Scrunch (density) is based on the original symbol size.

• Size uses the original symbol size.

• Spin uses the mouse direction (or no orientation if the mouse doesn’t move).

• Screen uses 100% opacity.

• Stain uses the current fill color and full tint amount.

• Style uses the current style.

To create a symbol instance set:

1 Select a symbol in the Symbols palette, and then select the symbol sprayer tool .

2 Click or drag where you want the symbol instances to appear.

To add symbol instances to an existing set:

Select the symbol sprayer tool , a symbol in the Symbols palette, and an existing symbol 
set. Then click or drag where you want the new instances to appear.
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To delete symbol instances from a set:

1 Select the set from which you want to delete instances.

2 Select the symbol sprayer tool, and hold down Alt (Windows) or Option (Mac OS) as you 
click or drag where you want to remove instances.

To expand a symbol set into individual symbol instances:

Select the set, and choose Object > Expand.

Using the symbol shifter tool
The symbol shifter tool moves symbol instances around. It can also change the relative 
paint order of symbol instances in a set. 

You can use one of the following Method options when using the symbol shifter tool:

• User Defined gradually pulls symbols toward or away from the cursor.

• Random modifies the density randomly in the area under the cursor.

• Average gradually smooths out the density values.

To move or shift symbol instances:

Select the symbol shifter tool  and drag in the direction you want the symbol instances 
to move.

To change the stacking order of symbol instances within the brush’s diameter:

Select the symbol shifter tool  and do one of the following:

• To bring symbol instances forward, Shift-click the symbol instance. 

• To send symbol instances backward, hold down Alt (Windows) or Option (Mac OS) and 
Shift-click the symbol instance. 

Using the symbol scruncher tool
The symbol scruncher tool pulls symbol instances together or apart. Use this tool to shape 
the density distribution of a symbol set.

To scrunch symbols:

Select the symbol scruncher tool  and do one of the following:

• Click or drag in the area where you want to pull the symbol instances toward each 
other.

• Hold down Alt (Windows) or Option (Mac OS), and click or drag in the area where you 
want to push symbol instances away from each other.

Using the symbol sizer tool
Use the symbol sizer tool to increase or decrease the size of symbol instances in an 
existing symbol set. 

When setting options for the symbol sizer, you can select Proportional Resizing if you want 
to keep each symbol instance shape uniform as you resize. You can also select Resizing 
Affects Density to move symbol instances away from each other when they are scaled up 
and move them toward each other when they are scaled down. You can use one of the 
following Method options when using the symbol sizer tool:

• User Defined gradually increases or decreases the size.
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• Random modifies the scale randomly in the area under the cursor.

• Average gradually smooths out the sizes of the symbol instances.

To change the size of symbol instances:

Select the symbol sizer tool  and do one of the following:

• Click or drag in the set where you want to increase the size of the symbol instances.

• Hold down Alt (Windows) or Option (Mac OS), and click or drag where you want to 
decrease the size of the symbol instances.

Using the symbol spinner tool
Use the symbol spinner tool to orient the symbol instances in a set. Symbol instances 
located near the cursor orient in the direction you move the cursor. As you drag the 
mouse, an arrow appears above the cursor to show the current orientation of symbol 
instances.

You can use one of the following Method options when using the symbol spinner tool:

• User Defined orients the symbol instances in the direction of the cursor. 

• Random gradually orients the symbol instances randomly.

• Average gradually smooths the orientation of all symbol instances.

To rotate symbol instances:

1 Select the symbol spinner tool  and click or drag in the direction you want the symbol 
instances to orient.

Using the symbol stainer tool
Use the symbol stainer tool to colorize symbol instances. Colorizing a symbol instance 
changes the hue toward the tint color, while preserving the original luminosity. (It works in 
the same way as the Tints and Shades colorization method of tinting brushes.) This 
method uses the luminosity of the original color and the hue of the colorization color to 
generate the resulting color. Consequently, colors with very high or very low luminosity 
change very little; black or white objects don’t change at all.

To achieve a method of colorization that will also affect black and white objects, use 
the symbol styler tool with a style that uses the desired fill color.

You can choose one of the following Method options when using the symbol stainer tool:

• User Defined gradually changes the colorization of the symbol instances toward the 
currently selected tint color. 

• Random changes the colorizaton and amounts randomly. 

• Average smooths out the colorization and amounts over symbols in the same set. 

Note: Using the symbol stainer tool results in increased file size and decreased perfor-
mance. When memory or exported Flash/SVG file size is a concern, do not use this tool. 

To stain symbol instances:

1 In the Color palette, select the fill color that you want to use as the colorization color.
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2 Select the symbol stainer tool  and do one of the following:

• Click or drag over the symbol instances you want to stain with the colorization color. 
The amount of colorization gradually increases, and the symbol instance’s color 
gradually changes to the colorization color.

• Hold down Alt (Windows) or Option (Mac OS) as you click or drag to decrease the colori-
zation amount and reveal more of the original symbol color. 

• Hold down Shift as you click or drag to keep the colorization amount constant, while 
gradually changing the color of the symbol instances to the colorization color. 

Using the symbol screener tool
Use the symbol screener tool to increase or decrease the transparency of the symbol 
instances in a set.

You can use one of the following Method options when using the symbol screener tool:

• User Defined gradually increases or decreases the transparency.

• Random gradually adds random transparency.

• Average gradually smooths out the transparency values.

To adjust transparency:

Select the symbol screener tool  and do one of the following:

• Click or drag where you want to increase the symbol’s transparency.

• Hold down Alt (Windows) or Option (Mac OS), and click or drag where you want to 
decrease the symbol’s transparency.

Using the symbol styler tool
The symbol styler tool applies the selected style to the symbol instance. 

You can switch to the symbol styler tool when using any other symbolism tool, 
by clicking a style in the Styles palette.

You can use one of the following Method options when using the symbol styler tool:

• User Defined gradually increases the application of the selected style. Hold down 
Alt (Windows) or Option (Mac OS) to decrease the style amount and reveal more of the 
original unstyled symbol. Hold down Shift to keep the amount of style applied 
constant.

• Random gradually changes the amount of style applied to symbol instances by a 
random amount.

• Average gradually averages the styles and style amounts of the symbol instances in the 
set. Hold down Shift to keep the style amounts constant.

To apply a style to a symbol:

1 Select the symbol styler tool .

2 Select a style in the Styles palette, and do one of the following:

• Click or drag where you want to apply the style to the symbol set. The amount of style 
applied to the symbol instances increases, and the style gradually changes.

• Hold down Alt (Windows) or Option (Mac OS), and click or drag where you want to 
reduce the amount the style applied.
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• Hold down Shift as you click or drag to keep the amount of style constant, while 
gradually changing the symbol instance style to the selected style. 

Note: It is very important to perform steps 1 and 2 in the specified order. If you select a 
style while a tool other than the symbolism tools is selected, the style will apply immedi-
ately to the entire selected symbol instance set.

Drawing and editing brushed paths
The Brushes palette in Illustrator contains four brush types—Calligraphic, Scatter, Art, and 
Pattern brushes—to use in adding art to paths. You can choose from the brush effects that 
have been preloaded into the Brushes palette. You can also modify these brushes, create 
brushes, or import a brush from the Brush Libraries to the Brushes palette. 

Brushes that you create and store in the Brushes palette are associated only with the 
current file. Each Illustrator file can have a different set of brushes in its Brushes palette. 

You can achieve the following effects using the four brush types:

• Calligraphic brushes create strokes that resemble strokes drawn with the angled point 
of a calligraphic pen, drawn along the center of the path.

• Scatter brushes disperse copies of an object (such as a ladybug or a leaf ) along the 
path.

• Art brushes stretch an object or artwork (such as an arrow or dog bone) evenly along 
the length of the path.

• Pattern brushes paint a pattern—made of individual tiles—that repeats along the path. 
Pattern brushes can include up to five tiles, for the sides, inner corner, outer corner, 
beginning, and end of the pattern.

Sample brushes 
A. Calligraphic brush B. Scatter brush C. Art brush  D. Pattern brush

Drawing a brushed path with the paintbrush tool
The paintbrush tool creates paths painted with a brush selected in the Brushes palette. 
You must select a brush in the Brushes palette to use the paintbrush tool. 

To draw a path with the paintbrush tool: 

1 Choose Window > Brushes to display the Brushes palette, and select a brush from the 
Brushes palette. 

DCBA
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2 Double-click the paintbrush tool , set preferences, and click OK:

• In the Fidelity text box, enter the number of pixels (from 0.5 to 20) for the number of 
pixels the stroke can stray from the path to produce smooth curves, or use the slider. 
The higher the value, the smoother the stroke or curve.

• In the Smoothness text box, enter a value (0% to 100%) for the percentage stroke and 
curve smoothness, or use the slider. The higher the value, the smoother the stroke or 
curve.

• Select Fill New Brush Strokes to have paths drawn by the brush filled. When the option 
is unselected, paths are unfilled.

• Select Keep Selected to keep the path just drawn with the brush selected.

• Select Edit Selected paths to make the selected paths editable.

3 Position the tip of the paintbrush where you want the path to begin, and drag the 
paintbrush to draw the path. By default, the path is selected when you release the mouse 
button.

To draw a closed path with the paintbrush tool:

1 Select the paintbrush tool. 

2 Position the pointer where you want the path to begin, and start dragging to draw 
a path.

3 As you drag, hold down Alt (Windows) or Option (Mac OS). The paintbrush tool displays 
a small loop to indicate drawing a closed path.

4 When the path is the size and shape you want, release the mouse button (but not the 
Alt or Option key). After the path closes, release the Alt or Option key.

To edit a brushed path with the paintbrush tool:

1 Select the path to edit with the selection tool , or Ctrl-click (Windows) or Command-
click (Mac OS) the path to select it.

2 Position the paintbrush tool on or near the path to redraw, and drag the tool until the 
path is the desired shape.

Creating a brushed path with a drawing tool
You can create a brushed path from any path created with an Illustrator drawing tool, 
including the pen or pencil tool or any of the basic shapes tools. You can then edit the 
brushed path as you would any path drawn with the tools.

To create a brushed path with a drawing tool:

1 Draw a path using a drawing tool, including the pen or pencil tool or a basic shape tool.

2 Choose a method for applying a brush to the path:

• Select the path that is to be brushed. In the Brushes palette, select a brush with which 
to brush the path.

• Drag a brush from the Brushes palette onto a path.

Note: To preserve brush stroke options previously applied to the object when applying a 
new brush, Alt-click (Windows) or Option-click (Mac OS) the new brush.
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Modifying brushed paths
After you have applied a brush to a path, you can modify the attributes of the path in 
several ways. 

To convert brushes in artwork to outlined paths:

1 Select the object or objects to convert.

2 Choose Object > Expand Appearance.

To remove a brush from a path:

1 Select the path to change.

2 Do one of the following:

• In the Brushes palette, choose Remove Brush Strokes from the palette menu or click the 
Remove Brush Strokes button . 

• In the toolbox or the Color palette, click the Stroke box and apply a stroke of None.

The brush is removed and the path remains.

Managing brushes
You can use the Brushes palette to organize your brushes. 

To display the Brushes palette:

Choose Window > Brushes.

To display brushes by name:

Choose List View from the Brushes palette menu. A picture of the brush displays to the left 
of the name. The picture to the right of the name indicates the brush type.

To display brushes by thumbnail only:

Choose Thumbnail View from the Brushes palette menu. A picture of the brush displays. 

To modify the type of brushes displayed:

From the Brushes palette menu, choose the type of brush to display in the palette. You can 
choose more than one brush. 

To select all brushes not currently used in the file:

Choose Select All Unused from the Brushes palette menu. Only brushes that are not 
currently used in the active file are selected. 

To move a brush in the Brushes palette:

Drag a brush to the new location in the Brushes palette. You can move brushes only within 
their type. (For example, you cannot move a Calligraphic brush to the Scatter brush area.)

To duplicate a brush in the Brushes palette:

1 Select a brush to duplicate. To select multiple brushes, Ctrl-click (Windows) or 
Command-click (Mac OS) each brush to duplicate. To select a range of brushes, Shift-click 
to define the range.
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2 Do one of the following:

• Choose Duplicate Brush from the Brushes palette menu.

• Drag the selection to the New Brush button  in the Brushes palette.

To delete a brush from the Brushes palette:

1 In the Brushes palette, select the brush to delete. To select multiple brushes, Ctrl-click 
(Windows) or Command-click (Mac OS) each brush to delete. To select a range of brushes, 
Shift-click to define the range.

2 Do one of the following:

• Choose Delete Brush from the Brushes palette menu.

• Click the Delete Brush button  in the Brushes palette.

• Drag the selection to the Delete Brush button in the Brushes palette.

Creating brushes
You can create each of the four types of brushes in the Brushes palette. All brushes must 
be made up of simple open and closed path vectors. Brushes cannot have gradients, 
blends, other brush strokes, mesh objects, bitmap images, graphs, placed files, or masks.

• Art brushes and pattern brushes cannot include type. However, to achieve a brush 
stroke effect with type, create an outline of the type and then create a brush with the 
outline. (See “Modifying letterforms as graphic objects” on page 267.)

Creating a calligraphic brush
You can change the angle, roundness, and diameter of strokes painted with calligraphic 
brushes.

To create a calligraphic brush:

1 Click the New Brush button  in the Brushes palette, or choose New Brush from the 
palette menu. Select New Calligraphic Brush and click OK.

2 In the Name text box, enter a name for the brush (up to 30 characters).

3 Specify values for the angle, roundness, and diameter of the brush (the preview in the 
dialog box reflects your settings): 

• To set the ellipse angle of rotation, drag the arrowhead in the preview, or enter a value 
in the Angle text box.

• To set the roundness, drag a black dot in the preview away from or toward the center, 
or enter a value in the Roundness text box. The higher the value, the greater the 
roundness.

• To set the diameter, use the Diameter slider, or enter a value in the Diameter text box.

4 From each pop-up menu, choose the way in which you want to control variations in the 
angle, roundness, and diameter:

• Choose Fixed to use the value in the associated text box. For example, when the 
Diameter value is 20, Fixed always uses 20 for the brush diameter.

• Choose Random to use a random value within a specified range. When you choose 
Random, you also need to enter a value in the Variation text box, or use the Variation 
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slider, to specify the range by which the brush characteristic can vary. For each stroke, 
Random uses any value between that in the text box for the brush characteristic plus or 
minus the Variation value. For example, when the Diameter value is 15 and the Variation 
value is 5, the diameter can be 10, or 20, or any value in between.

• Choose Pressure (if you will use the brush with a graphics tablet) to use a value deter-
mined by the pressure of your stylus. When you choose Pressure, you also need to enter 
a value in the Variation text box, or use the Variation slider. Pressure uses the value in 
the text box for the brush characteristic minus the Variation value for the lightest tablet 
pressure. It uses the value in the text box for the brush characteristic plus the Variation 
value for the heaviest pressure. For example, when the Roundness value is 75% and the 
Variation value is 25%, the lightest stroke is 50% and the heaviest stroke is 100%. The 
lighter the pressure, the more angular the brush stroke.

5 Click OK.

Creating a scatter brush
You use artwork from an illustration to define the scatter brush.You can change the size, 
spacing, scatter pattern, and rotation of objects painted on a path with scatter brushes.

To create a scatter brush:

1 Select the artwork to be used as a scatter brush. 

2 Click the New Brush button  in the Brushes palette, or choose New Brush from the 
palette menu. Select New Scatter Brush and click OK.

3 In the Name text box, enter a name for the brush (up to 30 characters).

4 Drag each Minimum slider or enter a value in each leftmost text box for the brush’s size, 
spacing, scattering, and angle of rotation:

• Size controls the size of the objects.

• Spacing controls the amount of space between objects.

• Scatter controls how closely objects follow the path independently on each side of the 
path. The higher the value, the farther the objects are from the path.

• Rotation controls the angle of rotation of the objects.

5 From each pop-up menu, choose the way in which you want to control variations in the 
size, spacing, scattering, and rotation:

• Choose Fixed to use the value in the associated text box. For example, when the Scatter 
value is 50%, Fixed always uses 50% to scatter objects along the path.

• Choose Random to use a random value. When you choose Random, you also need to 
enter a value in the rightmost text box, or use the Maximum slider, to specify the range 
by which the brush characteristic can vary. For each stroke, Random uses any value 
between the Minimum and the Maximum value. For example, when the Minimum 
value is 50% and the Maximum value is 100% for Size, the objects’ sizes can be 50%, or 
100%, or any size in between. 

• Choose Pressure (if you will use the brush with a graphics tablet) to use a value deter-
mined by the pressure of your stylus. When you choose Pressure, you also need to enter 
a value in the rightmost text box, or use the Maximum slider. Pressure uses the 



Using Help | Contents | Index Back 84  

Adobe Illustrator Help Drawing 

Using Help | Contents | Index Back 84  

Minimum value for the lightest tablet pressure and the Maximum value for the heaviest 
pressure. The heavier the stroke, the larger the objects. 

Note: To keep the same range of values between the two sliders, Shift-drag the sliders. 
To move the sliders an equal value apart or together, Alt-drag (Windows) or Option-drag 
(Mac OS) them.

6 Choose a relative orientation from the Rotation Relative To pop-up menu:

• For Page, the angle of rotation of scattered objects is relative to the page (0 degrees 
points to the top).

• For Path, the angle of rotation of scattered objects is relative to the path (0 degrees is 
tangent to the path).

7 Choose a method of colorization from the Method pop-up menu. (See “Choosing a 
colorization method” on page 86.)

8 Click OK.

Creating an art brush
You use artwork from an illustration to define the art brush.You can change the direction 
and size of objects painted along a path with art brushes and also flip the objects along 
the path or across the path.

To create an art brush:

1 Select the artwork to be used as an art brush. 

2 Click the New Brush button  in the Brushes palette, or choose New Brush from the 
palette menu. Select New Art Brush and click OK.

3 In the Name text box, enter a name for the brush (up to 30 characters).

4 For Direction, click a button for the direction in which you want the art to be drawn as 
you drag the paintbrush. In each button, the arrowhead represents the end of the brush 
stroke. 

When you drag the paintbrush in the artwork window, the art is drawn as follows:

• For , the left side of the art is the end of the stroke.

• For , the right side of the art is the end of the stroke.

• For , the top of the art is the end of the stroke.

• For , the bottom of the art is the end of the stroke.

5 For Size, enter a percentage by which to scale the art in the Width text box. To preserve 
the proportion, select Proportional.

6 To change the orientation of the art on the path, choose Flip Along or Flip Across.

7 Choose a method of colorization from the Method pop-up menu. (See “Choosing a 
colorization method” on page 86.)

8 Click OK.
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Creating a pattern brush
To create a pattern brush, you can use pattern swatches in the Swatches palette or artwork 
from an illustration to define the tiles in the brush. When using swatches to define a 
pattern brush, you can use preloaded pattern swatches, or create your own Pattern 
swatches. 

You can change the size, spacing, and orientation of pattern brushes. In addition, you can 
apply new artwork to any of the tiles in a pattern brush to redefine the brush. 

To apply new art to tiles in existing pattern brushes, you select pattern swatches from the 
scroll list in the Pattern Brush Options dialog box. (The scroll list displays all the Pattern 
swatches available in the Swatches palette.) 

To create a pattern brush using pattern swatches in the Swatches palette:

1 Click the New Brush button  in the Brushes palette, or choose New Brush from the 
palette menu. Select New Pattern Brush and click OK.

2 In the Name text box, enter a name for the brush (up to 30 characters).

3 Click a tile button for the tile you want to define. For example, to define the side tile, 
click the Side tile button .

Components of a tile 
A. Side tile B. Outer Corner tile C. Inner Corner tile D. Start tile E. End tile 

4 In the scroll list, select a Pattern swatch to apply to the selected tile.

The selected swatch appears in the selected tile button.

Note: To restore a pattern setting to its original value when modifying an existing Pattern 
brush, select Original from the scroll list.

5 Repeat steps 3 and 4 to apply Pattern swatches to other tiles as needed.

6 For Size, enter values for the scale (which preserves the proportion) and the spacing 
between tiles.

7 To change the orientation of the pattern on the path, choose Flip Along or Flip Across.

8 For Fit, choose how to fit the tiles on the path:

• Stretch to Fit lengthens or shortens the pattern tile to fit the object. This option can 
result in uneven tiling.

EDCBA
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• Add Space to Fit adds blank space between each pattern tile to apply the pattern 
proportionally to the path.

• Approximate Path (for rectangular paths only) fits tiles to the closest approximate path 
without changing the tiles. This option applies the pattern slightly inside or outside the 
path, rather than centered on the path, to maintain even tiling.

Results of different tile option settings 
A. Default tile and Fit options B. Stretch to Fit C. Add Space to Fit D. Approximate Path

9 Choose a method of colorization from the Method pop-up menu. (See “Choosing a 
colorization method” on page 86.)

10 Click OK.

Note: After you define a Pattern brush with Pattern swatches, you can delete the Pattern 
swatches from the Swatches palette if you don’t plan to use them for additional artwork.

To create a pattern brush using artwork from an illustration:

1 Create or display the artwork that you want to use as a Pattern brush. (See “Creating 
and working with patterns” on page 206.) Make sure to create artwork for each of the tiles 
in the Pattern brush, up to five tiles depending on the brush configuration desired.

2 In the Brushes palette, make sure the brushes are displayed by icon. (If necessary, 
choose Thumbnail View from the palette menu.)

3 Drag the artwork to be used as the side tile onto the Brushes palette.

4 Select New Pattern Brush, and then click OK.

5 In the Name text box, enter a name for the brush (up to 30 characters), and then 
click OK.

6 Alt-drag (Windows) or Option-drag (Mac OS) artwork for additional tiles onto the 
appropriate section of the entry for the brush in the Brushes palette, and then click OK 
after adding each tile. The side tile already appears in the second section. Alt-drag or 
Option-drag artwork for the outer corner tile to the first section. Alt-drag or Option-drag 
artwork for the inner corner tile, start tile, and end tile to the remaining sections.

Choosing a colorization method
For Scatter, Art, and Pattern brushes, you can choose a method by which to colorize a 
brush. 

A

B

C

D
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To choose a colorization method:

1 With the options dialog box for the selected brush type open, choose an option from 
the Method pop-up menu:

• None displays colors as they appear in the brush in the Brushes palette. Choose None to 
keep a brush the same colors as in the Brushes palette.

• Tints displays the brush stroke in tints of the stroke color. Portions of the art that are 
black become the stroke color, portions that aren’t black become tints of the stroke 
color, and white remains white. If you use a spot color as the stroke, Tints generates 
tints of the spot color. Choose Tints for brushes that are in black and white, or when you 
want to paint a brush stroke with a spot color.

• Tints and Shades displays the brush stroke in tints and shades of the stroke color. Tints 
and Shades maintains black and white, and everything between becomes a blend from 
black to white through the stroke color. Because black is added you may not be able to 
print to a single plate when using Tints and Shades with a spot color. Choose Tints and 
Shades for brushes that are in grayscale.

• Hue Shift uses the key color in the brush artwork, as shown in the Key Color box. 
(By default, the key color is the most prominent color in the art.) Everything in the 
brush artwork that is the key color becomes the stroke color. Other colors in the brush 
artwork become colors related to the stroke color. Hue Shift maintains black, white, 
and gray. Choose Hue Shift for brushes that use multiple colors. You can change the key 
color. 

For information and samples about each choice, click Tips.

Note: You can experiment with different colorization methods to achieve the result 
you want.

To change the key color:

1 With the options dialog box for the selected brush type open, click the Key Color 
eyedropper.

2 Move the eyedropper to the preview in the dialog box, and click the color you want to 
use as the key color. The color in the Key Color box changes.

3 Click the eyedropper again to deselect it.

Modifying existing brushes
You can modify existing brushes. When you change the options of a brush, you can apply 
the changes to brush strokes already drawn in the artwork with the brush, or apply the 
changes to new strokes only. You can also change the brush stroke options of a selected 
object without affecting other objects in the artwork and without changing the brush’s 
attributes.

To modify an existing brush:

1 Double-click the brush in the Brushes palette, or select the brush and choose Brush 
Options from the palette menu.

2 Choose an option for applying changes to pre-existing strokes:

• Click Apply To Strokes to change pre-existing strokes. (The modified brush will be 
applied to new strokes as well.)
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• Click Leave Strokes to leave pre-existing strokes unchanged, and apply the modified 
brush to new strokes only.

3 Change options, and click OK.

To change options of a selected object without changing the brush attributes for all 
objects:

1 Select a brush in the artwork.

2 Choose Options of Selected Object from the Brushes palette menu, or click the Options 
of Selected Object button  in the palette.

3 Change the options, and click OK. Only the selected objects are changed with the new 
options. Any other objects in the artwork that were painted with the brush remain with 
the original brush attributes. Attributes of the brush are not affected; the next time you 
use the brush, it uses the current attributes.

Note: To reset changed objects to the original brush options, select the objects, apply a 
different brush to them, and then reapply the original brush.

To modify brushes by dragging into your artwork:

1 Select a brush from the Brushes palette.

2 Drag the brush into your artwork.

3 Make the changes you want.

Drag the modified brush into the Brushes palette.

Using the brush libraries
You can import brushes from other Adobe Illustrator files into a palette associated with 
the current file using the Brush Libraries command. These libraries are stored in the 
Brushes folder, located in the Presets folder inside the Adobe Illustrator application folder. 
You cannot add, delete, or edit brushes in a library; however, once you import a brush, 
you can change its attributes.

To import a brush from a Brush Library to the current Brushes palette:

1 Make sure the Brushes palette into which you want to import a brush is open.

2 Choose Window > Brush Libraries > Brush Library name. To locate a Brush Library not 
stored in the Brushes folder, choose Window > Brush Libraries > Other Library.

3 Select the brush you want, and then if the brush does not automatically appear in the 
Brushes palette, do one of the following:

• Use the selected brush in the current artwork (recommended for one or two brushes at 
a time). Once you use it in the artwork, the brush is copied from the Brush Library to the 
Brushes palette.

• Drag the selected brush to the current Brushes palette (recommended for multiple 
brushes at a time).

To have a Brush Library appear in the Brush Libraries menu:

1 Drag the Brush Library file into the Brushes folder.

2 Restart Adobe Illustrator.
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To create a Brush Library:

1 Create an Adobe Illustrator file containing the brushes you want in the Brush Library.

2 Save the file in the Brushes folder.

3 Restart Adobe Illustrator.

Tips for using brushes
When you work with brushes, keep the following points in mind:

• You can often use Scatter brushes and Pattern brushes to achieve the same effect. 
However, one way in which they differ is that Pattern brushes follow the path exactly, 
while Scatter brushes do not.

Arrows in a Pattern brush bend to follow the path (left); arrows remain straight in a Scatter 
brush (right).

• If you apply a brush to a closed path and want to control the placement of the end of 
the path, select the scissors tool and split the path. To change again, select the 
endpoints, choose Object >Path > Join, and use the scissors again. (See “Splitting paths 
with the scissors tool” on page 61.)

• To select all brush stroke paths in the current artwork, choose Select > Object > Brush 
Strokes.

• For better performance when creating a brush from art that contains multiple 
overlapping paths filled with the same color and with no stroke, use the Add filter in the 
Pathfinder palette before you create the brush. (See “Creating a final shape quickly” on 
page 148). 

Tracing artwork 
There may be times when you want to base a new drawing on an existing piece of 
artwork. For example, you may want to create a graphic based on a pencil sketch drawn 
on paper or on an image saved in another graphics program. In either case, you can bring 
the image into Illustrator and trace over it. You can create a layer to use especially as a 
template. 

You can trace artwork in the following ways, depending on the source of the artwork to 
trace and how you want to trace it:

• Use the auto trace tool (ICON) to trace automatically any image you bring into 
Illustrator.

• Place any EPS, PDF, or image file into an Illustrator file as a template layer and manually 
trace over it using the pen or pencil tool. (See “Changing the display of layered artwork” 
on page 219.)
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Tracing with the auto trace tool
The auto trace tool traces any image shape automatically. With this tool, you can click the 
edge of a shape you want to trace, and Illustrator draws the entire outline of the shape. 
You can use the auto trace tool to trace lines as well as shapes. When you use the auto 
trace tool to trace a line, it travels all the way around the line and comes back to where you 
clicked, forming a closed path.

The auto trace tool is especially suited to tracing simple shapes and lines. For the best 
results when tracing artwork, trace simpler shapes with the auto trace tool and draw more 
complex shapes with either the pencil tool or the pen tool. You can also use a dedicated 
tracing program such as Adobe Streamline™.

To trace a bitmap image shape: 

1 Open the file that contains the bitmap image you want to trace.

2 Select the auto trace tool .

3 Position the cross hair on the object you want to trace. You must position the cross hair 
within 6 pixels of the edge of a bitmap shape. The auto trace tool is guided by the 
boundary between differently shaded areas. 

4 Do one of the following:

• To trace the entire object, click the object. Illustrator draws the path, beginning where 
you clicked, and follows the shape, keeping the shape on its right. 

The path may be drawn clockwise or counterclockwise, depending on where you click and 
on the shape of the path.

• To trace part of the object, drag the pointer from the place on the bitmap shape where 
you want the path to start to the place where you want the path to end. When tracing 
only part of an image, you must start and stop dragging within 2 pixels of the edge of 
the shape.

• To connect a new auto trace path to an existing auto trace path, start dragging at the 
anchor point where you want the paths to connect. 

Setting the auto trace gap distance
The lines and shapes in bitmap images often contain gaps that become visible when you 
enlarge your view of the image. You can control the accuracy with which the auto trace 
tool traces these gaps using the Tracing Gap option in the Type & Auto Tracing Preferences 
dialog box. 

The gap distance setting tells the auto trace tool to ignore gaps that are equal to or less 
than the number of pixels you specify. For example, setting the distance to 1 tells the auto 
trace tool to ignore gaps of 1 pixel or less.

To set the auto trace gap distance: 

1 Choose Edit > Preferences > Type & Auto Tracing (Windows and Mac OS 9) or 
Illustrator > Preferences > Type & Auto Tracing (Mac OS X).

Enter 0 (the default), 1, or 2 in the Tracing Gap text box. The value is calculated in number 
of pixels. Click OK. 
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Working with Objects

Correcting mistakes
You can use the Undo command to correct mistakes you make while using the Adobe 
Illustrator program. You can even undo an operation after you choose the Save command 
(but not if you closed and then reopened the file). If an operation cannot be undone, 
the Undo command is dimmed. 

Depending on how much memory is available, you can undo an unlimited number of the 
last operations you performed, in reverse order, by repeatedly choosing the Undo 
command. The Illustrator performance is usually not affected by the number of undo 
levels you choose; however, if you are trying to display complex artwork, you may receive 
a message asking you to reduce the number of undo levels because of insufficient 
memory.

You can also revert a file to the version that was last saved (but not if you closed and then 
reopened the file). 

To undo or redo an operation:

Choose Edit > Undo or Edit > Redo. (Depending on the memory available to your system, 
you can choose Undo an unlimited number of times.) 

To change the minimum number of undo levels:

1 Choose Edit > Preferences > Units & Undo (Windows and Mac OS 9) or Illustrator > 
Preferences > Units & Undo (Mac OS X).

2 Enter a value for Minimum Undo Levels, and click OK. The default undo level is 5. 

To revert a file to the last saved version:

Choose File > Revert. You cannot undo this action.

Using rulers
Illustrator can display rulers, one along the top and one along the left side of the illus-
tration window. 

When you open a new file, the rulers are not visible, but you can display them at any time. 
These rulers are a tool for accurately placing and measuring objects on the artboard. As 
you scroll and zoom around the file, the rulers adjust accordingly.

To show or hide rulers: 

Choose View > Show Rulers, or View > Hide rulers.
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Defining ruler units
The large tick marks on the rulers indicate the unit of measure (such as inches), and the 
small tick marks indicate increments of the unit of measure (such as 1/8 inch). When you 
magnify or reduce your view, the increments of the unit of measure reflect the change in 
magnification. 

The default units of measure for the rulers are points (a point equals .3528 millimeter). You 
can change the unit of measure to inches, millimeters, centimeters, picas (a pica equals 12 
points or 4.2333 millimeters), or pixels by using the Units & Undo panel of the Preferences 
dialog box or the Artboard panel of the Document Setup dialog box.

The unit of measure that you set for the rulers applies when you measure objects, move 
and transform objects, set grid and guides spacing, and create ellipses and rectangles. It 
does not affect the units in the Character and Paragraph palettes, which always display 
size, leading, vertical shift, line width, and line dash in the units set in the Type pop-up 
menu in the Units & Undo Preferences dialog box. (See “Setting type attributes” on 
page 256.)

To set the ruler unit of measure for all files:

1 Choose Edit > Preferences > Units & Undo (Windows and Mac OS 9) or Illustrator > 
Preferences > Units & Undo (Mac OS X). 

2 From the General pop-up menu, choose the unit of measure you want to use, and 
click OK.

To set the ruler unit of measure for only the current file:

1 Choose File > Document Setup. Choose Artboard from the pop-up menu at the top left 
of the Document Setup dialog box.

2 From the Units pop-up menu, choose the unit of measure you want to use, and click OK. 

You can quickly change the units of measure by right-clicking (Windows) or Control-
clicking (Mac OS) the ruler and choosing a new unit of measure from the menu that 

appears.

Automatically converting unit values in text boxes
If you use a unit other than the preset unit to enter values, Illustrator converts it to the set 
unit. For example, entering 3cm in a text box set to inches converts the value to 1.1811 
inches.

You can also add, subtract, multiply, divide, define percentages, and perform other mathe-
matical operations in any Illustrator text box that accepts numeric values. For example, 
when specifying the size of a rectangle, you can type 72 pt + 2cm for the height. Illustrator 
performs the calculation and uses the result. 

The following rules apply when entering unit values:

• You can use the following units and abbreviations in text boxes: inch, inches, in, milli-
meters, millimetres, mm, Qs (one Q equals 0.25 millimeter), centimeters, centimetres, 
cm, points, p, pt, picas, pc, pixel, pixels, and px. 

• Units are in points by default unless a different unit of measure was set in Edit > 
Preferences > Units & Undo (Windows and Mac OS 9) or Illustrator > Preferences > Units 
& Undo (Mac OS X). 
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• When mixing picas and points, you can enter values as XpY, where X and Y are the 
number of picas and points (for example, 12p6 for 12 picas, 6 points). 

• A value without a specified unit uses the default unit for that text box, unless it follows a 
value with a specified unit. For example, in a text box that uses inches by default, typing 
3 + 6 would equal 3 inches plus 6 inches, or 9 inches. Typing 3cm + 6 would equal 3 
centimeters plus 6 centimeters, or 3.5433 inches.

• You can use percentages in combination with units. For example, typing 3cm*50% 
would equal 3 centimeters multiplied by 50%, or 1.50 cm. Typing 50pt + 25% would 
equal 50 points plus 25% of 50 points, or 62.5 points. 

Changing the ruler origin
The point where 0 appears on each ruler is called the ruler origin. When you open a file, 
the position of the ruler origin depends on the View option selected in the Artboard 
panel of the Document Setup dialog box. Generally, if you selected either the Single Full 
Page or the Tile Full Pages option, the default ruler origin is located at the lower left corner 
of page 1. 

When you change the ruler setting, the new setting becomes the default for the file 
whenever that file is opened. You can change the origin for the rulers at any time. For 
example, you may be working on a 3-inch-by-5-inch card that is centered on an 8.5-inch-
by-11-inch page. Setting the ruler origin to line up with the 3-by-5-inch artwork rather 
than the 8.5-by-11-inch page can make precision editing easier for you.

Note: The position of the ruler origin affects the tiling of patterns, as well as the bounding 
box information for the Separation Setup command. (See “Specifying the printing 
bounding box in the separation” on page 355.)

To change the ruler origin: 

1 Move the pointer to the upper left corner of the rulers where the rulers intersect. 

2 Do one of the following:

• Drag the pointer to where you want the new ruler origin. As you drag, a cross hair in the 
window and in the rulers indicates the changing ruler origin. 

• Double-click the upper-left corner where the rulers intersect to restore the default 
settings.

Using the measure tool
The measure tool calculates the distance between any two points in the work area. When 
you measure from one point to another, the distance measured is displayed in the Info 
palette. The Info palette shows the horizontal and vertical distances from the x and y axes, 
the absolute horizontal and vertical distances, the total distances, and the angle 
measured. 

All measurements except the angle are calculated in the unit of measure currently set in 
the Units & Undo Preferences dialog box or in the Artboard panel of the Document Setup 
dialog box. (See “Defining ruler units” on page 92.)

To measure the distance between two points: 

1 Select the measure tool .
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2 Do one of the following:

• Click the two points to measure the distance between them.

• Click the first point and drag to the second point. Shift-drag to constrain the tool to 
multiples of 45 degrees.

Using guides and grids
To help align text and graphic objects on the page, you can use background grids or you 
can create and display alignment outlines called guides. 

Grids normally appear as lines or dots behind the artwork, and they do not print. You use 
grids to lay out objects or elements symmetrically. Selected artwork and tools snap to the 
grid if Snap To Grid is turned on. Grid spacing, color, and style can be different for each file. 

Note: When your document’s viewing mode is Pixel Preview, the Snap to Grid command 
on the View menu changes to Snap to Pixel. For more information, see “Working in pixel 
preview mode” on page 292.

Guides act as alignment tools. They also do not print. You can define any object as a guide 
to which you want to align artwork. Selected artwork and tools snap to guides when they 
are within tolerance of the guide. Guide color and style are the same for all files. 
(See “Setting guide and grid preferences” on page 95.)

Using guides
You can create two kinds of guides:

• Ruler guides are straight horizontal or vertical lines created with the ruler. These guides 
are the simplest to make and are useful for setting alignment lines across the length or 
width of the work area.

• Guide objects are objects (such as lines, rectangles, or any other artwork consisting of 
paths, except type) that are converted to guides. Using guide objects can help you plan 
and create your artwork around one or more objects. You can convert guide objects 
back into graphic objects at any point.

New guides are locked in place to orient your artwork. However, you can unlock a guide to 
select, move, delete, modify, or revert it to a graphic object.

By default, objects are aligned with guides whenever they are dragged within 2 pixels of 
the guide. (See “Moving, copying, and deleting objects” on page 102.)

To create a ruler guide:

1 If the rulers are not already displayed, choose View > Show Rulers.

2 Position the pointer on the left ruler for a vertical guide or on the top ruler for a 
horizontal guide. Press Alt (Windows) or Option (Mac OS) to switch the ruler guide from 
horizontal to vertical, and vice versa.

3 Drag the ruler guide into position.

To make working with multiple guides easier, place all guides on a single layer. You can 
then choose the layer to select all guides for moving or adjusting. (See “About layers” 

on page 215.)
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To convert an object into a guide object:

1 Select an object, a group of objects, or any combination of objects and groups.

2 Choose View > Guides > Make Guides.

To move, delete, or release a guide:

1 Choose View > Guides > Lock Guides to lock or unlock the guide. When a guide is 
locked, a check mark appears next to the Lock Guides command. 

2 Select the guide you want to move, delete, or release, and do one of the following:

• Move the guide by dragging or copying.

• Delete the guide by pressing Backspace or Del (Windows) or Delete (Mac OS), or by 
choosing Edit > Cut or Edit > Clear.

• Delete all guides at once by choosing View > Guides > Clear Guides.

• Release the guide object, turning it back into a regular graphic object, by choosing 
View > Guides > Release Guides.

To show or hide guides:

Choose View > Guides > Show Guides to show all guides or View > Hide Guides to hide 
them.

Using grids
You can choose between two grid styles—dots and lines—and you can change the color 
of the grid by using either predefined grid colors or colors you select using a color picker.

Spacing of grids is defined by two values: the distance between major lines, and the 
spacing between subdivisions. The visibility of the grid and snapping to the grid are 
controlled by the Show Grid command and the Snap to Grid command in the View menu. 

Setting guide and grid preferences
Use the Guides & Grid preferences to set the color and style of guides and the grid, and 
grid spacing. 

To set guide and grid preferences:

1 Choose Edit > Preferences > Guides & Grid (Windows and Mac OS 9) or Illustrator > 
Preferences > Guides and Grid (Mac OS X).

2 Set options for guides and the grid:

• For Color, choose a color for guides, or the grid, or both. If you choose Other, click the 
color box, choose a color from the color picker, and click OK. 

• For Style, choose a display option for guides, or the grid, or both. 

• For Gridline Every, enter a new value (and unit of measure if necessary) for the spacing 
of primary gridlines.

• For Subdivisions, enter a value to subdivide the grid.

• For Grids in Back, select the option to display the grid behind all artwork; deselect the 
option to display the grid in front of all artwork.

3 Click OK.



Using Help | Contents | Index Back 96  

Adobe Illustrator Help Working with Objects 

Using Help | Contents | Index Back 96  

Using Smart Guides
Smart Guides are temporary, “snap to” guides that help you create, align, edit, and 
transform objects relative to other objects. You can also use Smart Guides when rotating, 
scaling, and shearing objects. Objects can snap to locked objects and objects on locked 
layers.

You choose the point on the selected object at which you want to snap by selecting the 
object at that point. Illustrator determines additional points on artwork to create guides 
and snapping points. These points are determined by the last objects the cursor has 
passed over with the selected object.

You can create intersecting Smart Guides by passing over two Smart Guide lines, and then 
moving your selected object to the intersection point. 

As you create, align, move, edit, and transform objects, Smart Guides appear from any 
anchor point on a nearby object over which the pointer recently passed. The direction, 
angle, tolerance, and appearance of Smart Guides are determined by settings in 
Preferences.

To turn Smart Guides on or off:

To turn Smart Guides on or off, choose View > Smart Guides. A check mark appears next to 
the command when Smart Guides are turned on. 

To change Smart Guide preferences:

1 Choose Edit > Preferences > Smart Guides (Windows and Mac OS 9) or Illustrator > 
Preferences > Smart Guides (Mac OS X).

2 Specify options for Smart Guides:

• Select Text Label Hints to display information about the position the cursor is currently 
snapped to (such as center) as you manipulate the cursor. 

• Select Construction Guides to see guidelines in the file as you use Smart Guides.

• Select Transform Tools to have Smart Guides help when you scale, rotate, and shear 
objects.

• Select Object Highlighting to highlight the object below the pointer as you drag 
around it. 

3 Click a text box and set an angle at which you want guide lines drawn from the anchor 
points of a nearby object (the preview reflects your settings). You can set up to six angles. 
Do one of the following:

• Enter an angle in the selected Angles text box. 

• Choose a set of angles from the Angles pop-up menu.

• Choose a set of angles from the pop-up menu and change one of the values in the text 
box to customize a set of angles.

4 Type a value in the Snapping Tolerance text box to specify the number of points the 
pointer must be from another object for Smart Guides to take effect. Then click OK.
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How Smart Guides work
When Smart Guides are turned on and you move the cursor over your artwork, the cursor 
looks for objects, page boundaries, and intersections of construction guides to snap to 
that are within the tolerance range set in Smart Guides Preferences. 

You can use Smart Guides in the following ways when you create, move, and transform 
objects:

• When you create an object with the pen or shape tools, use the Smart Guides to 
position the new object’s anchor points relative to the other object. 

• When you move an object, use the Smart Guides to align to the point on the object that 
you have selected. You can align to the anchor point at the corner of a selected object 
near the bounding box. To do so, select the object just inside the bounding box handle. 
If the tolerance is 5 points or greater, you can snap to the corner point from 5 points 
away. (See “Using the bounding box” on page 99.)

• When the Transform Tools option is selected in Smart Guides Preferences and you 
transform an object, Smart Guides appear to assist the transformation. 

Note: When Snap to Grid is turned on, you cannot use Smart Guides (even if the menu 
command is selected).

Selecting objects
Before you can modify an object, you need to distinguish it from the objects around it. 
You do that by selecting the object with a selection tool or command. Once you’ve 
selected an object, or a part of an object, you can edit it by moving or copying, deleting, 
or adjusting paths.

Note: You can drag to move an object you have just selected with the selection, direct-
selection, and group-selection tools, but not with the lasso or direct-lasso tools.

Using the selection tools
You select objects with the following selection tools:

• The selection tool  lets you select entire paths, objects, and groups by selecting any 
spot on them (or within them if the path, object, or group is filled). When the selection 
tool is over an unselected path, object, or group, it changes to . When it is over a 
selected path, object, or group, the tool changes to . When it is over an anchor point, 
a hollow square appears next to the arrow  or , depending on whether the path, 
object, or group is selected or not. 

• The direct-selection tool  lets you select individual anchor points or segments on a 
path. All direction lines then appear on that part of the path for adjusting. When the 
direct-selection tool is over an unselected path or object, it changes to . When it is 
over the anchor point of a selected path or object, it changes to .

• The group-selection tool  lets you select an object within a group, a single group 
within multiple groups, or a set of groups within the artwork. Each additional click adds 
all objects from the next group in the hierarchy. (See “Grouping and ungrouping 
objects” on page 110.)

• The lasso tool  lets you select entire paths and objects by dragging around any part of 
the path. 
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• The direct-lasso tool  lets you select individual anchor points or segments on a path 
by dragging around parts of a path. All direction lines then appear on that part of the 
path for adjusting. 

• The magic wand tool  lets you select objects of the same color, stroke weight, stroke 
color, opacity, or blending mode by clicking in a colored area.

To use the last-used selection, direct-selection, or group-selection tool when using 
any other tool (except these selection tools), hold down Ctrl (Windows) or Command 

(Mac OS).

To select an entire object or line:

1 Select the selection tool  or the group-selection tool .

2 Do one of the following:

• If the object is filled and you are in Preview view, click within the object.

Note: Clicking a filled object in Preview view selects the object only if the Use Area Select 
option in the General Preferences dialog box is selected. (See “Selecting filled objects” on 
page 100.)

• Click the path of the object.

• Click an anchor point of the object.

• Drag a dotted rectangle, called a marquee, around part or all of the object.

To select an entire object or line with the lasso tool:

1 Select the lasso tool .

2 Drag around or across the object.

To select a segment:

Do one of the following:

• Select the direct-selection tool , and then click within 2 pixels of the segment or drag a 
marquee over part of the segment.

• Select the direct-lasso tool , and drag around part of the segment.

When you select a segment, all of the anchor points on the path are displayed, including 
all direction lines and direction points on that part of the path if the selected segment is 
curved. Direction points appear as filled circles; selected anchor points appear as filled 
squares; unselected anchor points appear as hollow squares.

To deselect a segment:

Using a selection tool, Shift-click or Shift-drag over the path or segment you want to 
deselect. 

To add or remove selections with the selection, direct-selection, or group-selection 
tool:

Hold down Shift while selecting or deselecting additional objects or segments.

To add or remove selections with the lasso or direct-lasso tool:

1 Do one of the following:

• Hold down Shift while selecting to add to the selection.
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• Hold down Alt (Windows) or Option (Mac OS) to subtract from the selection.

Using the bounding box
When you select one or more objects with the selection tool, you see a bounding box 
around them. With the bounding box, you can move, rotate, duplicate, and scale objects 
easily by dragging the selection or a handle (one of the hollow squares surrounding the 
selected objects).

The bounding box creates a temporary border around the selected object. You see an 
outline of the selection as you drag it. When you release the mouse button, the object 
snaps to the current border created by the bounding box, and you see the object’s 
outline move.

Selected objects before (left) and after (right) scaling using the bounding box

If you are working in Pixel Preview mode and want the object to snap to pixels when you 
drag it, turn off Use Preview Bounds in the General panel of the Preferences dialog box.

To move, duplicate, or scale objects, use the selection tool . 

Note: You can also move and scale selected objects, as well as perform other transfor-
mation actions, using the free transform tool, transformation tools, and the Transform 
palette. (See “Transforming selected objects” on page 113.) 

If you rotate an object, its bounding box is also rotated. To reorient the bounding box 
to the page, choose Object > Transform > Reset Bounding Box.

To show or hide the bounding box:

Choose View > Show Bounding Box or View > Hide Bounding Box. 

To move objects with the bounding box:

1 Select one or more objects using the selection tool. 

2 Drag any part of the selection (but not a handle). 

To rotate objects with the bounding box:

1 Select one or more objects using the selection tool. 

2 Move the pointer near a corner handle so that it changes to a curve with arrows on 
both ends.

3 Drag the handle. 

To duplicate objects with the bounding box:

1 Select one or more objects using the selection tool. 

2 Alt-drag (Windows) or Option-drag (Mac OS) the selection (but not a handle).
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Selecting filled objects
The Use Area Select option in the General Preferences dialog box determines whether you 
can select a filled object in Preview view by clicking anywhere within the area or whether 
you must click a path segment or anchor point. By default, the Use Area Select option is 
on. In some cases, you may want to turn off the Use Area Select option—for example, 
when you work with overlapping filled objects. 

With Use Area Select option off, dragging selects points and segments within marquee. 

With Use Area Select option on, dragging selects object.

To turn the Use Area Select option on or off:

1 Choose Edit > Preferences > General (Windows and Mac OS 9) or Illustrator > 
Preferences > General (Mac OS X).

2 Select or deselect the Use Area Select option, and click OK.

Selecting and deselecting multiple objects 
You can select several objects at a time and then move, paint, group, transform, or edit 
them using any editing tool. You deselect objects when you no longer want to edit them. 
You can deselect one object, several objects, or all objects in your artwork.

You can also select objects based on their paint style, stroke color, stroke weight, style, 
blending mode, opacity, and whether they are masks, stray points, or brush strokes. For 
more information, see “Changing global colors and tints” on page 163. 

Note: Objects that have been locked or hidden are not selected with the selection 
commands. (See “Locking and hiding objects” on page 112.)

To select multiple objects:

Do one of the following:

• With the selection tool, drag a marquee over all of the objects.

• With an object selected, Shift-drag a marquee over other objects to select.

• With the selection tool, select an object and then Shift-click to select additional objects. 

To select all objects in a file:

Choose Select > All. 
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To deselect all objects in a file: 

Do one of the following:

• Using a selection tool, click or drag at least 2 pixels away from any object.

• Choose Select > Deselect. 

To select all unselected objects, and deselect all selected objects:

Choose Select > Inverse. 

To repeat the last type of selection you made:

Choose Select > Reselect. 

To select all objects with the same attributes:

1 Select an object that has the attribute you want.

2 To select all objects with one of the following attributes, choose Select > Same > 
Blending Mode, Fill & Stroke, Fill Color, Opacity, Stroke Color, Stroke Weight, Style, or 
Symbol Instance. 

3 To select all objects with one of the following attributes, choose Select > Object > All on 
Same Layer, Direction Handles, Brush Strokes, Clipping Masks, Stray Points, or Text Objects. 

Note: You can also use the magic wand tool to select all objects with the same color, 
stroke weight, stroke color, opacity, or blending mode. (See “Using the magic wand tool” 
on page 101.)

Using the magic wand tool
Use the magic wand tool to select all objects in a document with the same or similar fill 
color, stroke weight, stroke color, opacity, or blending mode. You specify the color range, 
or tolerance, for the magic wand tool’s selection.

To use the magic wand tool:

1 Select the magic wand tool .

2 Do one of the following: 

• To create a new selection, click the object containing the attributes you want to select.

• To add to the current selection, press Shift and click the attributes you want to add.

• To subtract from the current selection, press Alt (Windows) or Option (Mac OS) and click 
the attributes you want to subtract. 

To set options for the magic wand tool:

1 Do one of the following to open the Magic Wand palette:

• Double-click the magic wand tool in the toolbox.

• Choose Window > Magic Wand.

2 Do any or all of the following, and then click OK:

• Enter a Tolerance value in pixels for Fill Color. Values can range from 0 to 255 for RGB or 
0 to 100 for CMYK. Enter a low value to select colors similar to the pixel you click, or 
enter a higher value to select a broader range of colors. Deselect Fill Color if you don’t 
want to select objects according to their color.
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• Select Show Stroke Options from the Magic Wand palette menu; then select the stroke 
options you want to use and specify tolerance values in pixels. 

• Select Show Transparency Options from the Magic Wand palette menu; then select the 
options you want and enter a tolerance value for Opacity, if necessary. (Blending Mode 
selects all objects with blending modes applied.)

Saving, editing, and loading selections
Using the commands in the Select menu, you can save, edit, and load selections for reuse 
in your artwork. 

To save a selection:

1 Select one or more objects on the artboard, and choose Select > New Selection.

2 In the New Selection dialog box, enter a name in the Name text box, and click OK.

The new selection name appears in the Select menu.

To delete a saved selection or change its name:

1 Choose Select > Edit Selection.

2 Select the selection you want to edit, do one of the following, and then click OK:

• Type a new name in the Name field.

• Click Delete to remove the selection from the list.

Moving, copying, and deleting objects 
You can move objects in your artwork by cutting them from one spot and pasting them 
into another, by dragging them, and by using the arrow keys, the Move dialog box, and 
the Transform Each dialog box. Dragging also enables you to copy objects between open 
Illustrator files and Photoshop files.

Note: You can also move objects using the Transform palette. (See “Using the Transform 
palette” on page 121.)

To set general preferences that affect how objects move:

1 Choose Edit > Preferences > General (Windows and Mac OS 9) or Illustrator > 
Preferences > General (Mac OS X). 

2 Choose options for Preferences:

• Enter an angle between 0 and 360 degrees in the Constrain Angle text box to rotate the 
x and y axes. The rotation of the axes determines how drawing and movement are 
constrained when you hold down Shift. (See “Rotating the x and y axes” on page 107.)

• Select Transform Pattern Tiles to specify whether you want to transform any patterns 
within objects when you apply a transformation such as scaling, rotating, or shearing. 
(See “Creating and working with patterns” on page 206.)

• Deselect Use Area Select to select objects underneath filled objects by clicking an 
anchor point or path segment (in Preview view). (See “Selecting filled objects” on 
page 100.)
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3 Click OK. 

Note: Smart Guides preferences also affect how objects move.

To set keyboard preferences that affect how objects move:

1 Choose Edit > Preferences > General (Windows and Mac OS 9) or Illustrator > 
Preferences > General (Mac OS X).

2 In the Keyboard Increment text box, enter the distance you want each press of an arrow 
key to move a selection, and then click OK.

To move or copy an object by pasting:

1 Select one or more objects that you want to cut or copy.

2 Choose Edit > Cut or Edit > Copy. 

Note: To copy a bitmap version of the selected object onto the Clipboard for pasting into 
Adobe Photoshop, choose Edit > Copy. (See “Using the Clipboard to copy artwork” on 
page 104.)

3 To paste an object into another file, open the file and choose one of the following 
commands: 

• Edit > Paste to paste the objects into the center of the active window. 

• Edit > Paste in Front to paste the object directly in front of the selected object.

• Edit > Paste in Back to paste the object directly in back of the selected object.

Note: The Paste in Front and Paste in Back commands paste the object in the same 
position on the new file’s artboard as in the original file. 

To move an object or a copy of an object by dragging:

1 Select the object. 

You can also select multiple objects.

2 Position the pointer on an anchor point or path segment of the selected object. In 
Preview view, you can click anywhere on the object when the Use Area Select option is 
selected in General Preferences. 

3 Drag the object to its new location. Shift-drag to constrain the object to multiples of 
45 degrees. 

You can use the Snap to Point command in the View menu to have the cursor snap to an 
anchor point or guide when you drag an object within 2 pixels of the anchor point or 
guide. Snap to Point is turned on when a check mark appears by the menu command. 

To drag a copy of the object, press Alt (Windows) or Option (Mac OS) as you drag.

Note: You can use this technique to drag copies of objects between Illustrator and 
Photoshop files. (See “Using the drag-and-drop feature to copy artwork” on page 105.)

To move an object by using the arrow keys:

1 Select the object. 

2 Press the arrow key for the direction in which you want to move the object.

The distance the object moves each time you press an arrow key is determined by the 
value specified in the Keyboard Increment text box in the General Preferences dialog box. 
The default distance is 1 point (1/72 of an inch, or .3528 millimeter).
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To move a selection with the free transform tool:

1 With the selection tool , select one or more objects to move. 

2 Select the free transform tool .

3 Drag any part of the selection (but not a handle). 

To move or copy an object a specified distance and direction:

1 Select the object.

2 Choose Object > Transform > Move.

When an object is selected, you can also double-click the selection tool—or press 
Enter or Return—to open the Move dialog box.

The Move dialog box displays the results of the last move or measure operation using the 
unit of measure set in the Units & Undo Preferences dialog box.

3 Do one of the following:

• Enter the horizontal and vertical distances that you want the object to move. Positive 
values move the object up and to the right of the x axis; negative values move the 
object down and to the left. 

• Enter the distance and angle for the move. The angle you enter is calculated in degrees 
from the x axis. Positive angles specify a counterclockwise move; negative angles 
specify a clockwise move. You can also enter values between 180 and 360 degrees; 
these values are converted to their corresponding negative values (for example, a value 
of 270° is converted to –90°).

Directions relative to the x axis

Using the Clipboard to copy artwork
You can use the Clipboard to transfer selections between an Illustrator file and other 
Adobe products such as Adobe Photoshop, Adobe Streamline™, Adobe® Dimensions®, 
and Adobe Premiere. The Clipboard is particularly useful for importing paths because 
paths are copied to the Clipboard as PostScript language descriptions. 

When you copy a selection to the Clipboard, it is copied in PICT and, depending on which 
option you specify, as PDF or AICB (a format similar to EPS). Artwork copied to the 
Clipboard is pasted as PICT in most other applications.

However, some applications take the PDF version (such as Adobe InDesign) or the AICB 
version (such as Adobe Photoshop). PDF preserves transparency, whereas AICB breaks 
selections into many smaller opaque objects that give an overall look of transparency. 
If you choose AICB, you can also specify whether you want to preserve the overall 
appearance of the selection or copy the selection as a set of paths (which can be useful 
for Photoshop).

90°
45°

– 45°

135°

–135°

0°180°

–90°
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To specify copying preferences:

1 Choose Edit > Preferences > Files & Clipboard (Windows and Mac OS 9) or Illustrator > 
Preferences > Files & Clipboard (Mac OS X).

2 Select one or more of the following formats:

• PDF to copy the selection as PDF.

• AICB to copy the selection as AICB. You can then select whether to preserve the 
appearance or paths of the selection in AICB format.

3 Click OK.

To copy using the Clipboard:

1 Select the object or objects you want to copy in a non-Illustrator file. Then choose Edit > 
Copy.

2 In the Illustrator file to which you want to paste the object, choose Edit > Paste.

Note: Some file formats cannot be pasted into Illustrator, but they can be dropped into 
Illustrator by applications that support the drag-and-drop feature.

Using the drag-and-drop feature to copy artwork
The drag-and-drop feature lets you copy and move artwork between Illustrator and other 
applications. 

In Windows, the other application must be OLE-compliant. To copy an OLE object that 
contains .psd data, use the OLE Clipboard. (See your Windows documentation.) Dragging 
vector artwork from Adobe Illustrator or from other applications that use the Illustrator 
Clipboard converts the artwork to a bitmap image (also called raster format). 

In Mac OS, the application must support Macintosh Drag Manager.

To drag and drop selections of artwork between Illustrator and the desktop 
(Mac OS only):

1 Select the artwork you want to copy.

2 Drag the selection onto the desktop. Selections are copied to the desktop as a picture 
clipping, which can be dragged and dropped into the desired document. Picture clippings 
are converted to PICT format when dragged to the desktop.

To drag and drop artwork into a Photoshop image window:

1 Select the artwork you want to copy.

2 Open the Photoshop image into which you want to copy the selection.

3 Drag the selection toward the Photoshop window, and when a black outline appears, 
release the mouse button. To position the selection in the center of the Photoshop image, 
hold down Shift before dragging the selection. 

To drag and drop artwork into Photoshop as paths: 

1 Select the artwork you want to copy.

2 Open the Photoshop image into which you want to copy the selection.
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3 Hold down Ctrl (Windows) or Command (Mac OS), and drag the selection to the 
Photoshop document. When you release the mouse button, the selection becomes a 
Photoshop path. By default, selected objects are copied as bitmap images to the 
active layer. 

To drag and drop artwork into Illustrator from Photoshop: 

1 Open the Photoshop image from which you want to copy.

2 Select the artwork you want to copy.

3 Select the move tool  and drag the selection from Photoshop into the Illustrator file. 

Aligning and distributing objects vertically and horizontally
The Align palette enables you to align selected objects along the axis you specify. You can 
align objects along the vertical axis, using the rightmost, center, or leftmost anchor point 
of the selected objects. Or you can align objects along the horizontal axis, using the 
topmost, center, and bottommost anchor points of the selected objects. 

Note: Paragraph alignment of point type overrides the Align Objects options. (See “Speci-
fying alignment options” on page 273.)

You can also distribute objects evenly along the horizontal axis or vertical axis.

In addition, you can distribute the space between objects evenly, both horizontally and 
vertically. 

To align or distribute objects:

1 Select the objects to align or distribute.

2 Choose Window > Align. 

In the Align palette, you see the Align Objects and Distribute Objects options. If you don’t 
see the Distribute Spacing options, choose Show Options from the pop-up menu in the 
Align palette. 

3 Click the object to which you want the other objects to align.

4 Click the button for the type of alignment or distribution you want. 

Moving groups of objects
The Move option in the Transform Each dialog box moves objects in a selection in a 
specified or random direction. Use the Random option to give a slightly less rigid, more 
natural look to a group of items. For example, if you draw a brick wall and want the bricks 
to appear slightly offset from each other instead of perfectly aligned, you could select the 
Random option. 

To move groups of objects: 

1 Select the objects you want to move.

2 Choose Object > Transform > Transform Each.

3 In the Move Horizontal and Vertical text boxes, enter the distance you want to move the 
selected objects, or use the associated sliders. These numbers must be between –4000 
and 4000 points and must not cause the objects to move beyond the edge of the 
artboard.
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4 Do one of the following:

• To move the objects by the specified amounts, click OK.

• To move the objects randomly, but no more than the specified amounts, select the 
Random option. Then click OK. 

Offsetting objects
You can create a replica of a path, set off from the selected path by a specified distance, by 
using the Offset Path command. This is useful when you want to create concentric shapes 
or make many replications of a path at a regular distance from the original path. You can 
create an offset path from a closed path or an open path; if created from a closed path, the 
new offset path appears at the specified distance outside or inside the original path. 

You can apply the Offset Path command as a filter or as an effect. For more information on 
effects, see “Using effects” on page 235.

Use the Offset Path command to “convert” a mesh shape into a regular path. For 
example, if you have released an envelope, or want to convert a mesh shape for use in 

another application, apply the offset path filter with a setting of 0, and then delete the 
mesh shape. You can then edit the remaining path.

To create an offset path:

1 Do one of the following:

• To apply the command as a path command, select the paths you want to offset. Then 
choose Object > Path > Offset Path. 

• To apply the command as an effect, select an object or group in the artwork, or target a 
group or layer in the Layers palette. (For more information on targeting, see “Selecting 
artwork in layers” on page 221.) Then choose Effect > Path > Offset Path. 

2 Specify the offset distance, line join type, and miter limit. (For more information about 
line join type and miter limit, see “Creating line effects” on page 131.) Then click OK.

Deleting objects
Deleting an object removes it permanently.

To delete an object:

1 Select the object.

2 Press Backspace or Del (Windows) or Delete (Mac OS), or choose Edit > Clear or 
Edit > Cut.

Rotating the x and y axes 
When you open a new file, the x and y axes are parallel to the horizontal and vertical sides 
of the window. You can rotate the axes by specifying an angle of constraint in the General 
Preferences dialog box. 
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Rotating the axes is useful if your artwork contains elements that are rotated to the same 
angle, such as a logo and text displayed on a 20-degree angle. Instead of rotating each 
element you add to the logo, you can simply rotate the axes by 20 degrees. Everything you 
draw is created along the new axes.

Object aligned with default axes (left) and axes rotated 20º (right)

You can then use the Shift key to constrain the movement of one or more objects so that 
they move in a precise horizontal, vertical, or diagonal direction relative to the current 
orientation of the x and y axes. 

Hold down Shift while dragging or drawing to limit movement to the nearest 45º angle.

To rotate the axes: 

1 Choose Edit > Preferences > General (Windows and Mac OS 9) or Illustrator > 
Preferences > General (Mac OS X).

2 In the Constrain Angle text box, enter the angle at which you want the axes rotated. 
If you enter a positive number, the axes are rotated counterclockwise. If you enter a 
negative number, the axes are rotated clockwise. Then click OK.

The rotation of the axes is saved in the Preferences file; it therefore affects new artwork in 
all files until you change its value or delete the Preferences file. 

The following objects and actions are aligned along the new axes:

• Text and objects you draw with the graph tool.

• Scaling, reflecting, and shearing.

• Moving objects with the arrow keys.

• Any objects or operations to which you apply constraint (by holding down Shift while 
performing the action), limiting them to 45-degree multiples relative to the axes.

• The angle reported in the Info palette.

• Construction guides, which appear with Smart Guides. 

The following objects and actions are not affected by the new axes:

• Objects that already exist.

• Rotating and blending.

x

y

20°
x
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• Drawing with the pencil or auto trace tool.

Stacking objects
The Adobe Illustrator program stacks successively drawn objects, beginning with the first 
object drawn. How objects are stacked determines how they are displayed when they 
overlap. In addition, stacking is important when you make masks. (See “Working with 
clipping masks” on page 149.)

You can change the stacking order (also called the painting order) of objects in your 
artwork at any time. By creating multiple layers in your artwork, you can also control how 
overlapping objects are displayed.

Note: Grouping objects may affect the way the objects are stacked in relation to other, 
nongrouped objects in the artwork. (See “Grouping and ungrouping objects” on 
page 110.)

Moving objects frontward or backward in a stack of objects
The Bring to Front and Send to Back commands let you move an object to the front or the 
back of the stack of objects on its layer. The Bring Forward and Send Backward commands 
let you move an object just one object forward or back in the stack of objects.

If the object is part of any type of group—including masked artwork, compound paths, 
text, and word wraps—the object is moved to the front or back of the group rather than 
the front or back of the entire layer. 

To make an object the frontmost or backmost object in its group or on its layer:

1 Select the object you want to move.

2 Choose either Object > Arrange > Bring to Front or Object > Arrange > Send to Back. 

To move an object one layer to the front or one layer to the back of a stack:

1 Select the object you want to move.

2 Choose either Object > Arrange > Bring Forward or Object > Arrange > Send Backward. 

Pasting objects in front or in back of other objects
The Paste in Front and Paste in Back commands let you paste copies of objects directly on 
top of and behind the objects you select. This is useful if you want to move the copy a 
specified distance from the original location. These commands also let you paste the 
artwork into the same position in a new file as it was in the old file, relative to the page 
origin.

To move an object in front or in back of other objects in the stacking order:

1 Select the object you want to move. 

2 Choose Edit > Cut. The selected object is temporarily deleted and is placed onto the 
Clipboard.

3 Select the object or objects in front or in back of where you want the cut object to 
appear. 

4 Choose Edit > Paste in Front or Edit > Paste in Back. 
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The cut object is pasted into position. If no object was selected in step 3, the object is 
pasted on top of or in back of the stack.

If you paste more than one object, all pasted objects appear in front or in back of the 
selected artwork. However, the relative painting order among the individual pasted 
objects remains the same. If you are working with multiple layers in the file that you 
defined with the Layers palette, the layers may affect how objects are pasted. 
(See “Changing the stacking order of artwork using the Layers palette” on page 222.)

Pasting objects in the current layer
Pasted objects (even if copied from different layers) are placed directly in front or in back 
of all selected objects on the current layer if Paste Remembers Layers is turned off in the 
Layers palette menu. However, the relative painting order among the individual pasted 
objects remains the same. 

When Paste Remembers Layers is on, objects are always pasted onto the layer where they 
originated. (See “Pasting artwork between layers” on page 223.)

To paste objects into the current layer:

Make sure the Paste Remembers Layers is turned off in the Layers palette menu. 

Grouping and ungrouping objects
You can combine several objects into a group so that the objects are treated as a single 
unit. You can then move or transform a number of objects without affecting their 
individual positions or attributes. For example, you might group the objects in a logo 
design so that you can move and scale the logo as one unit. 

Groups can also be nested—that is, they can be grouped within other objects or groups to 
form larger groups.

To group or ungroup objects: 

1 Select the objects to be grouped or ungrouped. Selecting part of an object and 
grouping it will group the entire object.

2 Choose either Object > Group or Object > Ungroup. 

Selecting grouped objects 
Once objects are grouped, selecting any part of the group with the selection tool or the 
lasso tool selects the entire group. If you are unsure whether an object is part of a group, 
select it with the selection tool. 
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The direct-selection tool and direct-lasso tool let you select a single path or object that is 
part of one group or several groups. If you have groups of objects within other groups, 
you can select the next group in the grouping hierarchy by using the group-selection tool. 
Each successive click adds another subset of grouped objects to the selection. 

Three groups: Group A is part of group B, which in turn is part of group C.

To select grouped objects with the group-selection tool:

1 Select the group-selection tool , and click the path you want to select. 

2 Click the same place again to select successive groups until you have selected every-
thing you want to include in your selection.

First click selects an object (left). Second click selects group A (right).

Third click selects next group, which is group B (left). Fourth click selects group C (right).

Grouping stacked objects
Grouped objects must be stacked in succession on the same layer of the artwork; 
therefore, grouping may change the layering of objects and their stacking order on a 
given layer. (See “Stacking objects” on page 109 and “About layers” on page 215.)

Grouped objects are stacked together behind the frontmost object in the group. If you 
group two objects that are separated by a nongrouped object in the stacking order, 
the nongrouped object is moved behind the grouped objects.

A B C
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Locking and hiding objects
You can use the Lock and Hide commands to isolate parts of your artwork on which you 
do not want to work. Once an object is locked or hidden, it cannot be selected or modified 
in any way. These features are useful when you are working on objects that overlap. In 
addition, the Hide command makes objects temporarily invisible, and so may speed 
performance when you work on large or complex artwork.

Locked objects remain locked when files are closed and reopened. However, hidden 
objects reappear when files are reopened.

To lock or hide artwork: 

Choose from the following options:

• To lock objects, select the objects and choose Object > Lock > Selection.

• To lock all objects above the selected object, choose Object > Lock > All Artwork Above.

• To lock all objects on other layers, choose Object > Lock > Other Layers.

• To hide a selected object, select the objects and choose Object > Hide > Selection.

• To hide all objects on other layers, choose Object > Hide > All Artwork Above.

• To lock all objects on other layers, choose Object > Lock > Other Layers.

Note: You can lock or hide entire objects only. Selecting part of an object (anchor points or 
segments) and locking or hiding it affects the entire object.

To unlock all objects:

Choose Object > Unlock All. All previously locked objects are unlocked and selected. 
Any previously selected objects are deselected. 

To show all objects:

Choose Object > Show All. All previously hidden objects are shown. Any previously 
selected objects are selected.

To unlock or show all objects within a selected group:

1 Select an unlocked and visible element within a group.

2 Hold down Alt (Windows) or Option (Mac OS) and choose either Object > Unlock All or 
Object > Show All.
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Transforming and Distorting 
Shapes

Transforming selected objects
You can transform selected objects—that is, change their size, shape, and orientation by 
selecting one or more objects and then applying various transformation actions on them. 
For example, you can change the angle of an object by rotating it. 

To transform an object, you can use the free transform tool, individual transformation 
tools, or the Transform palette:

• Use the free transform tool to rotate, scale, reflect, shear, and distort objects quickly. 

• Use the transformation tools to change the size, shape, and orientation of selected 
objects. The transformation tools are the rotate tool, scale tool, reflect tool, and shear 
tool. You can also use individual transform dialog boxes to specify numeric values, 
to preview the transformation before applying it, and to select other transformation 
options. 

• Use the Transform palette to modify selected objects by changing information in the 
palette. (See “Using the Transform palette” on page 121.)

As you transform objects, keep the following in mind:

• Transformation dialog boxes and commands can be opened for selected objects by 
using context-sensitive menus. To display context-sensitive menus, hold down the right 
mouse button (Windows) or Control-click (Mac OS). 

• You can transform selected objects by using the bounding box. (See “Using the 
bounding box” on page 99.)

Defining the point of origin
All transformation actions perform their functions in relation to some fixed point on or 
around the object. This fixed point is called the point of origin. The default point of origin is 
the object’s center point. For example, you can drag an object to rotate it around its center, 
or you can set a new point of origin and then drag to rotate around it. You can also click a 
point of origin that you have set, and then drag it to a new position.

To reset the point of origin:

1 Select the object you want to transform. 
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2 Select the transform tool you want to use (such as rotate or scale), and click the 
artboard to set the new point. 

Object scaled from center (left) and from new point of origin (right)

Rotating
Rotating an object turns it around a fixed point that you designate. The default point of 
origin is the object’s center point. Copying while rotating is a useful way to create radially 
symmetrical objects, such as the petals of a flower.

To rotate with the bounding box:

1 With the selection tool, select the object or objects to rotate. 

2 Move the pointer near a corner handle so that the pointer changes to .

3 Drag the handle. 

To rotate with the free transform tool:

1 With the selection tool , select the object or objects to rotate. 

2 Select the free transform tool . 

3 Position the pointer anywhere outside the bounding box. The pointer changes to . 

4 Drag until the selection is at the desired angle of rotation.

To rotate with the rotate tool: 

1 With the selection tool, select the object or objects to rotate. 

2 Select the rotate tool . 

3 Do any of the following:

• Drag to rotate around the object’s center point.

• Click once to set the point of origin around which you want the object to rotate. Then 
move the pointer away from the point of origin and drag in a circular motion. Shift-drag 
to constrain the tool to multiples of 45 degrees. 

• To rotate a copy of the object instead of the object itself, hold down Alt (Windows) or 
Option (Mac OS) after you start to drag. 

• For finer control, drag farther from the object’s point of origin. 

To rotate by specifying an angle: 

1 With the selection tool, select the object or objects to rotate.

2 Do one of the following:

• To use the default point of origin, choose Object > Transform > Rotate, or double-click 
the rotate tool. 
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• To change the point of origin, select the rotate tool, and click where you want the new 
point of origin.

3 Enter the rotation angle, in degrees, in the Angle text box. Enter a negative angle to 
rotate the object clockwise; enter a positive angle to rotate the object counterclockwise. 

4 To preview the effect before you apply it, select Preview.

5 Do one of the following:

• To rotate the object, click OK. 

• To rotate a copy of the object, click Copy. 

Note: To place multiple copies of the object in a circular pattern around a point of origin, 
move the point of origin away from the center of the object, click Copy, and then 
repeatedly choose Object > Transform > Transform Again.

To rotate each object individually in a selection:

1 Select the object or objects to rotate. Then choose Object > Transform > 
Transform Each. 

2 In the Angle text box, enter the angle by which to rotate the selected objects, between 
–360 degrees and 360 degrees.

3 To preview the effect before you apply it, select Preview, and then click OK.

Rotate tool (left) and Transform Each command (right)

Scaling 
Scaling an object enlarges or reduces it horizontally (along the x axis), vertically (along the 
y axis), or both horizontally and vertically, relative to the point of origin you designate. 
The default point of origin is the object’s center point.

To scale stroke weights and effects when you scale objects by dragging the bounding box 
or the free transform tool, select Scale Strokes & Effects in the General Preferences dialog 
box. When scaling objects by setting scale values in the Scale Options dialog box, you can 
turn the Scale Strokes & Effects option on or off (this option overrides the General 
Preferences option).

Scale Strokes & Effects option on (left) and off (right)
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To scale with the bounding box:

1 With the selection tool, select the object or objects to scale. 

2 Drag a handle until the selection is the desired size. 

• Shift-drag the handle to preserve the proportion.

• Alt-drag (Windows) or Option-drag (Mac OS) to scale from the center of the bounding 
box (instead of the opposite handle).

To scale with the free transform tool:

1 With the selection tool, select the object or objects to scale. 

2 Select the free transform tool . 

3 Drag a handle of the bounding box until the object is the desired size. 

• Shift-drag the handle to preserve the proportion.

• Alt-drag (Windows) or Option-drag (Mac OS) to scale from the center of the bounding 
box (instead of the opposite handle).

To scale with the scale tool: 

1 With the selection tool, select the object or objects to scale. 

2 Select the scale tool . 

3 Do any of the following:

• Drag the object to resize it around the center point.

• Click to set a new point of origin, move the pointer away from the new point of origin, 
and then drag to scale the object. 

• Shift-drag along a diagonal to scale the object uniformly. Shift-drag vertically or 
horizontally to scale the object along a single axis. 

• To scale a copy of the object instead of the object itself, start dragging and then hold 
down Alt (Windows) or Option (Mac OS).

• For finer control over scaling, start dragging farther from the point of origin. 

To scale by specifying scale factors: 

1 With the selection tool, select the object or objects to scale. 

2 Do one of the following:

• To use the default point of origin, choose Object > Transform > Scale, or double-click 
the scale tool. 

• To change the point of origin, select the scale tool, and click where you want the new 
point of origin.

3 In the Scale dialog box, do one of the following:

• Select Uniform, and enter a percentage in the Scale text box to preserve the relative 
height and width of the object. 

• Select Non-Uniform, and enter the horizontal and vertical scale factors as percentages 
to scale the height and width separately. The scale factors are relative to the specified 
point of origin and can be negative numbers. 
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• Select Scale Strokes & Effects to scale the line weights of all stroked paths (as specified 
in the Stroke palette), and scale any size-related effects, along with the objects.

4 To preview the effect before you apply it, select Preview.

5 Do one of the following:

• To scale the object, click OK.

• To scale a copy of the object, click Copy. 

To scale objects individually in a selection:

1 Select the objects to scale. Then choose Object > Transform > Transform Each. 

2 In the Scale Horizontal and Vertical text boxes, enter the percentages by which to scale 
the selected objects.

3 Select Preview to preview the effect before you apply it; then click OK. 

Uniform scaling with a non-default origin point specified (left); uniform scaling with the default 
origin point (right). 

Reflecting
Reflecting an object flips the object across an invisible axis that you specify. Copy while 
reflecting to create a mirror image of an object.

To reflect with the free transform tool:

1 With the selection tool, select the object or objects to reflect. 

2 Select the free transform tool . 

3 Drag a handle of the bounding box past the opposite edge or handle until the object is 
at the desired level of reflection.

To reflect with the reflect tool: 

1 With the selection tool, select the object or objects to reflect. 

2 Select the reflect tool .

3 Position the pointer on one point along the invisible axis across which you want the 
reflection to occur, and click to set the point of origin. The pointer changes to an 
arrowhead.
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4 Position the pointer at another point along the invisible axis, and do one of the 
following:

• Click to set a point across which to reflect the object. When you click, the selected 
object flips over the defined axis. 

Click to set origin (left), then click again to reflect across axis (right). 

• Adjust the axis of reflection by dragging instead of clicking. Shift-drag to constrain. 
As you drag, the invisible axis of reflection rotates around the point you clicked in step 
3. When the image is in the desired position, release the mouse button. 

Drag reflect tool to rotate axis of reflection.

• For finer control over the reflection, drag farther from the object’s point of origin.

To reflect by specifying an axis: 

1 With the selection tool, select the object or objects to reflect. 

2 Do one of the following:

• To use the default (center point) point of origin, choose Object > Transform > Reflect or 
double-click the reflect tool.

• To change the point of origin from which to reflect the object, select the reflect tool and 
click where you want the new point of origin. 

3 In the Reflect dialog box, select the axis across which you want the object to be 
reflected. You can reflect an object across a horizontal, a vertical, or an angled axis.

4 If the object contains patterns and you want to reflect the patterns, select Patterns. 
(To reflect only the patterns, deselect Objects.)

5 To preview the effect before you apply it, select Preview.

6 Do one of the following:

• To reflect the object, click OK. 

• To reflect a copy of the object, click Copy. 
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Shearing
Shearing an object slants, or skews, the object along the axis you specify. Copying while 
shearing is useful for creating cast shadows.

To shear with the free transform tool:

1 With the selection tool, select the object or objects to shear. 

2 Select the free transform tool . 

3 Start dragging a handle on the side of the bounding box (not a corner) and then hold 
down Ctrl+Alt (Windows) or Option+Command (Mac OS) as you drag until the object has 
the desired shape. Shift-drag to constrain the tool to multiples of 45 degrees.

To shear with the shear tool: 

1 With the selection tool, select the object or objects to shear. 

2 Select the shear tool .

3 Do one of the following:

• Drag the object to shear by using the object’s center point as the point of origin.

• Click to set the point of origin from which you want the object to be sheared. Then 
move the pointer away from the shear axis, and drag in the direction you want to shear 
the object. 

• Shift-drag to constrain the tool. 

Select object (left); then drag with the shear tool (right).

• To shear a copy of the object instead of the object itself, start dragging and then hold 
down Alt (Windows) or Option (Mac OS). 

• For finer control over shearing, start dragging farther from the point of origin. 

To shear by specifying an angle and an axis: 

1 With the selection tool, select the object or objects to shear. 

2 Do one of the following:

• To use the default (center point) point of origin, choose Object > Transform > Shear or 
double-click the shear tool.

• To change the point of origin from which to shear the object, select the shear tool and 
click where you want the new point of origin. 

3 In the Shear dialog box, enter the new shear angle. The shear angle is the amount of 
slant to be applied to the object, relative to a line perpendicular to the shear axis. 
(Contrary to the way the program works with other transformation tools, the shear angle is 
calculated clockwise from the current axis.)
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4 Specify the axis along which the object is to be sheared. You can shear an object along a 
horizontal, a vertical, or an angled axis. 

If you choose an angled axis, enter the angle of the axis that you want, in degrees, relative 
to the x axis.

5 To preview the effect before you apply it, select Preview.

6 Do one of the following:

• To shear the object, click OK. 

• To shear a copy of the object, click Copy.

Distorting with the free transform tool
Distorting an object varies the size and shape of an object by dragging the corner points 
of the free transform tool’s bounding box. As you drag the corner handles of the bounding 
box, the object’s shape is distorted accordingly. 

To distort with the free transform tool:

1 With the selection tool, select the object or objects to distort.

2 Select the free transform tool . 

3 Start dragging a handle on the corner of the bounding box (not a side) and then do one 
of the following:

• Hold down Ctrl (Windows) or Command (Mac OS) until the selection is at the desired 
level of distortion.

• Hold down Shift+Alt+Ctrl (Windows) or Shift+Option+Command (Mac OS) to distort in 
perspective.

Distorting in perspective

Resetting the bounding box angle
After you transform a selection, you can return the angle of the bounding box to its 
original orientation. 

To reset the bounding box angle:

Choose Object > Transform > Reset Bounding Box. 

Repeating transformations
Sometimes you may want to repeat the same transformation several times, especially 
when you are copying objects. The Transform Again command in the Object menu lets 
you repeat a move, scale, rotate, reflect, or shear operation as many times as you want, 
until you perform a different transform operation. 
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To repeat the previous transformation:

1 Make sure the object on which you want to repeat the transformation is selected.

2 Do one of the following:

• Choose Object > Transform > Transform Again. 

• Press the right mouse button (Windows), or Control-click (Mac OS), and choose 
Transform > Transform Again from the context-sensitive menu. 

Using the Transform palette
The Transform palette displays information about the location, size, and orientation of one 
or more selected objects. By typing new values, you can modify the selected objects. 
All values in the palette refer to the bounding boxes of the objects. You can also use 
commands in the Transform palette menu for such actions as flipping an object across the 
path or scaling the stroke weight.

To use the Transform palette:

1 Choose Window > Transform.

2 With the selection tool, select the object or objects to transform.

3 Do any of the following in the Transform palette:

• To select the reference point from which you are modifying the selection, click a handle 
on the square representing the object’s bounding box.

• To change a selection to a new horizontal orientation, enter a value in the X text box.

• To change a selection to a new vertical orientation, enter a value in the Y text box.

• To change the width of a selection, enter a value in the W text box.

• To change the height of a selection, enter a value in the H text box.

• To rotate a selection, enter a new angle between 0° and 360° in the Rotate text box, 
or choose a value from the pop-up menu.

• To shear a selection, enter a value in the Shear text box, or choose a value from the 
pop-up menu.

4 Press Tab, Enter, or Return to apply the change. 

To use commands in the Transform palette menu:

1 Choose Window > Transform.

2 With the selection tool, select the object or objects to transform.

3 Choose a command from the palette menu:

• To reflect a selection horizontally, choose Flip Horizontal. 

• To reflect a selection vertically, choose Flip Vertical.

• To include the stroke when an object is transformed, choose Scale Strokes & Effects. 

• To transform only the object, choose Transform Object Only.

• To transform only the pattern, choose Transform Pattern Only.
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• To transform both the object and pattern, choose Transform Both.

Note: To ensure that values entered in the Info and Transform palettes include stroke 
weight and effects, choose Edit > Preferences > General (Windows and Mac OS 9) or 
Illustrator > Preferences > General (Mac OS X), select the Use Preview Bounds option, and 
click OK. 

Using Warp effects
Using preset warp effects, you can distort or deform Illustrator artwork, including paths, 
text, meshes, blends, and raster images. Because warp effects are live effects, available 
from the Effect menu, you can apply a warp to your artwork and then continue to manip-
ulate the artwork at any time. (See “Using effects” on page 235.) Once you apply the Warp 
effect, the warp appears in the Appearance palette, where you can save it as part of a style, 
select it for modifications, expand it, or delete it. It also appears in the Layers palette, 
which displays the object as having an appearance applied. (See “Working with 
appearance attributes” on page 228 and “Using the Layers palette” on page 215.)

Expanding a warped object removes the warp effect while leaving the object in its 
warped state. 

To apply a Warp effect:

1 Select the object or group of objects that you want to warp.

2 Choose Effect > Warp, and then choose one of the predefined warp shapes.

3 Select either Horizontal or Vertical to specify which axis the bending option affects.

4 Specify the amount of bending to apply.

5 Specify the amount of Horizontal and Vertical distortion to apply, and then click OK.

To remove a Warp effect:

In the Appearance palette, drag the warp object to the trash.

To expand a warp effect:

Select the warped object, and choose Object > Expand Appearance.

Using envelopes
Envelopes are objects that distort or reshape selected objects. You can make an envelope 
out of objects on your artboard, or you can use a preset warp shape or a mesh object as an 
envelope. You can use envelopes on all artwork except linked objects (with the exception 
of TIFF, GIF, and JPEG), graphs, or guides. You can use envelopes with paths, compound 
paths, text objects, meshes, blends, and raster images.

Circle (left) used as an envelope to create a warped shape (right). 
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Once you apply an envelope, you can continue to edit the original objects. At any time you 
can also edit, delete, or expand an envelope. 

Creating envelopes
You can create an envelope from three sources: the topmost selected object, a preset 
warp shape, or a mesh. You can edit any of these envelopes at any time.

To make an envelope with a preset warp shape:

1 Select the object or group of objects, and choose Object > Envelope Distort > Make 
with Warp.

2 Choose a warp style from the Style pop-up menu, and then specify the options you 
want. (See “Using Warp effects” on page 122).

To make an envelope with a mesh:

1 Select the object or group in the artwork, and choose Object > Envelope Distort > Make 
with Mesh.

2 Specify the number of Rows and Columns that you want the mesh to contain. Then 
click OK.

To make an envelope with a path:

1 Select the object or group you want to distort and the path you want to use as the 
envelope. Make sure the envelope path is topmost in the stacking order.

2 Choose Object > Envelope Distort > Make with Top Object.

Note: To apply a stroke or fill to an envelope, use the Appearance palette. See “Working 
with appearance attributes” on page 228.

Editing envelopes
When you create an envelope, Illustrator groups the envelope and the original artwork. 
You can edit either the envelope or the artwork, but not both at the same time. 

When editing text inside an envelope, turn on Smart Guides to help while typing.

To edit the original art in an envelope:

Select the envelope, and choose Object > Envelope Distort > Edit Contents. The Layers 
palette displays a small triangle to the left of the <Envelope> entry so that you can access 
the contents. (See “Using the Layers palette” on page 215.)

Note: When you modify the contents of an envelope, the envelope shifts to recenter the 
results with the original content. 

To return to the original editing mode, choose Object > Envelope Distort > Edit Envelope.

To modify the shape of a warp or mesh envelope:

1 Select the envelope in the artwork. (If necessary, choose Object > Envelope Distort > 
Edit Envelope.)

2 Do one of the following:

• Select the envelope in the artwork, and choose Object > Envelope Distort > Reset with 
Mesh or Reset with Warp. Select Maintain Envelope Shape to keep the outer shape 
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intact while you reset the inner nodes; deselect it to alter the entire shape. Specify Rows 
and Columns, and click OK.

• Use the direct-selection tool, add anchor point tool, or delete anchor point tool to 
modify the shape on the artboard.

• Use the mesh tool to modify the shape on the artboard.

Removing envelopes
You can remove envelopes by releasing them or expanding them. Releasing the envelope 
creates two separate objects: the envelope content in its original state and the mesh 
object. The mesh object is above the envelope content in the stacking order.

Expanding an envelope removes the envelope from the object, but the object retains its 
deformed state. For information on expanding an envelope pattern or fill, see “Setting 
envelope options” on page 124.

To release an envelope:

Select the envelope in the artwork, and choose Object > Envelope Distort > Release.

To expand an envelope:

Select the envelope in the artwork, and choose Object > Envelope Distort > Expand.

Setting envelope options
You can set options for envelopes to determine what, if any, attribute of the envelope is 
expanded with the original object and how precisely the art is distorted to fit the 
envelope.

To set envelope options:

1 Select the envelope in the artwork, and choose Object > Envelope Distort > Envelope 
Options.

2 Select Anti-Alias to smooth rasters when distorted with an envelope. Deselecting Anti-
Alias can decrease the time it takes to distort rasters.

3 The Preserve Shape Using option lets you specify how rasters preserve their shape 
when distorted by non-rectangular envelopes:

• Clipping Mask uses a clipping mask on the raster.

• Transparency applies an alpha channel to the raster.

4 Specify a Fidelity percentage to indicate how precisely you want the object to fit the 
envelope mold. Increasing the Fidelity percentage can add more points to the distorted 
paths and increase the time it takes to distort the objects.

5 Select Distort Appearance if you want to distort the appearance of an object (such as 
applied effects or styles) and not just the object’s underlying geometry. When this option 
is not selected, the appearance is applied after the envelope distorts the underlying 
geometry. 

6 Select Distort Linear Gradients or Distort Pattern Fills if you want to distort the 
respective fill type.
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7 Click OK.

Note: If you expand the envelope with a Distort option selected, the respective property is 
expanded separately.

Modifying shapes with liquify tools
Illustrator provides a variety of liquify tools for changing an object’s shape. Using these 
tools alters the original object’s shape. To distort objects with liquify tools, simply hold 
down the mouse and draw over the object with the tool—the tool adds anchor points and 
adjust paths as you draw.

Note: You cannot use liquify tools on objects that contain text, graphs, or symbols.

Use any of the following tools to distort an object:

The warp tool Stretches objects as if they were made of clay. When you drag or pull 
portions of an object using this tool, the pulled areas attenuate.

The twirl tool Creates swirling distortions of an object.

The pucker tool Deflates an object by moving control points toward the cursor.

The bloat tool Inflates an object by moving control points away from the cursor.

The scallop tool Adds random, smooth, arc-shaped details to the outline of an object.

The crystallize tool Adds random spike, arc-shaped details to the outline of an object.

The wrinkle tool Adds random arc and spike-shaped details to the outline of an 
object.

To distort an object using a liquify tool: 

1 Select the liquify tool in the toolbox.

2 Click or drag over the object you want to distort.

To specify liquify tool options:

1 Double-click the tool in the toolbox.

2 In the Options dialog box, specify the following Global Brush Dimensions settings:

• For Width and Height, enter values for the size of the tool cursor.

• For Angle, enter a value for the orientation of the tool cursor.

• For Intensity, enter a value to specify the rate of change (higher values equal faster 
changes), or select Use Pressure Pen to use the input from a tablet or pen instead of the 
Intensity value. 

Note: If you don’t have a pressure pen attached, the Use Pressure Pen option is dimmed.

3 Specify values for any of the following options that apply: 

• For Complexity, enter a value to specify how closely the details of the particular brush 
are spaced on the object’s outline. This is closely tied with the Detail value. 

• For Detail, enter a value to specify the spacing between points introduced into the 
object’s outline (higher values space points closer together). 

• For Simplify, enter a value to specify how much you want to reduce the superfluous 
points that do not measurably affect the overall appearance of the shape.
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• For Twirl Rate, enter a value between –180˚ to 180˚ to specify the rate at which the twirl 
is applied. The closer to an end range, the faster the object twirls. To twirl slowly, specify 
a rate close to 0˚.

• For Horizontal and Vertical, enter a value to specify how far apart the control points are 
placed.

4 If available, select Brush Affects Anchor Points, Brush Affects In Tangent Handles, or 
Brush Affects Out Tangent Handles if you want the brush to make changes to these 
properties.

5 Select Show Brush Size to see the size of the brush as you use the tool on the artboard.

Modifying shapes with filters and effects
Illustrator provides a variety of filters and effects for changing an object’s shape and path 
direction. Using these commands as filters alters the original object’s shape, whereas 
applying them as effects just changes the appearance of the object without altering the 
underlying structure of the object. For more information, see “Using effects” on page 235.

Comparison between filters and effects 
A. Original object B. With Roughen filter applied in Preview and Outline views C. With Roughen 
effect applied in Preview and Outline views

Note: All of the following filters work with vector graphics only; you cannot use these 
filters with raster images.

Distorting with the Free Distort command
The Free Distort command lets you change the shape of a selection by dragging any of 
four corner points.

You can apply the Free Distort command as a filter or as an effect. (See “Using effects” on 
page 235.)

To apply the Free Distort command:

1 Do one of the following:

• To apply the command as a filter, select an object. Then choose Filter > Distort > Free 
Distort. 

• To apply the command as an effect, select an object or group in the artwork, or target a 
group or layer in the Layers palette. (For more information on targeting, see “Changing 
the appearance of artwork using the Layers palette” on page 223.) Then choose Effect > 
Distort & Transform > Free Distort. 

2 Select Preview to preview the effect within the dialog box.

A

B

C
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3 Drag one or more of the handles in the dialog box to distort the selection.

4 Click OK.

Rounding corners
The Round Corners command converts the corner points of an object to smooth curves. 

You can apply the Round Corners command as a filter or as an effect (see “Using effects” 
on page 235.)

To round corners on an object:

1 Do one of the following:

• To apply the command as a filter, select the object. Then choose Filter > Stylize > Round 
Corners. 

• To apply the command as an effect, select an object or group in the artwork, or target a 
group or layer in the Layers palette. (For more information on targeting, see “Changing 
the appearance of artwork using the Layers palette” on page 223.) Then choose Effect > 
Stylize > Round Corners. Select Preview if you want to preview the effect.

2 Enter a value (in the unit of measure specified in the General Preferences dialog box) in 
the Radius text box to determine the curvature of the rounded curve, and click OK. 

Making selections rectangular or elliptical
The Convert to Shape commands Rectangle, Rounded Rectangle, and Ellipse let you make 
objects (and rasters) appear to have this shape. These commands are useful when applied 
to a fill or stroke of an object with multiple fills or strokes. For more information, 
see “Working with appearance attributes” on page 228.

This command is only available as an effect (see “Using effects” on page 235.)

To make objects rectangular or elliptical:

1 Make the selection to which you want to apply the Rectangle, Rounded Rectangle, 
or Ellipse command.

2 Choose Effect > Convert to Shape > Rectangle, Rounded Rectangle, or Ellipse.

3 Do one of the following:

• Select Absolute, and enter the height and width you want to make the selection.

• Select Relative and enter a value that represents how much higher and wider to make 
the selection than its current height and width. (Enter a negative value to make the 
selection shorter or narrower than its current height and width.)

4 If you are applying the Rounded Rectangle command, enter a value (in the unit of 
measure specified in the General Preferences dialog box) in the Corner Radius text box to 
determine the curvature of the rounded edge.

5 Click OK. 

Curving objects using Pucker and Bloat
The Pucker & Bloat command curves objects inward and outward from their anchor 
points.

You can apply the Pucker & Bloat command as a filter or as an effect (see “Using effects” on 
page 235.)
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To bloat or pucker an object: 

1 Do one of the following:

• To apply the command as a filter, select the object to pucker or bloat. Then choose 
Filter > Distort > Pucker & Bloat. 

• To apply the command as an effect, select an object or group in the artwork, or target 
an item in the Layers palette. (For more information on targeting, see “Changing the 
appearance of artwork using the Layers palette” on page 223.) Then choose Effect > 
Distort & Transform > Pucker & Bloat. 

2 Drag the slider toward Pucker to curve the object inward from its anchor points and 
move the anchor points outward; drag the slider toward Bloat to curve the object outward 
from its anchor points and move the anchor points inward. You can also enter a value, 
from –200% to 200%, in the Percentage text box. 

3 To preview the effect before you apply it, select Preview, and click OK.

Roughening
The Roughen command moves anchor points in a jagged array from the original object, 
creating a rough edge on the object. 

You can apply the Roughen command as a filter or as an effect (see “Using effects” on 
page 235).

To roughen an object:

1 Do one of the following:

• To apply the command as a filter, select the object to roughen. Then choose Filter > 
Distort > Roughen. 

• To apply the command as an effect, select an object or group in the artwork, or target 
an item in the Layers palette. (For more information on targeting, see “Changing the 
appearance of artwork using the Layers palette” on page 223.) Then choose Effect > 
Distort & Transform > Roughen. 

2 Select Relative to distort by a percentage of the size of the object or Absolute to distort 
a specific amount.

3 Set the size of the distortion by dragging the Size slider or typing a value in the Size 
text box.

4 Specify the details per inch by dragging the slider or typing a value between 0 and 100 
in the Detail text box.

5 Select the enter of distortion you want around each anchor point: Smooth (for soft 
edges) or Corner (for sharp edges). 

6 To preview the effect before you apply it, select Preview, and click OK.

Scribbling and tweaking
Scribbling randomly distorts objects by moving anchor points away from the original 
object. Tweaking randomly distorts objects by moving anchor points on the selected 
object by an amount that you specify. 

You can apply the Scribble & Tweak command as a filter or as an effect (see “Using effects” 
on page 235.)
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To scribble and tweak an object:

1 Do one of the following:

• To apply the command as a filter, select the object to scribble or tweak. Then choose 
Filter > Distort > Scribble & Tweak. 

• To apply the command as an effect, select an object or group in the artwork, or target 
an item in the Layers palette. (For more information on targeting, see “Changing the 
appearance of artwork using the Layers palette” on page 223.) Then choose Effect > 
Distort & Transform > Scribble & Tweak. 

2 Select Relative to distort by a percentage of the size of the object or Absolute to distort 
a specific amount.

3 In the Horizontal and Vertical text boxes, enter the amount to move points or drag the 
sliders.

4 Select options for the anchor points:

• Anchor Points moves anchor points. Deselecting this option keeps anchor points 
anchored while a filter is applied to the rest of the object.

• “In” Control Points moves control points that lead into anchor points on the path.

• “Out” Control Points moves control points that lead out of anchor points on the path.

5 Because results vary, select Preview to preview the effect before you apply it, and 
click OK.

Twisting
The Twist command and the twist tool rotate a selection more sharply in the center than 
at the edges. 

You can apply the Twist command as a filter or as an effect (see “Using effects” on 
page 235).

To twist an object with the twist tool:

1 Select the object to twist.

2 Select the twist tool , and drag the object clockwise or counterclockwise.

To twist an object with the twist command:

1 Do one of the following:

• To apply the command as a filter, select the object to twist. Then choose Filter > 
Distort > Twist. 

• To apply the command as an effect, select an object or group in the artwork, or target a 
group or layer in the Layers palette. (For more information on targeting, see “Changing 
the appearance of artwork using the Layers palette” on page 223.) Then choose Effect > 
Distort & Transform > Twist. 

2 Enter a value for the twist angle, from –3600 to 3600 (a positive value twists clockwise 
and a negative value twists counterclockwise).

3 Click OK. 
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Adding drop shadows
The Drop Shadow command creates a three-dimensional shadow on any selected object. 
You can offset the drop shadow any distance from the object along the x or y axis, as well 
as vary the opacity, blending mode, blur, color, and darkness of the drop shadow.

You can apply the Drop Shadow command as a filter or as an effect (see “Using effects” on 
page 235.)

To create a drop shadow:

1 Do one of the following:

• To apply the command as a filter, use a selection tool and select the object. Then choose 
Filter > Stylize > Drop Shadow. 

• To apply the command as an effect, select an object or group in the artwork, or target 
an item in the Layers palette. (For more information on targeting, see “Changing the 
appearance of artwork using the Layers palette” on page 223.) Then choose Effect > 
Stylize > Drop Shadow. 

2 Choose a blending mode from the Mode menu. For more information, see “About 
blending modes” on page 196.

3 Enter the amount of opacity you want for the shadow.

4 Enter the distance you want the drop shadow to be offset from the object on the x axis 
or the y axis (in the unit of measure set in the General Preferences dialog box). 

5 Enter the distance from the edge of the shadow where you want any blurring to occur. 
To blur the shadow, a transparent raster object is created.

6 Do one of the following:

• Select Color, and click the color preview to specify a color for the shadow. For more 
information, see “Using the Color Picker” on page 169.

• Select Darkness, and enter the percentage darkness (percentage of black added) you 
want for the drop shadow. In a CMYK document, a value of 100% used with a selected 
object that contains a fill or stroke color other than black creates a multicolored black 
shadow. A value of 100% used with a selected object that contains only a black fill or 
stroke creates a 100% black shadow. A value of 0% creates a drop shadow the color of 
the selected object. 

7 To place each shadow directly behind the object to which the shadow is applied, select 
Create Separate Shadows (this option is only available when you choose Drop Shadow 
from the Filter menu). Leaving this option unselected places all of the shadows together 
behind the bottom-most selected object.

8 Click OK.

Adding inner and outer glows
The Inner Glow and Outer Glow commands let you add glows that emanate from the 
inside or outside edges of the selection. When you add an inner glow, a raster object is 
created inside an opacity mask; when you add an outer glow, a transparent raster object is 
created.

These commands are only available as effects (see “Using effects” on page 235.)
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To apply an inner or outer glow:

1 Select an object or group in the artwork, or target an item in the Layers palette. For 
more information on targeting, see “Changing the appearance of artwork using the Layers 
palette” on page 223.

2 Choose Effect > Stylize > Inner Glow or Outer Glow. 

3 Select Preview to preview the effect.

4 Choose a blending mode from the Mode menu. For more information, see “About 
blending modes” on page 196.

5 Click the color preview next to the blending mode menu to specify a color for the glow. 
For more information, see “Using the Color Picker” on page 169.

6 Specify the amount of transparency you want for the glow. For more information, 
see “Using the Transparency palette” on page 192.

7 If you are applying an inner glow, select a glow source option:

• Center to apply a glow that emanates from the center of the selection.

• Edge to apply a glow that emanates from the inside edges of the selection.

8 For Blur, enter the distance from the center or edge of the selection where you want any 
blurring to occur.

9 Click OK.

Feathering edges
The Feather command softens the edges of an object (or rasters) by fading them to trans-
parent over the distance you specify. 

This command is only available as an effect (see “Using effects” on page 235.)

To make the edges of an object fade from opaque to transparent:

1 Select the object with the edges you want to feather.

2 Choose Effect > Stylize > Feather.

3 Select Preview to display a preview of the results.

4 For Feather Radius, enter the distance over which you want the change from opaque to 
transparent to occur.

Creating line effects
Using the Zig Zag and Add Arrowheads commands, you can create wavy and zig zag 
effects and add various arrowhead styles to lines. 

You can apply these commands as a filter or as an effect (see “Using effects” on page 235.)

The Zig Zag command adds anchor points to an existing object and then moves some of 
the points to the left of (or upward from) the path and some to the right of (or downward 
from) the path. You can specify the number of anchor points to create and the distance to 
move them. You can also choose whether to create smooth anchor points for a wavy line 
effect, or corner anchor points for a jagged line effect. 



Using Help | Contents | Index Back 132  

Adobe Illustrator Help Transforming and Distorting Shapes 

Using Help | Contents | Index Back 132  

The Add Arrowheads command lets you add an arrowhead or arrow tail to any selected 
line. If applied as a filter, the resulting arrows can be edited like any other object, but they 
do not move with the line to which they are attached. If applied as an effect, the arrows are 
similar to brush strokes.That is, the arrows change location, direction, and color along with 
the line, but they cannot be edited separately.

For information about creating stroked lines, see “Using the Stroke palette” on page 159. 

To convert straight lines to Zig Zags:

1 Do one of the following:

• To apply the command as a filter, select the object you want to convert. Then choose 
Filter > Distort > Zig Zag. 

• To apply the command as an effect, select an object or group in the artwork, or target 
an item in the Layers palette. (For more information on targeting, see “Changing the 
appearance of artwork using the Layers palette” on page 223.) Then choose Effect > 
Distort & Transform > Zig Zag. 

2 Select Relative to move points by a percentage of the size of the object or Absolute to 
move points a specific amount.

3 For Size, enter the distance you want to move points on the line, or drag the slider.

4 For Ridges per Segment, enter the number of ridges per line segment you want, or drag 
the slider.

5 Select from the following options:

• Smooth to create smooth points, resulting in a wavy line.

• Corner to create corner points, resulting in a jagged line.

• Preview to preview the line.

6 Click OK.

To add arrowheads to a line:

1 Do one of the following:

• To apply the command as a filter, select a line to which you want to add arrowheads. 
Then choose Filter > Stylize > Add Arrowheads. 

• To apply the command as an effect, select an object or group in the artwork, or target 
an item in the Layers palette. (For more information on targeting, see “Changing the 
appearance of artwork using the Layers palette” on page 223.) Then choose Effect > 
Stylize > Add Arrowheads. 

2 Choose from various arrowhead designs for each end of the line by clicking the forward 
icon or backward icon below the Start and End arrow boxes. The start and end of the line 
refer to the order in which the line was drawn.

3 To rescale the size of an arrowhead, enter the percentage you want in the Scale text 
box. This scales the arrowhead relative to the stroke weight of the line.

4 Click OK. 
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Blending shapes
The Adobe Illustrator blend tool and the Make Blend command let you create a series of 
intermediate objects and colors between two or more selected objects. You can blend 
between two open paths (such as two different lines), between two closed paths (such as 
a circle and a square), between gradients, or between other blends. Depending on the 
way you paint the objects you are blending, you can produce airbrush effects such as 
complex shading, highlighting, and contouring. The Blend filters can also be used to blend 
colors between filled objects.

You can edit blends that you created by moving, resizing, deleting, or adding objects. 
After you make editing changes, the artwork is automatically reblended. 

About blending
One of the simplest uses for blending is to create and distribute shapes evenly between 
two objects. For example, you can create a series of evenly spaced bars using the blend 
tool or the Make Blend command. 

Two objects selected using the blend tool

Blending distributes shapes evenly

You can also blend between two open paths to create a smooth transition between 
objects, or you can combine blends of colors and objects to create color transitions in the 
shape of a particular object.

The following rules apply to blending shapes and their associated colors:

• You can blend between an unlimited number of objects, colors, opacities, or gradients. 

• Blends can be directly edited with tools such as the selection tools, the rotate tool, or 
the scale tool.

• A straight path is created between blended objects when the blend is first applied. You 
can edit the blend path by dragging anchor points and path segments. (See “Adjusting 
path segments” on page 56.)

• You cannot blend between mesh objects.

• If you blend between one object painted with a process color and another object 
painted with a spot color, the blended shapes are painted with a blended process color. 
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If you blend between two different spot colors, process colors are used to paint the 
intermediate steps. If, however, you blend between tints of the same spot color, the 
steps are all painted with percentages of the spot color. 

• If you blend between two patterned objects, the blended steps will only use the fill of 
the object on the topmost layer.

• If you blend between objects that have blending modes specified with the Trans-
parency palette, the blended steps will only use the blending mode of the top object.

• If you blend between objects with multiple appearance attributes (effects, fills, or 
strokes), Illustrator attempts to blend the options.

• If you blend between two instances of the same symbol, blended steps will be 
instances of that symbol. If, however, you blend between two instances of different 
symbols, the blended steps will not be symbol instances. (See “Working with symbols” 
on page 71.)

• By default, blends are created as knockout transparency groups, so that if any of the 
steps consist of overlapping transparent objects, these objects will not show through 
each other. You can change this setting by selecting the blend and deselecting 
Knockout Group in the Transparency palette.

• The Adobe Illustrator program automatically calculates the number of steps in a blend, 
unless you select Specify Steps in the Blend Options dialog box. 

Creating blends
You create blends in Illustrator by clicking objects with the blend tool, or by selecting 
objects with a selection tool and using the Blend commands.

Original objects before blending

Multiple objects are clicked sequentially with the blend tool

Objects are blended relative to selected anchor points on each blended object. If the 
objects are unselected, or if you have only one anchor point selected, Illustrator automati-
cally selects the two points from which the blend commences and finishes. You can also 
select two or more anchor points from which to blend by clicking anchor points with the 
blend tool. By selecting different anchor points on the objects, you can create the effect of 
rotating the blend from one point in an object to a selected point in the next object.
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To create a blend with the blend tool:

1 Select the blend tool . 

2 Click objects to blend in sequential order. If you want to blend to a specific anchor point 
on an object, click the anchor point with the blend tool. If you are blending open paths, 
select an endpoint on each path.

3 When you are finished adding objects to the blend, you can click the blend tool again 
to start a new blend.

Click anchor point on first object with blend tool (left). Then click anchor point on second 
object (right).

Result of creating a blend with the blend tool.

To create a blend with the Make Blend command:

1 Select the objects to blend with any selection tool. 

2 Choose Object > Blend > Make. 

To release a blend:

1 Select the blend with any selection tool. 

2 Choose Object > Blend > Release. 

To change the number of steps between blends:

1 Choose Object > Blend > Blend Options. 

2 Select from the following options in the Spacing pop-up menu:

• Specified Steps. Enter a value to specify the number of steps between the start and end 
of the blend. 

• Specified Distance. Enter a value to specify the distance between the steps in the blend. 
The distance specified is measured from the edge of one object to the corresponding 
edge on the next object (for example, from the rightmost edge of one object to the 
rightmost edge of the next object).

• Smooth Color has the Adobe Illustrator program autocalculate the number of steps for 
the blends. If objects are filled or stroked with different colors, the steps are calculated 
to provide the optimum number of steps for a smooth color transition. If the objects 
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contain identical colors, or if they contain gradients or patterns, the number of steps is 
based on the longest distance between the bounding box edges of the two objects.

To change the orientation of the blend to the path:

1 Choose Objects > Blend > Blend Options.

2 Select from the following options:

• Click the Align to Page button to orient the blend perpendicular to the x axis of 
the page.

• Click the Align to Path button to orient the blend perpendicular to the path.

Align to Page option applied

Align to Path option applied

Creating blends on paths
Once you create a blend, you can then apply the blend to a path. Applying a blend to a 
path is an easy way to wrap a blend around an object or create special effects in your 
artwork.

The blend follows the contours of the path in the orientation specified in the Blend 
Options dialog box. If Align to Path is selected, the alignment of the blend follows the 
contours of the path. If Align to Page (the default setting) is selected, the blend is aligned 
with the x axis of the page.

To apply a blend to a path:

1 Select a blend and hold down Shift to select a path.

2 Choose Object > Blend > Replace Spine.

To reverse the order of a blend on a path:

1 Select the blend.

2 Choose Object > Blend > Reverse Spine. The objects are ordered in reverse on the path.

To reverse the stacking order of a blend on a path:

1 Select the blend.
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2 Choose Object > Blend > Reverse Front to Back. The objects are reversed in the stacking 
order on the path, so that those objects on the frontmost stacking order are moved to the 
back of the stacking order, and vice-versa. (See “Stacking objects” on page 109.)

Original (top) and with Reverse Front to Back command applied (bottom)

Editing blends
You can move, delete, transform, edit anchor points and Bezier curves, or change colors on 
blends, using any of the editing tools available in the Adobe Illustrator program. When you 
edit a blend path, the changes take place interactively while you work. 

Blending colors between filled objects
The Blend filters create a series of intermediate colors from a group of three or more filled 
objects, based on the objects’ vertical or horizontal orientation, or on their stacking order. 
The filters do not affect strokes or unpainted objects. (See “Stacking objects” on page 109.)

To blend colors and opacities between filled objects:

1 Select three or more filled objects to blend. 

2 Do one of the following:

• To fill the intermediate objects with gradated blends between the frontmost and 
backmost filled objects, choose Filter > Colors > Blend Front to Back.

• To fill the intermediate objects with gradated blends between the leftmost and 
rightmost filled objects, choose Filter > Colors > Blend Horizontally.

• To fill the intermediate objects with gradated blends between the topmost and 
bottommost filled objects, choose Filter > Colors > Blend Vertically.

Using the Pen & Ink filters
The Pen & Ink > Hatch Effects filter creates textured gradations, such as cross-hatching, 
and irregular random textures, such as wood grains, that you can apply to artwork to 
simulate the look of an ink pen drawing. A similar tool, called the Photo Crosshatch filter, 
can convert a bitmap photographic image into a series of hatched layers, so that it 
appears to be sketched by an ink pen. (See “Using the Photo Crosshatch filter” on 
page 248.)
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The Hatch Effects filter converts a selected object into a mask and then draws lines or 
shapes behind it. The shapes created by the Hatch Effects filter are objects and can require 
significant program memory. Thus, consider applying Pen & Ink effects as the last step in 
creating your artwork: Make the entire drawing and paint it as desired. Then apply the 
hatch effects.

The hatch (or hatch style) is the design element of the Hatch Effects filter. The particular 
options associated with a hatch are called hatch settings. You can select from hatch 
settings supplied with the Adobe Illustrator program by using the Hatch Effects dialog 
box. You can also create your own hatched designs by drawing or selecting an object, 
naming it as a hatch in the New Hatch dialog box, and then applying it to artwork by using 
the Hatch Effects dialog box. Try experimenting with applying different hatches to your 
artwork before creating your own.

Applying a hatch effect
To apply a hatch effect to a selected object, you choose a hatch setting and its associated 
hatch style, modify the settings if desired, and apply them through the Hatch Effects 
dialog box. The Hatch Effects dialog box lets you adjust the hatch. 

To fill an object with an existing ink pen hatch:

1 Select the object you want to fill with a hatch.

2 Choose Filter > Pen & Ink > Hatch Effects.

3 Choose a hatch from the Hatch pop-up menu and an effect from the Hatch Effect 
pop-up menu.

4 To improve the program’s performance by turning off the hatch preview, deselect the 
Preview option at the lower right of the dialog box. 

5 To adjust the number of hatch elements applied to the selection, drag the Density 
slider or enter values in the text box. To intensify the effect, click a gradation within the 
density adjustment bar.

6 To specify hatch uniformity or design characteristics, adjust sliders or enter values for 
Dispersion, Thickness, Scale, or Rotation. 

Enter an angle along which to apply the effect by typing a value from -360 to 360 in the 
text boxes. Then drag the slider or enter values in the text boxes to specify a range, 
as follows: 

• Dispersion, which controls the spacing of hatch elements, ranges from 0% to 300%.

• Thickness, or stroke weight, of the hatch elements ranges from 10 pts to 1000 pts. (This 
option is dimmed if the selection is unstroked.) 

• Scale, which sets the size of the hatch elements, ranges from 10% to 1000%.

• Rotation, which sets the angle at which the hatch elements are applied, ranges from 
–180 degrees to 180 degrees. 

7 Use the dial or text boxes to enter a value between –360 and 360 for effect variables as 
follows:

• Linear increases the effect progressively.

• Reflect varies the effect from the center of the object outward.

• Constant creates the same effect evenly across the shape.
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• Symmetric varies the effect proportionately and evenly, for example, if applying 
hatches to round or cylindrical shapes.

• Random applies the effect irregularly.

• Fade specifies whether the hatch fades across the object. Choose the fade properties 
from the Fade pop-up menu: None for no fade, To White to fade the hatch to white, 
To Black to fade the hatch to black, or Use Gradient if the object is filled with a gradient 
and you want that gradient to define the fade’s direction and colors. 

Hatch options results 
A. Original hatch B. Constant C. Linear D. Reflect E. Symmetric F. Random

8 Select from the following color options for the hatch:

• Match Object’s Color changes the hatch fill to the selection’s fill. 

• Keep Object’s Fill Color applies the hatch in its original color on top of the object’s fill 
color.

9 When you finish adjusting the hatch options, click OK.

Creating and saving hatches
You can create and save your own hatches or modify existing hatches and save them for 
reuse. To save hatches, you use either the New Hatch or the Hatch Effects dialog box.

To create a hatch:

1 Draw the objects you want to convert to a hatch design for the ink pen effect.

2 Select the artwork.

3 Choose Filter > Pen & Ink > New Hatch.

4 Click New. Enter a name for the new hatch and click OK. 

5 To improve the program’s performance, deselect Preview to turn off the preview of the 
hatch and click OK.

To modify an existing hatch:

1 Make sure that nothing is selected in the artwork.

2 Choose Filter > Pen & Ink > New Hatch.

3 Choose a hatch from the Hatch pop-up menu.

4 Click Paste and then click OK.

D E F

A B C
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5 Edit the hatch as desired, and then select it.

6 Choose Filter > Pen & Ink > New Hatch.

7 Click New. Name the new hatch and click OK. 

To save hatch settings:

1 Select an object in the artwork and choose Filter > Pen & Ink > Hatch Effects.

2 Specify the hatch settings and any style options you want to save.

3 To save the settings in the file, click New. Enter a new name for the settings, and 
click OK.

To delete hatch settings:

1 Select an object in the artwork and choose Filter > Pen & Ink > Hatch Effects.

2 Select the hatch settings and any style options you want to delete.

3 Click Delete, and then click OK.

To delete an existing hatch:

1 Choose Filter > Pen & Ink > New Hatch.

2 Choose a hatch from the Hatch pop-up menu.

3 Click Delete, and then click  OK.

Using Pen & Ink hatch libraries
When using the Hatch Effects filter you may want to import hatches that you previously 
created in Illustrator, or save the current set of hatches you made into a hatch library. 
Hatch libraries are stored in the Illustrator 10.0 \ Plug-Ins \ Illustrator Filters \ Pen and Ink 
folder.

Once you have opened a hatch library, all the hatches in the library are loaded into the 
Hatch Effects dialog and can be viewed in the Hatch Effect pop-up menu at the upper left 
corner of the dialog. 

To load a Pen & Ink hatch library into Illustrator:

1 Choose Filter > Pen & Ink > Library Open.

2 In the dialog box, locate the hatch library you want to open and click OK. The hatch 
libraries are located in the Illustrator 10.0 \ Plug-Ins \ Illustrator Filters \ Pen and Ink folder. 

Once the new library has been loaded, use the Pen & Ink filter as described in “Applying a 
hatch effect” on page 138.

To save new hatches in an ink pen library:

1 Create new hatches as described in “Creating and saving hatches” on page 139.

2 Choose Filter > Pen & Ink > Library Save As. 

3 In the dialog box, name the new file, save it in the Illustrator 10.0 \ Plug-Ins \ Illustrator 
Filters \ Pen and Ink folder, and click OK. 
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Using the Pathfinder palette
Use the Pathfinder palette to combine paths into new objects and shapes. In the 
Pathfinder palette, you can access filters for combining paths and you can access shape 
mode commands, which create and modify compound shapes. For more information on 
how filters affect the objects to which they’re applied, see “Using filters and filter effects” 
on page 239. 

You access Pathfinder filters by clicking a Pathfinders button or pressing Alt (Windows) or 
Option (Mac OS) and clicking a Shape Modes button. (See “Creating a final shape quickly” 
on page 148.) You access shape modes by clicking a Shape Modes button. (See “About 
compound shapes” on page 142.) 

To open the Pathfinder palette:

Choose Window > Pathfinder.

To display the Pathfinder palette menu:

Click the triangle at the upper right corner of the palette.

To repeat the action of the most recent Pathfinder palette button:

In the Pathfinder palette menu, choose Repeat <command>.

The command is applied with the most recently used options.

To set Pathfinder options:

1 Choose Window > Pathfinder.

2 Choose Pathfinder Options from the Pathfinder palette menu.

3 Specify any of the following Pathfinder options, and then click OK: 

• Type a precision value in the Precision text box to affect how precisely the Pathfinder 
filters calculate an object’s path. The more precise the calculation, the more accurate 
the drawing and the more time is required to generate the resulting path. 

• Select Remove Redundant Points to remove redundant points as you click a Pathfinder 
button.

• Select Divide and Outline Will Remove Unpainted Artwork to delete any unfilled objects 
in the selected artwork as you click the Divide or Outline button. 

• To reset all options to their default settings, click Defaults. 

Combining objects into complex shapes
You can combine paths and objects to create shapes in a variety of ways in Illustrator. 
The resulting paths or shapes differ depending on the method you use to combine the 
paths. Illustrator creates the following types of shapes:

• Compound shapes consist of two or more paths, compound paths, groups, blends, 
envelopes, warps, text, or other compound shapes that interact with and intercept one 
another to create new, editable shapes. Some compound shapes may appear like 
compound paths, but you can control them on a per-path basis.

• Compound paths consist of two or more simple paths that interact with or intercept 
each other. They are more basic than compound shapes and are recognized by all 
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PostScript-compliant applications. You cannot view individual components of 
compound paths in the Layers palette, or give the components their own appearance 
attributes (such as distortion or effects). 

• Simple paths are the most basic building block shape in Illustrator. They consist of one 
open or closed path, which may be self-intersecting.

Types of paths and shapes 
A. Three simple paths B. Compound path C. Compound shape

You can use any of the following methods to combine paths and create new paths or 
shapes: Make Compound Shape command in the Pathfinder palette, Shape Modes 
buttons in the Pathfinder palette, Compound Path command, Pathfinder effects, 
and Pathfinder filters in the Pathfinder palette.

About compound shapes
A compound shape is editable art consisting of two or more objects, each assigned a shape 
mode. Compound shapes make it easy to create complex shapes because you can 
precisely manipulate the shape mode, stacking order, shape, and location for each path 
included. Within a compound shape, you can include paths, compound paths, groups, 
other compound shapes, blends, text, envelopes, and warps, any of which can carry live 
effects. Open paths included in compound shapes are automatically closed. 

Compound shapes act as grouped objects. To select components of a compound shape, 
use the direct-selection tool or the group-selection tool. To make changes to the stacking 
order of the components, use the Layers palette.

Application of compound shapes 
A. Original objects B. Compound shape created C. Individual shape modes applied to each 
component D. Style applied to entire compound shape

A B C
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The shape layers and layer clipping paths (vector masks) in Adobe Photoshop are types of 
compound shapes. You can import shape layers and layer clipping paths into Illustrator as 
compound shapes and continue to manipulate them. In addition, you can export 
compound shapes to Photoshop. Keep the following in mind when using compound 
shapes with Photoshop:

• Only compound shapes that reside at the top level of the layer hierarchy are exported 
to Photoshop as shape layers.

• A compound shape painted with a stroke using a join other than round or with a weight 
in points that is not an integer, is rasterized when exported to the PSD file format. (See 
“Using the Stroke palette” on page 159.)

Creating and adjusting compound shapes
You create compound shapes using the Make Compound Shape command on selected 
objects. By default, each component is assigned the Add mode and the Make Compound 
Shape command combines them into a unified shape. You then design the shape and 
control the interaction between paths using the Shape Modes buttons in the Pathfinder 
palette on individual paths within the shape. You can apply the following shape modes 
one at a time:

Add to Shape Area Adds the area of the component to the underlying geometry. 

Subtract from Shape Area Cuts out the area of the component from the underlying 
geometry. 

Intersect Shape Areas Uses the area of the component to clip the underlying geometry 
as a mask would. 

Exclude Overlapping Shape Areas Uses the area of the component to invert the under-
lying geometry, turning filled regions into holes and vice versa. 

Shape modes 
A. All components in Add mode B. Subtract mode applied to squares C. Intersect mode applied to 
squares D. Exclude mode applied to squares

A B

C D
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When you create a compound shape, it takes on the paint and transparency attributes of 
the topmost component in Add, Intersect, or Exclude mode. Subsequently, you can 
change the paint, style, or transparency attributes of the compound shape. Illustrator facil-
itates this process by automatically targeting the whole compound shape when you select 
any part of it, unless you explicitly target a component in the Layers palette. Releasing the 
compound shape reveals each path’s previous paint attributes. Expanding a compound 
shape creates a simple path or a compound path. (See “Creating compound paths” on 
page 145.)

To create a compound shape using the Make Compound Shape command:

1 Choose Window > Pathfinder.

2 Select all of the objects to include in the compound shape.

3 Choose Make Compound Shape from the Pathfinder palette menu. The resulting shape 
appears in the Layers palette as a <Compound Shape>.

4 Use the direct-selection tool  and select a component of the compound shape (except 
for the backmost component, because its mode is never relevant).

5 In the Pathfinder palette, click a Shape Modes button. The shape changes accordingly.

6 Repeat steps 4 and 5 for each component, except the backmost component, until you 
obtain the desired combination of shape areas.

Note: To sustain maximum performance, create complex compound shapes by nesting 
other compound shapes (containing up to about 10 components each) instead of using 
many individual components.

To create a compound shape using only Shape Modes buttons:

1 Choose Window > Pathfinder.

2 Select all the objects you want to be part of the compound shape.

3 In the Pathfinder palette, click a Shape Modes button.

A compound shape is automatically created with the selected objects as its components. 
It appears in the Layers palette as a <Compound Shape>. Each component is assigned the 
shape mode that you selected. This method is useful when you want most of the compo-
nents to use the same mode. However, at this point, you can still change the mode of any 
component, except the backmost component.

To modify a compound shape: 

1 Use the direct-selection tool to select an individual component of the compound 
shape.

2 Look for the highlighted Shape Modes button in the Pathfinder palette to identify 
which mode is currently applied to a selected component.

Note: If you’ve selected two or more components that use different modes, question 
marks appear on the Shape Modes buttons.

3 In the Pathfinder palette, click a different Shape Modes button.

To undo a compound shape and release its components:

1 With the selection tool, select the compound shape to release.

2 Choose Release Compound Shape from the Pathfinder palette menu.
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To flatten a compound shape into a path or compound path:

1 With the selection tool, select the compound shape to expand.

2 Do one of the following:

• Click Expand in the Pathfinder palette.

• Choose Expand Compound Shape from the Pathfinder palette menu.

Creating compound paths
A compound path contains two or more paths that are painted so that holes appear where 
paths overlap. Compound paths act as grouped objects; to select part of a compound 
path, use the direct-selection tool or the group-selection tool. You can manipulate the 
shape of individual components of a compound path, but you cannot change appearance 
attributes, styles, or effects for individual components, and you cannot manipulate 
components individually in the Layers palette.

Use the Compound Path command to create paths that have holes where the original 
objects overlapped (such as the interiors of the letters o and g). When you define objects 
as a compound path, all objects in the compound path take on the paint and style 
attributes of the backmost object in the stacking order. 

Note: If you want more flexibility in the compound path creation, you can create a 
compound shape and then expand it. (See “Creating and adjusting compound shapes” on 
page 143.) 

To create a compound path using the Compound Path command:

1 Select the paths you want to include in the compound path. 

2 Choose Object > Compound Path > Make. 

The resulting shape appears in the Layers palette as a <Compound Path>.

Adjusting the appearance of compound paths
You can specify whether a compound path is a non-zero winding path or an even-odd 
path. Both the non-zero winding fill rule and the even-odd fill rule use mathematical 
equations to determine if a point is outside or inside a shape. The even-odd rule is more 
predictable: every other region within an even-odd compound path is a hole, regardless of 
path direction. Illustrator uses the non-zero winding rule as the default rule. Photoshop 
and Macromedia Freehand both use the even-odd rule by default, so compound paths 
imported from either of these applications will use the even-odd rule. 
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When you create a non-zero winding compound path, you can specify whether 
overlapping paths appear with holes or filled by clicking a Reverse Path Direction button 
in the Attributes palette.

Fill rules 
A. Non-zero winding compound path B. Non-zero winding compound path with Reverse Path 
Direction on C. Even-odd compound path

Self-intersecting paths are paths that intersect themselves. You can choose to make these 
paths either non-zero winding or even-odd, depending on how you want them to look.

Self-intersecting path 
A. With Use Non-Zero Winding Fill Rule applied B. With Use Even-Odd Fill Rule applied

To specify a non-zero winding or even-odd compound path:

1 With the selection tool, select the compound path.

2 Choose Window > Attributes.

3 Click the Use Non-Zero Winding Fill Rule button  or the Use Even-Odd Fill Rule 
button .

To change which areas are filled or become holes in a non-zero winding 
compound path:

1 With the direct-selection tool , select the part of the compound path to reverse. 
Do not select the entire compound path.

2 Choose Window > Attributes.

3 Click the Reverse Path Direction Off button  or the Reverse Path Direction On 
button . 

Returning a compound path to its original shape
To retrieve the individual paths that make up a compound path, use the Release 
command.

To release a compound path:

1 With the selection tool, select the compound path to release.

2 Choose Object > Compound Path > Release.

A B C
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Using effects to combine shapes nondestructively
You can use Pathfinder effects to combine all the paths in a group, layer, or sublayer. When 
you combine paths using effects, each path uses the same intersection method, such as 
Add, Subtract, or Divide. For more information on the Effect menu, see “Using effects” on 
page 235.

You can choose from any of the following Pathfinder effects: 

Add Traces the outline of all objects as if they were a single, merged object. The resulting 
shape takes on the paint attributes of the top object. 

Intersect Traces the outline of the region overlapped by all the objects. 

Exclude Traces all nonoverlapping areas of the objects, and makes overlapping areas 
transparent. Where an even number of objects overlap, the overlap becomes transparent. 
Where an odd number of objects overlap, the overlap becomes filled.

Subtract Subtracts the frontmost objects from the backmost object. You can use this 
command to delete areas of an illustration by adjusting the stacking order. (See “Stacking 
objects” on page 109.)

Minus Back Subtracts the backmost objects from the frontmost object. You can use this 
command to delete areas of an illustration by adjusting the stacking order. (See “Stacking 
objects” on page 109.)

Divide Divides a piece of artwork into its component filled faces (a face is an area 
undivided by a line segment). 

Note: When you use the Divide Pathfinder button in the Pathfinder palette, you can use 
the direct-selection or group-selection tool and manipulate the resulting faces indepen-
dently of each other. You can also choose to delete or preserve unfilled objects when 
applying the Divide command. (See “Using the Pathfinder palette” on page 141.)

Trim Removes the part of a filled object that is hidden. It removes any strokes and does 
not merge objects of the same color.

Merge Removes the part of a filled object that is hidden. It removes any strokes and 
merges any adjoining or overlapping objects filled with the same color. 

Crop Divides artwork into its component filled faces, and then deletes all the parts of the 
artwork that fall outside the boundary of the topmost object. It also removes any strokes.

Outline Divides an object into its component line segments, or edges. This command is 
useful for preparing artwork that needs a trap for overprinting objects. 

Note: When you use the Outline Pathfinder button in the Pathfinder palette, you can use 
the direct-selection or group-selection tool and manipulate each edge independently. You 
can also choose to delete or preserve unfilled objects when applying the Outline 
command. (See “Using the Pathfinder palette” on page 141.)

Hard Mix, Soft Mix, and Trap Mix colors that overlap or adjoin. (See “Using the Hard Mix 
and Soft Mix effects” on page 171.)

Combining paths using Pathfinder effects
Use Pathfinder effects on groups, layers, or sublayers that you want to combine into one, 
editable object.
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After you combine paths using the Pathfinder effects, you can select individual paths and 
move them, or change the appearance attributes. You can also change the stacking order 
of the paths in the Layers palette to alter the shape and color of the resulting art. Once 
applied, Pathfinder effects can be included as part of a style. 

To combine paths with a Pathfinder effect:

1 Select a group, or target a layer or sublayer in the Layers palette.

2 Choose Effect > Pathfinder and choose a Pathfinder effect. (See “Using effects to 
combine shapes nondestructively” on page 147.)

To quickly apply the same Pathfinder effect again:

Choose Effect > Apply <effect>.

The command is applied with the most recently used settings.

Creating a final shape quickly
If you know what shape you want to create, and you don’t need the live, editable 
attributes of a compound shape or Pathfinder effect, use the filters in the Pathfinder 
palette. The Pathfinder filters produce final objects directly. Using Pathfinder filters is the 
same as creating a Pathfinder effect or (when using Add, Subtract, Intersect, or Exclude) a 
compound shape, and then expanding it—it’s just a faster way of getting the same result.

To create a final shape using Pathfinder filters:

Select the objects you want to combine, and then in the Pathfinder palette, do one of the 
following:

• Click a Pathfinder button. 

• Press Alt (Windows) or Option (Mac OS) and click a Shape Modes button.

Note: For a description of each button, see the respective name and description in “Using 
effects to combine shapes nondestructively” on page 147.

Converting strokes to filled objects
The Outline Stroke command traces the outline of all stroked paths within the selected 
artwork and substitutes a filled object with the same width as the original stroked path. 
This commands lets you modify the outline of an object more than you could if it were 
only a stroke. 

The Outline Stroke command is useful when you prepare artwork for trapping color 
separations.You can apply it as a filter or as an effect. For more information on effects, 
see “Using effects” on page 235.

To create stroke-shaped objects from strokes:

1 Do one of the following:

• To apply the command as a Path command, select the artwork to process. The artwork 
can contain filled and stroked paths; however, only stroked paths become stroke-
shaped objects. Then choose Object > Path > Outline Stroke. 



Using Help | Contents | Index Back 149  

Adobe Illustrator Help Transforming and Distorting Shapes 

Using Help | Contents | Index Back 149  

• To apply the command as an effect, select an object or group in the artwork. Then 
choose Effect > Path > Outline Stroke. 

The outline replaces the original artwork and is selected.

Cutting objects
The Divide Objects Below command in the Object menu and the knife tool in the toolbox 
cut objects in a designated shape. The Divide Objects Below command lets you use a 
selected object as a cookie cutter or stencil to cut through other objects. It discards the 
original selection. 

The knife tool cuts objects along a freehand path you draw with the tool, dividing objects 
into their component filled faces (a face is an area undivided by a line segment). 

To cut objects by using the Divide Objects Below command:

1 Select the object to use as a cutter, and position it so that it touches the object to cut. 
(To retain the original selection, save a copy elsewhere in your document.) The object cuts 
any filled object that it’s touching.

2 To cut the object, choose Object > Path > Divide Objects Below. The shapes that result 
are ungrouped and selected.

To cut objects by using the knife tool:

1 Select the knife tool .

2 Do one of the following:

• To cut in a curved path, drag the pointer over the object.

• To cut in a straight path, hold down Alt (Windows) or Option (Mac OS) as you click on 
the artboard with the knife tool. Then drag.

Working with clipping masks 
Clipping masks crop part of the artwork so that only a portion of the artwork appears 
through the shape or shapes you create. In Adobe Illustrator, you mask objects by using 
the Clipping Mask > Make command. 

Masking object placed on top of artwork (left) and Clipping Mask > Make command applied (right)

You can also make semitransparent masks with the Transparency palette. (See “About 
opacity masks” on page 194.) And you can create clipping mask sets that mask multiple 
objects with the Layers palette. (See “Creating clipping masks” on page 226.)

To see whether an object is a mask:

1 Select the object.
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2 Choose Window > Layers.

3 From the Layers palette menu, choose Locate Object. The name of a clipping path 
appears in the palette with a solid underline. Clipping groups appear with dotted-line 
separators.

Note: You can also select all masks in your artwork by using the Clipping Masks command 
in the Select menu. (See “Modifying and selecting masks” on page 150.)

Creating masks
A masking object can consist of a single path or a compound path. 

To mask objects: 

1 Draw or use the selection tool to select the object to use as a mask. 

2 Make sure that the object is on top of the objects you want to mask. 

When you mask objects on different layers, keep in mind that objects on intermediate 
layers become part of the masked artwork. 

3 Select the mask and the objects you want masked. 

4 Choose Object > Clipping Mask > Make. The mask loses its paint attributes and is 
assigned a fill and stroke value of None. 

To undo the effects of a mask:

1 Use the selection tool or drag a marquee to select the objects you no longer want to 
use as a mask. 

2 Choose Object > Clipping Mask > Release. 

Because the mask was assigned a fill and stroke value of None, it is not visible unless you 
select it or assign it new paint attributes.

Modifying and selecting masks
Once you create a mask, the mask and the masked objects can be selected and modified 
as any other object. Masked objects are unlocked by default. You can lock the mask so that 
mask objects are secured together. By locking the mask, individual objects cannot be 
unintentionally moved with the direct-selection tool.

The Clipping Masks command in the Select menu finds and selects all masks in the 
document. If objects are selected, the command deselects any objects that are not masks.

When you rasterize a mask, the full stroke value of the mask is displayed. 

To select all masks in a file:

Choose Select > Object > Clipping Masks.

To find out which objects are affected by a mask:

1 Select the group-selection tool.

2 Click the mask once to select it, and then click once more to select the objects in the 
corresponding clipping group.

To add an object to masked artwork:

1 Use the selection tool to select the object to add to the masked artwork, and drag it in 
front of the mask.
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2 Choose Edit > Cut. 

3 With the direct-selection tool, select an object within the masked artwork.

4 Do one of the following:

• Choose either Edit > Paste in Front or Edit > Paste in Back. The object is pasted in front 
of or behind the selected object and becomes part of the masked artwork. 

• In the Layers palette, drag the object into the clipping group. 

To remove an object from masked artwork:

1 With the direct-selection tool, select the object you want to remove.

2 Do one of the following:

• Choose Edit > Cut.

• In the Layers palette, drag the object out of the clipping group. 

To lock a mask:

1 With the direct-selection tool, select the mask to lock.

2 Choose Object > Lock > Selection. 

Filling and stroking masks 
You can add a fill and stroke to a mask by setting these attributes using either the toolbox 
or the Color palette. (See “Applying color using the toolbox” on page 157 and “Using the 
Color palette” on page 158.)

To apply a fill and stroke to a mask:

1 With the direct-selection tool, select the mask you want to fill or stroke.

2 Use the Fill selection box or the Stroke selection box in the toolbox or Color palette to 
choose the mask’s fill or stroke. If the Color palette is not visible, choose Window > Color. 

3 Choose a fill color or stroke color for the mask.

The fill is drawn below the clipped objects, and the stroke is drawn on top.
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Applying Color

Color modes and models
A color mode in Illustrator determines the color model used to display and print Illustrator 
files. Illustrator bases its color modes on established models for describing and repro-
ducing color. Common models include HSB for hue, saturation, brightness); RGB (for red, 
green, blue); and CMYK (for cyan, magenta, yellow, black). 

HSB model
Based on the human perception of color, the HSB model describes three fundamental 
characteristics of color:

• Hue is the color reflected from or transmitted through an object. It is measured as a 
location on the standard color wheel, expressed as a degree between 0º and 360º. 
In common use, hue is identified by the name of the color such as red, orange, or green. 

• Saturation, sometimes called chroma, is the strength or purity of the color. Saturation 
represents the amount of gray in proportion to the hue, measured as a percentage 
from 0% (gray) to 100% (fully saturated). On the standard color wheel, saturation 
increases from the center to the edge.

• Brightness is the relative lightness or darkness of the color, usually measured as a 
percentage from 0% (black) to 100% (white).

HSB color model 
A. Saturation B. Hue C. Brightness D. All hues

RGB model
A large percentage of the visible spectrum can be represented by mixing red, green, and 
blue (RGB) colored light in various proportions and intensities. Where the colors overlap, 
they create cyan, magenta, and yellow.

C
D

A B
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RGB colors are called additive colors because you create white by adding R, G, and B 
together—that is, all light is reflected back to the eye. Additive colors are used for lighting, 
television, and computer monitors. Your monitor, for example, creates color by emitting 
light through red, green, and blue phosphors.

Additive colors (RGB)

How Illustrator uses the RGB model
You can work with color values using the RGB color mode, which is based on the RGB color 
model. In RGB mode, each of the RGB components can use a value ranging from 0 (black) 
to 255 (white). For example, a bright red color might have an R value of 246, a G value of 
20, and a B value of 50. When the values of all three components are equal, the result is a 
shade of gray. When the value of all components is 255, the result is pure white; when all 
components have values of 0, the result is pure black.

Illustrator also includes a modified RGB color model called Web Safe RGB, which includes 
only those RGB colors that are appropriate for use on the Web.

CMYK model
Whereas the RGB model depends on a light source to create color, the CMYK model is 
based on the light-absorbing quality of ink printed on paper. As white light strikes trans-
lucent inks, a portion of the spectrum is absorbed. Color that is not absorbed is reflected 
back to your eye.

Combining pure cyan (C), magenta (M), and yellow (Y) pigments would result in black by 
absorbing, or subtracting, all colors. For this reason they are called subtractive colors. Black 
(K) ink is added for better shadow density. (The letter K came into use because black is the 
“key” color for registering other colors, and because the letter B also stands for blue.) 
Combining these inks to reproduce color is called four-color process printing.

 
Subtractive color (CMYK)
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How Illustrator uses the CMYK model
You can work with color values using the CMYK color mode, which is based on the CMYK 
color model. In CMYK mode, each of the CMYK process inks can use a value ranging from 0 
to 100%. The lightest colors are assigned small percentages of process ink colors; darker 
colors have higher percentage values. For example, a bright red might contain 2% cyan, 
93% magenta, 90% yellow, and 0% black. In CMYK objects, low ink percentages are closer 
to white, and high ink percentages are closer to black.

Use CMYK when preparing a document to be printed using process inks.

Grayscale model
Grayscale uses tints of black to represent an object. Every grayscale object has a 
brightness value ranging from 0% (white) to 100% (black). Images produced using black-
and-white or grayscale scanners are typically displayed in grayscale.

Grayscale also lets you convert color artwork to high-quality black-and-white artwork. In 
this case, Adobe Illustrator discards all color information in the original artwork; the gray 
levels (shades) of the converted objects represent the luminosity of the original objects. 

When you convert grayscale objects to RGB, the color values for each object are assigned 
that object’s previous gray value. You can also convert a grayscale object to a CMYK object.

Color gamuts
The gamut, or color space, of a color system is the range of colors that can be displayed or 
printed. The spectrum of colors that can be viewed by the human eye is wider than any 
method of reproducing color.

The RGB gamut contains the subset of colors that can be viewed on a computer or 
television monitor (which emits red, green, and blue light). Some colors, such as pure cyan 
or pure yellow, can’t be displayed accurately on a monitor. The smallest gamut is that of 
the CMYK model, which consists of colors that can be printed using process-color inks. 
When colors that cannot be printed are displayed on the screen, they are referred to as 
out-of-gamut colors (that is, they are outside the CMYK gamut).

Comparison of RGB and CMYK color gamuts 
A. RGB color gamut B. CMYK color gamut The extent of the RGB color gamut exceeds that of the 
CMYK color gamut.

About spot and process color types
You can designate colors as either spot or process color types, which correspond to the 
two main ink types used in commercial printing. In the Swatches palette, you can identify 
the color type of a color using icons that appear next to the name of the color. 

A

B
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Spot colors
A spot color is a special premixed ink that is used instead of, or in addition to, CMYK 
process inks, and that requires its own printing plate on a printing press. Use spot color 
when few colors are specified and color accuracy is critical. Spot color inks can accurately 
reproduce colors that are outside the gamut of process colors. However, the exact 
appearance of the printed spot color is determined by combination of the ink as mixed by 
the commercial printer and the paper it’s printed on, so it isn’t affected by color values you 
specify or by color management. When you specify spot color values, you’re describing the 
simulated appearance of the color for your monitor and composite printer only (subject to 
the gamut limitations of those devices).

For best results in printed documents, specify a spot color from a color-matching system 
supported by your commercial printer. Several color-matching system libraries are 
included with Illustrator; see “Loading colors from other color systems” on page 166.

Minimize the number of spot colors you use. Each spot color you create will generate an 
additional spot color printing plate for a printing press, increasing your printing costs. 
If you think you might require more than four colors, consider printing your document 
using process colors.

Process colors
A process color is printed using a combination of four standard process inks: cyan, 
magenta, yellow, and black (CMYK). Use process colors when a job requires so many 
colors that using individual spot inks would be expensive or impractical, such as when 
printing color photographs. Keep the following guidelines in mind when specifying a 
process color:

• For best results in a printed document, specify process colors using CMYK values 
printed in process-color reference charts, such as those available from a commercial 
printer.

• The final color values of a process color are its values in CMYK, so if you specify a process 
color using RGB, those color values will be converted to CMYK when you print color 
separations. These conversions will work differently if you turn on color management; 
they’ll be affected by the profiles you’ve specified.

• Don’t specify a process color based on how it looks on your monitor unless you have set 
up a color management system properly and you understand its limitations for 
previewing color.

• Avoid using process colors in documents intended for online viewing only, because 
CMYK has a smaller color gamut than a typical monitor.

Using spot and process colors together
Sometimes it’s practical to print process and spot inks on the same job. For example, you 
might use one spot ink to print the exact color of a company logo on the same pages of an 
annual report where photographs are reproduced using process color. You can also use a 
spot color printing plate to apply a varnish over areas of a process color job. In both cases, 
your print job would use a total of five inks—four process inks and one spot ink or varnish.

Important: If an object contains spot colors and overlaps another object containing 
transparency features, undesirable results may occur when exporting to EPS format, when 
converting spot colors to process colors using the Print dialog box, or when creating color 
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separations in an application other than Illustrator. To prevent problems in these cases, 
you should first convert the spot colors to process colors.

Comparing global and non-global process colors
Illustrator lets you specify a process color as either global or non global. Global process 
colors remain linked to a swatch in the Swatches palette, so that if you modify the swatch 
of a global process color, all objects using that color are updated.

Global process colors make it easier to modify color schemes without locating and 
adjusting each individual object. This is especially useful in standardized, production-
oriented documents such as magazines. 

Non-global process colors do not automatically update throughout the document when 
the color is edited. Process colors are non-global by default; a non-global process color can 
be changed to a global process color using the Swatch Options dialog box.

Global and non-global process colors only affect how a particular color is applied to 
objects, never how colors separate or behave when you move them between applications.

Working with swatches and unnamed colors
You must create spot colors as named swatches stored in the Swatches palette, so that you 
and your prepress service provider can uniquely identify each resulting spot color printing 
plate. In comparison, printing any process color requires no more than four inks, so you 
can use process colors either as swatches or as unnamed colors.

Swatches A swatch appears in the Swatches palette with a name you specify, making a 
color, gradient, pattern, or tint easy to locate and edit.

Note: Although colors from swatch libraries are named, they aren’t saved as named 
swatches in your document unless you add them to the Swatches palette before you apply 
them to objects.

Unnamed colors You can create colors faster when you don’t have to name them. 
However, unnamed colors are more difficult to edit later because they do not appear on 
the Swatches palette. When many objects use unnamed colors, document colors can be 
difficult to maintain because you must locate and select each individual object to edit 
its color. 

You can create a swatch from any unnamed color. See “Adding, duplicating, and deleting 
swatches” on page 162.

Applying color
When you create an object or when you want to change the paint attributes of an existing 
object in Illustrator, you use a combination of the Fill and Stroke boxes in the toolbox, 
the Color palette, the Gradient palette, and the Swatches palette. 

To apply colors to artwork: 

1 Select an object’s fill or stroke using one of the following:

• Select the object and then click the Fill or Stroke box in the toolbox. (See “Applying 
color using the toolbox” on page 157.)
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• Click the Color button in the toolbox, or choose Window > Color. (For information about 
the toolbox, see “Applying color using the toolbox” on page 157.) Select the object, 
and click the Fill or Stroke box in the Color palette.

2 Apply a color to the selected fill or stroke, or a gradient to a fill, using one of the 
following:

• In the Color palette, mix a color using the Grayscale, RGB, Web Safe RGB, HSB, or CMYK 
sliders, or select a color from the color bar. (See “Using the Color palette” on page 158.)

Hold down the Shift key, and click on the color bar to cycle through the Grayscale, 
RGB, Web Safe RGB, HSB, or CMYK sliders.

• Double-click the Fill or Stroke box in the toolbox to display the Adobe Color Picker. 
You can then pick a color in the Color Picker dialog box. (See “Using the Color Picker” on 
page 169.)

• Choose Window > Swatches, and select a predefined color or gradient. (See “Using the 
Swatches palette” on page 160.)

• Choose Window > Swatch Libraries, and select a predefined color library. (See “Using 
the Swatch Libraries command” on page 166.)

• Drag a color or gradient to the artwork. (See “Applying color by dragging and 
dropping” on page 159.)

• Use the paint bucket or eyedropper tool to copy attributes between objects. 
(See “Copying attributes between objects” on page 170.)

• If you are stroking the object or path, choose line attributes. (See “Using the Stroke 
palette” on page 159.)

Applying color using the toolbox
Use the Fill and Stroke boxes in the toolbox to select an object’s fill and stroke, to swap the 
fill color with the stroke color, and to return the fill and stroke to their default colors. 

To switch between fill and stroke as the active selection, press x on the keyboard. 
To swap the fill and stroke colors of a selected object, press Shift+x. 

Below the Fill and Stroke boxes are the Color, Gradient, and None buttons. You use these 
buttons to change the selected fill or stroke to a color, to change a fill to a gradient, or to 
remove the fill or stroke from the selected object.

To change fill or stroke attributes using the toolbox:

1 Select an object using any selection tool. 

2 Do one of the following:

• Click the Swap Fill and Stroke button , or press Shift+x to swap colors between the fill 
and the stroke. 

• Click the Default Fill and Stroke button  to return to the default color settings (white 
fill and black stroke).

• Click the Color button  to change the currently selected stroke or fill to the last-
selected solid color in the Color palette.
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• Click the Gradient button  to change the currently selected fill to the last-selected 
gradient in the Gradient palette.

• Click the None button  to remove the object’s fill or stroke.

• Double-click the Fill or Stroke button to choose a color with the Color Picker. See “Using 
the Color Picker” on page 169.

Use keyboard shortcuts to switch to Color, Gradient, or None: Press < to change the 
selection to a color; > to change the selection to a gradient; and / to change to None.

Using the Color palette
You use the Color palette to apply color to an object’s fill and stroke, and also to edit and 
mix colors—either colors that you create or colors that you selected from the Swatches 
palette, from an object, or from a color library. 

Selecting colors in the Color palette

To edit the fill or stroke color using the Color palette: 

1 Select an object using any selection tool.

2 Choose Window > Color. 

3 Select the Fill box or Stroke box in the Color palette or in the toolbox.

4 Do one of the following:

• Position the pointer over the color bar (the pointer turns into the eyedropper), and click.

• Adjust the Tint slider if using a global color from the Swatches palette. (See “Changing 
global colors and tints” on page 163.)

• Choose an RGB, Web Safe RGB, HSB, CMYK, or Grayscale color model from the Color 
palette menu, and use the sliders to change the color values. You can also enter 
numeric values in the text boxes next to the color sliders. 

An exclamation point inside a yellow triangle in the Color palette when using HSB or RGB 
color indicates that you have chosen an out-of-gamut color—that is, a color that cannot 
be printed using CMYK inks. The closest CMYK equivalent appears below the triangle. Click 
the CMYK equivalent to substitute it for the out-of-gamut color. 

A cube above the yellow triangle in the Color palette when using RGB, HSB, or CMYK color 
indicates that you have not chosen a Web-safe color. Click the cube to substitute the 
closest Web-safe color. 
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Applying color by dragging and dropping
An easy way to paint an object is to drag a color directly from the Fill box or Stroke box in 
the toolbox, the Color palette, or the Gradient palette and drop the color onto the object, 
or to drag a swatch from the Swatches palette and drop it on an object. Dragging and 
dropping lets you paint objects without first selecting them. You can also drag and drop 
colors from the Swatches palette to the Fill box or Stroke box in the toolbox, the Color 
palette, or the Gradient palette. 

When you drag, the color is applied to either the object’s fill or stroke, depending on 
whether the Fill box or Stroke box is currently selected. (For example, if you drag a red 
color to an unselected object when the stroke box in the toolbox is selected, the object’s 
stroke is painted red.)

Using the Stroke palette
Stroke attributes are available only when you stroke a path. These attributes, available in 
the Stroke palette, control whether a line is solid or dashed, the dash sequence if it is 
dashed, the stroke weight, the miter limit, and the styles of line joins and line caps.

Use the Stroke palette to select stroke attributes, including the thickness (weight) of the 
stroke, how the stroke is capped and joined, and whether a stroke is solid or dashed. 

To set stroke attributes using the Stroke palette:

1 With any selection tool, select the object with the stroke attributes you want to change.

2 Click the Stroke box in the toolbox to select the object’s stroke.

3 Choose Window > Stroke. 

4 To specify a stroke weight, enter the desired weight in the Weight text box or choose a 
value from the pop-up menu. You can enter a value in inches (in), millimeters (mm), centi-
meters (cm), or picas (pi), and Illustrator converts it to an equal value in points. 

The stroke weight determines the thickness of the stroke, in points. Illustrator strokes a 
path by centering the stroke on the path; half of the stroke appears on one side of the 
path, and the other half of the stroke appears on the other side of the path. 

If you enter a weight of 0, the stroke is changed to None.

5 To see other options, choose Show Options from the Stroke palette menu; then select 
from the following options:

• Butt Cap for stroked lines with squared ends.

• Round Cap for stroked lines with semicircular ends. 

• Projecting Cap for stroked lines with squared ends that extend half the line width 
beyond the end of the line. This option makes the weight of the line extend equally in 
all directions around the line.

6 Select one of the following options:

• Miter Join for stroked lines with pointed corners. Enter a miter limit between 1 and 500. 
The miter limit controls when the program switches from a mitered (pointed) join to a 
beveled (squared-off ) join. The default miter limit is 4, which means that when the 
length of the point reaches four times the stroke weight, the program switches from a 
miter join to a bevel join. A miter limit of 1 results in a bevel join.
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• Round Join for stroked lines with rounded corners. 

• Bevel Join for stroked lines with squared corners.

• Dashed Line for a dashed line; then specify a dash sequence by entering the lengths of 
dashes and the gaps between them in the Dash Pattern text boxes. As with the stroke 
weight, you can enter a value in inches (in), millimeters (mm), centimeters (cm), or picas 
and Illustrator converts it to an equal value in points. 

The numbers entered are repeated in sequence so that once you have established the 
pattern, you don’t need to fill in all the text boxes. Dash patterns are specified in points.

Effects of line cap styles on dashed lines with dash gap of 1, 6, 10, 6

Using the Swatches palette
You can control all document colors and gradients from the Swatches palette alone. Use it 
to create, name, and store colors and gradients for instant access. When a selected object’s 
fill or stroke contains a color or gradient applied from the Swatches palette, the applied 
swatch is highlighted in the Swatches palette.

About swatch types
The Swatches palette stores the following types of swatches: 

Colors Icons on the Swatches palette identify the spot color type , the process color 
type , the HSB color mode , the RGB color mode , or the CMYK color mode . If the 
RGB or CMYK color is a spot color, a dot appears in the corner of the icon.

Tints A percentage value next to a swatch in the Swatches palette indicates a tint of a 
spot or process color. See “Changing global colors and tints” on page 163.

Gradients An icon on the Swatches palette indicates a gradient.

Patterns An icon on the Swatches palette filled with a pattern indicates the specific 
pattern type.

None The None swatch removes the stroke or fill from an object. You can’t edit or remove 
this swatch.

Registration The registration swatch  is a built-in swatch that causes objects filled or 
stroked with it to print on every separation from a PostScript printer. For example, regis-
tration marks use the Registration color so that printing plates can be aligned precisely on 
a press. You can edit the Registration color by double-clicking it in the Swatches palette. 
You can’t remove this swatch.

Note: If you use the Registration color for registration marks and for type, and then you 
separate the file and print it, the type may not register properly and the black ink may 
appear muddy. To avoid this, use black ink instead for type.

You can also add any colors from any swatch library to the Swatches palette so that they 
are saved with your document. (See “Applying color using the toolbox” on page 157.)
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Working with the Swatches palette
You can add colors and gradients to the Swatches palette by dragging them from the 
Color palette, from the Gradient palette, or from the toolbox Fill and Stroke boxes to the 
Swatches palette. You can add a pattern to the Swatches palette by dragging it from the 
artwork or by selecting it and choosing Edit > Define Pattern. (See “Creating and working 
with patterns” on page 206.)

New colors, gradients, or patterns that you create and store in the Swatches palette are 
associated only with the current file. Each new Adobe Illustrator file can have a different 
set of swatches stored in its Swatches palette. Swatches stored in the RGB Startup file or 
CMYK Startup file are loaded into all new Illustrator documents, depending on which color 
mode you select when you create the new document. (See “Creating a custom startup file” 
on page 168.)

To choose a color, gradient, or pattern from the Swatches palette:

1 Choose Window > Swatches.

2 Click a color, gradient, or pattern swatch in the Swatches palette. The selected color, 
gradient, or pattern appears in the Color palette and in the Fill box or Stroke box in the 
toolbox, and it is applied to any selected object.

To modify the swatch display:

1 Choose Window > Swatches. 

2 Choose one of the following display options from the pop-up menu:

• List View displays a small swatch next to the name of the swatch. The icons to the right 
of the name show the color model (CMYK, RGB, and so on), and whether the color is a 
spot color, global process color, non-global process color, registration color, or none.

• Small Thumbnail View or Large Thumbnail View displays only the swatch. A triangle 
with a dot in the corner of the swatch indicates that the color is a spot color. A triangle 
without a dot indicates a global process color.

To modify the type of swatches displayed:

1 Choose Window > Swatches.

2 Click one of the following buttons at the bottom of the Swatches palette:

• The Show All Swatches button  displays all color, gradient, and pattern swatches.

• The Show Color Swatches button  displays only process color and spot color swatches.

• The Show Gradient Swatches button  displays only gradient swatches.

• The Show Pattern Swatches button  displays only pattern swatches.

To select all swatches not currently used in the file:

1 Choose Window > Swatches.

2 Choose Select All Unused from the pop-up menu. Only swatches that are not currently 
used in the active file are selected.

To sort swatches by swatch type or by name:

1 Choose Window > Swatches.
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2 Choose from the sorting options in the pop-up menu:

• Sort by Name sorts all swatches alphabetically by name.

• Sort by Kind sorts all swatches in ascending order by swatch type: colors, gradients, and 
patterns.

• Show Find Field displays a text box in the palette, in which you can type the name of the 
swatch you want to find.

Adding, duplicating, and deleting swatches
You can add color swatches to the Swatches palette by dragging and dropping colors on 
the palette or by using commands in the Swatches palette. To duplicate swatches, use the 
commands in the Swatches palette or drag the swatch onto the New Swatch button.

To add a color to the Swatches palette: 

1 In the Color palette, Gradient palette, or the Fill box and Stroke box in the toolbox, 
select the color or gradient you want to add to the Swatches palette.

2 Do one of the following:

• Click the New Swatch button  at the bottom of the Swatches palette. 

• Choose New Swatch from the pop-up menu in the Swatches palette. Enter a name in 
the Swatch Name text box, choose Process Color or Spot Color from the Color Type 
pop-up menu, and click OK.

• Drag the color or gradient to the Swatches palette, positioning the pointer where you 
want the new swatch to appear. 

• Ctrl-drag (Windows) or Command-drag (Mac OS) a color to the Swatches palette to 
create a spot color. You can also press Ctrl (Windows) or Command (Mac OS) while 
clicking the New Swatch button to create a spot color. 

To duplicate a swatch in the Swatches palette:

1 Select the swatch you want to duplicate. To select multiple swatches, hold down Ctrl 
(Windows) or Command (Mac OS) and click each swatch. To select a range of swatches, 
hold down Shift and click to define the range.

2 Do one of the following:

• Choose Duplicate Swatch from the pop-up menu.

• Drag the swatches to the New Swatch button on the bottom of the palette.

To replace a swatch in the Swatches palette:

Hold down Alt (Windows) or Option (Mac OS) and drag the color or gradient from the 
Color palette, Gradient palette, or the Fill box and Stroke box in the toolbox to the 
Swatches palette, highlighting the swatch you want to replace.

Important: Replacing an existing color, gradient, or pattern in the Swatches palette 
globally changes artwork in the file containing that swatch color with the new color, 
gradient, or pattern. The only exception is for a process color that does not have the Global 
option selected in the Swatch Options dialog box.
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To delete a swatch from the Swatches palette:

1 Select the swatch you want to delete. To select multiple swatches, hold down Ctrl 
(Windows) or Command (Mac OS) and click each swatch. To select adjacent swatches, hold 
down Shift and click to define the range.

2 Delete the selected swatches in one of the following ways:

• Choose Delete Swatch from the pop-up menu.

• Click the Delete Swatch button  at the bottom of the palette.

• Drag the selected swatches to the Delete Swatch button.

Note: When you delete a spot color or global process color swatch (or a pattern or 
gradient containing a spot or global process color), all objects painted with those colors 
will be converted to the non-global process color equivalent. 

Editing swatches
You can change individual attributes of a swatch—such as its name, color mode, color 
definition, whether it is process or spot, or whether a process color can be changed 
globally—using the Swatch Options dialog box. 

Any swatch can be named in Adobe Illustrator; for example, you can change the name of a 
CMYK process color, and it still prints and separates with each of its CMYK values intact.

To edit a swatch:

1 Choose Window > Swatches.

2 Select a swatch, and do one of the following:

• Double-click the swatch. 

• Choose Swatch Options from the pop-up menu in the Swatches palette. 

3 Enter the relevant information in the Swatch Options dialog box:

• Enter a name in the Swatch Name text box.

• Choose Spot Color or Process Color from the Color Type pop-up menu. Both spot colors 
and process colors can be changed globally.

• Click Global if you want changes to the selected process color to be applied globally 
throughout the document. (For more information, see “Comparing global and non-
global process colors” on page 156.)

• Choose CMYK, RGB, Web Safe RGB, HSB, or Grayscale from the Color Mode pop-up 
menu and change the color definition (if desired) using the color sliders or text boxes at 
the bottom of the palette.

4 Click OK.

Note: When separated, each spot color is converted to a process color by default, unless 
you deselect the Convert to Process option in the Separation Setup dialog box. 
(See “Separating spot colors as process colors” on page 358.)

Changing global colors and tints
You can change the color or tint of all objects that share the same properties, or you can 
use the Swatches palette to change a color or tint throughout a file. You can change 
process colors or spot colors. 
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The Tint slider in the Color palette is used to modify a global color’s intensity. The tint 
range is from 0% to 100%; the lower the number, the lighter the tint will be. The Tint slider 
only appears in the Color palette when a global color is selected. It is the slider that 
appears directly to the right of the letter “t.”

Note: To ensure that a process color is global, make sure the Global option is selected in 
the Swatch Options dialog box. (See “Editing swatches” on page 163.)

To change the color or tint of objects with the same properties:

1 Select an object using one of the following methods:

• To select all objects with the same style, select an object with the style or choose the 
style from the Styles palette. Then choose Select > Same > Style.

• To select all objects with the same fill or stroke color, select an object with that fill color 
or choose the fill color from the Color palette or Swatches palette. Then choose Select > 
Same > Fill Color or Select > Same > Stroke Color.

• To select all objects with the same stroke weight, select an object with that stroke 
weight or choose the stroke weight from the Stroke palette. Then choose Select > 
Same > Stroke Weight.

• To apply the same selection options using a different object (for example, if you have 
already selected all red objects using the Same Fill Color command and now you want 
to search for all green objects), select a new object and then choose Select > Reselect. 

2 In the Color palette, drag the Tint slider or enter a tint value in the Tint Percentage 
text box. 

To change a global process color or a spot color throughout a file:

Replace a color swatch in the Swatches palette using one of the following options:

• Alt-drag (Windows) or Option-drag (Mac OS) a swatch from the Swatches palette over 
the swatch you want to replace.

• Alt-drag (Windows) or Option-drag (Mac OS) a color from the Color palette over the 
swatch you want to replace.

• Alt-drag (Windows) or Option-drag (Mac OS) a color from the Fill box or the Stroke box 
over the swatch you want to replace.

• Double-click the swatch and edit the color in the Swatch Options dialog box.

To change the tint of a global process color or spot color:

1 Select a color swatch in the Swatches palette.

2 In the Color palette, drag the Tint slider or enter a tint value in the Tint Percentage 
text box.

To save a tint in the Swatches palette:

1 Create a tint by modifying the swatch. 

2 Save the tint in the Swatches palette using one of the following:

• Drag the Fill or Stroke box in the toolbox to the Swatches palette.

• Click the New button in the Swatches palette.
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The tint is saved with the same name as the base color, but with the tint percentage added 
to the name. For example, if you saved a color named “Sky Blue” at 51 percent, the swatch 
name would be “Sky Blue 51%.”

Important: Tints of the same color are linked together, so that if you edit a tint swatch, all 
associated tint swatches (and the objects painted with those swatches) are also changed. 

Adding colors from other documents and merging swatch names
When you copy objects from one document to another, any swatches (global process 
colors, spot colors, patterns, or gradients) contained in the object are added to the desti-
nation document’s Swatches palette. If swatches in the two documents have the same 
name, but different color values, a warning dialog appears and you can choose to either 
add the duplicate swatch or merge the swatches together and use only one set of 
color values. 

If the color spaces of the source file from which you are copying or dragging the object do 
not match the color spaces of the destination document, the color spaces will be deter-
mined by options that you select in the Color Settings dialog box. (See “Producing 
Consistent Color” on page 174.) 

You can also merge swatches together using the Merge Swatches command. When you 
merge swatches together, all objects painted with either of the swatch colors will be 
updated with the merged swatch color. 

To add color, gradient, or pattern swatches from one document to another:

1 Copy an object into the current document using drag-and-drop, copy-and-paste, or the 
Place command. You can also use the Swatch Libraries command to add new swatch 
palettes. (See “Using the Swatch Libraries command” on page 166.)

2 If one or more swatches have the same name (but with different color values), select 
from the following options in the Swatch Conflict dialog box:

• Add Swatches adds the new swatch to the Swatches palette, appending the word copy 
to the name of the new swatch. 

• Merge Swatches combines the two swatches into a single swatch, using the color value 
of the destination document’s swatch.

3 If there are multiple naming conflicts, select the Apply to All check box to automatically 
apply the selected method (either adding swatches or merging swatches) to all naming 
conflicts in the document. This prevents the Swatch Conflict dialog box from appearing for 
each naming conflict in the document. 

To merge multiple colors in the Swatches palette:

1 In the Swatches palette select two or more swatches to merge. Press Shift and click to 
select a range of swatches; press Ctrl (Windows) or Command (Mac OS) and click to select 
non-contiguous swatches. 

2 Choose Merge Swatches from the Swatches palette menu. The first selected swatch 
name and color value replaces all other selected swatches.
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Using the Swatch Libraries command
The Swatch Libraries command lets you import colors, gradients, and patterns from other 
Adobe Illustrator files into a palette. It also lets you import entire color libraries from other 
color systems, such as the PANTONE® Process Color System.

When you import color libraries, the colors in the library are permanent. To modify a 
color library, copy it to the Swatches palette.

Loading colors from other files
Use the Other Library command to import colors, gradients, and patterns from other 
Adobe Illustrator files. When you select a file using the Other Library command, all of the 
source file’s spot and process colors, gradients, and patterns are added to a new palette. 

If you select a file whose color mode is different than the current document, the colors will 
be converted into the closest equivalent color in the destination document’s color mode. 

To import colors, gradients, or patterns from other files:

1 Choose Window > Swatch Libraries > Other Library.

2 Select the file from which you want to import swatches, and click Open. 

To add colors from the other file’s library into the Swatches palette:

1 Select one or more swatches in the library:

• Click to select a single swatch.

• Shift-click to select a range of swatches.

• Ctrl-click (Windows) or Command-click (Mac OS) to select noncontiguous swatches.

2 Do one of the following:

• Drag and drop the selected swatches from the library to the Swatches palette.

• Choose Add to Swatches from the library palette’s pop-up menu.

Loading colors from other color systems
The Swatch Libraries command lets you select from a range of color libraries—including 
the PANTONE Process Color System, Toyo™ Ink Electronic Color Finder™ 1050, the Focoltone® 
color system, the Trumatch™ color swatching system, the DIC Process Color Note, and 
libraries created especially for Web use. Each color system that you select appears in its 
own Swatch Library palette. 

Spot colors from color libraries, as are all spot colors, are converted to process colors when 
separated unless you deselect the Convert to Process option in the Separation Setup 
dialog box. (See “Separating spot colors as process colors” on page 358.) 

To load predefined custom color libraries into Illustrator:

1 Choose Window > Swatch Libraries.

2 Select the color system you want from the submenu. The color system that you select 
appears as a tabbed palette.

To make a custom color library appear each time Illustrator is started:

1 Select a custom color swatch library.
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2 Choose Persistent from the swatch library palette’s pop-up menu. The library will now 
automatically open in the same position each time the Illustrator application is started.

To select a swatch by its name or number:

1 Select the Swatches palette or a swatch library of a particular color system (for example, 
the PANTONE color system).

2 In the Find text box, type the name or the number of a swatch to select it. (For example, 
in the PANTONE Process library palette you can type 11-7 CVS to select PANTONE 
swatch 11-7.)

Note: If the Find text box is not available, choose Show Find Field from the Swatches 
palette menu.

Choosing a custom color system
The Swatch Libraries command supports various color systems, including the following:

PANTONE Used for printing inks. Each PANTONE color has a specified CMYK equivalent. 
To select a PANTONE color, first determine the ink color you want, using either the 
PANTONE Color Formula Guide or an ink chart obtained from your printer. PANTONE books 
are available from PANTONE’s Web site.

By default, Illustrator 10.0 installs the following PANTONE Solid Coated, PANTONE Solid 
Matte, PANTONE Solid Uncoated, PANTONE Process Coated, PANTONE Process Coated 
EURO, PANTONE Process Uncoated, PANTONE Pastel Coated, PANTONE Pastel Uncoated, 
and PANTONE Metallic.

Important: Illustrator 10.0 includes new PANTONE color libraries. If you work with an 
Illustrator 9.0 or earlier file that uses PANTONE colors, the older version of the PANTONE 
color is used. However, the following two situations may require you to update older 
versions of a color: copying artwork that uses a spot color into a document that uses a 
different spot color with the identical name; and placing an Illustrator EPS file that uses a 
spot color into an application that uses the same spot color with a different name. 

TRUMATCH Provides predictable CMYK color matching with more than 2000 achievable, 
computer-generated colors. TRUMATCH colors cover the visible spectrum of the CMYK 
gamut in even steps. The TRUMATCHCOLORFINDER displays up to 40 tints and shades of 
each hue, each originally created in four-color process and each reproducible in four 
colors on electronic imagesetters. In addition, four-color grays using different hues are 
included. 

FOCOLTONE Consists of 763 CMYK colors. FOCOLTONE colors help avoid prepress 
trapping and registration problems. 

A swatch book with specifications for process and spot colors, overprint charts, and a chip 
book for marking up layouts are available from FOCOLTONE. 

TOYO Color Finder 1050 Consists of more than 1000 colors based on the most common 
printing inks used in Japan. The TOYO Color Finder 1050 Book contains printed samples of 
Toyo colors and is available from printers and graphic arts supply stores. 

DIC Color Guide Commonly used for printing projects in Japan. 
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Creating a custom startup file
Adobe Illustrator provides two different startup files: a startup file for the CMYK color 
mode and a startup file for the RGB color mode. When you create a new document, you 
are asked to choose a color mode for the new document. Depending on the startup file 
you choose (CMYK or RGB), your new document will contain the default settings for that 
particular startup file: brushes, swatches, gradients, patterns, and styles. The startup files 
are called Adobe Illustrator Startup_CMYK and Adobe Illustrator Startup_RGB, respec-
tively, and are found in the Plug-ins folder inside the Adobe Illustrator application folder. 

You can create a custom startup file that defines the contents of the Swatches palette by 
default, including any custom color libraries that you want to appear in the Swatches 
palette. In this way, you can have easy access to the patterns, gradients, brushes, graph 
designs, colors, and color libraries that you use most frequently. By adding these elements 
to one or both of the startup files, you make them available in every new Adobe Illustrator 
file you create. 

In addition, any files you create have the same Document Setup and Page Setup settings 
as those found in the CMYK or RGB startup files, and they use the same zoom level, 
window size, viewing preferences, and scroll position as that of the startup file when it was 
last saved.

To create a custom startup file:

1 Make a backup copy of the current default startup file, Adobe Illustrator Startup_CMYK 
or Adobe Illustrator Startup_RGB, and then save the backup file outside of the Plug-ins 
folder. This action saves the original startup file in case you need it again. The startup files 
are located in the Plug-ins folder in the Adobe Illustrator application folder.

2 Open one of the default startup files (either CMYK or RGB, depending on which type of 
document you intend to use) as a template for the custom startup file. This file contains 
squares filled with the default colors, patterns, and gradients available in the Swatches 
palette.

3 Delete any existing colors, patterns, and gradients you don’t want to retain. Note that 
you must delete them from their respective palettes as well as from the artwork in the 
startup file.

4 Add new paint style attributes to the startup file as follows:

• Create any colors, patterns, and gradients you want. You can also import swatches using 
the Swatch Libraries command and then move the swatches you want in the startup 
file into the default Swatches palette. (See “Loading colors from other files” on 
page 166.)

• Save any graph designs that you want available in your files using the Graph Design 
dialog box. As with the new paint style attributes, add the graphs to the artwork in the 
startup file so you can see and refer to the graphs later if necessary.

5 Select the options you want as default settings in the Print Setup (Windows), Page 
Setup (Mac OS), and Document Setup dialog boxes, as well as the view preferences, the 
ruler origins, and the page origins.
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Save the new file as Adobe Illustrator Startup _CMYK or Adobe Illustrator Startup_RGB, 
and place it inside the Plug-ins folder.

Important: Make sure that you select the correct type of startup file (that is, CMYK or RGB) 
and that you save it with the exact name for its color mode. Also, you must quit the 
Illustrator application and restart it before the new startup settings are applied to a new 
document.

Using the Color Picker 
You can use the Color Picker to select the fill or stroke color by choosing from a color 
spectrum or by defining colors numerically. In addition, you can select colors based on the 
HSB, RGB, and CMYK color models (see “Color modes and models” on page 152), or enter a 
hexadecimal value to specify a color.

To display the Color Picker:

Do one of the following:

• Double-click the fill or stroke color selection box in the toolbox.

• Double-click the active color selection box in the Color palette. 

Specifying a color using the color field and color slider
With the HSB, RGB, and CMYK color modes, you can use the color field and the color slider 
in the Color Picker dialog box to select a color. The color slider displays the range of color 
levels available for the selected color component (for example, R, G, or B). The color field 
displays the range for the remaining two components—one on the horizontal axis, one on 
the vertical.

For example, if the current color is black and you click the red component (R) using the 
RGB color model, the color slider displays the range of color for red (0 is at the bottom of 
the slider and 255 is at the top). The color field displays the values for blue along its 
horizontal axis, for green along its vertical axis. 

To choose a color:

1 Click a component next to the HSB, RGB, or CMYK values.

2 Select the Only Web Colors option to display only Web-safe colors in the Color Picker.

3 Select a color:

• Drag the triangles along the slider.

• Click inside the color slider.

• Click inside the color field. 

When you click in the color field, a circular marker indicates the color’s position in the field. 

As you adjust the color using the color field and color slider, the numerical values change 
to reflect the new color. The color rectangle to the right of the color slider displays the new 
color in the top section of the rectangle. The original color appears at the bottom of the 
rectangle.

Specifying a color using numeric values
In the Color Picker, you can select a color in any of the color models by specifying numeric 
values for each color component. 
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To specify colors using numeric values:

Do one of the following:

• In CMYK color mode, specify each component value as a percentage of cyan, magenta, 
yellow, and black. 

• In RGB color mode (this is the mode your monitor uses), specify component values from 
0 to 255 (0 is black, and 255 is the pure color). 

• In HSB color mode, specify saturation and brightness as percentages; specify hue as an 
angle, from 0 to 360°, that corresponds to a location on the color wheel. (See “Color 
modes and models” on page 152 for information on the color wheel.)

Recognizing nonprintable or non-Web-safe colors
Some colors in the RGB and HSB color models, such as neon colors, cannot be printed, 
because they have no equivalents in the CMYK model. When you select a nonprintable 
color, an alert triangle with an exclamation point appears in the Color Picker dialog box 
and in the Color palette. The closest CMYK equivalent is displayed below the triangle. 
(See “Color gamuts” on page 154.)

Printable colors are determined by the printing values you enter for the selected ink set in 
the CMYK Setup dialog box.

A cube above the yellow triangle indicates that you have not chosen a Web-safe color. 

To select the closest CMYK equivalent for a nonprintable color:

Click the alert triangle that appears in the Color Picker dialog box or the Color palette.

To select the closest Web-safe equivalent for a non-Web-safe color:

The closest Web-safe equivalent color appears below (Windows) or above (Mac OS) the 
cube. Click the cube to substitute the closest Web-safe color.

Modifying colors
Illustrator provides a wide variety of tools to modify and edit colors in your file. You can use 
the paint bucket and eyedropper tools to copy paint attributes from one object to 
another. 

The eyedropper tool copies the entire style of an object. To copy just the color from a 
portion of a gradient, pattern, mesh object, or placed image, press the Shift key as you 
click the object.

Copying attributes between objects
You can use the eyedropper tool to copy appearance and color attributes—including 
transparency, live effects, and other attributes—from any object in an Illustrator file, from 
a paint swatch, or from anywhere on the desktop, including from another application. You 
can then use the paint bucket tool to apply the current attributes to an object. Together 
these tools let you copy attributes from one object to another. 

By default, the eyedropper and paint bucket tools affect all attributes of an object. You can 
use the tool’s options dialog box to change the object’s attributes. You can also use the 
eyedropper tool and paint bucket tool to copy and paste type attributes. (See “Copying 
type attributes between objects” on page 263.)
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To copy attributes using the eyedropper tool:

1 Select the object with the attributes you want to change.

2 Select the eyedropper tool .

3 Click the object that has the attributes you want to sample with the eyedropper tool. 
The selected object is automatically updated with the attributes of the sampled object.

Click the eyedropper tool to sample all appearance attributes. Shift-click to sample 
only the color. To duplicate the appearance of an object, hold down Alt (Windows) or 

Option (Mac OS) and Shift-click.

To copy attributes from the desktop to Illustrator using the eyedropper tool:

1 Select the object whose attributes you want to change. 

2 Select the eyedropper tool.

3 Click anywhere on the document and continue to hold down the mouse button.

4 Without releasing the mouse button, move the pointer over the object on your 
computer’s desktop whose attributes you want to copy. When directly over the object, 
release the mouse button. 

Important: When you copy an object’s characteristics from the desktop, the eyedropper 
tool only copies the RGB color from the screen, even if the object in another application is 
colored in the CMYK color mode.

To apply attributes using the paint bucket tool: 

1 Select the paint bucket tool .

2 Click any object to apply the saved attributes. 

If you are working in Outline view or if the object is stroked and not filled, be sure to click 
the object’s outline.

To toggle between the eyedropper tool and the paint bucket tool, press Alt 
(Windows) or Option (Mac OS) while either tool is selected.

To change the attributes affected by the paint bucket or eyedropper tool:

1 Double-click the paint bucket or eyedropper tool.

2 Select the attributes you want to copy with the eyedropper tool, then apply with the 
paint bucket tool and click OK.

Using the Hard Mix and Soft Mix effects
The Hard Mix and Soft Mix Pathfinder effects let you control the mix of overlapping fill 
colors. (See “Step 2: Select overprint options for overlapping colors” on page 346.)

Important: You can also control the mix of overlapping colors using the blending modes 
in the Transparency palette. Blending modes provide many options for controlling 
overlapping colors, and should always be used for artwork containing spot colors, 
patterns, gradients, text, or other complex artwork. 

Pathfinder effects can only be used on groups, layers, or sublayers. For more information 
on using effects, see “Using effects” on page 235.

• The Hard Mix effect combines colors by choosing the highest value of each of the color 
components. For example, if Color 1 is 20% cyan, 66% magenta, 40% yellow, and 0% 
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black; and Color 2 is 40% cyan, 20% magenta, 30% yellow, and 10% black; the resulting 
hard color is 40% cyan, 66% magenta, 40% yellow, and 10% black. 

• The Soft Mix effect makes the underlying colors visible through the overlapping 
artwork, and then divides the image into its component faces. You specify the 
percentage of visibility you want in the overlapping colors.

Note: Applying either the Hard Mix or Soft Mix effect to objects removes their strokes and 
groups the objects.

In most cases, applying the Hard Mix or Soft Mix effect to objects painted using a mix of 
process and spot colors converts the color to CMYK. In the case of mixing a non-global 
process RGB color with a spot RGB color, all spot colors are converted to a non-global 
process RGB color.

If you overlap multiple objects, all overlapping objects are given the visibility level you 
select.

To mix colors by selecting each highest CMYK component value (Hard Mix):

1 Select a group in the artwork, or target a group or layer in the Layers palette. (For more 
information on targeting, see “Changing the appearance of artwork using the Layers 
palette” on page 223.) 

2 Choose Effect > Pathfinder > Hard Mix. 

To mix colors by specifying a mixing rate (Soft Mix):

1 Select a group in the artwork, or target a group or layer in the Layers palette. (For more 
information on targeting, see “Changing the appearance of artwork using the Layers 
palette” on page 223.) 

2 Choose Effect > Pathfinder > Soft Mix. 

3 Enter a value between 1% and 100% in the Mixing Rate text box to determine the 
percentage of visibility you want in the overlapping colors, and click OK.

Using filters to modify colors
Illustrator filters provide shortcuts for changing color attributes or blending colors 
between objects. 

Using the Adjust Colors and Convert filters
The Adjust Colors filter lets you change the color values in objects, as well as the tint of 
global colors. You can also use the Convert filters to convert objects between grayscale 
and your document’s color mode.

To adjust colors using the Adjust Colors filter:

1 Select the objects whose colors you want to adjust.

2 Choose Filter > Colors > Adjust Colors.

3 Select Convert and then a color mode. If the document is an RGB document, you can 
select between RGB and Grayscale; if the document is CMYK, you can select between 
CMYK and Grayscale.

4 Select Fill or Stroke (or both) to adjust the fill or stroke or both. 

5 Drag the sliders or enter values in the color value text boxes. 
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6 Click Preview to preview the effect and click OK.

To convert an object to a different color mode using a Convert filter:

1 Select the object you want to convert.

2 Convert the object to grayscale or to your document’s color mode:

• If the document is a CMYK document, choose Filter > Colors > Convert to Grayscale or 
Filter > Colors > Convert to CMYK.

• If the document is an RGB document, choose Filter > Colors > Convert to Grayscale or 
Filter > Colors > Convert to RGB.

Saturating and desaturating colors
The Saturate filter darkens or lightens the colors of selected objects by increasing or 
decreasing the percentages of color values or the percentage tint of spot colors. You set 
the desired percentage using the Saturate dialog box.

To saturate or desaturate colors:

1 Select the objects whose colors you want to saturate or desaturate. 

2 Choose Filter > Colors > Saturate. 

3 Drag the slider or enter a value from –100% to 100% to specify the percentage by which 
to decrease or increase the color or the spot color tint.

4 Click Preview to preview the effect and click OK.

Inverting colors
The Invert Colors filter creates a color negative (or inverse) of the selected object. When 
you invert an object, its color values are converted to the inverse of the color values of the 
original. 

To invert colors:

1 Select the objects whose colors you want to invert.

2 Choose Filter > Colors > Invert Colors.
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Producing Consistent Color

Why colors sometimes don’t match
No device in a publishing system is capable of reproducing the full range of colors 
viewable to the human eye. Each device operates within a specific color space which can 
produce a certain range, or gamut, of colors.

The RGB (red, green, blue) and CMYK (cyan, magenta, yellow, and black) color models 
represent two main categories of color spaces. The gamuts of the RGB and CMYK spaces 
are very different; while the RGB gamut is generally larger (that is, capable of representing 
more colors) than CMYK, some CMYK colors still fall outside the RGB gamut (see “Color 
gamuts” on page 154 for an illustration). In addition, different devices produce slightly 
different gamuts within the same color model. For example, a variety of RGB spaces can 
exist among scanners and monitors, and a variety of CMYK spaces can exist among 
printing presses.

Because of these varying color spaces, colors can shift in appearance as you transfer 
documents between different devices. Color variations can result from different image 
sources (scanners and software produce art using different color spaces), differences in 
brands of computer monitors, differences in the way software applications define color, 
differences in print media (newsprint paper reproduces a smaller gamut than magazine-
quality paper), and other natural variations, such as manufacturing differences in monitors 
or monitor age.

About color management
Because color-matching problems result from various devices and software using 
different color spaces, one solution is to have a system that interprets and translates color 
accurately between devices. A color management system (CMS) compares the color space 
in which a color was created to the color space in which the same color will be output, and 
makes the necessary adjustments to represent the color as consistently as possible among 
different devices.

The following components are integral to a color-managed workflow:

Device-independent color space To successfully compare different device gamuts and 
make adjustments, a color management system must use a reference color space—an 
objective way of defining color. Most CMSs use the internal CIE (Commission Interna-
tionale d’Eclairage) LAB color model, which exists independently of any device and is large 
enough to reproduce any color visible to the human eye. For this reason, CIE LAB is 
considered device-independent.



Using Help | Contents | Index Back 175  

Adobe Illustrator Help Producing Consistent Color 

Using Help | Contents | Index Back 175  

Color management engine Different companies have developed various ways to 
manage color. To provide you with a choice, a color management system lets you choose a 
color management engine that represents the approach you want to use. Sometimes called 
the color management module (CMM), the color management engine is the part of the 
CMS that does the work of reading and translating colors between different color spaces. 

Color profiles The CMS translates colors with the help of color profiles. A profile is a 
mathematical description of a device’s color space, that is, how the reference CIE values of 
each color in the color space map to the visual appearance produced by the device. For 
example, a scanner profile tells a CMS how your scanner “sees” colors so that an image 
from your scanner can be translated into the CIE color space accurately. From the CIE 
space, the colors can then be translated accurately again, via another profile, to the color 
space of an output device. Illustrator uses ICC profiles, a format defined by the Interna-
tional Color Consortium (ICC) as a cross-platform standard.

Rendering intents No single color translation method can manage color correctly for all 
types of graphics. For example, a color translation method that preserves correct relation-
ships among colors in a wildlife photograph may alter the colors in a logo containing flat 
tints of color. Color management engines provide a choice of rendering intents, or trans-
lation methods, so that you can apply a method appropriate to a particular graphical 
element. For descriptions of the rendering intents available to Illustrator, see “Specifying a 
rendering intent” on page 184.

Note: Don’t confuse color management with color correction. A CMS won’t correct an 
image that was saved with tonal or color balance problems. It provides an environment 
where you can evaluate images reliably in the context of your final output.

Do you need color management?
Use the following guidelines to determine whether or not you need to use color 
management:

• You might not need color management if your production process is tightly controlled 
for one medium only. For example, you or your prepress service provider may prefer to 
tailor CMYK images and specify color values for a known, specific set of printing condi-
tions. 

• You can benefit from color management when you have more variables in your 
production process. Color management is recommended if you anticipate reusing 
color graphics for print and online media, using various kinds of devices within a single 
medium (such as different printing presses), if you manage multiple workstations, or if 
you plan to print to different domestic and international presses. If you decide to use 
color management, consult with your production partners—such as graphic artists and 
prepress service providers—to ensure that all aspects of your color management 
workflow integrate seamlessly with theirs.
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Creating a viewing environment for color management
Your work environment influences how you see color on your monitor and on printed 
output. For best results, control the colors and light in your work environment by doing 
the following:

• View your documents in an environment that provides a consistent light level and color 
temperature. For example, the color characteristics of sunlight change throughout the 
day and alter the way colors appear on your screen, so keep shades closed or work in a 
windowless room. To eliminate the blue-green cast from fluorescent lighting, consider 
installing D50 (5000 degree Kelvin) lighting. Ideally, view printed documents using a 
D50 lightbox.

• View your document in a room with neutral-colored walls and ceiling. A room’s color 
can affect the perception of both monitor color and printed color. The best color for a 
viewing room is polychromatic gray. Also, the color of your clothing reflecting off the 
glass of your monitor may affect the appearance of colors on-screen.

• Match the light intensity in the room or lightbox to the light intensity of your monitor. 
View continuous-tone art, printed output, and images on-screen under the same 
intensity of light.

• Remove colorful background patterns on your monitor desktop. Busy or bright patterns 
surrounding a document interfere with accurate color perception. Set your desktop to 
display neutral grays only.

• View document proofs in the real-world conditions under which your audience will see 
the final piece. For example, you might want to see how a housewares catalog looks 
under the incandescent light bulbs used in homes, or view an office furniture catalog 
under the fluorescent lighting used in offices. However, always make final color judge-
ments under the lighting conditions specified by the legal requirements for contract 
proofs in your country.

Setting up color management
Illustrator simplifies the task of setting up a color-managed workflow by gathering most 
color management controls in a single Color Settings dialog box. Rather than adjusting 
each control manually, you can choose from a list of predefined color management 
settings. Each predefined configuration includes a set of color management options 
designed to produce consistent color for a common publishing workflow, such as prepa-
ration for Web or domestic prepress output. These predefined configurations can also 
serve as starting points for customizing your own workflow-specific configurations.

Illustrator also uses color management policies, which determine how to handle color 
data that does not immediately match your current color management workflow. Policies 
are designed to clarify the color management decisions that you need to make when you 
open a document or import color data into an active document.

Keep in mind that you must specify color management settings before opening or 
creating files in order for the settings to take effect in those files.

Note: Illustrator supports color management for files that use either the RGB or CMYK 
color model. Illustrator does not support color management for the grayscale color model 
or for spot colors. If a file containing a grayscale object (defined in tints of black) is opened 
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or imported into Illustrator, that object will retain its grayscale qualities but will not be 
color-managed.

To open the Color Settings dialog box:

Choose Edit > Color Settings.

To display helpful descriptions of the terminology and options in the dialog box, position 
the mouse over a section heading or menu item. These descriptions appear in the lower 
area of the dialog box. 

Using predefined color management settings
Illustrator offers a collection of predefined color management settings, each with corre-
sponding color profile and conversion options designed to preserve consistent color for a 
particular publishing workflow under typical conditions. In most cases, the predefined 
settings will provide sufficient color management for your needs.

To choose a predefined color management setting:

1 Choose Edit > Color Settings.

2 For Settings, choose one of the following configuration options: 

Emulate Adobe® Illustrator® 6.0 Emulates the color workflow used by Illustrator 6.0 and 
earlier. This configuration does not recognize or save color profiles in documents. When 
you choose this configuration, the Assign Profile and soft-proofing commands are not 
available, and color management options in the Print dialog box are not available. 

Custom Uses the settings you choose in the Color Settings dialog box.

Color Management Off Uses minimal color management settings to emulate the 
behavior of applications that do not support color management. Use this option for 
content that will be output on video or as onscreen presentations.

ColorSync Workflow (Mac OS only) Manages color using the ColorSync 3.0 CMS with 
the profiles chosen in the ColorSync control panel. This color management configuration 
is not recognized by Windows systems, or by earlier versions of ColorSync.

Emulate Acrobat 4 Emulates the color workflow used by Adobe Acrobat 4.0 and earlier.

Emulate Photoshop 4 Emulates the color workflow used by Adobe Photoshop 4.0 and 
earlier.

Europe Prepress Defaults Manages color for content that will be output under common 
press conditions in Europe.

Japan Prepress Defaults Manages color for content that will be output under common 
press conditions in Japan.

Photoshop 5 Default Spaces Emulates the color workflow used by Adobe 
Photoshop 5.0

U.S. Prepress Defaults Manages color for content that will be output under common 
press conditions in the U.S.

Web Graphics Defaults Manages color for content that will be published on the World 
Wide Web.

When you choose a predefined configuration, the Color Settings dialog box updates to 
display the specific color management settings associated with the configuration.
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About working spaces
Among other options, predefined color management settings specify the default color 
profiles to be associated with the RGB and CMYK color models. Central to the color 
management workflow, these default profiles are known as the RGB and CMYK working 
spaces, respectively. The working spaces specified by predefined settings represent the 
color profiles that will produce the best color fidelity for several common output condi-
tions. For example, the U.S. Prepress Defaults setting uses a CMYK working space that is 
designed to preserve color consistency under standard Specifications for Web Offset 
Publications (SWOP) press conditions.

A working space acts as the default color profile for newly created documents that use the 
associated color model. For example, if Adobe RGB (1998) is the current RGB working 
space, each new RGB document that you create will use colors within the Adobe RGB 
(1998) gamut. Working spaces also define the destination gamut of documents converted 
to the RGB or CMYK color model.

Using color management policies
When you specify a predefined color management setting, Illustrator sets up a color 
management workflow that will be used as the standard for all documents and color data 
that you open or import. For a newly created document, the color workflow operates 
relatively seamlessly: the document uses the working space profile associated with its 
color model for creating and editing colors, and the profile is usually embedded in the 
saved document to provide color translation information for the destination output 
device.

However, some existing documents may not use the working space that you have 
specified, and some existing documents may not be color-managed. It is common to 
encounter the following exceptions to your color-managed workflow:

• You might open a document or import color data from a document that has not been 
color-managed and lacks a profile altogether. This is often the case when you open a 
document created in an application that either does not support color management or 
has color management turned off.

• You might open a document or import color data from a document that contains a 
color profile different from the current working space. This may be the case when you 
open a document that has been created using different color management settings, or 
a document that has been scanned and assigned with a scanner profile.

In either case, Illustrator must decide how to handle the color data in the document. A 
color management policy looks for the color profile associated with an opened document 
or imported color data, and compares the profile (or lack of profile) with the current 
working space to make default color management decisions. If the profile matches the 
working space, the colors are automatically brought into the color management workflow 
that you have specified, using the working space profile. If the profile is missing or does 
not match the working space, Illustrator displays a message that alerts you to the 
mismatch situation and, in many cases, lets you specify how to handle the colors in 
question. 
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The following table provides a summary of the policy decisions you may be prompted to 
consider when opening or importing mismatched color data:

The predefined color management workflows are set to display warning or option 
messages when a default color management policy is about to be implemented. 
Although you can disable the repeated display of some of the messages, it is highly 
recommended that you continue to display all policy messages, to ensure the appropriate 
color management of documents on a case-by-case basis. You should only turn off 
message displays if you are very confident that you understand the default policy decision 
and are willing to accept it for all documents that you open. You cannot undo the results 
of a default policy decision once a document has been saved.

To turn off the display of a policy message:

In the message dialog box, select the Don’t Show Again option if it is available.

To reset the display of policy messages that have been disabled:

1 Choose Edit > Preferences > General (Windows and Mac OS 9) or Illustrator > 
Preferences > General (Mac OS X).

2 Click Reset All Warning Dialogs, and click OK.

Customizing color management settings
Although the predefined settings should provide sufficient color management for most 
publishing workflows, you may sometimes want to customize individual options in a 
configuration. For example, you might want to change the CMYK working space to a 
profile that matches the proofing system used by your service bureau.

Mismatch situation Policy options that may be available

Opening non-color-
managed document 
without color profile

• Use working space for editing but not saving; 
do not color-manage document. 

• Use working space for editing, and save work-
ing space with document.

• Use another color profile for editing, and save 
profile with document.

Opening document 
with color profile that 
does not match work-
ing space

• Use profile (instead of working space) for 
editing, and save profile with document.

• Convert colors to working space, and save 
working space with document.

• Discard profile, and do not color-manage 
document.

Importing color data 
into destination docu-
ment

• Import and convert numeric values of source 
colors to color space of destination document 
in order to preserve color appearances.

• Import and preserve numeric values of 
source colors.
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Color management settings can be shared with other users and with other applications 
that use the Color Settings dialog box, such as Adobe Photoshop 6.0 and later. It’s 
important to save your custom configurations if you want to reuse and share them with 
other users who use the same color management workflows; for more information, 
see “Saving and loading custom color management settings” on page 185. The color 
management settings that you customize in the Color Settings dialog box have an 
associated preferences file called AI Color Settings, located in the same location as Adobe 
Illustrator preference file. (See “Setting preferences” on page 20.)

To customize color management settings:

1 Choose Edit > Color Settings.

2 To use a preset color management configuration as the starting point for your customi-
zation, choose that configuration from the Settings menu.

3 Specify the desired color settings. (As you make adjustments, the Settings menu option 
changes to Custom by default.) Refer to the following sections for detailed customization 
instructions.

Specifying working spaces
In a color-managed workflow, each color model must have a working space associated 
with it. At times you may want to customize the RGB or CMYK working space to reflect a 
workflow that uses a particular output or display device. For more information, see “About 
working spaces” on page 178. 

Illustrator ships with a standard set of color profiles that have been recommended and 
tested by Adobe Systems for most color management workflows. By default, only these 
profiles appear under the working space menus. To display additional color profiles that 
you have installed on your system, select Advanced Mode at the top of the Color Settings 
dialog box. To appear under a working space menu, a color profile must be bi-directional, 
that is, contain specifications for translating both into and out of color spaces. 
For information on installing color profiles, see “Adding device profiles to the color 
management system” on page 187.

For the RGB color model, the following standard working space options are available:

Adobe RGB (1998) Provides a fairly large gamut (range) of colors and is well-suited for 
documents that will be converted to CMYK. Use this space if you need to do print 
production work with a broad range of colors.

sRGB IEC61966-2.1 Reflects the characteristics of the average PC monitor. This standard 
space is endorsed by many hardware and software manufacturers, and is becoming the 
default color space for many scanners, low-end printers, and software applications. This 
space is recommended for Web work but not for prepress work (because of its limited 
color gamut).

Apple RGB Reflects the characteristics of the Apple Standard 13-inch monitor, and is 
used by a variety of desktop publishing applications, including Adobe Photoshop 4.0 and 
earlier. Use this space for files that you plan to display on Mac OS monitors, or for working 
with legacy (older) desktop publishing files.

ColorMatch RGB Matches the native color space of Radius Pressview monitors. 
This space provides a smaller gamut alternative to Adobe RGB (1998) for print 
production work.
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Monitor RGB Sets the RGB working space to the current color profile of your monitor. Use 
this setting if other applications in your workflow do not support color management. If a 
color management configuration that specifies Monitor RGB is shared with another user 
working on a different system, the configuration uses that system’s monitor profile as the 
working space.

ColorSync RGB (Mac OS only) Matches the RGB space specified in the control panel for 
Apple ColorSync 3.0 or later. If a color management configuration specifying this setting is 
shared with another user working on a different system, the configuration uses that 
system’s ColorSync RGB space as the working space.

For the CMYK color model, the following standard working space options are available:

Euroscale Coated v2 Uses specifications designed to produce quality separations using 
Euroscale inks under the following printing conditions: 350% total area of ink coverage, 
positive plate, bright white coated stock.

Euroscale Uncoated v2 Uses specifications designed to produce quality separations 
using Euroscale inks under the following printing conditions: 260% total area of ink 
coverage, positive plate, uncoated white offset stock.

Japan Standard v2 Uses specifications designed to produce quality separations using 
Japan Standard inks under the following printing conditions: 300% total area of ink 
coverage, positive plate, coated publication-grade stock.

U.S. Sheetfed Coated v2 Uses specifications designed to produce quality separations 
using U.S. inks under the following printing conditions: 350% total area of ink coverage, 
negative plate, bright white coated stock.

U.S. Sheetfed Uncoated v2 Uses specifications designed to produce quality separations 
using U.S. inks under the following printing conditions: 260% total area of ink coverage, 
negative plate, uncoated white offset stock.

U.S. Web Coated (SWOP) v2 Uses specifications designed to produce quality separa-
tions using U.S. inks under the following printing conditions: 300% total area of ink 
coverage, negative plate, coated publication-grade stock. This profile was created using 
the TR001 characterization data.

U.S. Web Uncoated v2 Uses specifications designed to produce quality separations 
using U.S. inks under the following printing conditions: 260% total area of ink coverage, 
negative plate, uncoated white offset stock.

ColorSync CMYK (Mac OS only) Matches the CMYK space specified in the control panel 
for Apple ColorSync 3.0 or later. If a color management configuration specifying this 
setting is shared with another user working on a different system, the configuration uses 
that system’s ColorSync CMYK space as the working space.

Specifying color management policies
Each predefined color management configuration sets up a color management policy for 
each color model and displays warning messages to let you override the default policy 
behavior on a case-by-case basis. If desired, you can change the default policy behavior to 
reflect a color management workflow that you use more often. For more information on 
policies, see “Using color management policies” on page 178. 
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To customize color management policies:

1 In the Color Settings dialog box, under Color Management Policies, choose one of the 
following to set the default color management policy for each color model:

• Off if you do not want to color-manage imported or opened color data.

• Preserve Embedded Profiles if you anticipate working with a mix of color-managed and 
non-color-managed documents, or with documents that use different profiles within 
the same color model.

• Convert to Working Space if you want to color-manage all documents using the current 
working spaces.

For detailed descriptions of the default behaviors associated with each policy option, 
see the table following this procedure.

Policy option Default color management behavior

Off • No profiles are saved with new documents.

• If opened document’s profile does not match cur-
rent working space, profile is discarded and not saved 
with document.

• If opened document’s profile matches current 
working space, profile is preserved and saved with 
document.

• For color data imported into same color model, 
numeric values of colors are preserved.

• For color data imported into different color model, 
colors are converted to destination document’s color 
space.

Preserve 
Embedded Pro-
files

• Working space profile is saved with new documents.

• If opened document’s profile does not match cur-
rent working space, profile is preserved and saved 
with document. 

• If opened document does not contain a profile, 
working space is used for editing but not saved with 
document. 

• For color data imported within same color model 
between either a non-color-managed source or desti-
nation, or from a CMYK document into a CMYK docu-
ment, numeric color values are preserved.

• For all other import cases, colors are converted to 
destination document’s color space.
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2 Select either, both, or neither of the following:

• Ask When Opening to display a message whenever the embedded color profile in a 
newly opened document does not match the current working space. You will be given 
the option to override the policy’s default behavior.

• Ask When Pasting to display a message whenever color profile mismatches occur as 
colors are imported into a document (via pasting, drag-and-drop, placing, and so on). 
You will be given the option to override the policy’s default behavior.

It is strongly recommended that you keep both options selected. Deselecting the options 
causes Illustrator to implement default policy behavior without notification.

Customizing advanced color management settings
When you select Advanced Mode at the top of the Color Settings dialog box, you have the 
option of further customizing settings used for color management.

Specifying a color management engine
The color management engine specifies the system and color-matching method used to 
convert colors between color spaces. For more information, see “About color 
management” on page 174.

The following standard engine options are available. If you have installed additional color 
management engines, they may also appear as options.

Adobe (ACE) Uses the Adobe color management system and color engine. This is the 
default setting for most preset color configurations.

Apple ColorSync Uses the color management system provided by Apple Computer, Inc. 
for Mac OS computers.

Microsoft ICM Uses the color management system provided by Microsoft Corporation 
for Windows 98 and Windows 2000 computers.

Apple CMM Uses the color management system provided by Apple Computer, Inc. for 
Mac OX computers.

Heidelberg CMM Uses the color management system provided by Heidelberg for Mac 
OX computers.

Convert to 
Working Space

• Working space profile is saved with new documents.

• If opened document’s profile does not match cur-
rent working space, document is converted to work-
ing space; working space is saved with document.

• If opened document does not contain a profile, 
working space is used for editing but not saved with 
document.

• For color data imported within same color model 
between either a non-color-managed source or desti-
nation, numeric color values are preserved.

• For all other import cases, colors are converted to 
destination document’s color space.

Policy option Default color management behavior
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Specifying a rendering intent
Translating colors to a different color space usually involves an adjustment of the colors to 
accommodate the gamut of the destination color space. Different translation methods use 
different rules to determine how the source colors are adjusted; for example, colors that 
fall inside the destination gamut may remain unchanged, or they may be adjusted to 
preserve the original range of visual relationships as translated to a smaller destination 
gamut. These translation methods are known as rendering intents because each technique 
is optimized for a different intended use of color graphics.

Note: The result of choosing a rendering intent depends on the graphical content of 
documents and on the profiles used to specify color spaces. Some profiles produce 
identical results for different rendering intents. Differences between rendering intents are 
apparent only when you print a document or convert it to a different working space.

The following rendering intent options are available:

Perceptual This intent aims to preserve the visual relationship between colors in a way 
that is perceived as natural to the human eye, although the color values themselves may 
change.

Saturation Appropriate for office and presentation graphics, this intent aims to create 
vivid color at the expense of accurate color. It scales the source gamut to the destination 
gamut but preserves relative saturation instead of hue, so when scaling to a smaller 
gamut, hues may shift. This rendering intent is suitable for business graphics, where the 
exact relationship between colors is not as important as having bright saturated colors.

Absolute Colorimetric Leaves colors that fall inside the destination gamut unchanged. 
This intent aims to maintain color accuracy at the expense of preserving relationships 
between colors. When translating to a smaller gamut, two colors that are distinct in the 
source space may be mapped to the same color in the destination space. 

Relative Colorimetric This intent is identical to absolute colorimetric except for the 
following difference: relative colorimetric compares the white point (extreme highlight) of 
the source color space to that of the destination color space and shifts all colors accord-
ingly. Relative colorimetric can be more accurate if the image’s profile contains correct 
white point information. This is the default rendering intent used by all predefined color 
management configurations.

Using black-point compensation
The Use Black Point Compensation option controls whether to adjust for differences in 
black points when converting colors between color spaces. When this option is enabled, 
the full dynamic range of the source space is mapped into the full dynamic range of the 
destination space. When disabled, the dynamic range of the source space is simulated in 
the destination space; although this mode can result in blocked or gray shadows, it can be 
useful when the black point of the source space is lower than that of the destination 
space.

The Use Black Point Compensation option is selected for all predefined color management 
configurations. It is highly recommended that you keep this option selected. 
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Saving and loading custom color management settings
When you create a custom color management configuration, you should name and save 
the configuration to ensure that it can be reused and shared with other users. You can 
also load previously saved color management configurations into the Color Settings 
dialog box.

To save a custom color management configuration:

1 In the Color Settings dialog box, click Save.

2 Name your color settings file, and click Save. 

To ensure that Illustrator displays the saved configuration in the Settings menu of the 
Color Settings dialog box, save the file in the Color Settings folder (the default location 
when you first open the Save dialog box).

To load a color management configuration:

1 In the Color Settings dialog box, click Load.

2 Locate and select the desired color settings file, and click Open.

When you load a custom color settings file, it appears as the active choice in the Settings 
menu of the Color Settings dialog box. If you choose a different option from the Settings 
menu, you must reload the custom settings file in order to access it again.

Soft-proofing colors
In a traditional publishing workflow, you print a hard proof of your document to preview 
how the document’s colors will look when reproduced on a specific output device. In a 
color-managed workflow, you can use the precision of color profiles to soft-proof your 
document directly on the monitor. You can display an onscreen preview of how your 
document’s colors will look when reproduced on a particular output device.

Keep in mind that the reliability of the soft proof is highly dependent upon the quality of 
your monitor, your monitor profile, and the ambient lighting conditions of your work 
station. For information on creating a monitor profile, see “Creating an ICC monitor 
profile” on page 188.

Note: The soft-proofing commands are not available when the Emulate Adobe Illustrator 
6.0 setting is chosen in the Color Settings dialog box.

To display a soft proof:

1 Choose View > Proof Setup, and choose the output display that you want to simulate:

• Choose Custom to soft-proof colors as displayed on a specific output device. Then 
follow the instructions outlined in the next procedure to set up the custom proof.

• Choose Macintosh RGB or Windows RGB to soft-proof colors using either a standard 
Mac OS or Windows monitor as the proof profile space that you want to simulate.

• Choose Monitor RGB to soft-proof colors using your current monitor color space as the 
proof profile space.

2 Choose View > Proof Colors to toggle the soft-proof display on and off. When soft 
proofing is on, a checkmark appears next to the Proof Colors command.



Using Help | Contents | Index Back 186  

Adobe Illustrator Help Producing Consistent Color 

Using Help | Contents | Index Back 186  

To create a custom proof setup:

1 Choose View > Proof Setup > Custom.

2 In the Proof Setup dialog box, for Profile, choose the color profile for the device for 
which you want to create the proof.

3 If you chose a proof profile using the document’s current color model, do one of the 
following:

• Select Preserve Color Numbers to simulate how the document will appear without 
converting colors to the proof profile space.

• Deselect Preserve Color Numbers to simulate how the document will appear if colors 
are converted to the proof profile space in an effort to preserve the colors’ visual 
appearances. Then specify a rendering intent for the conversion; for more information, 
see “Specifying a rendering intent” on page 184.

4 Click OK.

Changing the color profile of a document
In some cases you may want to use the Assign Profile command to assign a different color 
profile to a document with an existing profile, or remove the existing profile altogether. 
For example, you may want to prepare the document for a different output destination, 
or you may want to correct a policy behavior that you no longer want implemented on the 
document. The Assign Profile command is recommended only for advanced users.

Note: The Assign Profile command is not available when the Emulate Adobe Illustrator 6.0 
setting is chosen in the Color Settings dialog box.

To reassign or discard the profile of a document:

1 Choose Edit > Assign Profile.

2 Select one of the following:

• Don’t Color Manage This Document to remove the existing profile from the document. 
Select this option only if you are sure that you do not want to color-manage the 
document.

• Working <color model: working space> to assign the working space profile to a 
document that either uses no profile or a profile different from the working space. 

• Profile to reassign a different profile to a color-managed document. Choose the desired 
profile from the menu. Illustrator assigns the new profile to the document without 
converting colors to the profile space.

3 Click OK.

Embedding profiles in saved documents
By default, a document for which you have specified color management will have its 
profile embedded upon saving in a file format that supports embedded ICC profiles. These 
formats include the native Illustrator format (.ai), PDF, JPEG, TIFF, and the native Photoshop 
format (.psd). Profiles are not saved by default with non-color-managed documents. 
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You can change the default behavior to embed or not to embed profiles as you save a 
document. Changing the default behavior, however, is recommended only for advanced 
users who are very familiar with color management.

To change the embedding behavior of a profile in a document:

1 Choose File > Save. Name the document, specify a file format, and click Save.

2 In the file format options dialog box that appears, select or deselect Embed ICC Profile.

3 Click OK to save the document.

Obtaining, installing, and updating color profiles
Precise, consistent color management requires accurate ICC-compliant profiles of all of 
your color devices. For example, without an accurate scanner profile, a perfectly scanned 
image may appear incorrect in another program, simply due to any difference in gamuts 
between the scanner and the program displaying the image. This misleading represen-
tation may cause you to make unnecessary, time-wasting, and potentially damaging 
“corrections” to an already satisfactory image. With an accurate profile, a program 
importing the image can correct for any gamut differences and display a scan’s actual 
colors.

Once you obtain accurate profiles, they will work with all applications that are compatible 
with your color-management system. You can obtain profiles in the following ways, with 
the most precise methods listed first:

• Generate profiles customized for your specific devices using professional profiling 
equipment.

• Check with your service provider. Some providers will use their equipment to create a 
profile for your equipment.

• Obtain a profile created by the manufacturer. Unfortunately, such profiles do not 
account for individual variations that naturally occur among machines (even identical 
models from the same manufacturer) or from age.

• Substitute an available profile that may be appropriate given information you have 
about the device’s gamut. For example, many Mac OS scanners have been optimized 
for an Apple RGB monitor gamut, so you might try using an Apple monitor profile for 
these devices. Be sure to proof images created with the profile before using the profile 
in production. This workaround is unlikely to produce results suitable for professionally 
color-managed work.

Adding device profiles to the color management system
The Illustrator installer lets you choose from manufacturer-supplied device profiles for 
some commonly used equipment. This is useful if you don’t have access to hardware-
based calibration tools. It is not possible for the installer to supply profiles for all devices. 
If the installer did not install a profile for your device, create one or contact the device 
manufacturer to obtain one.

To minimize confusion when working with profiles, delete any profiles for devices not 
used by you or your workgroup.

In Mac OS, you can organize the ColorSync Profiles folder by creating additional 
folders within it, or adding aliases to other folders.
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To add profiles to your system:

Do one of the following:

• In Windows NT or 2000, copy profiles into the WinNT\System32\Color folder.

• In Windows 98, copy profiles into the Windows\System\Color folder.

• In Mac OS, copy profiles into the ColorSync Profiles folder in the System Folder 
(ColorSync 2.5 or later).

Note: If you use ColorSync 2.5 but have used earlier versions, some profiles may still be 
stored in System Folder/Preferences/ColorSync™ Profiles on your hard disk. For compati-
bility with ColorSync 2.5 or later, store profiles in the ColorSync Profiles folder in the System 
Folder.

Updating profiles
The color reproduction characteristics of a color device change as it ages, so recalibrate 
devices periodically and generate updated profiles. Profiles should be good for approxi-
mately a month depending on the device. Some monitors automatically compensate for 
phosphor aging.

Also, recalibrate a device when you change any of the factors that affect calibration. For 
example, recalibrate your monitor when you change the room lighting or the monitor 
brightness setting.

Creating an ICC monitor profile
Your monitor will display color more reliably if you use color management and accurate 
ICC profiles. The Adobe Gamma utility, which is automatically installed into your Control 
Panels folder, lets you calibrate and characterize your monitor to a standard and then save 
the settings as an ICC-compliant profile available to any program that uses your color 
management system. This calibration helps you eliminate any color cast in your monitor, 
make your monitor grays as neutral as possible, and standardize image display across 
different monitors.

Although Adobe Gamma is an effective calibration and profiling utility, hardware-based 
utilities are more precise. If you have a hardware-based utility that can generate an ICC-
compliant profile, you should use that instead of Adobe Gamma. 

Depending on your workflow scenario, an ICC monitor profile can be either a source 
profile, a destination profile, or both. 

Note: Adobe Gamma can characterize, but not calibrate, monitors used with Windows NT. 
In addition, the ICC profile you create with Adobe Gamma can be used as the system-level 
profile in Windows NT. Its ability to calibrate settings in Windows 98 depends on the video 
card and video driver software. In such cases, some calibration options documented here 
may not be available.
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Calibrating versus characterizing a monitor
Profiling software such as Adobe Gamma can both characterize and calibrate your 
monitor. When you characterize your monitor, you create a profile that describes how the 
monitor is currently reproducing color. When you calibrate your monitor, you bring it into 
compliance with a predefined standard; adjusting your monitor so that it displays color 
using the graphics arts standard white point color temperature of 5000 kelvin is an 
example of calibration.

Determine in advance the standard to which you are calibrating so that you can enter the 
set of values for that standard. Coordinate calibration with your workgroup and prepress 
service provider to make sure you’re all calibrating to the same standard.

About monitor calibration settings
Monitor calibration involves adjusting video settings, which may be unfamiliar to you. 
A monitor profile uses these settings to precisely describe how your monitor reproduces 
color.

Brightness and contrast The overall level and range, respectively, of display intensity. 
These parameters work just as they do on a television. Adobe Gamma helps you set an 
optimum brightness and contrast range for calibration.

Gamma The brightness of the midtone values. The values produced by a monitor from 
black to white are nonlinear—if you graph the values, they form a curve, not a straight 
line. Gamma defines the value of that curve at halfway between black and white. Gamma 
adjustment compensates for the nonlinear tonal reproduction of output devices such as 
monitor tubes.

Phosphors The substance that monitors use to emit light. Different phosphors have 
different color characteristics.

White point The RGB coordinates at which red, green, and blue phosphors at full 
intensity create white.

Guidelines for creating an ICC monitor profile
The following guidelines can help you create an accurate monitor profile.

 You may find it helpful to have your monitor’s user guide handy while using Adobe 
Gamma.

• You don’t need to calibrate your monitor if you’ve already done so using an 
ICC-compliant calibration tool such as Adobe Gamma and haven’t changed your video 
card or monitor settings.

• If you have the Mac OS Gamma control panel (included with Adobe Photoshop 4.0 and 
earlier) or the Monitor Setup utility (included with PageMaker® 6.0) for Windows, 
remove it; it is obsolete. Use the latest Adobe Gamma utility instead.

• Make sure your monitor has been turned on for at least a half hour. This gives it suffi-
cient time to warm up for a more accurate color reading.

• Make sure your monitor is displaying thousands of colors or more.

• Remove colorful background patterns on your monitor desktop. Busy or bright patterns 
surrounding a document interfere with accurate color perception. Set your desktop to 
display neutral grays only, using RGB values of 128. For more information, see the 
manual for your operating system.
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• If your monitor has digital controls for choosing the white point of your monitor from 
a range of preset values, set those controls before starting Adobe Gamma. Later, in 
Adobe Gamma, you’ll set the white point to match your monitor’s current setting. Be 
sure to set the digital controls before you start Adobe Gamma. If you set them after you 
begin the calibration process in Adobe Gamma, you’ll need to begin the process again.

• Monitor performance changes and declines over time; recharacterize your monitor 
every month or so. If you find it difficult or impossible to calibrate your monitor to a 
standard, it may be too old and faded.

Calibrating with Adobe Gamma
The ICC profile you get using Adobe Gamma uses the calibration settings to describe how 
your monitor reproduces color. 

To use Adobe Gamma:

1 Do one of the following to start the Adobe Gamma utility:

• In Windows, double-click Adobe Gamma, located in the Program Files\Common Files 
\Adobe\Calibration folder on your hard drive.

• In Mac OS, from the Apple menu, choose Control Panels > Adobe Gamma.cpl.

2 Do one of the following:

• To use a version of the utility that will guide you through each step, select Step by Step, 
and click Next. This version is recommended if you’re inexperienced. If you choose this 
option, follow the instructions described in the utility. Start from the default profile for 
your monitor if available.

• To use a compact version of the utility with all the controls in one place, select Control 
Panel, and click Next. This version is recommended if you have experience creating 
color profiles.

Any time while working in the Adobe Gamma control panel, you can click the Wizard 
(Windows) or Assistant (Mac OS) button to switch to the wizard for instructions that 

guide you through the same settings as in the control panel, one option at a time.
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Using Transparency, Gradients, 
and Patterns

About transparency
In Illustrator, you can add transparency to your artwork in a variety of ways. You can vary 
the degree of transparency of an object, a group of objects, or a layer from 100% opacity 
(completely solid) to 0% opacity (completely transparent). When you decrease an object’s 
opacity, the underlying artwork becomes visible through the surface of the object. 

Using commands in the Transparency palette, you can also create special effects, 
such as knocking out underlying colors, or creating graduated transparencies or blends. 
For example, you can use the Knockout option in the Transparency palette to have an 
overlapping stroke knock out the color of the underlying fill.

Filled circle and overlying stroke without Knockout Group option (left) and with Knockout Group 
option applied (right).

Transparency is such an integral part of Illustrator that it’s possible to add transparency to 
your artwork without realizing it. For example, applying effects and styles may introduce 
transparency into your artwork. It’s important to be aware of when you’re using trans-
parency because you need set some extra options when printing and saving transparent 
artwork. (See “Printing and saving transparent artwork” on page 336.)

Using grouped objects with the Transparency palette
By default the Transparency palette acts on objects, but you can also use it to create 
unique transparency effects at the group or layer level.

If you simply select objects and change the opacity setting, the selected objects’ opacity 
will change relative to the others. Any overlapping areas will show an accumulated 
opacity. 
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In contrast, if you target a group that has been created with the Group command and then 
change the opacity, the group is treated as a single object by the Transparency palette and 
the opacities within the group do not change. Only objects outside the group are made 
transparent relative to the group.

Individual objects selected and set to 50% opacity (left). Group selected and set to 50% opacity 
(right).

Printing and exporting files containing transparency effects
Before you print a file containing transparency effects, make sure to check the trans-
parency preferences first. Printing automatically flattens the artwork and may affect the 
appearance of the transparency effects. See “About printing” on page 332 and “Printing 
and saving transparent artwork” on page 336.

When you share files between Illustrator and Adobe Photoshop, transparency is 
preserved. Opacity masks in Illustrator convert to layers masks in Photoshop, and vice 
versa. See “Opening Photoshop files in Illustrator” on page 34.

Using the Transparency palette
Use the Transparency palette to specify the opacity and blending mode of objects, to 
create opacity masks, or to knock out a portion of one object with the overlying portion of 
a transparent object (see “About opacity masks” on page 194 and “About transparency 
knockouts” on page 198).

Displaying the Transparency palette Choose Window > Transparency.

Using the Transparency palette menu Click the triangle  in the upper right corner of 
the palette to access commands for working with transparency.

Displaying transparency options Choose Show Options from the Transparency palette 
menu. 

Using the Transparency Grid
You can display a checkered background grid that lets you more easily view the areas of 
the artwork that are transparent when you are working on the artwork.

Viewing the Transparency Grid Choose View > Show Transparency Grid, or View > Hide 
Transparency Grid. 

Specifying transparency
By default, the entire object (both the stroke and the fill) is affected by transparency 
commands. To change the transparency of only the fill or only the stroke, you can select 
the fill or stroke in the Appearance palette. You can then apply transparency effects to the 
selected fill or stroke using the Transparency palette. 
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Use the Layers palette to target an object, group of objects, or layer when applying trans-
parency effects. (See “Changing the appearance of artwork using the Layers palette” on 
page 223.) This is the only way to ensure that the effect is applied only to the artwork you 
want to target. When you make transparency changes on a targeted layer, the changes are 
applied to the layer as a whole, not to objects on the layer. Objects moved out of the layer 
do not retain the layer’s transparency values.

To change the opacity of an object, group, or layer:

1 Select the object, group, layer, or sublayer using one of the following methods:

• Use the selection tool or direct-selection tool to select the object, or target it in the 
Layers palette.

• Use the selection tool to select a group on the artboard. To select more than one group, 
hold down Shift and click the other groups.

• In the Layers palette, click the target icon of the desired layer or group. To select more 
than one layer or group, hold down Shift, and click their target icons.

2 In the Transparency palette, drag the Opacity slider or enter a transparency value.

Changing the display of transparent artwork
You use the Document Setup dialog box to set transparency preferences, which 
determine how transparent artwork displays. Using these settings, you can change the 
size or color of the Transparency Grid, or you can adjust the quality or printing speed of 
transparent artwork. 

To set transparency preferences:

1 Choose File > Document Setup.

2 Choose Transparency from the menu at the top of the Document Setup dialog box.

3 In the Grid Size menu, choose the desired checkerboard size.

4 In the Grid Colors pop-up menu, do one of the following: 

• Choose a preset pair of grid colors.

• Create a custom pair of grid colors by clicking each color swatch to the right of the Grid 
Colors pop-up menu. In the color picker, select a color, and then click OK.

5 Check the Simulate Paper option to view your document as it might appear when 
printed on paper whose color matches the top swatch. For example, if you were to draw a 
blue object on a yellow artboard background, the object would appear green. The 
simulation is only performed when the transparency grid is not shown.

In CMYK documents, choosing the Simulate Paper option is even useful with a white 
background, as it gives you a more accurate preview of how non-opaque artwork will 

print.

6 Click OK.
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About opacity masks
An opacity mask lets you partially hide artwork using the mask’s luminosity. Patterns or 
gradients contained in the mask are visible on the masked artwork. 

Creating opacity masks
You create the opacity mask from the topmost shape in the selected set of objects. Once 
the mask is created, a thumbnail of it appears in the Transparency palette next to the 
thumbnail of the object being masked. By default, the mask and the object are linked 
together (as shown by a link between the thumbnails), and move together as a unit. 

You can create an opacity mask from virtually any artwork imaginable, including a 
gradient, mesh, or pattern (see “About gradients, meshes, and blends” on page 200). 

To create an opacity mask:

Do one of the following:

• Select at least two objects or groups, and choose Make Opacity Mask in the Trans-
parency palette menu. The topmost selected object or group is used as the mask.

• Target a single object, group, or layer, and double-click the mask thumbnail area 
(directly to the right of the object thumbnail) of the Transparency palette. An empty 
mask is created and Illustrator automatically enters mask-editing mode. Use the 
drawing tools to draw a mask shape. 

Note: If you use black type to create an opacity mask with the Clip option turned on, the 
type will not be visible. To see the type, use a different color of type or deselect the Clip 
option.

To remove or disable an opacity mask:

Select the masked artwork and do one of the following:

• Choose Release Opacity Mask in the Transparency palette menu to remove the mask. 
The contents of the mask appear on top of the artwork that was masked.

• Choose Disable Opacity Mask in the Transparency palette menu to deactivate the mask 
without removing it. To reactivate the mask, choose Enable Opacity Mask from the 
Transparency palette menu. A red x appears over the mask thumbnail in the palette.

To edit an opacity mask:

1 Do one of the following to enter mask-editing mode:

• Click on the mask thumbnail in the Transparency palette. 

• Alt-click (Windows) or Option-click (Mac OS) on a mask thumbnail to view only the 
mask in the document window.

2 Use any of the Illustrator editing tools and techniques to edit the mask. Changes made 
to the mask are immediately visible in the Transparency palette.

3 Click the artwork thumbnail in the Transparency palette to exit mask-editing mode.
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To unlink or relink a mask:

Select the artwork and then do one of the following:

• Click the link symbol  between the artwork thumbnail and the mask thumbnail in the 
Transparency palette. Click the area between the thumbnails again to relink the mask 
and artwork.

• Choose Unlink Opacity Mask in the Transparency palette menu. To relink the mask, 
choose Link Opacity Mask in the Transparency palette menu. 

Clipping and inverting the values of an opacity mask
When you select artwork that has an opacity mask, the Clip and Invert Mask buttons 
become enabled in the Transparency palette. The Clip button specifies that the mask 
doubles as a clipping mask, making the masked objects fully transparent outside the 
boundaries of the masking artwork. The Invert Mask command reverses the luminosity 
values of the masking artwork, which reverses the opacity of the masked artwork (for 
example, areas that are 90% transparent become 10% transparent after inverting). Select 
both options to create a clipping opacity mask that uses inverted luminosity values.

Clip and Invert Mask options 
A. Neither Clip or Invert Mask selected B. Clip selected C. Invert Mask selected D. Both options 
selected

To create a clipping mask from the opacity mask:

1 Select the masked artwork. 

2 Select the Clip option. Deselect the Clip option to remove the clipping mask. 

To specify all mask are clipping masks by default:

Choose New Opacity Masks Are Clipping from the Transparency palette menu. 

To invert the opacity of a mask or to restore an inverted mask to its original state:

1 Select the masked artwork. 

2 Select the Invert Mask option. Deselect the Invert Mask option to return the mask to the 
original state. 
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To invert all masks by default: 

Choose New Opacity Masks Are Inverted from the Transparency palette menu. 

About blending modes
You can blend the colors between two superimposed objects by using the blending 
modes in the Transparency palette. 

Blending modes let you vary the ways that the colors of objects blend with the colors of 
underlying objects. 

It’s helpful to think in terms of the following colors when visualizing a blending mode’s 
effect: 

• The base color is the underlying color in the artwork. 

• The blend color is the color of the selected object, group, or layer.

• The resulting color is the color resulting from the blend. 

Selecting blending modes
You can apply blending modes to any object, group, layer, or sublayer in your artwork.

To specify the blending mode of an object:

1 Target the desired object, group, layer, or sublayer.

2 In the Transparency palette, choose one of the following blending modes from 
the menu: 

Normal Paints the selection with the blend color, without interaction with the base color. 
This is the default mode. 

Multiply Multiplies the base color by the blend color. The resulting color is always a 
darker color. Multiplying any color with black produces black. Multiplying any color with 
white leaves the color unchanged. The effect is similar to drawing on the page with 
multiple magic markers. 

Screen Multiplies the inverse of the blend and base colors. The resulting color is always a 
lighter color. Screening with black leaves the color unchanged. Screening with white 
produces white. The effect is similar to projecting multiple slide images on top of 
each other. 

Overlay Multiplies or screens the colors, depending on the base color. Patterns or colors 
overlay the existing artwork, preserving the highlights and shadows of the base color 
while mixing in the blend color to reflect the lightness or darkness of the original color. 

Soft Light Darkens or lightens the colors, depending on the blend color. The effect is 
similar to shining a diffused spotlight on the artwork. 

If the blend color (light source) is lighter than 50% gray, the artwork is lightened, as if it 
were dodged. If the blend color is darker than 50% gray, the artwork is darkened, as if it 
were burned in. Painting with pure black or white produces a distinctly darker or lighter 
area but does not result in pure black or white. 

Hard Light Multiplies or screens the colors, depending on the blend color. The effect is 
similar to shining a harsh spotlight on the artwork. 
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If the blend color (light source) is lighter than 50% gray, the artwork is lightened, as if it 
were screened. This is useful for adding highlights to artwork. If the blend color is darker 
than 50% gray, the artwork is darkened, as if it were multiplied. This is useful for adding 
shadows to artwork. Painting with pure black or white results in pure black or white.

Color Dodge Brightens the base color to reflect the blend color. Blending with black 
produces no change.

Color Burn Darkens the base color to reflect the blend color. Blending with white 
produces no change.

Darken Selects the base or blend color—whichever is darker—as the resulting color. 
Areas lighter than the blend color are replaced, and areas darker than the blend color do 
not change. 

Lighten Selects the base or blend color—whichever is lighter—as the resulting color. 
Areas darker than the blend color are replaced, and areas lighter than the blend color do 
not change. 

Difference Subtracts either the blend color from the base color or the base color from the 
blend color, depending on which has the greater brightness value. Blending with white 
inverts the base color values; blending with black produces no change.

Exclusion Creates an effect similar to but lower in contrast than the Difference mode. 
Blending with white inverts the base color components. Blending with black produces 
no change.

Hue Creates a resulting color with the luminance and saturation of the base color and the 
hue of the blend color. 

Saturation Creates a resulting color with the luminance and hue of the base color and 
the saturation of the blend color. Painting with this mode in an area with no saturation 
(gray) causes no change. 

Color Creates a resulting color with the luminance of the base color and the hue and 
saturation of the blend color. This preserves the gray levels in the artwork and is useful for 
coloring monochrome artwork and for tinting color artwork.

Luminosity Creates a resulting color with the hue and saturation of the base color and 
the luminance of the blend color. This mode creates an inverse effect from that of the 
Color mode.

Note: The Difference, Exclusion, Hue, Saturation, Color, and Luminosity modes do not 
blend spot colors—and with most blending modes, a black designated as 100% K knocks 
out the color on the underlying layer. Instead of 100% black, specify a rich black using 
CMYK values.

Isolating blending modes
When you apply blending modes to objects in a group, the effects of the blending modes 
are normally seen on any objects beneath the group.

You can use the Isolate Blending command to change the behavior of blending modes so 
that only members of the selected group are affected and objects beneath the group are 
unaffected by the blending modes. 

Note: The Isolate Blending command is only useful when used on groups or layers 
containing objects that have a blending mode other than Normal applied to 
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them.The command also works on individual objects that have had blending modes other 
than Normal applied to overlapping strokes or fills.

Group selected without Isolate Blending option applied (left) and with it applied (right).

To isolate blending modes:

1 In the Layers palette, target a group, layer, or sublayer containing two or more objects 
to which blending modes are applied. You can also select individual objects with 
overlapping strokes or fills to which different blending modes have been applied.

2 In the Transparency palette, click Isolate Blending.

About transparency knockouts
You use the Knockout Group option in the Transparency palette to make every object of 
the selected group or layer knock out—that is, visually block out—the other objects in the 
group or layer that it overlays. Only artwork within the selected group or layer is knocked 
out. Objects beneath the selected group or in different layers are still visible relative to the 
group or layer. 

You can also control the interaction of transparent fills and strokes within an object if the 
transparency is applied directly to the fill or stroke in the Appearance palette. To do this, 
select or target the object and then select a Knockout Group option.

Creating transparency knockouts
Selecting the Knockout Group option cycles it through three states: on (check mark), off 
(no mark), and neutral (gray or dash). Use the neutral option when you want to group 
artwork without interfering with the knockout behavior determined by the enclosing 
layer or group. Use the off option when you want to ensure that a layer or a group of trans-
parent objects will never knock each other out. 

Group with Knockout Group option off (left) and on (right).

To knock out objects within a group or layer:

1 Select the group using the selection tool, or target it in the Layers palette.

2 Choose Show Options from the Transparency palette menu, if necessary.
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3 In the Transparency palette, select Knockout Group to turn it on (check mark).

To prevent objects from knocking out within a knockout group or layer:

1 Select the group using the selection tool, or target it in the Layers palette.

2 Choose Show Options from the Transparency palette menu, if necessary.

3 In the Transparency palette, deselect Knockout Group to turn it off (no mark).

Defining the knockout shape
Use the Opacity & Mask Define Knockout Shape option to keep the knockout effect 
proportional to the object’s opacity—in areas of the mask that are close to 100% opacity, 
the knockout effect will be strong; in areas with less opacity, the knockout effect will be 
weaker. For example, if you use a gradient mask as a knockout group, the underlying 
object will be knocked out progressively, as if it were being shaded by a gradient. You can 
create knockout shapes with both vector and raster images.

Note: The Opacity & Mask Define Knockout Shape option is most useful for objects that 
use a blending mode other than Normal.

Knocking out shapes using a gradient mask 
A. Original objects B. Multiply blending mode applied to circle C. Circle with gradient added
D. Both circles targeted and Make Opacity Mask selected in Transparency palette menu E. Star 
and circles grouped, and Knockout Group option applied F. Opacity & Mask Define Knockout 
Shape option applied to circle

Knocking out shapes using a raster image 
A. Guitar raster image with transparent pixels and Color Burn blending mode B. Ellipse and guitar 
grouped and Knockout Group option applied C. Opacity & Mask Define Knockout shape option 
applied to guitar

To define a knockout shape:

1 Group the objects you want to knockout.
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2 Select the group using the selection tool, or target it in the Layers palette.

3 In the Transparency palette, select Knockout Group.

4 Among the grouped objects, select the one that you want to reshape according to its 
opacity.

5 In the Transparency palette, select Opacity & Mask Define Knockout Shape.

About gradients, meshes, and blends
Depending on the effect you want, you can use different methods to apply blends or color 
gradients to objects.

To apply a graduated blend of colors as you would apply any other color, create a gradient 
fill using the Gradient palette or the gradient tool. Applying a gradient in this way does not 
transform the object. Creating a gradient fill is a good way to create a smooth color 
gradation across one or more objects.

In contrast, the mesh tool transforms a path object (or a bitmap image) into a single, 
multicolored object. Once an object is transformed into a mesh, you can create smooth 
shifts in color and precisely adjust and manipulate the color by moving and adjusting the 
mesh lines. The mesh tool provides the most precise method for shifting colors within a 
single object.

You can create blends of colors, opacities, and shapes between objects using the Blend 
command or the blend tool. You can select the beginning and ending shapes, opacities, 
and colors, and have Illustrator create the intermediate steps to create the final blend. 

Working with gradient fills
A gradient fill is a graduated blend between two or more colors or tints of the same color. 
Gradient colors can be assigned as CMYK process color, RGB process color, or a spot color. 
When a gradient is printed or separated, mixed-mode gradient colors are all converted to 
CMYK process color. (See “Printing gradients, mesh objects, and color blends” on 
page 337.)

Creating gradient fills
You use the Gradient palette to create your own gradients and—in combination with the 
Color palette and Swatches palette—to modify existing gradients. You can also add inter-
mediate colors to a gradient to create a fill defined by multiple blends among colors. 

To create a gradient:

1 Select an object with a selection tool, and click the Fill box in the toolbox to select the 
object’s fill.

2 To apply a gradient, do one of the following:

• Choose Window > Gradient, and click the Gradient Fill box at the upper left of the 
Gradient palette. (If the Gradient Fill box is not displayed, choose Show Options from 
the pop-up menu in the Gradient palette.)

• Click the Gradient button in the toolbox.

• Click a gradient swatch in the Swatches palette. To see only gradients in the palette, 
click the Show Gradient Swatches button .



Using Help | Contents | Index Back 201  

Adobe Illustrator Help Using Transparency, Gradients, and Patterns 

Using Help | Contents | Index Back 201  

3 To define the starting color of a gradient, click the left square below the gradient slider 
in the Gradient palette, and then do one of the following:

• Alt-click (Windows) or Option-click (Mac OS) a color swatch in the Swatches palette.

• Create a color using the sliders or the color slider in the Color palette.

• Drag a color from the Color palette or the Swatches palette to the square below the 
gradient slider.

Note: If you create a gradient between spot colors, you must deselect Convert to Process in 
the Separation Setup dialog box to print the gradient in individual spot color separations. 
(See “Printing gradients as separations” on page 346.)

4 To define the ending color of the gradient, click the right square below the gradient 
slider. Then choose the color you want as described in step 3.

5 Choose Linear or Radial from the pop-up menu to indicate the type of gradient you 
want. With a radial gradient, the beginning point of the gradient defines the center point 
of the fill, which radiates outward to the endpoint.

6 To adjust the beginning point or endpoint of the gradient, drag the squares located 
below the slider. To adjust the midpoint of the gradient (the point at which the colors are 
at 50%), drag the diamond icon located above the slider. 

7 Enter the angle of direction for the gradient in the Angle text box. The angle can range 
from –180 to 180 degrees. (The angle option is not available when a radial gradient is 
chosen.)

8 To save the gradient, do one of the following:

• Drag the completed gradient from the Gradient palette to the Swatches palette.

• Drag the gradient from the Fill box in the toolbox to the Swatches palette.

• Click the New Swatch button in the Swatches palette.

Modifying gradients
You can modify gradients by adding colors to make blends from multiple colors or by 
adjusting the endpoints and midpoints of the gradients. 

Gradient colors are defined by a series of stops in the gradient slider. A stop is the point at 
which a gradient changes from one color to the next and is identified by a square below 
the gradient slider. The squares in the Gradient palette display the color currently assigned 
to each gradient stop. 

It’s a good idea to fill an object with the gradient you plan to adjust so that you can 
preview the effect on the artwork as you adjust the gradient.

To add intermediate colors to a gradient:

Do one of the following:

• Drag and drop a color from the Swatches palette or the Color palette onto the gradient 
slider in the Gradient palette. 

• Click anywhere below the gradient slider to define another color square. You can then 
select a color and adjust the square as you would any other starting or ending color. 
To delete an intermediate color, drag the square off the gradient slider.
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Adjusting gradients with the gradient tool
Once you have filled an object with a gradient, the gradient tool lets you modify the 
gradient by “repainting” the fill along an imaginary line you drag. This tool lets you change 
the direction of a gradient, change the beginning point and endpoint of a gradient, and 
apply a gradient across multiple objects.

To use the gradient tool:

1 Select an object whose gradient you want to modify. 

2 Select the gradient tool .

3 Position the pointer where you want to define the beginning point of the gradient, and 
drag across the object in the direction you want the gradient to be painted. Hold down 
Shift to constrain the tool to multiples of 45 degrees.

4 Release the mouse button where you want to define the endpoint of the gradient.

To apply a gradient across multiple objects:

1 Fill each object with a gradient using the Gradient palette, the Swatches palette, or the 
paint bucket tool.

2 Select all of the objects.

3 Select the gradient tool .

4 Position the pointer where you want to define the beginning point of the gradient, and 
drag across the objects in the direction you want the gradient to be painted. 

5 Release the mouse button where you want to define the endpoint of the gradient.

Creating multicolored objects with the mesh tool
The mesh tool, the Create Mesh command, and the Expand command can all be used to 
transform an object into a mesh object. A mesh object is a single, multicolored object on 
which colors can flow in different directions, and transition smoothly from one point to 
another. 

By creating a fine mesh on an object and manipulating the color characteristics at each 
point in the mesh, you can precisely manipulate the coloring of the mesh object. You can 
also apply color to four mesh points at the same time by clicking the patch between them, 
to create broad color changes on part of the object.

About meshes
When you create a mesh object, multiple lines called mesh lines crisscross the object and 
provide a way to easily manipulate color transitions on the object. By moving and editing 
points on the mesh lines, you can change the intensity of a color shift, or change the 
extent of a colored area on the object. 

At the intersection of two mesh lines is a special kind of anchor point called a mesh point. 
Mesh points appear as diamonds and have all of the same properties as anchor points but 
with the added capability of accepting color. You can add and delete mesh points, edit the 
mesh points, or change the color associated with each mesh point. 
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Anchor points also appear in the mesh (differentiated by their square rather than diamond 
shape), and can be added, deleted, edited, and moved as with any anchor points in 
Illustrator. Anchor points can be placed on any mesh line; you can click an anchor point 
and drag its direction lines to modify it. (See “About direction lines and direction points” 
on page 51.) 

The area between any four mesh points is called the mesh patch. You can also change the 
color of the mesh patch using the same techniques as changing colors on a mesh point.

Diagram of a mesh object 
A. Mesh line B. Anchor point C. Mesh patch D. Mesh point 

Tips for creating mesh objects
You can create a mesh object out of any path object, or any bitmap image (such as a 
photographic image imported from Adobe Photoshop). There are a few important guide-
lines to keep in mind when creating mesh objects:

• You cannot create mesh objects from compound paths, text objects, or linked EPS files.

• Once a mesh object has been created, it cannot be converted back to a path object.

• When converting complex objects, use the Create Mesh command for the best results. 

• When converting simple objects, use either the mesh tool or the Create Mesh 
command. However, if you want to add a highlight to a particular spot, use the mesh 
tool and click at the point you want the highlight to appear.

• To create a mesh object with a regular pattern of mesh points and mesh lines, use the 
Create Mesh command. 

• When converting complex objects, Illustrator can add hidden anchor points to maintain 
the shape of a line. If you want to edit, add, or delete one or more of these anchor 
points, use the add-anchor-point tool or the delete-anchor-point tool.

• To improve performance and speed of redrawing, keep the size of mesh objects to a 
minimum. Complex mesh objects can greatly reduce performance. Therefore, it is 
better to create a few small, simple mesh objects than to create a single, complex mesh 
object.

Creating a mesh object
Use the mesh tool or the Create Gradient Mesh command to convert objects to mesh 
objects. You can also use the Expand command to convert radial or linear gradient path 
objects into mesh objects.

To create a mesh object with the mesh tool:

Choose the mesh tool  and click a filled object. The object is converted to a mesh object 
with the minimum number of mesh lines.

C

A B

D



Using Help | Contents | Index Back 204  

Adobe Illustrator Help Using Transparency, Gradients, and Patterns 

Using Help | Contents | Index Back 204  

To create a mesh object with the Create Mesh command:

1 Select a filled object.

2 Choose Object > Create Gradient Mesh.

3 Enter the number of horizontal rows of mesh lines to create on the object in the Rows 
text box.

4 Enter the number of vertical columns of mesh lines to create on the object in the 
Columns text box.

5 Select the direction of the highlight from the Appearance pop-up menu:

• To Center creates a highlight in the center of the object. 

• To Edge creates a highlight on the edges of the object.

• Flat applies the object’s original color evenly across the surface, resulting in no 
highlight.

6 Enter a percentage of white highlight to apply to the mesh object. A value of 100% 
applies maximum white highlight to the object; a value of 0% applies no white highlight 
to the object.

Creating a mesh object using the Expand command:

1 Select an object containing a radial or linear gradient fill.

2 Choose Object > Expand.

3 Select the Gradient Mesh option in the Expand dialog box and click OK. The selected 
object is converted to a mesh object that takes the shape of the gradient, either circular 
(radial) or rectangular (linear). 

Editing mesh objects
Once you have created a mesh object, you can adjust or edit its mesh points, anchor 
points, and mesh lines. Anchor points can be added with the add-anchor-point tool or 
deleted with the delete-anchor-point tool on any mesh line. 

To add or delete mesh points and mesh lines:

1 Select the mesh tool .

2 Do one of the following:

• To add a mesh point colored with the current fill color, click anywhere in the mesh 
object. The corresponding mesh lines extend from the new mesh point to the edges of 
the object. Clicking on an existing mesh line adds a single intersecting mesh line.

• To add a mesh point without changing to the current fill color, press Shift and click.

• To delete a mesh point and the corresponding mesh lines, Alt-click (Windows) or 
Option-click (Mac OS) directly on the mesh point. 

To edit a mesh point:

1 Select the mesh tool and click directly on a mesh point. Direction lines appear on the 
mesh point. 
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2 Do one of the following:

• Drag the direction points on the direction lines to edit the mesh point as you would any 
anchor point. For more information about editing anchor points, see “About direction 
lines and direction points” on page 51.

• Shift-drag a direction point to move all direction lines from the mesh point at once.

• Use the direct-selection tool, the convert-selection-point tool, or the transformation 
tools to edit mesh points.

To move a mesh point:

1 Select the mesh tool.

2 Do one of the following:

• Click a mesh point and drag to freely move the point and the connecting mesh lines.

• Press Shift and drag the mesh point to constrain the movement to follow a mesh line. 
This is a convenient way to move a mesh point along a curved mesh line without 
distorting the mesh line. 

Dragging to move mesh point (left) and Shift-dragging with the mesh tool to constrain to mesh line 
(right)

Adjusting colors on mesh objects
Colors are added to mesh objects using the Color palette, by dragging and dropping 
colors, or by using the paint bucket tool. When you select and color a mesh point, the 
mesh point and surrounding area are colored with the current fill color. When you click 
over a mesh patch, all four mesh points surrounding the patch are colored. You can also 
use color filters to change the color of mesh points. 

Adding color to a mesh point (left) and to a mesh patch (right)

Once color is applied to parts of a mesh object, you can change the shape and extent of 
the colored areas by editing the mesh points, anchor points, and mesh lines. (See “Editing 
mesh objects” on page 204.) 

To add color to a mesh point or mesh patch with the Color palette:

1 Select a mesh point or mesh patch with the mesh tool  or the direct-selection tool .
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2 Do one of the following:

• In the Color palette, select a color using the sliders or the color bar. 

• In the Swatches palette, select a swatch.

To add color to a mesh point or mesh patch by dragging and dropping:

Do one of the following:

• Drag a color from the Color palette directly over a mesh point or mesh patch and 
release the mouse button. 

• Drag a swatch color from the Swatches palette directly over a mesh point or mesh 
patch and release the mouse button. 

To add color to a mesh point or mesh patch with the paint bucket:

1 Select the paint bucket tool. 

2 Click directly on a mesh point or a mesh patch. The point or patch is colored with the 
current fill color.

Creating and working with patterns
To create a pattern, you create artwork you want to use as a pattern and then drag the 
artwork to the Swatches palette or use the Edit > Define Pattern command. You can use 
paths, compound paths, or text with solid fills or no fill for a pattern, or you can design a 
pattern from scratch with any of the tools in the Adobe Illustrator program. (However, 
you cannot use patterns, gradients, blends, brushstrokes, meshes, bitmap images, graphs, 
placed files, or masks in a pattern.) You can customize any pattern by resizing the pattern, 
moving or transforming it, or coloring its objects. 

Patterns intended for filling objects (fill patterns) differ in design and tiling from patterns 
intended to be applied to a path with the Brushes palette (brush patterns). For best results, 
use fill patterns to fill objects and brush patterns to outline objects. 

How patterns tile
When designing patterns, it helps to understand how Adobe Illustrator tiles patterns:

• Patterns tile from left to right from the ruler origin (by default, the bottom of the 
artwork) to the top of the artwork. Typically, only one tile makes up a fill pattern. Brush 
patterns can consist of up to five tiles—for the sides, outer corners, inner corners, and 
the beginning and end of the path. The additional corner tiles enable brush patterns to 
flow smoothly at corners.

• Fill patterns tile perpendicular to the x axis. In contrast, brush patterns tile perpen-
dicular to the path (with the top of the pattern tile always facing outward). Also, corner 
tiles rotate 90 degrees clockwise each time the path changes direction. 

• Fill and brush patterns also tile differently in relation to the pattern bounding box—
an unfilled and unstroked rectangle backmost in the artwork. For fill patterns, the 
bounding box acts as a mask; fill patterns tile only the artwork within the pattern’s 
bounding box. In contrast, brush patterns tile artwork within the bounding box and 
protruding from or grouped with it. 
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Constructing simple patterns and defining patterns
To create a pattern, you create artwork that you want to use as a pattern tile and then drag 
it to the Swatches palette.

To create a pattern:

1 Create artwork for the pattern following “Guidelines for constructing patterns” on 
page 207. 

2 To make the pattern less complex so that it prints more rapidly, remove any unnec-
essary detail from the pattern artwork, and group objects that are painted with the same 
color so that they are adjacent in the stacking order.

3 Optionally, to control the spacing between pattern elements or to clip out portions of 
the pattern, draw a pattern bounding box (an unfilled rectangle) around the artwork you 
want to use as a pattern. Choose Object > Arrange > Send to Back to make the rectangle 
the backmost object. To use the rectangle as a bounding box for a brush or fill pattern, fill 
and stroke it with None.

4 Use the selection tool to select the artwork and bounding box (if any) that will make up 
the pattern tile. 

5 Do one of the following:

• Choose Edit > Define Pattern, and enter a name in the New Swatch dialog box.

• Choose Window > Swatches (if necessary), and then drag the artwork to the Swatches 
palette.

To name a pattern in the Swatches palette:

1 Double-click a pattern swatch.

2 Enter the new pattern name in the Swatch Name text box, and click OK.

Guidelines for constructing patterns
Follow these general guidelines for constructing pattern tiles:

• As you create your pattern tile, zoom in on the artwork to align elements more 
accurately, and then zoom out from the artwork for the final selection.

• For greatest efficiency in previewing and printing, a fill pattern tile should be about 
1/2 inch to 1 inch square. Side tiles for brush patterns should be no larger than 1/2 inch 
to 1 inch high by 1 inch to 2 inches wide; the corner tiles must be the same height as 
the side tiles and should be square. 

• The more complex the pattern, the smaller the selection used to create it should be; 
however, the smaller the selection (and the pattern tile it creates), the more copies are 
needed to create the pattern. Thus, a 1-inch-square tile is more efficient than a 1/4-inch-
square tile. If you are creating a simple pattern, you can include multiple copies of the 
object within the selection intended for the pattern tile.

• To create simple line patterns, layer stroked lines of varying widths and colors and place 
an unfilled and unstroked bounding box behind the lines to create a pattern tile.

• To make an organic or textural pattern appear irregular, vary the tile artwork subtly, not 
dramatically, for a more realistic effect. You can use the Roughen filter in the Distort 
menu to control variations.

• To ensure smooth tiling, close paths before defining the pattern.
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• Enlarge your artwork view, and check for flaws before defining a pattern.

• If you draw a bounding box around the artwork, make sure that the box is a rectangle, 
that it is the backmost object of the tile, and that it is unfilled and unstroked. To have 
Illustrator use this bounding box for a brush pattern, do not fill or stroke the box and 
make sure that nothing protrudes from it. 

Follow these additional guidelines when creating brush patterns:

• When possible, confine artwork to an unpainted bounding box so that you can control 
how the pattern tiles. (See “How patterns tile” on page 206.)

• Corner tiles must be square and have the same height as side tiles to align properly on 
the path. If you plan to use corner tiles with your brush pattern, align objects in the 
corner tiles horizontally with objects in the side tiles so that the patterns tile correctly.

• Create special corner effects for brush patterns using corner tiles. 

For more information on using brush patterns, see “Creating a pattern brush” on page 85.

Constructing geometric patterns 
To construct a geometric pattern that tiles uniformly, first construct a geometric object 
with a center point and paint the object. Then arrange copies of the object in the pattern 
you want, select the artwork, and define it as a pattern tile by dragging it to the Swatches 
palette.

To construct a geometric pattern: 

1 Make sure that Smart Guides are turned on and that the View > Snap to Point 
command has been selected.

2 Select the geometric object. For precise positioning, use the direct-selection tool 
positioned on one of the object’s points. 

3 Begin dragging the object vertically from one of its anchor points; then press Alt+Shift 
(Windows) or Option+Shift (Mac OS) to copy the object and constrain its movement.

4 When the copy of the object has snapped into place, release the mouse button and 
then release Alt+Shift (Windows) or Option+Shift (Mac OS).

5 Using the group-selection tool, shift-click to select both objects, and begin dragging 
the objects horizontally by one of their anchor points; then press Alt+Shift (Windows) or 
Option+Shift (Mac OS) to create a copy and constrain the move. 

Select both objects (left) and drag to create a copy (right)

6 When the copy of the object has snapped into place, release the mouse button, and 
then release Alt+Shift (Windows) or Option+Shift (Mac OS).

7 Repeat steps 2 through 6 until you’ve built the pattern you want.
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8 Using the rectangle tool , follow one of two methods:

• For a fill pattern, draw a bounding box from the center point of the upper left object to 
the center point of the lower right object.

• For a brush pattern, draw a bounding box that surrounds the objects and coincides 
with their outer boundaries. If the pattern is to be a corner tile, hold down Shift as you 
drag to constrain the bounding box to a square. The bounding box should surround 
the objects and coincide with their outer boundaries. 

Bounding box for a fill pattern (left) and for a brush pattern (right)

9 Paint the geometric objects the desired color. 

10 Define the geometric objects as a pattern, following the procedure in “Constructing 
simple patterns and defining patterns” on page 207.

Constructing patterns with irregular textures
You can create an irregularly textured fill pattern that tiles seamlessly. Remember that fill 
patterns clip any artwork outside the bounding box, whereas brush patterns do not. To 
create an irregularly textured brush pattern, you should select and define as a pattern only 
the textured artwork within the bounding box. 

To create an irregular texture:

1 Make sure that View > Snap to Point has been selected.

2 Draw a bounding box. If you are creating a brush pattern, skip to step 13. 

3 Draw the texture with the objects or lines that intersect only the left side of the 
bounding rectangle. 

4 Using the direct-selection tool, select the texture and the rectangle, and place the 
pointer on the lower left corner of the rectangle. 

5 Drag the rectangle to the right; then press Alt+Shift (Windows) or Option+Shift 
(Mac OS) to create a copy and to constrain the move. 

Draw texture on left side of bounding box (left). Then copy texture and rectangle (right).
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When the upper left corner point of the copy snaps to the upper right corner point of the 
bounding box, release the mouse button, and then release Alt+Shift (Windows) or 
Option+Shift (Mac OS). 

If you know the exact dimensions of the bounding box, you can select only the 
textures and use the Move command to specify a horizontal move the width of the 

rectangle. Be sure to click Copy instead of OK in the Move dialog box.

6 Click outside the rectangle to deselect it.

7 Select the right rectangle, and delete it.

8 Using the pencil tool , continue drawing your texture with only the objects or lines 
that intersect the top side of the rectangle. When you finish with the top side only, select 
all of the lines or objects crossing the top side and the bounding box.

Draw texture on top side of bounding box (left). Then copy texture and rectangle (right).

9 When the upper left corner point of the copy snaps to the lower left corner point of the 
rectangle, release the mouse button and then Alt+Shift (Windows) or Option+Shift 
(Mac OS). 

10 Deselect everything.

11 Select the lower rectangle and any objects that don’t cross the top rectangle, and 
delete them. 

12 Using the pencil tool, fill the middle of the rectangle with your texture. Be careful not 
to intersect any of the rectangle edges. Paint the texture.

13 Define the artwork and rectangle as a pattern, following the procedure in 
“Constructing simple patterns and defining patterns” on page 207.

Creating corner tiles for brush patterns
Corner tiles lend special border effects when applying brush patterns. You can create 
corner tiles from scratch, or you can use a brush pattern’s side tile as the basis for 
designing complementary outer and inner (reflected –135 degrees) corner tiles. 

To create symmetrical corner tiles from a side tile:

1 Choose File > Open, locate a brush pattern file, supplied with Adobe Illustrator, that you 
want to use, and click Open.

2 Choose Window > Brushes. Select the tile you want to use, and drag it to the center of 
your artwork.

3 If the tile does not have a square bounding box, create a box that completely encom-
passes the artwork, the same height as the side tile. (Side tiles can be rectangular.) Fill and 
stroke the box with None, and choose Object > Arrange > Send to Back to make the box 
backmost in your artwork. (The bounding box helps you align the new tile.)
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4 Select the tile and the bounding box.

5 Use the rotate tool  to rotate the tile and its bounding box 180 degrees. 

Pasted tile (left) and tile rotated 180º (right)

6 Using the rotate tool, Alt+Shift (Windows) or Option+Shift (Mac OS) the lower left 
corner of the bounding box. Enter a value of 90 degrees, and click Copy to create a copy 
flush left of the first tile. This tile becomes the corner tile.

7 Using the selection tool, drag the left tile down by the top right anchor point, pressing 
Alt+Shift (Windows) or Option+Shift (Mac OS) to make a copy and constrain the move so 
that you create a third tile beneath the second. When the copy’s upper right anchor point 
snaps to the corner tile’s lower right anchor point, release the mouse button and Alt+Shift 
(Windows) or Option+Shift (Mac OS).

You use the third copy for alignment. 

Rotate 90º and copy left tile (left). Then Alt-drag/Option-drag corner tile to make copy 
beneath it (right).

8 Select the artwork in the right tile. Drag it to the left, pressing Alt+Shift (Windows) or 
Option+Shift (Mac OS) so that the artwork overlaps that in the corner tile. 

Copy (left) and move upper right tile over corner tile (right).
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9 Edit the corner tile so that its artwork lines up vertically and horizontally with the tiles 
next to it. Select and delete any portions of the tile that you do not want in the corner and 
edit the remaining art to create the final outer corner tile.

Unneeded elements selected (left) and deleted; Final outer corner tile (right).

10 Select all of the tile including the bounding box. 

11 Save the new pattern following the procedure in “Constructing simple patterns and 
defining patterns” on page 207.

12 Double-click the new pattern swatch to bring up the Swatch Options dialog box, 
name the tile as a variation of the original (for example, use the suffix .outer), and click OK.

To create an inner corner tile:

Do one of the following:

• If the side tile for the brush pattern is horizontally symmetric (that is, if it looks the same 
when flipped top to bottom), you can use the same tile for the inner corner tile as for 
the outer corner tile.

• If the side tile for the brush pattern is not horizontally symmetric, follow the same steps 
as to create symmetrical corner tiles from a side tile, but skip step 5 (rotating the tile by 
180 degrees).

Modifying patterns
You can modify a pattern by editing the artwork and then replacing the old pattern in the 
Swatches palette with the new artwork. If you replace an old pattern with a new pattern, 
any new and existing objects painted with that pattern are painted with the new 
definition rather than with the old definition.

To modify an existing pattern:

1 Make sure that nothing is selected in your artwork.

2 Choose Windows > Swatches, and select the pattern swatch you want to modify.

3 Drag the pattern swatch onto your artwork.

4 Select artwork in the pattern tile, and edit the tile. (To do this, use the direct-selection 
tool or group-selection tool, or ungroup the pattern.)

5 Select the pattern tile.

6 Alt-drag (Windows) or Option-drag (Mac OS) the modified pattern on top of the old 
pattern swatch in the Swatches palette. The pattern is replaced in the Swatches palette 
and is updated in the current file.



Using Help | Contents | Index Back 213  

Adobe Illustrator Help Using Transparency, Gradients, and Patterns 

Using Help | Contents | Index Back 213  

Moving patterns
Patterns begin tiling from the ruler origin and continue to tile in a left-to-right sequence, 
from bottom to top, until the object is filled. To adjust where all patterns in your artwork 
begin tiling, you can change the file’s ruler origin.

To move all of the patterns within a file:

1 Choose View > Show Rulers.

2 Move the selection pointer to the box in the upper left corner where the rulers 
intersect.

3 As you drag into the window, two intersecting lines, indicating the ruler origin, follow 
the pointer. When the ruler origins are positioned as desired, release the mouse button. 
(See “Changing the ruler origin” on page 93.) 

Transforming pattern-filled objects
If an object that you want to transform is filled with a pattern, you can choose to transform 
only the pattern, transform only the object, or transform the pattern and the object 
simultaneously. 

Once you have transformed a fill pattern, all patterns that you subsequently apply are 
transformed the same way. To return fill patterns to their original states, select another 
paint style and then reselect the desired pattern.

You can transform fill patterns using the dialog box associated with a transformation tool. 
Regardless of the method you choose, turning this option on or off in any dialog box 
updates the option in all dialog boxes. (See “Moving, copying, and deleting objects” on 
page 102.)

To transform a pattern and object using a transformation tool:

1 Use the selection tool to select the pattern-filled object. 

2 Double-click the transformation tool you want to use.

3 Select one or both of the following options:

• Patterns to transform the pattern tiles.

• Objects to transform the object.

4 Enter the desired transformation values in the text boxes and click OK.

To transform patterns using the mouse:

1 Select the pattern-filled object.

2 Select the transformation tool you want to use.

3 Hold down the tilde key (~) and drag. 

4 Release the mouse button when the transformation is as desired.

Important: The borders of the object appear to be transformed while dragging with the 
mouse, but when the mouse button is released the borders snap back to their original 
configuration, leaving only the pattern transformed. 
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To select the Transform Pattern Tiles preferences option:

1 Choose Edit > Preferences > General (Windows and Mac OS 9) or Illustrator > 
Preferences > Workgroup (Mac OS X).

2 Select Transform Pattern Tiles to select Pattern Tiles automatically in the transformation 
dialog boxes, and click OK.

Changing strokes, gradients, blends, patterns, flares, 
envelopes, and symbols into regular objects 
The Expand command can convert strokes, gradients, blends, patterns, flares, envelopes, 
and symbols into regular objects. For example, you can use this command to convert fills 
and strokes into individual objects, or convert gradients into mesh objects. (See “Creating 
a mesh object” on page 203.) This command can be particularly useful if you are having 
difficulty printing objects that contain these effects. 

To convert fills or strokes into objects:

1 Select a filled or stroked object, or an object that has been both filled and stroked.

2 Choose Object > Expand. If the Expand command is dimmed, you may need to choose 
Object > Expand Appearance first.

3 Do one of the following:

• To expand only the fill, select Fill.

• To expand only the stroke, select Stroke.

• To expand both the fill and the stroke, select both Fill and Stroke.

4 Click OK.

To convert gradients, blends, and patterns into objects:

1 Select the blend, flare, envelope, symbol, or object that has been filled or stroked with a 
gradient or pattern.

2 Choose Object > Expand. 

3 Do one of the following:

• If you are expanding a complex object, select the Object option, and click OK.

• If you are expanding a gradient, select the Specify Objects option, enter the number of 
steps to which you want to convert the gradient, and click OK.

Hold down Alt (Windows) or Option (Mac OS) as you choose Object > Expand to 
expand a gradient using the settings last entered in the Expand dialog box.

To convert gradients into a mesh:

1 Select objects that have been filled or stroked with a gradient.

2 Choose Object > Expand. 

3 In the Expand Gradient To box, click Gradient Mesh.

4 Click OK.
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Using Layers

About layers
When creating complex artwork, it’s a challenge to keep track of all the items on your 
artboard. Small items get hidden under larger items, and selecting artwork becomes 
difficult. Layers provide a way to manage all the elements that make up your artwork. 
Think of layers as clear folders that contain artwork. If you reshuffle the folders, you 
change the stacking order of the items in your artwork. You can move items between 
folders and create subfolders within folders. 

The structure of layers in your document can be as simple or complex as you want it to be. 
By default, all items are organized in a single, parent layer. However, you can create new 
layers and move items into them. The Layers palette provides an easy way to select, hide, 
lock, and change the appearance attributes of artwork. You can even create template 
layers, which you can use to trace artwork, and import layers from Photoshop.

Using the Layers palette
The Layers palette lists all the layers in a document, starting with the frontmost layer. Each 
layer can contain items such as paths, groups, envelopes, compound shapes, compound 
paths, and sublayers. You can expand or collapse items in the Layers palette to display or 
hide their contents. 

Layers palette 
A. Parent layer B. Sublayer C. Group D. Path

Displaying the Layers palette Choose Window > Layers.

Expanding layers Click the triangle  to the left of the layer. If the layer is empty, no 
triangle appears and there is nothing to expand. Click again to collapse the layer.

Selecting layers Click the name of the layer in the Layers palette. Alternatively, Ctrl-Alt-
click (Windows) or Option-Command-click (Mac OS) anywhere in the layer list, and type 
the name or number of the layer you want to select. (For example, you can type 30 to go 
to “Layer 30.”) Shift-click or Ctrl-click to select multiple contiguous or noncontiguous 
layers. 

A

B

C

D
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Once you select a layer, it is highlighted and the current-layer indicator  appears at the far 
right of the item in the palette. Any path you create with a drawing or object tool is placed 
in the selected layer.

Important: Don’t confuse selecting layers with selecting artwork. For more information 
on selecting artwork, see “Selecting artwork in layers” on page 221.

Using the Layers palette menu Click the triangle  in the upper right corner of the 
palette to access commands for working with layers.

Displaying layer options Double-click a layer, or choose Options for “Layer name” from 
the Layers palette menu. (See “Setting layer options” on page 216.)

Changing the palette display Choose Palette Options from the Layers palette menu. 
Select Show Layers Only to hide paths, groups, and collective elements in the Layers 
palette. For Row Size, select an option to specify the height of rows. (To specify a custom 
size, enter a value between 12 and 100.) For Thumbnails, select a combination of layers, 
groups, and objects for which to display thumbnail previews.

Note: Displaying thumbnails in the Layers palette may result in slow performance when 
you are working with complex files. Turn off layer thumbnails to improve performance. 

Creating and modifying layers
The number of layers a document can have is limited only by your computer’s memory. 
You can add layers, nest sublayers within layers, and merge, flatten, and delete layers.

Adding layers
Every new Adobe Illustrator document contains one layer. You can add layers using a 
variety of methods.

To create a new layer above the selected layer:

Do one of the following:

• Click the New Layer button  in the Layers palette.

• Choose New Layer from the Layers palette menu, or Alt-click (Windows) or Option-click 
(Mac OS) the New Layer button. In the Layer Options dialog box, set layer options, and 
click OK. (“Setting layer options” on page 216.)

To create a new sublayer inside the selected layer:

Do one of the following:

• Click the New Sublayer button  in the Layers palette.

• Choose New Sublayer from the Layers palette menu, or Alt-click (Windows) or Option-
click (Mac OS) the New Sublayer button. In the Layer Options dialog box, set layer 
options, and click OK. (“Setting layer options” on page 216.)

To create a new layer at the top of the layer list:

Ctrl-click (Windows) or Command-click (Mac OS) the New Layer button.

Setting layer options
You use the Layer Options dialog box to set options for items in the Layers palette.
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To set layer options:

1 Do one of the following:

• To set options for an existing item in the Layers palette, double-click the item. Alter-
nately, select the item and choose Options for “Layer name” from the Layers palette 
menu.

• To set options when you create a new layer, choose New Layer or New Sublayer from 
the Layers palette menu.

2 Set one or more of the following options:

Name Specifies the name of the layer in the Layers palette.

Color Specifies the layer’s color setting. (See “Changing the display of layered artwork” on 
page 219.)

Template Makes the layer a template layer. (See “Creating template layers” on page 226.)

Lock Prevents changes to the artwork contained in the layer. (See “Locking artwork” on 
page 225.)

Show Displays all artwork contained in the layer on the artboard. (See “Hiding or 
displaying artwork” on page 224.)

Print Makes the artwork contained in the layer printable. (See “Making artwork 
nonprintable” on page 225.)

Preview Displays the artwork contained in the layer in Preview view. (See “Changing the 
display of layered artwork” on page 219.)

Dim Images Reduces the intensity of bitmap images contained in the layer to the 
specified percentage. (See “Changing the display of layered artwork” on page 219.)

Note: Only the Name, Show, and Lock options are available for groups, collective 
elements, and paths.

Releasing items to separate layers
The Release to Layers command redistributes all of the items in a layer into individual 
layers. You can use this feature to prepare files for further Web animation work. 

To release items to separate layers:

1 Select a layer or group in the Layers palette.

2 Do one of the following:

• To release each item to a new layer, choose Release to Layers (Sequence) from the 
Layers palette menu.

• To release items into layers in a cumulative sequence, choose Release to Layers (Build) 
from the Layers palette menu. For example, assume Layer 1 contains a circle, a square, 
and a triangle. This command creates three layers—one with a circle, square, 
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and triangle; one with a circle and square; and one with just a circle. This is useful for 
creating cumulative animation sequences.

Items released to layers in a cumulative sequence.

Collecting layers
The Collect in New Layer command moves all selected items in the Layers palette into a 
new layer.

To move items into a new layer:

1 Select the items you want to move into a new layer.

2 Choose Collect in New Layer from the Layers palette menu.

Merging and flattening artwork
Merging and flattening are similar in that they let you consolidate paths, groups, and 
sublayers. With merging, you can select which items you want to consolidate; with 
flattening, all visible items in the artwork are consolidated in a single, parent layer. With 
either option, the stacking order of the artwork remains the same.

To merge artwork into a single layer or group:

1 Select the items that you want to merge in the Layers palette.

2 Choose Merge Selected from the Layers palette menu. Items will be merged into the 
layer or group that you selected last.

To flatten artwork:

1 Select the layer into which you want to consolidate the artwork. You cannot flatten 
artwork into a layer that is hidden, locked, or is a template.

2 Choose Flatten Artwork from the Layers palette menu. 

If a hidden layer contains artwork, you are asked whether to make the artwork visible so 
that it can be flattened into the layer, or whether to delete the artwork and the hidden 
layer.
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Deleting items in the Layers palette
Deleting a layer also deletes all artwork that is in the layer. For example, if you delete a 
layer that contains sublayers, groups, paths, and clipping sets, all those elements will be 
deleted along with the layer.

To delete items in the Layers palette:

1 Select an item in the Layers palette. 

2 Do one of the following:

• Click the Trash button  in the Layers palette, or drag the item onto the Trash button.

• Choose Delete “Layer name” from the Layers palette menu.

Note: A document must have a least one layer. If a document has only one layer, the Trash 
button and Delete command are not available.

Changing the display of layered artwork
By default, Illustrator assigns different colors to selection marks on each layer and to the 
corresponding layer color square in the Layers palette. You can change this layer color 
setting to better suit your needs. 

You can switch the view mode of the artwork in a layer—between Preview view and 
Outline view—to display some items as outlines and other items as they will appear in the 
final artwork. (See “Viewing artwork as paths” on page 14.) You also can dim bitmap 
images to make it easier to edit artwork on top of the image. This is especially useful when 
tracing a bitmap image.

Display options for layered artwork 
A. Object displayed in Outline view. B. bitmap image dimmed to 50%. C. Layer color square and 
selection marks. 

To change the color setting for a layer:

1 Double-click a layer name in the Layers palette, or select a layer and choose Options for 
“Layer name” from the Layers palette menu.

B CA
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2 In the Layer Options dialog box, choose a color from the Color pop-up menu, or double-
click the color sample to open the Color dialog box. After you have selected a color, 
click OK.

To change the view mode of artwork:

Do one of the following

• Ctrl-click (Windows) or Command-click (Mac OS) the eye icon for a layer in the Layers 
palette to toggle between Outline view and Preview view. 

Note: The eye icon has a hollow center  when Outline view is enabled and a filled center  
when Preview view is enabled.

• Alt+Ctrl-click (Windows) or Option+Command-click (Mac OS) the eye icon to toggle the 
view mode for all other layers in the Layers palette.

• Double-click a layer name in the Layers palette, or select a layer and choose Options for 
“Layer name” from the Layers palette menu. Deselect the Preview option to display all 
items in the layer in Outline view; select the Preview option to display all items in the 
layer in Preview view.

• Choose Preview All Layers from the Layers palette menu to display all layers in Preview 
view. 

• If all layers are in Preview view, select one or more layers, and choose Outline Others 
from the Layers palette menu to display unselected layers in Outline view.

To dim a bitmap image on the artboard:

1 Double-click the layer name that contains the bitmap image you want to dim, or select 
the layer and choose Options for “Layer name” from the Layers palette menu.

2 In the Layer Options dialog box, select Dim Images To, enter an intensity percentage 
(0% to 100%), and click OK.

To show bitmap images on template layers:

1 Choose File > Document Setup.

2 Choose Artboard from the pop-up menu at the top of the dialog box, select the Show 
Images In Outline option, and click OK. 

Working with layered artwork
There are many advantages to working with layered artwork. You can quickly select, hide, 
lock, and change the appearance of artwork using layers. 
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Selecting artwork in layers
You can quickly select artwork on the artboard using the Layers palette. Keep in mind that 
there is a difference between selecting an item in the Layers palette and selecting artwork 
using the Layers palette. When artwork is selected, the layer color square appears on the 
corresponding item in the Layers palette and selection marks appear around the artwork 
on the artboard. 

Layers palette 
A. Selected item in Layers palette B. Selected artwork

To select artwork using the Layers palette:

Click the right edge of an item in the Layers palette (between the target button and the 
scroll bar). The layer color square indicates that the artwork is selected. Shift-click at the 
right edge of additional items in the Layers palette to select additional artwork.

To select all artwork in a layer:

Do one of the following:

• Click the right edge of a layer in the Layers palette (between the target button and the 
scroll bar). The layer color square indicates that all artwork in the layer is selected.

• Alt-click (Windows) or Option-click (Mac OS) a layer name or layer thumbnail in the 
Layers palette. 

• To select all artwork in a layer based on the currently selected artwork, choose Select > 
Object > All on Same Layer.

Locating items in the Layers palette
When you select artwork on the artboard using a selection tool, you can quickly locate the 
corresponding item in the Layers palette using the Locate Object command. This 
command is especially helpful for locating items in collapsed layers.

To locate an item in the Layers palette:

1 Select an object on the artboard. If you select more than one object, the frontmost 
object in the stacking order will be located.

2 Choose Locate Object from the Layers palette menu. This command changes to Locate 
Layer if the Show Layers Only palette option is selected. (See “Using the Layers palette” on 
page 215.)

A

B
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Changing the stacking order of artwork using the Layers palette
The stacking order of artwork on the artboard corresponds to the hierarchy of items in the 
Layers palette. Artwork in the top layer in the Layers palette is at the front of the stacking 
order, while artwork in the bottom layer in the Layers palette is at the back of the stacking 
order. (See “Stacking objects” on page 109.)

Within a layer, objects are also arranged hierarchically. If you choose Object > Arrange > 
Bring to Front, the object will move to the top position within the layer; if you choose 
Object > Arrange > Send Backward, the object will move one position down within the 
layer.

Note: You cannot move a path, group, or collective element to the top position in the 
Layers palette—only layers can reside at the top of the layer hierarchy.

To change the order of items in the Layers palette:

Drag one or more items to a new position in the layer hierarchy:

• To added the dragged items between two items, release the mouse button when you 
see a black bar with small triangles in the desired position.

• To add the dragged items to a layer, group, or sublayer, release the mouse button when 
you see large black triangles at the left and right edges of the desired position.

To drag items between layers:

Do one of the following:

• Click the right edge of an item in the Layers palette (between the target button and the 
scroll bar), and drag the item’s layer color square to the desired layer.

• To move all items in a layer to a different layer, drag the layer color square for the source 
layer.

To reverse the order of items in the Layers palette:

1 Select the items whose order you want to reverse. The items must be at the same level 
in the layer hierarchy. For example, you can select two top-level layers, but you cannot 
select two paths that are in different layers.

2 Choose Reverse Order from the Layers palette menu.

To move artwork into a different layer using the Move to Current Layer command:

1 Select the artwork you want to move. (See “Selecting artwork in layers” on page 221.)

2 Click the name of a layer in the Layers palette. 

Important: Do not to click at the right edge of the layer. The selected layer should display 
the current-layer indicator , but not the layer color square. 

3 Choose Object > Arrange > Send to Current Layer.

You can also use the Cut and Paste commands to move artwork between layers. (See 
“Pasting objects in front or in back of other objects” on page 109.)
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Pasting artwork between layers
The Paste Remembers Layers option determines where artwork is pasted in the layer 
hierarchy. By default, Paste Remembers Layers is off, and artwork is pasted into the 
whichever layer is active in the Layers palette. When Paste Remembers Layers is on, 
artwork is pasted into the layer from which it was copied, regardless of which layer is 
active in the Layers palette. 

Turn on Paste Remembers Layers if you’re pasting artwork between documents and 
you want to automatically place it into a layer of the same name from which it origi-

nated. If the target document does not have a layer of the same name, Illustrator creates a 
new layer.

To set the Paste Remembers Layers option:

Choose Paste Remembers Layers from the Layers palette menu. A check displays when the 
option is on.

Working with grouped and collective elements in the Layers 
palette
Illustrator provides several ways to collect components in your artwork together: you can 
create groups, compound shapes, compound paths, pathfinder paths, and envelopes. The 
Layers palette is particularly useful for working with collective elements because it allows 
you to view their contents. 

Groups Appear as <Group> items in the Layers palette. You can use the Layers palette to 
move items in and out of groups. (See “Changing the stacking order of artwork using the 
Layers palette” on page 222.) 

Compound shapes Appear as <Compound Shape> items in the Layers palette. You can 
use the Layers palette to show and manipulate the contents of a compound shape—
for example, change the stacking order of its components. (See “Changing the stacking 
order of artwork using the Layers palette” on page 222.)

Compound paths Appear as <Compound Path> items in the Layers palette. You cannot 
show the contents of a compound path in the Layers palette. 

Pathfinder paths Appear as <Group> items that contain individual paths or as <Path> 
items. 

Envelopes Appear as <Envelope> items in the Layers palette. 

Changing the appearance of artwork using the Layers palette
The Layers palette makes it easy change the appearance of artwork. You can apply styles, 
apply effects, and set appearance attributes at any level of the layer hierarchy. For 
example, if you apply a drop shadow effect to a layer, all artwork in the layer takes on the 
drop shadow. However, if you move the artwork out of the layer, it will no longer have a 
drop shadow because the effect belongs to the layer, not to artwork within the layer. 
(See “About appearance attributes, styles, and effects” on page 228.)

Before you can set an appearance attribute, apply a style, or apply an effect to a layer, 
group, or collective element, you must target the item in the Layers palette. The target 
icon indicates whether an item in the layer hierarchy has any appearance attributes and 
whether it is targeted:

•  indicates the item is not targeted and has no appearance attributes.
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•  indicates the item is targeted but has no appearance attributes.

•  indicates the item is not targeted but has appearance attributes.

•  indicates the item is targeted and has appearance attributes.

To target an item in the Layers palette:

Click its target icon in the Layers palette. A double ring  or  indicates that the item is 
targeted. Shift-click to target additional items.

To move, copy, or delete appearance attributes:

Do one of the following:

• To move appearance attributes, drag the target icon  or  from an item onto the item 
to which you want to apply it. 

• To copy appearance attributes, Alt-drag (Windows) or Option-drag (Mac OS) the target 
icon from an item onto the item to which you want to apply it.

• To delete appearance attributes, drag the target icon from an item onto the Trash 
button  at the bottom of the Layers palette. Layers and groups lose all appearance 
attributes; paths lose all appearance attributes except a single fill and stroke.

Duplicating artwork using the Layers palette
You can quickly duplicate paths, groups, collective elements, and entire layers using the 
Layers palette. This is useful for creating animations. It also lets you create different 
versions of an element in your artwork.

To duplicate artwork:

1 Select the items you want to duplicate in the Layers palette. 

2 Do one of the following:

• Choose Duplicate “Layer name” from the Layers palette menu. 

• Drag the item to the New Layer button  at the bottom of the palette.

• Start to drag the item to a new position in the Layers palette, and then hold down Alt 
(Windows) or Option (Mac OS). Release the mouse button when the indicator is in the 
position where you want to place the duplicated item. If you release the mouse button 
when the indicator is pointing to a layer or group, the duplicated item is added to the 
layer or group. If you release the mouse button when the indicator is between items, 
the duplicated item will be added in the specified position.

Hiding or displaying artwork
You can selectively hide and display artwork on the artboard using the Layers palette. 
Hiding artwork is useful when you’re working on a complex piece and want to focus on a 
specific set of paths. You can quickly hide multiple paths, groups, and sublayers by hiding 
the parent layer.

To hide or display artwork:

Do one of the following:

• Click the eye icon  in the Layers palette for the item you want to hide. Click again to 
redisplay the items. 

• Drag across multiple eye icons to hide multiple items.
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• Double-click an item name in the Layers palette, or select an item and choose Options 
for “Layer name” from the Layers palette menu. In the Layer Options dialog box, select 
or deselect Show, and click OK. 

• To hide all unselected layers in the Layers palette, choose Hide Others from the Layers 
palette menu. Alternatively, you can Alt-click (Windows) or Option-click (Mac OS) the 
eye icon for the layer you want to show.

• To display all layers in the Layers palette, choose Show All Layers from the Layers palette 
menu.

Locking artwork
Locking an item in the Layers palette is equivalent to choosing the Lock command from 
the Object menu. You cannot select or edit artwork when it is locked. You can quickly lock 
multiple paths, groups, and sublayers by locking the parent layer.

To lock or unlock artwork:

Do one of the following:

• Click the edit column button (to the right of the eye icon) the Layers palette for the item 
you want to lock. Click the lock icon  to unlock the item.

• Drag across multiple edit column buttons to lock multiple items.

• Double-click an item name in the Layers palette, or select an item and choose Options 
for “Layer name” from the Layers palette menu. In the Layer Options dialog box, select 
or deselect Lock, and click OK. 

• To lock all unselected layers in the Layers palette, choose Lock Others from the Layers 
palette menu. 

• To unlock all layers in the Layers palette, choose Unlock All Layers from the Layers 
palette menu.

Making artwork nonprintable
The Layers palette makes it easy to print different versions of your artwork. For example, 
you can choose to print only the type objects in a document in order to proof your text. 
You can also add nonprinting elements to artwork to record important information.

To make artwork nonprintable:

Do one of the following:

• To prevent artwork from displaying on the artboard, from printing, and from exporting, 
hide the corresponding items in the Layers palette. (See “Hiding or displaying artwork” 
on page 224.)

• To prevent artwork from printing, but not from showing on the artboard or from being 
exported, double-click the corresponding items in the Layers palette. In the Layer 
Options dialog box, deselect the Print option, and click OK. The layer name changes to 
italics in the Layers palette. 

• To create artwork that does not print or export, even when visible on the artboard, 
select the Template option in the Layer Options dialog box. (See “Creating template 
layers” on page 226.)
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Creating clipping masks
A clipping mask is an object or group of objects whose shape masks artwork below it so 
that only artwork within the shape is visible—in effect, clipping the artwork to the shape 
of the mask. You can create a clipping mask to control how artwork on a layer is hidden 
and revealed.

A clipping set is a collection of items in the Layers palette consisting of one or more levels 
(such as a layer and a group), one or more clipping masks, and one or more objects that 
are masked by the clipping masks.

The following guidelines apply to clipping masks:

• A clipping mask and the objects to be masked must be in the same layer or group in the 
Layers palette.

• A top-level layer cannot be a clipping mask. However, you can put a clipping mask 
inside a top-level layer along with artwork to be masked below it.

• The first object in the layer or group becomes the clipping mask for everything that is a 
subset of the layer or group the clipping mask is in. For example, if a clipping mask is 
the first item in Layer 1, all objects in layers and groups within Layer 1 are masked. 

• Objects in the clipping path are indicated with a dotted line in the Layers palette.

• Regardless of its previous attributes, a clipping mask object changes to an object with 
no fill or stroke.

• The clipping mask and the artwork you want to mask must be in the same layer or 
group in the Layers palette. 

• The clipping mask is always at the top of the clipping set. Moving the mask does not 
change the appearance or masking.

To create a clipping set:

1 In the Layers palette, select the layer or group that contains the items that you want to 
become the clipping set. The topmost object will be the clipping mask.

2 Click the Make/Release Clipping Masks button  at the bottom of the Layers palette, 
or choose Make Clipping Mask from the Layers palette menu.

To convert a clipping mask back to an object:

1 Select the layer or group that contains the clipping mask.

2 Click the Make/Release Clipping Masks button  at the bottom of the Layers palette, or 
choose Release Clipping Mask from the Layers palette menu.

Creating template layers
Create a template layer whenever you want to base a new illustration on an existing piece 
of artwork—for example, when you want to trace over existing artwork or build an illus-
tration from it. (See “Tracing artwork” on page 89.) You can neither print nor export a 
template layer.



Using Help | Contents | Index Back 227  

Adobe Illustrator Help Using Layers 

Using Help | Contents | Index Back 227  

To create a template layer:

1 Do one of the following:

• Choose New Layer from the Layers palette menu, or double-click the name of an 
existing layer. In the Layer Options dialog box, select Template, and click OK. 

• Select a layer to be a template, and choose Template from the Layers palette menu.

• Choose File > Place, and click Template. A new template layer appears below the 
current layer in the palette. (See “Placing files” on page 35.) 

The eye icon is replaced by the template icon , and the layer is locked. 

Moving layers between Adobe Illustrator and Adobe 
Photoshop
When you import or place a Photoshop file that has multiple layers, you can flatten the 
layers into a single image or convert the layers to objects. (See “Opening and placing 
artwork” on page 33.) 

When you export layers, you can flatten them into one layer or preserve the individual 
layers and sublayers so that you can work with them in the Photoshop file. You can export 
Illustrator layers to Photoshop using the Export command. (See “Exporting artwork in 
Photoshop format” on page 326.) 



Using Help | Contents | Index Back 228  

Adobe Illustrator Help Using Appearance Attributes, Styles, and Effects 

Using Help | Contents | Index Back 228  

Using Appearance Attributes, 
Styles, and Effects

About appearance attributes, styles, and effects
Appearance attributes are properties that affect the look of an object without altering its 
underlying structure. If you apply an appearance attribute to an object and later edit or 
remove that attribute, it does not change the underlying object or any other attributes 
applied to the object. Fills, strokes, transparency, and effects are all types of appearance 
attributes. 

A style is a named set of appearance attributes. The Styles palette lets you store and apply 
a set of appearance attributes to objects, groups, and layers. This gives you a fast and 
consistent way to change the look of artwork in documents. If the style is replaced (that is, 
if any appearance attributes that make up the style are changed and the new attributes 
are saved as that style), all objects with that style change to the new appearance.

Effects are a type of appearance attribute and are listed under the Effect menu. Most 
effects have the same function and name as commands found elsewhere in the appli-
cation. However, Effect menu commands do not change the underlying object, only its 
appearance. You can distort, rasterize, and modify any path using any number of effects, 
but the original size, anchor points, and shape of the path never changes—only the way it 
looks. The underlying object remains editable, and an effect’s parameters can be changed 
at any time.

Working with appearance attributes
The Appearance palette is your gateway to working with appearance attributes, including 
styles and effects. Because you can apply appearance attributes to layers, groups, and 
objects, the hierarchy of attributes in your artwork can become very complex. For 
example, if you apply one effect to a layer and another effect to an object in the layer, it 
may be difficult to determine which effect is causing the artwork to change. The 
Appearance palette shows you exactly the fills, strokes, styles, and effects that have been 
applied to an object, group, or layer.

Using the Appearance palette
The Appearance palette shows you the hierarchy of appearance attributes in your artwork. 
When you make a selection on the artboard or target an item in the Layers palette, the 
Appearance palette displays the attributes associated with the artwork. Fills and strokes 
are listed in stacking order (front to back); effects are listed in the order in which they are 
applied to the artwork. 
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Layers, groups, type, meshes, linked files, bitmap images, blends, envelopes, flares, 
symbols, symbol sets, and graphs all function as containers in the Appearance palette. 
When you apply appearance attributes to a container, all artwork in the container takes on 
these additional attributes.

Appearance palette 
A. Path with stroke, fill, and effect B. Layer with transparency C. Group with effect D. Stroke with 
effect

Displaying the Appearance palette Choose Window > Appearance. 

Displaying attributes in the Appearance palette Make a selection on the artboard, or 
target an item in the Layers palette. (See “Changing the appearance of artwork using the 
Layers palette” on page 223.) The attributes of the selected item appear in the Appearance 
palette. If the item is a container (such as a layer or group), double-click the word Contents 
in the Appearance palette to display the attributes of artwork in the container. Click the 
name of the container to redisplay the its attributes. 

Expanding and collapsing fills and strokes Click the triangle  to the left of the fill or 
stroke in the Appearance palette. Click again to collapse the fill or stroke.

Reordering appearance attributes Drag an appearance attribute up or down in the 
palette to change the order that strokes, fills, and effects are applied. (If necessary, expand 
fills and strokes.) When the outline of the appearance attribute you are dragging appears 
in the desired position, release the mouse button.

The stacking order of strokes and fills directly affects an object’s appearance. For example, 
if the fill attribute is below the Contents entry, any fill attributes applied to objects will be 
applied in front of the fill.

If you apply a style to an object, but the style’s fill color doesn’t appear in the artwork, 
drag the Fill attribute above the Contents entry in the Appearance palette.

Using the Appearance palette menu Click the triangle  in the upper right corner of 
the palette to access commands for working with appearance attributes.

Showing and hiding thumbnails Choose Show Thumbnail or Hide Thumbnail from the 
Appearance palette menu.

A

B

C

D
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Modifying and removing appearance attributes
The Appearance palette makes it easy to modify appearance attributes. You can edit 
effects, copy attributes to items, duplicate attributes, and remove attributes.

Note: Changing the attributes of an item that has a style applied to it breaks the link 
between the item and the style. (See “Unlinking styles” on page 234.)

To display the dialog box for an effect:

Double-click an effect name in the Appearance palette. 

To copy attributes to an object:

1 If a thumbnail isn’t showing in the Appearance palette, choose Show Thumbnail from 
the palette menu.

2 Drag the thumbnail onto an object on the artboard. The object does not have to be 
selected first.

To duplicate an appearance attribute:

Select an attribute in the Appearance palette, and do one of the following:

• Click the Duplicate Selected Item button  in the palette, or choose Duplicate Item from 
the palette menu.

• Drag the appearance attribute onto the Duplicate Selected Item button in the palette.

• If the attribute is a fill or stroke, choose Add New Fill or Add New Stroke from the 
Appearance palette menu.

To remove appearance attributes:

Do one of the following:

• Select an attribute, and choose Remove Item from the palette menu.

• Select an attribute, and click the Trash button  in the palette.

• Drag an attribute to the Trash button.

• To remove all appearance attributes, including any fill or stroke, choose Clear 
Appearance from the palette menu or click the Clear Appearance button  in the 
palette.

• To remove all appearance attributes except a single fill and stroke, choose Reduce to 
Basic Appearance from the palette menu or click the Reduce to Basic Appearance 
button  in the palette.

Applying appearance attributes to new artwork
You can specify whether you want new objects to inherit appearance attributes or have 
only basic attributes. 

To specify how appearance attributes are applied to new objects:

Do one of the following:

• To apply only a single fill and stroke to new objects, click the New Art Has Basic 
Appearance button  in the Appearance palette, or select New Art Has Basic 
Appearance from the palette menu.
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• To apply all of the current appearance attributes to new objects, click the New Art 
Maintains Appearance button  in the Appearance palette, or deselect New Art Has 
Basic Appearance from the palette menu.

Applying fills and strokes to containers
Adding fills and strokes to a container (such as a group or layer) applies the fills and 
strokes to all artwork in the container.

To apply a fill or stroke to a container:

1 Target a container in the Layers palette. (See “Changing the appearance of artwork 
using the Layers palette” on page 223.)

2 Do one of the following:

• Choose Add New Fill or Add New Stroke from the Appearance palette menu.

• Click on a brush in the Brush palette to add a brushed stroke to the container.

• Click on a style in the Styles palette which has a fill or stroke.

Using styles
A style is a named set of appearance attributes. By applying different styles, you can 
quickly change the look of an object; for example, you can change its fill and stroke color, 
transparency, and Effect menu settings in one step. All the changes you apply with styles 
are completely reversible. 

Using the Styles palette
The Styles palette lets you create, name, save, and apply sets of appearance attributes. 

Displaying the Styles palette Choose Window > Styles.

Changing the order of styles Drag the style to a different position in the palette. When 
the outline of the style appears in the desired position, release the mouse button.

Using the Styles palette menu Click the triangle  in the upper right corner of the 
palette to access commands for working with styles.

Renaming styles Double-click a style, or select a style and choose Style Options 
command from the palette menu. Enter a style name, and click OK.

Changing the palette display Choose a view option from the Styles palette menu: 
Thumbnail View to display a scrollable list of thumbnails; Small List View to display a scrol-
lable list of named styles with a small thumbnail; or Large List View to display a scrollable 
named list of styles along with a large thumbnail.

Applying styles
You can apply styles to objects, groups, and layers. When you apply a style, the new style 
overrides any style that the item had before.
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When you apply a style to a group or layer, every object on the group or layer takes on the 
attributes of the style. For example, assume you have a style that consists of 50% opacity. If 
you apply the style to a layer, all objects in or added to that layer will appear 50% opaque. 
However, if you move an object out of the layer, the object’s appearance reverts to its 
previous opacity. (See “Changing the appearance of artwork using the Layers palette” on 
page 223.)

Note: You can’t apply styles to type objects that use outline-protected fonts or bitmap 
fonts. 

To apply a style:

1 Select artwork on the artboard, or target an item in the Layers palette. (See “Changing 
the appearance of artwork using the Layers palette” on page 223.

Note: If you selected a type object, select Override Character Color from the Styles palette 
menu to apply the style’s fill, stroke, and transparency attributes to the characters; or 
deselect Override Character Color from the Styles palette menu to preserve the current 
color of the characters.

2 Apply the style from the Styles palette:

• Click a style in the list.

• Drag the style onto an object on the artboard. The object does not have to be selected 
first.

• Copy and apply a style using the eyedropper and paint bucket tools. Depending on 
what you specify in the Paint Bucket/Eyedropper Options dialog box, you can copy and 
paste the entire style or selected attributes.

Creating and modifying styles
A style can contain any combination of color, fill, stroke, pattern, effect (that is, any 
command listed under the Effect menu), transparency, blend mode, gradient, transfor-
mation, and the like. Each style can contain multiple attributes. For example, you can have 
three fills in a style, each with a different opacity and blend mode that defines how the 
various colors interact. Similarly, you can have multiple strokes.

To create or modify a style:

1 Do one of the following:

• Select an object.

• Select a style in the Styles palette to use as a starting set of attributes.

• Start with no object or style selected.

2 Specify the appearance attributes you want, such as the fill or the stroke. You can use 
the Appearance palette to help specify and order the appearance attributes. (See 
“Working with appearance attributes” on page 228.)

3 Do one of the following:

• Click the New Style button  at the bottom of the Styles palette.
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• Drag the thumbnail from the Appearance palette into the Styles palette or onto the 
New Style button at the bottom of the Styles palette.

Dragging a thumbnail from the Appearance palette to the Styles palette.

• Drag the object with the appearance attributes you want into the Styles palette or onto 
the New Style button at the bottom of the Styles palette.

• Choose New Style from the Styles palette menu, enter a name for the style, and click OK. 
The new style appears at the bottom of the list in the Styles palette.

• Alt-click (Windows) or Option-click (Mac OS) the New Style button, enter the name of 
the style, and click OK.

To create a new style by merging existing styles:

1 In the Styles palette, Ctrl-click (Windows) or Command-click (Mac OS) to select all the 
styles you want to merge.

2 Choose Merge Styles from the palette menu.

The new style contains all the attributes of the selected styles and is added to the end of 
the list of styles in the palette.

To replace style attributes:

Do one of the following:

• Alt-drag (Windows) or Option-drag (Mac OS) the style you want to use onto the style 
you want to replace. 

• Select artwork (or target an item in the Layers palette) that has the attributes you want 
to use. Then Alt-drag (Windows) or Option-drag (Mac OS) the thumbnail from the 
Appearance palette onto the style you want to replace in the Styles palette.

• Select the style you want to replace. Then select artwork (or target an item in the Layers 
palette) that has the attributes you want to use, and choose Redefine Style “Style name” 
from the Appearance palette menu. 

The replaced style keeps its name but takes on new appearance attributes. All occurrences 
of the style in the Illustrator document are updated to use the new attributes.

To duplicate a style:

1 In the Styles palette, select the style you want to duplicate.

2 Choose Duplicate Style from the Styles palette menu.

The new style appears at the bottom of the list in the Styles palette.
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Unlinking styles
You can remove a style from an object, group, or layer by breaking the link to the style. 
The object, group, or layer retains the same appearance attributes; however, these 
attributes are no longer associated with a style.

To break the link between a style and a selection:

1 Select the object, group, or layer that has the style applied to it.

2 Do one of the following:

• Choose Break Link to Style from the Styles palette menu, or click the Break Link to Style 
button  in the palette.

• Change any appearance attribute of the selection (such as a fill, stroke, transparency, 
or effect).

Deleting styles
Deleting a style removes it from the Styles palette. Any objects, groups, or layers that used 
the style retain the same appearance attributes; however, these attributes are no longer 
associated with a style.

To delete a style:

1 In the Styles palette, select a style you want to delete.

2 Delete the style:

• Choose Delete Style from the Styles palette menu.

• Click the Trash button  in the palette.

• Drag the style onto the Trash button in the palette.

Using style libraries
You can import styles from other files into a palette associated with the current file using 
the Style Libraries command. These libraries are stored in the Presets/Styles folder inside 
the Adobe Illustrator application folder. You cannot add, delete, or edit styles in a library; 
however, once you import a style, you can change its attributes using the Appearance 
palette.

To import a style from a Style Library to the current Styles palette:

1 Make sure the Styles palette into which you want to import a style is open.

2 Choose Window > Style Libraries > Style Library name. To locate a Style Library not 
stored in the default location, choose Window > Style Libraries > Other Library.

3 Select a style you want, and then do one of the following:

• Use the selected style in the current artwork (recommended for one or two styles at a 
time). Once you use it in the artwork, the style is copied from the Styles Library to the 
Styles palette.

• Drag the selected style to the current Styles palette (recommended for multiple styles 
at a time).
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To create a Styles Library:

1 Create a file containing the styles you want in the Styles Library.

Delete all unused Swatches, Brushes, Symbols, and Styles to reduce the library’s 
file size.

2 Save the file.

3 Choose Window > Style Libraries > Other Library, and navigate to the location where 
you saved the file.

To have a Styles Library appear in the Styles Libraries menu:

1 Do one of the following:

• When you save your Library file, save it into the Presets/Styles folder inside the 
Illustrator application folder.

• Drag the Styles Library file into the Presets/Styles folder inside the Illustrator application 
folder.

2 Restart the program.

Using effects
The commands listed under the Effect menu alter the appearance of an object without 
changing the underlying object itself. For example, you can apply the Roughen command, 
transform the object with the rotate tool, scale it, and fill it with a 50% opaque red. You can 
then edit the roughen amount or remove it entirely, change the rotation, or adjust the 
opacity with no need to redraw the original object.

Editing object with effect applied

Most commands in the Effect menu have the same function and name as commands 
found elsewhere in the application. For more information on a specific command, see the 
Index.

Note: Many effects are available only for RGB documents. If you apply an effect, and then 
change the document’s color mode to CMYK, Illustrator will not be able to preserve the 
effect.

To apply an effect:

1 Do one of the following:

• Select artwork on the artboard.
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• Target an item in the Layers palette. (See “Changing the appearance of artwork using 
the Layers palette” on page 223.)

• Select a stroke or fill in the Appearance palette. (See “Working with appearance 
attributes” on page 228.)

• Select a style in the Styles palette. (See “Using styles” on page 231.)

2 Choose a command from the Effect menu.

3 Specify settings, and apply the effect.

4 If you selected a style, the appearance attributes are unlinked from that style. In this 
case, you can do any of the following:

• Create a new style.(See “Using the Styles palette” on page 231.)

• Leave the appearance attributes unlinked. 

Note: You can apply effects to type objects, but not to selected characters within the type 
objects.

To edit or remove an effect:

Edit or remove the effect as described in “Modifying and removing appearance attributes” 
on page 230.
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Working with Bitmap Images

About working with bitmap images
You can do the following with bitmap images:

• Place an image into a file. (See “Placing files” on page 35.)

• Use the Links palette to see information about the image. (See “Managing linked and 
embedded images” on page 37.)

• Trace images using the auto trace tool. (See “Tracing artwork” on page 89.)

• Create bitmap artwork with a transparent background using the Rasterize filter. By 
using the Transparent option in the Rasterize filter, you create an alpha channel (as in 
the Adobe Photoshop application). The transparent background also provides superior 
anti-aliasing of the rasterized artwork than does using a clipping mask to mask the 
background.

• Create a clipping mask in the Rasterize filter to make the background appear trans-
parent. (See “Working with clipping masks” on page 149.)

• Use the Rasterize dialog box to convert vector objects (including paths and text 
objects) into an image, and choose other options for the image. You can also change 
the color model for the image by reselecting Rasterize and changing the color. 
(See “Changing vector graphics into bitmap images” on page 237.)

• Colorize 1-bit images. (See “Colorizing 1-bit images” on page 238.)

• Use bitmap filters and filter effects. (See “Choosing a filter or filter effect” on page 242.) 

• Use the Object Mosaic filter to convert the pixels to a collection of colored squares. 
Then you can use Illustrator tools. (See “Using the Object Mosaic filter” on page 247.)

• Apply the Photo Crosshatch filter, which gives a photographic image the appearance of 
a pen drawing. (See “Using the Photo Crosshatch filter” on page 248.)

Changing vector graphics into bitmap images
The process of changing a vector graphic to a bitmap image is called rasterization. During 
rasterization, Illustrator converts the graphic’s paths into pixels. The rasterization options 
you set determine the size and other characteristics of the resulting pixels.

There are two ways to rasterize vector graphics:

• The Object > Rasterize command permanently converts the graphic to a bitmap image 
using the specified rasterization settings. Once you apply the Object > Rasterize 
command, you cannot modify the image’s rasterization settings.

• The Effect > Rasterize command changes only the appearance of the graphic without 
changing the graphic’s underlying structure. You can modify the rasterization settings 
of the bitmap image or revert the bitmap image to a vector graphic at any time.



Using Help | Contents | Index Back 238  

Adobe Illustrator Help Working with Bitmap Images 

Using Help | Contents | Index Back 238  

Once graphics are converted by either method, you can apply plug-in filters, such as those 
designed for Adobe Photoshop, to the image as you would with any placed image. 
However, you cannot apply vector tools and commands (such as the type tools and the 
Pathfinder commands) to modify the bitmap image. 

To rasterize a vector graphic:

1 Do one of the following:

• Select one or more objects you want to rasterize, and choose Object > Rasterize. 

• Select one or more objects you want to rasterize, or target an item in the Layers palette. 
(See “Changing the appearance of artwork using the Layers palette” on page 223.) 
Then choose Effect > Rasterize.

2 Set the following rasterization options, and click OK:

Color Model Determines the color model that is used during rasterization. You can 
generate an RGB or CMYK color image (depending on the color mode of your document), 
a grayscale image, or a 1-bit image (which may be black-and-white or black-and-trans-
parent, depending on the background option selected). 

Resolution Determines the number of pixels per inch (ppi) in the rasterized image. 
(See “About resolution in bitmap images” on page 26.) Select Use Document Raster Effects 
Resolution to use global resolution settings. (See “Specifying raster effects settings” on 
page 239.)

Background Determines how transparent areas of the vector graphic are converted to 
pixels. Select White to fill transparent areas with white pixels, or select Transparent to 
make the background transparent. If you select Transparent, you create an alpha channel 
(for all images except 1-bit images). The alpha channel is retained if the artwork is 
exported into Photoshop.

Type Quality Determines the method used to rasterize type. Select Streamline if you 
want the rasterized type to be slender and attenuated. Select Outline if you want the 
rasterized type to be slightly heavier. 

Anti-aliasing Determines the type of anti-aliasing that is applied during rasterization. 
Anti-aliasing reduces the appearance of jagged edges in the rasterized image. Select None 
to apply no anti-aliasing and maintain the hard edges of line art when it is rasterized. 
Select Art Optimized to apply anti-aliasing that is best suited to artwork without type. 
Select Type Optimized to apply anti-aliasing that is best suited to type.

Create Clipping Mask Creates a mask that makes the background of the rasterized 
image appear transparent (See “Working with clipping masks” on page 149.)

Note: You do not need to create a clipping mask if you selected Transparent for 
Background. 

Add Around Object Adds the specified number of pixels around the rasterized image.

Colorizing 1-bit images
You can add color to 1-bit images using the Color palette.

To colorize a 1-bit image:

1 Select the image. Make sure the Fill button is selected, and no stroke is applied.
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2 Use the Color palette to paint the image with black, white, a process color, or a spot 
color.

Using filters and filter effects
Some commands in Adobe Illustrator let you apply a special look to bitmap images. 
For example, you can apply an impressionistic or mosaic look, apply lighting changes, 
distort images, and produce many other interesting visual results. 

Most of these commands are listed both under the Filter menu and the Effect menu, 
letting you apply the command either as a filter or a filter effect. The versions of the 
commands listed under Filter alter the structure of the objects to which they are applied. 
You can apply these commands only to bitmap images.

The commands listed under Effect change only the appearance of the object without 
changing the object’s underlying structure, letting you modify the settings of the 
command or remove the command at any time. You can apply these commands to bitmap 
images and also to vector objects, including paths and type. For more information, 
see “Using effects” on page 235.

Filters and filter effects don’t work on linked bitmap images. If you apply a filter or filter 
effect to a linked bitmap image, it is applied to an embedded copy of the image instead of 
to the original. For information on linked and embedded images, see “Opening and 
placing artwork” on page 33. 

About plug-in filters
Adobe Illustrator supports plug-in filters and filter effects from Adobe products such as 
Adobe Photoshop and from non-Adobe software developers. Once installed, most plug-in 
filters and effects appear in the Filter and Effect menus and work the same as built-in 
filters. 

For information on installing and developing these plug-in modules, see “Using plug-in 
modules” on page 18. For information on effects, see “Using effects” on page 235.

Specifying raster effects settings
Illustrator uses a document’s raster effects settings whenever you apply a filter to a bitmap 
image or apply a raster effect to a vector graphic. These settings can have a large impact 
on the resulting artwork; therefore, it’s important to check the Document Raster Effects 
Settings dialog box before you start working with filters and effects.

To set rasterization options for a document:

1 Choose Effect > Document Raster Effects Settings. 

2 Set the following rasterization options, and click OK:

Color Model Determines the color model that is used during rasterization. You can 
generate an RGB or CMYK color image (depending on the color mode of your document), 
a grayscale image, or a 1-bit image (which may be black-and-white or black-and-trans-
parent, depending on the background option selected). 

Resolution Determines the number of pixels per inch (ppi) in the rasterized image. 
(See “About resolution in bitmap images” on page 26.) 
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Background Determines how transparent areas of the vector graphic are converted to 
pixels. Select White to fill transparent areas with white pixels, or select Transparent to 
make the background transparent. If you select Transparent, you create an alpha channel 
(for all images except 1-bit images). The alpha channel is retained if the artwork is 
exported into Photoshop.

Anti-alias Applies anti-aliasing to reduce the appearance of jagged edges in the 
rasterized image. Deselect this option to maintain the crispness of fine lines and small text.

Create Clipping Mask Creates a mask that makes the background of the rasterized 
image appear transparent (See “Working with clipping masks” on page 149.)

Note: You do not need to create a clipping mask if you selected Transparent for 
Background. 

Add Around Object Adds the specified number of pixels around the rasterized image.

Applying filters and filter effects
To use a filter or filter effect, choose the appropriate submenu command from the Filter or 
Effect menu. The last filter or filter effect chosen appears at the top of the menu.

The commands in the top part of the menu can be applied to vector images, with the 
exception of Pen and Ink > Photo Crosshatch. The commands in the bottom part of the 
menu can be applied to bitmap images, but not to 1-bit (black-and-white) images. All the 
bitmap filters and filter effects work on RGB and grayscale images. The following filters and 
filter effects do not work with CMYK images: Artistic, Brush Strokes, Distort, Sketch, Stylize, 
Texture, and Video. 

Some commands let you preview the result before applying the command. Because 
applying a filter or filter effect—especially to large bitmap images—can be time-
consuming, use the Preview box to save time and prevent unintended results. 

Note: Some bitmap images take more memory to process. Make sure Illustrator has 
enough RAM allocated for performing tasks and for the scratch disk—temporary disk 
space used to work with bitmap images.

To apply a filter or filter effect:

1 Do one of the following:

• Select a bitmap image, and choose a filter from the Filter menu.

• Select artwork on the artboard, or target an item in the Layers palette. (See “Changing 
the appearance of artwork using the Layers palette” on page 223.) Then choose a filter 
effect from the Effect menu.

2 If a dialog box appears, enter values or select options.

3 To preview the result with the filter’s preview box, do either of the following:

• Drag in the image window to center a specific area of the bitmap image in the 
preview box. 

• Move the cursor inside the preview box to activate the hand tool to see part of the 
image that is not visible. Drag to see the bitmap image. Use the + or – button under the 
preview box to zoom in or zoom out of the preview. A flashing line beneath the preview 
size indicates that Illustrator is still rendering the preview. 
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4 Click OK to apply the filter. 

When a filter or filter effect takes some time to be applied, you see a progress dialog box 
that indicates the time remaining until the filter is applied.

Loading bitmap images and textures
Some commands let you load other bitmap images, such as textures and displacement 
maps, to use with a filter or filter effect. These commands include Glass and Rough Pastels. 

To load bitmap images and textures:

1 Choose one of the following:

• Filter > Artistic > Rough Pastels.

• Effect > Artistic > Rough Pastels.

• Filter> Distort > Glass.

• Effect > Distort > Glass.

2 Choose Load Texture from the Texture pop-up menu.

3 Open the texture bitmap image.

4 Click OK in the filter or effect dialog box to apply the settings.

Using texture and glass surface controls
Some commands included in Illustrator have texturizing options, such as the Glass, Rough 
Pastels, Grain, and Fresco commands. The texturizing options can make a bitmap image 
appear as though painted onto various textures, such as canvas and brick, or viewed 
through glass blocks. 

You can apply these command as a filter or as an effect. For more information on effects, 
see “Using effects” on page 235.

To use texture and glass surface controls:

1 From the Filter or Effect menu, choose Artistic > Rough Pastels; Artistic > Fresco; 
Distort > Glass; or Texture > Grain. 

2 Choose a texture type from the Texture pop-up menu (if available), or choose Load 
Texture from the Texture pop-up menu to specify a file.

3 Drag the Scaling slider (if available) to enlarge or reduce the effect on the bitmap 
image’s surface. 

4 Choose other available options:

• Drag the Relief slider (if available) to adjust the depth of the texture’s surface.

• From the Light Direction pop-up menu (if available), choose the direction from which 
you want the light to appear. 

• Select Invert (if available) to reverse the surface’s light and dark colors.

5 Click OK to apply the settings.
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Improving performance with filters and filter effects
Some filters and filter effects can be memory intensive, especially when applied to a high-
resolution bitmap image. Use the following techniques to improve performance when 
applying these commands:

• Change the settings. Some commands, such as Glass, are extremely memory-intensive. 
Try different settings to increase its speed. 

• If you plan to print to a grayscale printer, convert a copy of the bitmap image to 
grayscale before applying filters. Note, however, that in some cases, applying a filter to a 
color bitmap image and then converting it to grayscale may not have the same effect as 
applying the same filter to a grayscale version of the image.

Choosing a filter or filter effect
Adobe Illustrator includes a variety of filters and filter effects for applying a special look to 
bitmap images. For information on using the filters, see “Using filters and filter effects” on 
page 239.

Many filters and effects are available only for RGB documents. To change the color 
mode of a document, choose a color mode from the File > Document Color Mode 

submenu.

Artistic filters and effects
Choose a filter or effect from the Artistic submenu to achieve a painterly or special effect 
for a fine arts or commercial project. For example, use the Cutout filter for collages or type 
treatment. These filters replicate natural or traditional media effects and include:

Colored Pencil Draws an image using colored pencils on a solid background. Important 
edges are retained and given a rough crosshatch appearance; the solid background color 
shows through the smoother areas.

For a parchment effect, change the background color just before applying the Colored 
Pencil filter to a selected area.

Cutout Portrays an image as though it were made from roughly cut-out pieces of colored 
paper. High-contrast images appear as if in silhouette, while colored images are built up 
from several layers of colored paper.

Dry Brush Paints the edges of the image using a dry brush technique (between oil and 
watercolor). The filter simplifies an image by reducing its range of colors to areas of 
common color.

Film Grain Applies an even pattern to the shadow tones and midtones of an image. 
A smoother, more saturated pattern is added to the image’s lighter areas. This filter is 
useful for eliminating banding in blends and visually unifying elements from various 
sources.

Fresco Paints an image in a coarse style using short, rounded, and hastily applied dabs.

Neon Glow Adds various types of glows to the objects in an image and is useful for 
colorizing an image while softening its look. To select a glow color, click the glow box and 
select a color from the color picker.
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Paint Daubs Lets you choose from various brush sizes (from 1 to 50) and types for a 
painterly effect. Brush types include simple, light rough, light dark, wide sharp, wide 
blurry, and sparkle.

Palette Knife Reduces detail in an image to give the effect of a thinly painted canvas that 
reveal the texture underneath.

Plastic Wrap Coats the image in shiny plastic, accentuating the surface detail.

Poster Edges Reduces the number of colors in an image according to the posterization 
option you set, and finds the edges of the image and draws black lines on them. Large 
broad areas of the image have simple shading while fine dark detail is distributed 
throughout the image.

Rough Pastels Makes an image appear as if stroked with colored pastel chalk on a 
textured background. In areas of bright color, the chalk appears thick with little texture; in 
darker areas, the chalk appears scraped off to reveal the texture.

Smudge Stick Softens an image using short diagonal strokes to smudge or smear the 
darker areas of the images. Lighter areas become brighter and lose detail.

Sponge Creates images with highly textured areas of contrasting color, appearing to 
have been painted with a sponge.

Underpainting Paints the image on a textured background, and then paints the final 
image over it. For more on the filter options, see “Using texture and glass surface controls” 
on page 241.

Watercolor Paints the image in a watercolor style, simplifying details in an image, using a 
medium brush loaded with water and color. Where significant tonal changes occur at 
edges, the filter saturates the color.

Blur filters and effects
The blur filters and effects are useful for retouching images. They smooth transitions by 
averaging the pixels next to the hard edges of defined lines and shaded areas in an image. 

Gaussian Blur Quickly blurs a selection by an adjustable amount. Gaussian refers to the 
bell-shaped curve that is generated when Adobe Photoshop applies a weighted average 
to the pixels. This filter adds low-frequency detail and can produce a hazy effect.

Radial Blur Simulates the blur of a zooming or rotating camera to produce a soft blur. 
Choose Spin, to blur along concentric circular lines, and then specify a degree of rotation; 
or Zoom to blur along radial lines, as if zooming in or out of the image, and specify an 
amount from 1 to 100. Blur quality ranges from Draft for the fastest but grainy results; or 
Good and Best for smoother results, which are indistinguishable except on a large 
selection. Specify the origin of the blur by dragging the pattern in the Blur Center box.

Brush Stroke filters and effects
Like the Artistic filters, the Brush Stroke filters and effects give a painterly or fine-arts look 
using different brush and ink stroke effects. Some of the filters add grain, paint, noise, 
edge detail, or texture to an image for a pointillist effect. 

Accented Edges Accentuates the edges of an image. When the edge brightness control 
is set to a high value, the accents resemble white chalk; when set to a low value, the 
accents resemble black ink.
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Angled Strokes Repaints an image using diagonal strokes. The lighter areas of the image 
are painted in strokes going in one direction while the darker areas are painted in strokes 
going the opposite direction.

Crosshatch Preserves the details and features of the original image while adding texture 
and roughening the edges of the colored areas in the image with simulated pencil 
hatching. The Strength option controls the number of hatching passes, from 1 to 3.

Dark Strokes Paints dark areas of an image closer to black with short, tight strokes, and 
paints lighter areas of the image with long, white strokes.

Ink Outlines Redraws an image with fine narrow lines over the original details, in pen-
and-ink style.

Spatter Replicates the effect of a spatter airbrush. Increasing the options simplifies the 
overall effect.

Sprayed Strokes Repaints an image using its dominant colors with angled, sprayed 
strokes of color.

Sumi-e Paints an image in Japanese style as if with a wet brush full of black ink on rice 
paper. The effect is soft blurry edges with rich blacks.

Distort filters and effects
The Distort filters and effects geometrically distort an image, creating 3-D or other 
reshaping effects. Note that these filters can be very memory intensive.

Diffuse Glow Renders an image as though it were viewed through a soft diffusion filter. 
The filter adds see-through white noise to an image, with the glow fading from the center 
of a selection.

Glass Makes an image appear as if it is being viewed through different types of glass.You 
can choose a glass effect or create your own glass surface as a Photoshop file, and apply it. 
You can adjust scaling, distortion, and smoothness settings.

Ocean Ripple Adds randomly spaced ripples to the images surface, making the image 
look as if it were under water.

To replicate wave results on other selections, click Randomize, set the Number of 
Generators to 1, and set the minimum and maximum Wavelength and Amplitude 

parameters to the same value.

Pixelate filters and effects
The filters or effects in the Pixelate submenu sharply define a selection by clumping pixels 
of similar color values in cells.

Color Halftone Simulates the effect of using an enlarged halftone screen on each 
channel of the image. For each channel, the filter divides the image into rectangles and 
replaces each rectangle with a circle. The circle size is proportional to the brightness of the 
rectangle. 

To use the Color Halftone filter:

1 Choose Filter > Pixelate > Color Halftone.

2 Enter a value in pixels for the maximum radius of a halftone dot, from 4 to 127.
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3 Enter a screen-angle value (the angle of the dot from the true horizontal) for one or 
more channels:

• For Grayscale images use only channel 1. 

• For RGB images, use channels 1, 2, and 3, which correspond to the red, green, and blue 
channels. 

• For CMYK images, use all four channels, which correspond to the cyan, magenta, yellow, 
and black channels. 

• Click Defaults to return all the screen angles to their default values. 

4 Click OK.

Crystallize Clumps pixels into a solid color in a polygon shape.

Mezzotint Converts an image to a random pattern of black-and-white areas or of fully 
saturated colors in a color image. To use the filter, choose a dot pattern from the Type 
pop-up menu in the Mezzotint dialog box.

Pointillize Breaks up the color in an image into randomly placed dots, as in a pointillist 
painting, and uses the background color as a canvas area between the dots.

Sharpen filter and effect
The Sharpen filter and effect focus blurry images by increasing the contrast of adjacent 
pixels.

Unsharp Mask Finds the areas in the image where significant color changes occur and 
sharpens them. Use the Unsharp Mask filter to adjust the contrast of edge detail and 
produce a lighter and darker line on each side of the edge, to emphasize the edge and 
create the illusion of a sharper image.

Sketch filters and effects
Filters or effects in the Sketch submenu add texture to images, often for a 3-D effect. 
The filters also are useful for creating a fine-arts or hand-drawn look. Many of the Sketch 
filters use the foreground and background color as they redraw the image.

Bas Relief Transforms an image to appear carved in low relief and lit to accent the surface 
variations. Dark areas of the image take on the foreground color, light colors use the back-
ground color.

Chalk & Charcoal Redraws an image’s highlights and midtones with a solid midtone gray 
background drawn in coarse chalk. Shadow areas are replaced with black diagonal 
charcoal lines. The charcoal is drawn in the foreground color, the chalk in background 
color.

Charcoal Redraws an image to create a posterized, smudged effect. Major edges are 
boldly drawn while midtones are sketched using a diagonal stroke. Charcoal is the 
foreground color, and the paper is the background color.

Chrome Treats the image as if it were a polished chrome surface. Highlights are high 
points and shadows are low points in the reflecting surface. After applying the filter, 
use the Levels dialog box to add more contrast to the image.
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Conté Crayon Replicates the texture of dense dark and pure white Conté crayons on 
an image. The Conté Crayon filter uses the foreground color for dark areas and the 
background color for light areas. For a truer effect, change the foreground color to one of 
the common Conté Crayon colors (black, sepia, sanguine) before applying the filter. For a 
muted effect, change the background color to white with some foreground color added 
to it before applying the filter.

Graphic Pen Uses fine, linear ink strokes to capture the details in the original image and 
is especially striking with scanned images. The filter replaces color in the original image 
using the foreground color for ink and background color for paper.

Halftone Pattern Simulates the effect of a halftone screen while maintaining the 
continuous range of tones. 

Note Paper Creates an image that appears to be constructed of handmade paper. The 
filter simplifies an image, and combines the effects of the Texture > Emboss and Grain 
filters. Dark areas of the image appear as holes in the top layer of paper, revealing the 
background color.

Photocopy Simulates the effect of photocopying an image. Large areas of darkness tend 
to copy only around their edges and midtones fall away to either solid black or white.

Plaster Molds an image from 3-D plaster, and then colorizes the result using the fore-
ground and background color. Dark areas are raised, light areas are sunken (or reverse the 
effect by choosing the Invert option).

Reticulation Simulates the controlled shrinking and distorting of film emulsion, to create 
an image that appears clumped in the shadow areas and lightly grained in the highlights.

Stamp Is best used with black-and-white images. The filter simplifies the image to appear 
stamped with a rubber or wood stamp.

Torn Edges Is particularly useful for images consisting of text or high-contrast objects. 
The filter reconstructs the image as ragged, torn pieces of paper, and then colorizes the 
image using the foreground and background colors.

Water Paper Uses blotchy daubs that appear painted onto fibrous, damp paper, causing 
the colors to flow and blend.

Stylize filter and effect
The Stylize filter and effect produce a painted or impressionistic effect on a selection by 
displacing pixels and by finding and heightening contrast in an image. After using filters 
like Find Edges and Trace Contour that highlight edges, you can apply the Invert 
command to outline the edges of a color image with colored lines or to outline the edges 
of a grayscale image with white lines.

Glowing Edges Identifies the edges of color and adds a neon-like glow to them.

Texture filters and effects
Use the Texture filters and effects to give an image the appearance of depth or substance, 
or to add an organic look. 

Craquelure Paints an image onto a high-relief plaster surface, producing a fine network 
of cracks that follow the contours of the image. Use this filter to create an embossing 
effect with images that contain a broad range of color or grayscale values.
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Grain Adds texture to an image by simulating different kinds of grain—regular, soft, 
sprinkles, clumped, contrasty, enlarged, stippled, horizontal, vertical, and speckle.

Mosaic Tiles Draws the image as if it had been made up of small chips or tiles and adds 
grout between the tiles. (In contrast, the Pixelate > Mosaic filter breaks up an image into 
blocks of different colored pixels.)

Patchwork Breaks up an image into squares filled with the predominant color in that area 
of the image. The filter randomly reduces or increases the tile depth to replicate the 
highlights and shadows.

Stained Glass Repaints an image as single-colored adjacent cells outlined in the 
foreground color. 

Texturizer Applies a texture you select or create to an image.

Video filters and effects
The Video submenu contains the De-Interlace and NTSC Colors filters or effects. 

De-Interlace Smooths moving images captured on video by removing either the odd or 
even interlaced lines in a video image. You can choose to replace the discarded lines by 
duplication or interpolation.

NTSC Colors Restricts the gamut of colors to those acceptable for television repro-
duction to prevent oversaturated colors from bleeding across television scan lines.

Using the Object Mosaic filter
The Object Mosaic filter creates sharp definition in an image by clustering pixels of similar 
color values together into individual tiles. You can control the tile size, the spacing 
between tiles, and the total number of tiles, and you can preserve the proportions of the 
original image when creating the mosaic copy. 

The Object Mosaic filter works with any bitmap image format that Illustrator can place, 
and with bitmap images created with the Rasterize command. The Object Mosaic filter 
creates a tiled vector version of the bitmap image. You can choose to keep the original 
image or delete it.

To create a tiled effect on a copy of a bitmap image:

1 Select a bitmap image. The image must be embedded, not linked.

2 Choose Filter > Create > Object Mosaic. 

The dimensions of the bitmap image are displayed at the top left of the Object Mosaic 
dialog box.

3 Choose from the following options:

• To set the width and height of the mosaic in points, enter values for New Size.

• To set the distance in points between each tile in the mosaic, enter values for Tile 
Spacing.

• To set the number of tiles horizontally and vertically in the mosaic, enter values for 
Number of Tiles. 

• To lock the width or height dimensions to those of the original bitmap image, choose 
Width or Height for the Constrain Ratio option. Choosing Width calculates the appro-
priate number of tiles to use for the width of the mosaic, based on the original number 
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of tiles for the width. Choosing Height calculates the appropriate number of tiles to use 
for the height of the mosaic, based on the original number of tiles for the height.

• To have the result appear as a color or grayscale image, select Color or Gray.

• To change the size of the image by percentages of width and height, select Resize Using 
Percentages and enter new percentages in the Width and Height text boxes.

• To delete the original bitmap image, select Delete Raster. 

• To make tiles square, using the number of tiles specified in Number of Tiles, click Use 
Ratio. 

4 Click OK.

Using the Photo Crosshatch filter
The Photo Crosshatch filter can convert a photographic image, or any rasterized image, 
into a hatched ink pen image. The filter converts the photo into a series of overlapping 
hatch layers, each hatch layer representing different lightness areas of the original photo. 
Since there are many hatch layers overlapping where the image is darkest, and few where 
the image is lightest, the result is a simulated crosshatched drawing of the original photo-
graphic image.

Note: You can apply various hatch filters to images, to give the image the appearance of a 
pen drawing. (See “Using the Pen & Ink filters” on page 137.)

To convert a rasterized image into a crosshatched drawing:

1 Select a rasterized image.

2 Choose Filter > Pen and Ink > Photo Crosshatch.

3 Enter the number of hatch layers to create in the Hatch Layers text box. The maximum 
number of layers is 8. Each hatch layer receives a distribution of the lightness values 
between 0 and 255. For example, if you enter a Hatch Layer of 4, the first layer contains 
lightness values of 0 to 64, the second values of 0 to 128, the third values of 0 to 192, and 
the fourth values of 0 to 255.

4 Use the slider under the histogram to adjust the weighting of the threshold levels 
toward light or dark. The histogram shows how many pixels of the hatched image fall into 
each value of lightness between 0 and 255. Use the middle slider to skew the threshold 
levels on each level toward light (by moving the slider to the right) or dark (by moving the 
slider to the left). Adjust the end sliders to moderate the highest levels of light (the 
rightmost slider) and dark (the leftmost slider).

5 Use the sliders on the left side of the dialog box to adjust options as follows:

• Density adjusts the number of hatch elements applied to the selection, from .5 pt to 
10 pts.

• Dispersion Noise controls the spacing of hatch elements, from 0 to 300%.

• Thickness controls the stroke weight of the hatch elements, from .1 pt to 10 pts. 
(This option is dimmed if the selection is unstroked.) 

• Max. Line Length sets the length of the hatch elements, from 5 pts to 999 pts. 

• Rotation Noise sets the amount of random rotation of objects within the hatch layers, 
from –360 degrees to 360 degrees.



Using Help | Contents | Index Back 249  

Adobe Illustrator Help Working with Bitmap Images 

Using Help | Contents | Index Back 249  

• Rotation Variance sets the amount that each layer is rotated from the previous layer, 
from 0 to 100%.

• Top Angle sets the angle of rotation for the top-most hatch layer, from –360 degrees to 
360 degrees. 

6 Click OK.
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Using Type

About using type in Illustrator
No matter which language version you are using, Adobe Illustrator provides a wide range 
of multinational language features—from spell-checking and hyphenation support for 
numerous European languages to advanced typography features for Chinese, Japanese, 
and Korean (CJK) text. 

Note: Your operating system must support the languages in which you wish to work. 
Consult your system software manufacturer for more information.

The range of type tools in Illustrator make it easy to flow text into shapes and place type 
along a path in your artwork, such as along a circle or irregular path that you create. 
To enhance your designs, you can also paint type with colors and patterns, apply effects 
and styles, or transform type into entirely new shapes. 

You can enter type or import type into your artwork from another application. Adobe 
Illustrator imports and exports vertical text files, such as MS Word or RTF, as horizontal. 
Vertical text is imported into Illustrator horizontally, and vertical text is exported from 
Illustrator horizontally.

Creating type
Using the type tools, you can create horizontal or vertical type anywhere in a file. In 
addition, you can flow text into shapes or onto paths in a variety of ways: You can enter 
type in a containing column or rectangle, inside an irregularly shaped object, and inside or 
along a path.

Entering type at a point
The horizontal and vertical type tools are used to enter type anywhere in the Illustrator 
work area, without needing to define a bounding area for the type. Entering type this way, 
for example, is useful for adding a caption to an illustration.

To enter horizontal or vertical type at a specific point:

1 Select the type tool  or the vertical type tool . The pointer changes to an I-beam 
within a dotted box.

The small horizontal line near the bottom of the I-beam marks the position of the type 
baseline. The baseline is the line on which the type rests.

2 Click where you want the type to begin. 

Important: Be sure not to click an existing object, because doing so converts the object 
into a container or path for the type. If an existing object is located where you want to 
enter type, lock or hide the object or enter the type away from the object and reposition 
the type over the object afterward.

3 Enter the type you want. Press Enter or Return to begin a new line of type. 
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Entering horizontal or vertical type in a rectangle
You can use the type or vertical type tool to define a text rectangle into which you enter 
type. This method is useful when you want to create one or more columns of text, such as 
for a brochure. You can also create a rectangle with the rectangle tool and then use any 
type tool to convert it to a text rectangle. 

Once you’ve entered type, you can change the shape and size of the text rectangle. 

To create a text rectangle using a type tool:

1 Select the type tool  or the vertical type tool . The pointer changes to an I-beam 
within a dotted box.

2 Drag diagonally to define the text rectangle. The text rectangle you create is unpainted 
(not filled or stroked). Text rectangles are not visible in Preview view or when printing, 
unless filled or stroked with color. (See “Using the Color palette” on page 158.)

When you release the mouse button, the pointer reverts to an I-beam. (In Outline view, a 
rectangle appears with an insertion point at the top left corner of the text rectangle.)

3 Enter the type. The type wraps to fit inside the defined area. 

4 Press Enter or Return to begin a new paragraph.

If you enter more type than can fit within the rectangle, a small box containing a plus 
symbol  appears near the bottom of the rectangle when in Outline view or when the text 
rectangle or type is selected. The plus symbol is positioned at the end of the baseline of 
the last visible line of type. 

You can adjust the size of the rectangle to accommodate the type using either the 
bounding box or the direct-selection tool. When you adjust the size or shape of the 
rectangle, the text reflows within the adjusted shape.

Note: If you select objects, point text, or path text in addition to a text rectangle, scaling 
with the bounding box will cause all objects, including the area text, to be rescaled.

You can also create a linked copy of the rectangle to force extra type to flow into another 
text rectangle or object. (See “Linking type containers” on page 269.)

To change the size or shape of a text rectangle using the bounding box:

1 Select the selection tool .

2 Select the text rectangle to adjust. 

3 Drag a handle of the selection until the text rectangle is the desired size or shape. Shift-
drag to maintain the proportion. 

To change the size or shape of a text rectangle using the direct-selection tool:

1 Select the direct-selection tool .

2 If the type is selected, click outside the rectangle to deselect it.

3 Position the pointer on the edge of the text container you want to adjust. Do not select 
any type baselines.
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4 Click to select an edge or corner of the text rectangle, and drag to adjust the rectangle’s 
shape. Shift-drag to constrain the tool to multiples of 45 degrees (constraining makes it 
easier to retain the shape of a rectangle).

Adjusting the text rectangle using the direct-selection tool is easiest when you’re in 
Outline view.

Entering horizontal or vertical type in an object
You can use any object as an area within which to enter type. If the object is an open path, 
the program draws an imaginary line between the endpoints of the path to define the 
object for the type, just as it does to paint open paths. 

To create only area type or to create area type on an open path, you can use the type or 
vertical area-type tools exclusively. If, however, you want to create several kinds of type, 
you should use the type tool or the vertical type tool. When you move a type tool over 
different kinds of objects, the type tool appropriate to the specific object (for example, 
an area-type tool or a path-type tool) appears.

To enter type in an object:

1 Select the type tool  or the area-type tool  if the object is a filled open path.

2 Position the pointer on the path, and click. An insertion point appears.

When you turn an object into a type path, the path becomes unstroked and unfilled, even 
if the path was originally stroked or filled. When the entire text object is selected, any 
changes to the paint settings affect only the type, not the path.

3 Enter some type.

As with text rectangles, if you enter more type than can fit within the area, in Outline view 
and in Preview view (only when text is selected), a small box with a plus symbol  appears 
near the bottom of the area. 

You can paint the path after you enter type by selecting the path with the direct-selection 
tool and using the Color palette or Swatches palette. 

Entering horizontal or vertical type along a path
You can enter type that flows along the edge of an open or a closed path. The path can be 
regularly or irregularly shaped. When you enter type along a path, the path is no longer 
stroked or filled. You can paint it later if you want, without affecting the paint attributes of 
the type.

Entering horizontal type on a path results in letters that are perpendicular to the baseline. 
Entering vertical type on a path results in text orientation parallel to the baseline.

To toggle between the type tool and the vertical type tool when another type tool is 
currently selected, Shift-click.

To enter horizontal type along a path:

1 Select the type tool  or the path-type tool . 

2 Position the pointer on the path, and click. An insertion point appears on the path. 

3 Enter the type you want. Type appears along the path, perpendicular to the baseline. 
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To enter vertical type along a path:

1 Select the vertical type tool  or the vertical-path-type tool . 

2 If the multilingual options are not visible in the Character palette, choose Show Multi-
lingual from the palette menu.

3 Choose Standard from the Direction pop-up menu.

4 Position the pointer on the path, and click. An insertion point appears on the path. 

5 Enter the type you want. Type appears along the path, parallel to the baseline. 

To move type along a path:

1 Use the selection tool  or the direct-selection tool  to select the type path if it is not 
already selected.

2 Position the pointer on the I-beam in the type.

3 Use the selection tool to move the selected type along the path. Be careful not to drag 
across the path. 

Example of moving type along a path.

To align horizontal type evenly along a path, enter a negative baseline shift value in 
the Character palette so that the type runs along the center of the path. This method 

creates an even flow of type along the curve. (See “Specifying baseline shift” on page 261.)

To flip the direction of the type along a path:

1 Select the selection tool .

2 Position the pointer precisely on the I-beam.

3 Do one of the following:

• Drag the I-beam across the path.
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• Double-click the I-beam.

Example of flipping type along a path.

The initial direction of type flows in the order that points were added to the path. 
If you want your text to flow from left-to-right without having to flip the I-beam, 

construct your paths in that order.

To move type across a path without changing the direction of the type, use the Baseline 
Shift option in the Character palette. (See “Specifying baseline shift” on page 261.) For 
example, if you created type that runs from left to right across the top of a circle, you can 
enter a negative number in the Baseline Shift text box to drop the type so that it flows 
inside the top of the circle.

Deleting empty type paths from artwork 
The Delete Empty Text Paths option in the Cleanup dialog box lets you delete unused type 
paths and containers from your artwork. Doing so makes your artwork more efficient and 
easier to print. You can create empty type paths, for example, by inadvertently clicking the 
type tool in the artwork area and then choosing another tool. 

To delete an empty type path from your artwork:

1 Choose Object > Path > Clean Up.

2 Select Delete Empty Text Paths, and click OK.

Selecting type
Before you can format or edit type, you must select it. You can select one character, a range 
of characters, all type on a path, or all type in a container. In addition, you can easily select 
all the type in a document.

Note: The Type Area Select option in the Type & Auto Tracing preferences controls the 
sensitivity of the selection tools when selecting type. When Type Area Select is on, you can 
click anywhere in the type bounding box to select the type. When Type Area Select is off, 
you must click directly on the type path in order to select the type. 

To select characters:

1 Select any type tool.

2 Do one of the following:

• Drag to select the type you want to change. (Shift-drag to extend or reduce the 
selection.)

• Position the pointer in a word, and double-click to select that word.
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• Position the pointer in a paragraph, and triple-click to select the entire paragraph.

• Position the pointer at the beginning of a paragraph, and press Shift+Ctrl+Up Arrow 
(Windows) or Shift+Command+Up Arrow (Mac OS) to select the previous paragraph. 
With the pointer at the end of a paragraph, press Shift+Ctrl+Down Arrow (Windows) or 
Shift+Command+Down Arrow (Mac OS) twice to select the next paragraph.

• Press Shift+Ctrl+Right Arrow (Windows) or Shift+Command+Right Arrow (Mac OS) to 
select one word to the right. Press Shift+Ctrl+Left Arrow (Windows) or 
Shift+Command+Left Arrow (Mac OS) to select one word to the left.

To select all type on a path or in a container:

Do one of the following:

• Select one or more characters using a type tool, and then choose Select > All.

• Select the selection tool  or direct-selection tool , and click the type. (See “Selecting 
objects” on page 97.)

To select all type in a document:

Choose Select > Object > Text Objects.

To turn the Type Area Select option on or off:

1 Choose Edit > Preferences > Type & Auto Tracing (Windows and Mac OS 9) or Illustrator 
> Preferences > Type & Auto Tracing (Mac OS X).

2 Select or deselect the Type Area Select option, and click OK.

Showing hidden characters
As you work with type, nonprinting characters are embedded into the file to indicate 
keyboard actions or states, such as spaces, returns (line breaks), and tabs. These characters 
include hard returns (line breaks), soft returns (line breaks), tabs, spaces, nonbreaking 
spaces, double-byte characters (including spaces), discretionary hyphens, other 
nonprinting characters, and end of text. 

These characters are by default hidden. To help you format and edit type, you can make 
the characters visible. 

To show hidden characters:

Choose Type > Show Hidden Characters. A check mark appears next to the menu 
command. To hide visible characters, choose the command to remove the check mark.

Using multiple master fonts
Illustrator supports the Adobe multiple master font technology and provides special 
options for working with those fonts. 

Multiple master fonts are customizable Type 1 fonts whose typeface characteristics are 
described in terms of linear design axes such as weight, width, style, and optical size. 
Multiple master fonts include a number of primary instances. For example, Myriad® 
includes 15 primary instances, ranging from 215LT 300CN (Light condensed) to 830BL 
700SE (Black SemiExtended). Standard Type 1 fonts are single master fonts, which means 
they are adjustable in style only (for example, Roman, bold, italic).
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When you create a multiple master font, the font is available only when the file for which it 
was created is open. To have a multiple master font instance always available for Illustrator 
and other applications, you must first create it in Adobe® Type Manager®.

To modify a multiple master font from within Illustrator:

1 Using the type tool , select the text that uses a multiple master font. 

2 Choose Window > Type > MM Design.

3 Edit the font as described in the documentation included with your multiple 
master font. 

Setting type attributes
The Adobe Illustrator program gives you precise control over type attributes, including 
font, type size, leading, kerning, tracking, baseline shift, horizontal and vertical scale, 
spacing, and letter orientation. You can either set type attributes before you enter new 
type or reset them to change the appearance of existing, selected type. You can also set 
attributes for several type paths and type containers at once, if they are all selected. 

Using the Character palette
You change type attributes using the Character palette. Some of the type attributes also 
have separate submenus or palettes so that you do not have to open the Character or 
Paragraph palette to change only one attribute. In addition, some attributes can be 
changed using keyboard shortcuts. For a complete list of shortcuts, see the Adobe 
Illustrator Quick Reference Card.

Character palette 
A. Font B. Font Style C. Font Size D. Kerning E. Vertical Scale F. Baseline Shift G. Leading
H. Tracking I. Horizontal Scale

Displaying the Character palette Choose Window > Type > Character.

Changing the palette display size Click the up and down arrows  on a palette’s tab to 
cycle through the display sizes. Alternately, choose Show Options or Hide Options and 
Show Multilingual or Hide Multilingual from the palette menu to change the palette 
display size.

Editing type values To apply a value to the selected type without moving to the next 
text box in the palette, press Enter or Return. To apply a value and then highlight the value 
just edited, press Shift+Enter or Shift+Return.To apply a value and move to the next text 
box in the palette, press Tab.
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Choosing a font family
A font family is a complete set of characters, letters, and symbols of a particular typeface 
design. For example, the font used in this paragraph is Minion®. You can choose a font from 
the Character palette, or you can choose Type > Font and choose from the submenu.

You do not see fonts in their respective faces in the palette or submenu, even when you 
have a utility that shows typefaces installed (such as Adobe Type Reunion®). 

Note: When you open an Illustrator file on a Japanese system, the Font Details dialog box 
appears, showing the font format and Tsume information format for fonts used in the file. 
If the fonts in the file are different from those available on your system, the Font Issues 
dialog box appears, providing information about font substitution.

To choose a font from the Character palette:

1 Do one of the following:

• Select any type container or type path using a selection tool.

• Select a block of type using a type tool.

2 In the Character palette, do one of the following:

• In the Font text box, type the name of the font family you want to use. In the Font Style 
text box, enter the type style (for example, Bold, Condensed, Italic). As you type, the 
name of the first font or style beginning with that letter appears. Continue typing the 
name until the correct font or style name appears.

• Choose a font and style from the pop-up menus.

Note: Font styles are not available for Kanji fonts.

3 Press Enter, Return, or Tab to apply the new font.

To choose a font from the Type menu:

1 Do one of the following:

• Select any type container or type path using a selection tool.

• Set an insertion point or select a range of text using the type tool  or the vertical-type 
tool .

2 Choose Type > Font. A check mark appears next to the selected font. 

3 Drag to choose the font family you want. If more than one style of the font is installed, 
you see a submenu, which contains a list of styles available for the font family you choose. 

4 Select the style you want. The font you choose becomes the active font.

Note: When using 2-byte fonts, you can switch between showing a font’s name in a 2-byte 
script or showing the font in its English name by selecting or deselecting the Show Font 
Names in English option in the Type & Auto Tracing Preferences dialog box.

Choosing a type size
You can choose the type size in the Character palette, or from the Size submenu in the 
Type menu, or by using keyboard commands. The default type size is 12 points. Type size 
units can be set to points, inches, millimeters, or Q in the Units & Undo Preferences 
dialog box. 
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To choose a type size in the Character palette:

1 Do one of the following:

• Select any type container or type path using a selection tool.

• Set an insertion point or select a range of text using the type tools. 

2 In the Character palette, choose a new type size from the Font Size . You can also 
press Up Arrow or Down Arrow to change the size, or enter the size in the Font Size text 
box and press Enter, Return, or Tab.

To choose a type size from the Type menu:

1 Do one of the following:

• Select any type container or type path using a selection tool.

• Set an insertion point or select a block of type using a type tool. 

2 Choose Type > Size. A check mark appears next to the current type size in the Size 
submenu.

3 Do one of the following:

• Select a new type size from the Size submenu. 

• If the desired type size does not appear in the Size submenu, choose Other to display 
the Character palette. Enter a value in the Size text box, and press Enter, Return, or Tab.

To change type size units:

1 Choose Edit > Preferences > Units & Undo (Windows and Mac OS 9) or Illustrator > 
Preferences > Units & Undo (Mac OS X).

2 In the Type pop-up menu, choose the type units you want to use, and click OK.

Finding and replacing fonts
The Find Font command creates a list of all the fonts in your file and allows you to search 
for and replace them (including the font’s type style) by name. This command also lets you 
save the list of fonts as a separate file, which can be useful for a service bureau that is 
printing the file.

To find and replace fonts in your file:

1 Choose Type > Find Font.

2 Do one of the following:

• Select the Multiple Master, Standard (Chicago, Geneva, Monaco, New York, Courier, 
Souvenir, Symbol, Hobo, Helvetica*, and Times*), Roman, Type 1, TrueType, CID, or OTF 
(OpenType font) option to display these fonts. To display multiple master fonts, you 
must click the Multiple Master and Type 1 options (multiple master fonts are Type 1 
fonts).

• Choose System from the Replace Font From pop-up menu to make all fonts currently 
installed on your system (as filtered through the previous options you chose) available 
as replacements.

• Choose Document from the Replace Font From pop-up menu to limit the fonts you can 
use as replacements to those already in your file. 
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3 Select a font name from the Fonts in Document list. Illustrator selects the next instance 
of that font in your file.

4 Click Find Next to find the next instance of the font.

5 Select the font you want to use as a replacement from the Replace Font From list, and 
do one of the following:

• Click Change to change just that instance of the selected font.

• Click Change All to change all instances of the selected font. 

When there are no more instances of a font in your file, that font name is removed from 
the list of fonts to find.

6 To save a list of all fonts found in the file, click Save List, enter a filename and location in 
the Save Font List As text box, and click Save.

7 Click Done.

Specifying leading
Leading determines the amount of vertical space between baselines. Leading is always 
measured in units specified in the Type pop-up menu in the Units & Undo Preferences 
dialog box (the default units are points). If a line of type contains characters with different 
leading values, the line’s leading is set to the greater of the two values. 

You can adjust leading in the Character palette or directly from the keyboard. The default 
Auto-Leading option sets the leading at 120% of the type size. For example, 10-point type 
would have a leading value of 12 points (120% of 10 points). 

To change the leading value using the Character palette:

1 Do one of the following:

• Use a selection tool to select any type container or type path.

• Use the type tools to select a block of type.

2 In the Character palette, enter a value in the Leading text box , or choose a value from 
the pop-up menu.

3 Press Enter or Return.

Note: To set the leading to the same value as the font size, double-click the Leading icon. 
To reset a setting to its default value, Ctrl-click (Windows) or Command-click (Mac OS) the 
associated icon in the palette. 

To specify leading before a paragraph:

1 Do one of the following:

• To apply leading to a single paragraph in text, use the type tool to click anywhere in the 
paragraph. 

• To apply leading to all paragraphs in a type container, use the selection tool to select 
the entire type container. 

2 In the Paragraph palette, do one of the following:

• Enter a value in the Space before Paragraph text box .

• Press Up Arrow or Down Arrow to increase or decrease the leading value. 
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3 Press Enter, Return, or Tab.

Note: You can specify leading before a paragraph with area type only.

Specifying kerning and tracking
Kerning controls the spacing between two characters. You can control kerning manually, 
or you can turn on the kerning built into a font by the font designer. (See “Spacing 
characters with auto-kerning” on page 261.) Tracking inserts uniform spacing between 
more than two characters in selected type. Use tracking to adjust the spacing of a word or 
an entire block of type. 

Positive kerning or tracking values move characters apart; negative kerning or tracking 
values move characters closer together. Kerning and tracking values are measured in units 
that are 1/1000 of an em space. The width of an em space is relative to the current type 
size. In a 1-point font, 1 em corresponds to 1 point; in a 10-point font, 1 em corresponds to 
10 points. Because kerning units are 1/1000 em, 100 kerning units in a 10-point font are 
equivalent to 1 point.

Examples of kerning values and tracking values (“The Emperor’s”).

To change the kerning or tracking value using the Character palette:

1 Set an insertion point between two characters for kerning or select type for tracking 
using the type tools.

2 In the Character palette, do one of the following:

• Click the Kerning button  and enter a value in the Kerning text box.

• Click the Tracking button  and enter a value in the Tracking text box.

3 Press Enter, Return, or Tab.

To view the kerning value between two characters:

1 Set an insertion point between two characters whose kerning value you want to view, 
using the type tools.

2 Choose Window > Info. 

The Info palette displays the total spacing value for the two characters. For example, if the 
Info palette displays 109 = 100 + 9/1000 em, the characters have 9/1000 em kerning and 
the word has 100/1000 em tracking.
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Spacing characters with auto-kerning
To use a font’s kerning information to space characters, you can select the Auto-Kerning 
option in the Character palette. Many Roman fonts contain information about the spacing 
of character pairs. For example, the spacing between an A and a W often is less than the 
spacing between an A and an F. 

You can also choose a specific kerning value, rather than Auto-Kerning, in the Character 
palette until you finish creating your type. Then select the type and apply auto-kerning 
to it. 

To apply auto-kerning to existing type in a file:

1 Choose Select > All.

2 In the Character palette, choose Auto from the Kerning  pop-up menu or type Auto in 
the text box. 

To turn auto-kerning off:

Enter 0 in the Kerning text box. 

Specifying baseline shift
Baseline shift controls the distance that type appears from its baseline, either raising or 
lowering the selected type. The Baseline Shift option lets you create subscripts or super-
scripts or move path type above or below a path without changing the direction of the 
type flow. For example, using the path-type tool on a circle positions type above the circle. 
Using the Baseline Shift option, you can move the type inside the circle without changing 
the type’s orientation.

A positive value moves type above the baseline; a negative value moves it below the 
baseline. Baseline shift is measured by points unless you change the option set in the Type 
pop-up menu in the Units & Undo Preferences dialog box.

To specify baseline shift using the Character palette:

1 Select a type container or type path using a selection tool, or select a block of type 
using the type tools.

2 If the Baseline Shift button  is not visible in the Character palette, choose Show 
Options from the palette menu.

3 Enter a value in the Baseline Shift text box, or press Up Arrow or Down Arrow to 
increase or decrease baseline shift.

4 Press Enter or Return.

Adjusting horizontal or vertical scale
Horizontal scale and vertical scale specify the proportion between the height and width of 
the type relative to the baseline. You can adjust scale to compress or expand selected 
characters in both width and height.
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Scaling type using a transformation tool affects the type’s horizontal scale as well as the 
type size, leading, indentation, and baseline shift. When type has been scaled using a 
transformation tool, you can revert it to its original horizontal scale by setting the 
horizontal scale to 100%.

Note: Depending on the value you enter when you use vertical type, the horizontal scale 
may make the text appear narrower, because it functions relative to the baseline. The 
opposite is true for vertical scale.

To adjust the horizontal or vertical scale of type:

1 Select any type container or type path using a selection tool, or select a range of text 
using the type tools.

2 If the Horizontal Scale pop-up menu  and the Vertical Scale pop-up menu  are not 
visible in the Character palette, choose Show Options from the Character menu.

3 Enter a percentage in the Horizontal Scale or the Vertical Scale text box.

4 Press Enter or Return.

Adjusting spacing using the keyboard
You can set the increments in which baseline shift and kerning/tracking values increase or 
decrease when you use keyboard shortcuts. The default key increment values are 2 points 
for size/leading, 2 points for baseline shift, and 20/1000 of an em space for kerning/
tracking.

Settings in the Type & Auto Tracing Preferences and General Preferences dialog boxes 
control the keyboard shortcuts. 

The type units preference determines the units for font size, leading, and baseline shift.

To change keyboard increments:

1 Choose Edit > Preferences > Type & Auto Tracing (Windows and Mac OS 9) or 
Illustrator > Preferences > Type & Auto Tracing (Mac OS X). 

2 Enter the values you want in the Size/Leading, Baseline Shift, and Tracking text boxes, 
and click OK.

To change the cursor key increment value:

1 Choose Edit > Preferences > General (Windows and Mac OS 9) or Illustrator > 
Preferences > General (Mac OS X).

2 Enter the value you want in the Keyboard Increment text box, and click OK.

To change type units:

1 Choose Edit > Preferences > Units & Undo (Windows and Mac OS 9) or Illustrator > 
Preferences > Units & Undo (Mac OS X).

2 Choose a type unit from the Type pop-up menu, and click OK. 

The default type unit is points (a point equals 1/72 of an inch). You can choose inches, 
millimeters, Q (a Q equals 0.25 millimeter), or pixels.
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Painting type
You can paint type, the type container, or the type path. You may want to paint the 
container to create a background for your type, or paint the type path as a visual base for 
the type.

To paint type, a type container, or a type path:

1 Do one of the following:

• To paint the type, use the selection tool  to select the type. 

• To paint a type container or type path, use the direct-selection tool  or the group-
selection tool  and click the path or object. (Do not select the baselines.) 

• Use a type tool to select characters, words, or paragraphs.

2 Choose either Window > Color or Window > Swatches.

3 Paint the type or type path as desired.

Note: You can’t use a gradient swatch as a fill for type, but you can apply a style with 
gradient effects to type.

Copying type attributes between objects
You can use the eyedropper tool to copy—or sample—the character, paragraph, fill, and 
stroke attributes from type in an Illustrator file. You can then use the paint bucket tool to 
apply the copied attributes to other type.

By default, the eyedropper and paint bucket tools affect all attributes of a type selection, 
including appearance attributes. To customize the attributes affected by these tools, use 
the Paintbucket/Eyedropper dialog box. 

Note: When you select an entire type path or container, the fill, stroke, character, and 
paragraph attributes of that object are copied and applied to the new text. When you 
select a portion of text, only the fill, stroke, and character attributes are copied. 

To copy type attributes to selected text objects:

1 With the selection tool or any type tool, select the type container, type path, or a 
portion of text to which you want attributes copied.

2 Select the eyedropper tool.

3 Click the text from which you want attributes copied. The text can be unselected, 
locked, or in an inactive artwork file. The attributes are applied to the selected type, and 
that type remains selected.

To copy type attributes using the paint bucket tool:

1 Select the paint bucket tool .

2 Click the type path or type container, or drag to select a portion of text, to which you 
want attributes applied. The paint bucket displays a small t next to it, to indicate you are 
copying type attributes.

The attributes are applied to the selected type. 

To toggle between the eyedropper tool and the paint bucket tool, press Alt 
(Windows) or Option (Mac OS) when either tool is selected.
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To change type attributes:

1 Double-click the paint bucket or the eyedropper tool.

2 Select or deselect the attributes for the eyedropper to copy and the paint bucket to 
apply.

• To expand or collapse the list of attributes for each characteristic, click the triangle to 
the left of the list.

• To select or deselect all the attributes for each characteristic, click the group option.

• To select or deselect individual attributes for a characteristic, click the attribute.

3 Click OK.

Rasterizing and anti-aliasing type
When you save artwork in a bitmap format—such as JPEG, GIF, or PNG—Illustrator 
rasterizes all objects at 72 pixels per inch and applies anti-aliasing to them. However, if 
your artwork contains type, the default rasterization and anti-aliasing settings may not 
produce the desired results. Illustrator provides several options specifically for rasterizing 
type. In order to take advantage of these options, you must rasterize type objects before 
you save the artwork.

To set rasterization and anti-aliasing options for type objects:

1 Choose a Rasterize command as described in “Changing vector graphics into bitmap 
images” on page 237.

2 Choose a method for rasterizing type from the Type Quality pop-up menu. 

• Streamline to create slender, attenuated type. 

• Outline to create slightly heavier type. 

3 Choose an anti-aliasing option:

• None to apply no anti-aliasing and maintain the hard edges of type when it is 
rasterized. 

• Type Optimized to apply anti-aliasing that is best suited to type. Anti-aliasing reduces 
the appearance of jagged edges in the rasterized image and gives type a smoother on-
screen appearance. However, it can also make small text difficult to read.

Transforming type
The selection tool lets you select an entire type path or type container so that you can 
transform the type along with the path or container. You can also transform individual 
type containers within linked type containers.

To transform type including its path:

1 Do one of the following:

• To transform all of the type, use the selection tool  to select the type path or type 
container, or click its baseline.
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• To transform individual type containers in a series of linked type containers, use the 
direct-selection tool  to select the linked type containers you want to transform. Make 
sure the baselines appear, indicating that the type is selected within the containers.

Note: To transform the type path or type container without transforming the type, use the 
direct-selection tool to select just the path. Make sure that the baselines do not appear, 
indicating type is deselected.

2 Select the rotate , scale , or shear  tool to transform the type container and its 
path.

Rotated type container compared to rotated type container and type.

Changing text orientation
You can change the direction of individual characters as well as the flow of an entire block 
of text using the Character palette or the Text Orientation command.

Changing character direction using the Character palette
You can change the direction of individual characters or portions of a vertical text block 
using the Direction pop-up menu in the Character palette. 

Changing character direction maintains the original orientation of the text (for example, 
vertical text remains in a vertical orientation), but the direction of the individual character 
or portions of text are rotated 90 degrees. 

To change the direction of type:

1 Select the text whose direction you want to change.

2 If the multilingual options aren’t visible in the Character palette, choose Show Multi-
lingual from the palette menu.

3 Choose a direction from the Direction pop-up menu. 

• Standard orients text characters in line with the axis of the page.

• Rotate rotates Roman fonts and other one-byte characters 90 degrees from standard.

In 
the heart 

of the island of Niphon 
and in a mountainous region, 

fifty leagues from 

In the heart of the island of 

Niphon and in a mountainous 

region, fifty leagues from 

Yokohama, lies the ancient 
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• Tate Chu Yoko rotates the selected block of text (1- or 2-byte characters) in the plane 
opposite from the rest of the text. 

Vertical text in Standard direction compared to vertical text with Tate Chu Yoko option applied.

Changing text orientation using the Text Orientation command
The Text Orientation command lets you change text from a horizontal orientation to a 
vertical orientation, and vice versa. 

To change a text block orientation from horizontal to vertical, and vice versa: 

1 Select a text block with any selection tool.

2 Choose either Type > Type Orientation > Horizontal or Type > Type Orientation > 
Vertical.

Using the Wari-Chu (divided note) option
The Wari-Chu option in the Character palette decreases the type size of selected text to a 
percentage of the original and stacks the type—horizontally or vertically, according to the 
orientation—on two lines. 

Regardless of the point size of wari-chu text, the number of wari-chu lines is always two.

Text without Wari-Chu option compared to text with Wari-Chu option.

Note: The Wari-Chu option does not work with path type and does not affect type entered 
on open or closed paths.

To create a divided note with the Wari-Chu option:

1 Using any type tool, select the type to be divided.

2 If the multilingual options are not visible in the Character palette, choose Show Multi-
lingual from the palette menu.

3 Select the Wari-Chu option. 
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4 To change the wari-chu type size (as a percentage of the original point size), enter a 
percentage in the Scale text box (below the Wari-Chu option). The default is 50%.

Modifying letterforms as graphic objects 
The Create Outlines command (and the same command as an effect—Outline Object) lets 
you turn type into a set of compound paths that you can edit and manipulate as you 
would any other graphic object. Create Outlines and Outline Object are useful for 
changing the look of large display type, but they are rarely useful for body text or other 
type at small sizes.

These commands get font outline information from the actual Type 1, TrueType, or 
OpenType font files installed on your system. When you create outlines from type, 
characters are converted in their current positions; they retain all graphics formatting such 
as their stroke and fill. 

Note: You can’t convert bitmap fonts or outline protected fonts to outlines. 

When you convert type to outlines, the type loses its hints—instructions built into outline 
fonts to adjust their shape so that your system displays or prints them optimally at a wide 
range of sizes. Therefore, if you plan to scale the type, do so by adjusting its point size 
before converting it to outlines.

You must convert all the type in a selection to outlines; you cannot convert a single letter 
within a string of type. To convert a single letter into an outline, create a separate piece of 
type containing only that letter. 

To convert type to path outlines:

1 Do one of the following:

• To apply the Create Outline command, select the type you want to convert. Then 
choose Type > Create Outlines. 

• To apply the Outline Object command, select an object or group in the artwork, or 
target a group or layer in the Layers palette. (For more information on targeting, 
see “Changing the appearance of artwork using the Layers palette” on page 223.) Then 
choose Effect > Path > Outline Object. 

If you select type outlines and choose Object > Compound Paths > Release, you can 
use the outlines as type containers.

To use several outlined letters as a mask:

1 Select all of the letters.

2 Choose Object > Compound Paths > Make. 

3 Mask the letters. (See “Working with clipping masks” on page 149.)
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Working with columns of text
Adobe Illustrator provides several commands that make creating and working with 
columns or blocks of type easy. The various features enable you to import and export text 
from non-Illustrator files, link text so that it flows from one column to another, create sets 
of columns for text, wrap text so that it flows around a piece of artwork, and speed up the 
display of type when you don’t need to read the text in your artwork.

Note: When you are importing or exporting text, make sure that the fonts used in the file 
are available on the system where the text will be displayed or printed. Missing fonts and 
font styles—including fonts that have the same name but different formats (Type 1, 
TrueType, or CID)—may cause unexpected results. On Japanese systems, differences in 
character sets may prevent text that was entered in Windows from appearing on-screen in 
Mac OS.

Importing text files 
You can import text into Adobe Illustrator from a file that was created in another 
application. This allows you to format and spell-check your text in a word-processing 
application before you bring it into Illustrator. (For a list of supported text formats, 
see “About imported artwork” on page 31.)

One advantage of importing text from a file, rather than copying and pasting it, is that 
imported text retains its character and paragraph formatting. For example, text from an 
RTF (Rich Text Format) file retains its font and styles in Illustrator. You can also set encoding 
and formatting options when importing text from a plain text (.txt) file.

To import text into a new Illustrator file:

Choose File > Open, select the text file you want to open, and click Open. 

To import text into an existing Illustrator file:

1 Do one of the following:

• Choose File > Place. Select the text file you want to import, and click Place.

• Drag the text file from your desktop onto the selected object on your artboard.

2 If you selected a plain text (.txt) file, do the following, and then click OK:

• Specify the character set and platform that were used to create the file. 

• Select Extra Carriage Returns options to determine how Illustrator processes extra 
carriage returns in the file.

• Select the Extra Spaces option if you want Illustrator to replace strings of spaces in the 
file with tabs. Enter the number of spaces to be replaced by a tab.

Note: If the imported text uses an outline font that is not available on your system, a 
message appears. If you choose to import the text, letterforms in the missing font are 
converted to compound paths. (See “Modifying letterforms as graphic objects” on 
page 267.) You can modify these paths as graphic objects, but you can’t edit them as text.

Exporting text files 
The Export command exports text from point type, type paths, and type containers to a 
new text file in plain text format.
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To export text:

1 Using a type tool, select the text to export.

2 Choose File > Export.

3 Select the desired file format in the Export File pop-up menu. 

4 Enter the name of the new text file in the name box, and click Save (Windows) or Export 
(Mac OS).

Displaying overflow text
If a type container is too small, you cannot see all of the text within it. You can adjust the 
type container so that all of the text is visible.

To display all text:

Do one of the following:

• Adjust the size of the type container.

• Link the type container to another type container so that the overflow text flows 
into the second type container. Create one or more copies of the type container, 
if necessary. 

Linking type containers
You can link type containers created with the type tool or the area-type tool. When you 
link type containers, the text flows from one type container to another to fill in blank areas 
in one type container. Thus, the text can fill several different objects, such as several 
columns or several irregular shapes.

Type flows from one object to another based on the type container’s stacking order. Type 
flows first into the backmost object in the stacking order and continues to the next object 
in the stacking order. The most recently created object is frontmost. (See “Stacking 
objects” on page 109.) 

The following options are available when working with linked type containers:

• You can change the order in which type flows by changing the stacking order of type 
containers using the Send to Front and Send to Back commands. You can adjust the 
stacking order before or after linking type. 

• If you are working with type containers and you run out of room in a container, you can 
create a copy of the container for overflow type.

• You can also unlink type containers to change their stacking order without affecting the 
flow of type. Unlinking does not return the type to its original object and does not 
reflow the text. To return it to its original object, you must cut and paste the type. If you 
want to delete a single or unlinked type container without deleting the type within it, 
copy and paste the text elsewhere, and then delete the container.

To create a linked copy of a type container:

1 If you are not already in Outline view, choose View > Outline.

2 Select the group-selection tool  and position the pointer on the type container. Make 
sure the baselines aren’t selected.

3 Alt-drag (Windows) or Option-drag (Mac OS) the copy of the container to its new 
position. Shift-drag to constrain the tool to multiples of 45 degrees.



Using Help | Contents | Index Back 270  

Adobe Illustrator Help Using Type 

Using Help | Contents | Index Back 270  

4 When the new type container is in position, release the mouse button, and then 
Shift+Alt (Windows) or Shift+Option (Mac OS). You must release the mouse button before 
you release the keys.

The type flows from the first type container to the second, and the two type containers are 
linked.

You can choose Object > Transform > Transform Again to create additional columns.

To link or unlink type containers:

1 Select the selection tool .

2 Drag a marquee through the type containers to be linked, or Shift-click with the 
selection tool. The baselines should be selected.

3 Choose either Type > Blocks > Link or Type > Blocks > Unlink. 

To remove or replace a linked type container without deleting the type:

1 Select the group-selection tool .

2 Click the edge of the type container you want to remove. 

3 Press Delete. The type container you selected disappears, and the type that it contained 
flows into the next grouped or linked object in the stacking order. 

4 To add a new type container, create or select a type container, select the group-
selection tool, and Shift-click the type container to which you want to link the new type 
container. Then choose Type > Blocks > Link. The type flows into the new type container.

Creating rows and columns
By using the Rows & Columns dialog box, you can divide rectangles and text blocks into 
blocks of rows and columns and precisely change the height, width, and gutter size 
between rows and columns. The Rows & Columns dialog box can also be used to change 
the way in which text flows (from left-to-right or right-to-left for both vertical and 
horizontal text) by clicking the Text Flow buttons. 

It is also possible to create rows and columns of linked type containers. (See “Linking type 
containers” on page 269.)

Because the rows and columns created are simply graphic objects unless they contain 
type, you can also use the Rows & Columns dialog box to create rectangles. Select an 

existing rectangle and divide it into multiple rectangles using the dialog box.

In addition, using the Rows & Columns dialog box is a fast way to create guides for laying 
out artwork. (See “Using guides” on page 94.)

To divide a rectangular graphic object or type container into rows and columns:

1 Using the selection tool , select a rectangle or type container. If the selected object is 
not rectangular, it is converted into rows and columns based on the object’s rectangular 
bounding box.

2 Choose Type > Rows & Columns.
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3 Enter the number of columns you want in the Number (Columns) text box, and the 
number of rows you want in the Number (Rows) text box. You can either enter the number 
in the text boxes or use the buttons on the sides of the text boxes to increase or decrease 
the values. The dialog box adjusts the column-width and row-height values to fill the 
selected text box.

4 Change the dimensions of the column width, row height, column gutter, row gutter, 
or overall width and height by entering a new value in the corresponding text box or by 
using the buttons to increase or decrease the values.

5 Do any of the following:

• To change the direction of vertical or horizontal text flow from left-to-right or right-to-
left, click the Text Flow buttons.

• To preview the effect, select Preview. 

• To add path guides along the row and column edges, select Add Guides.

6 Click OK.

Wrapping type around a graphic object
You can make type wrap around a graphic object using the Make Wrap command. You 
must use area type when wrapping type around a path; point type and path type do not 
wrap around an object. You can make one or several type containers wrap around any 
number of objects.

Important: You cannot wrap type around an open path.

To wrap type around a graphic object:

1 Make sure that the object or objects around which you want to wrap type are in front of 
the type. If necessary, use either the Bring to Front or Paste in Front command to position 
the objects in front.

2 If desired, use any of the drawing tools to outline a graphic boundary for the area 
around which the type wraps. (This is necessary if you want to wrap text around a placed 
EPS file or bitmap image.) If the boundary is stroked or filled, it must be behind the graphic 
element but in front of the type.

You can use an unpainted graphic boundary to control how closely type wraps around 
an object. A boundary is useful to wrap type around a large type container consisting of a 
single piece of type, such as a large initial capital letter. You can then adjust and resize 
the unpainted boundary using a selection tool to achieve the exact kind of text wrap 
you want.

3 Using the selection tool , select the type containers that you want to wrap and the 
graphic object around which to wrap them.

4 Choose Type > Wrap > Make. The type wraps around the graphic object.

To separate a wrapped type container from a graphic object: 

1 Select the type container or graphic object.

2 Choose Type > Wrap > Release.
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Greeking type below a specified font size
Adobe Illustrator greeks—displays as a dimmed bar—type below a specified type size, as 
set in the Greeking Limit text box in the Type & Auto Tracing Preferences dialog box. Any 
type at or below the specified type size is replaced on-screen with non-letterforms that act 
as placeholders in the artwork. Greeking type affects only artwork displayed on-screen, 
not the printed image. 

In addition, if you reduce the document view so that type on-screen falls below the greek 
type limit, the type appears greeked. For example, if the greek type limit is set at 6 points, 
12-point type viewed at a 50% zoom level appears greeked.

To set the greek type limit:

1 Choose Edit > Preferences > Type & Auto Tracing (Windows and Mac OS 9) or 
Illustrator > Preferences > Type & Auto Tracing (Mac OS X).

2 Enter a value in points in the Greeking text box, and click OK.

Formatting columns and paragraphs
The Adobe Illustrator program includes a number of features especially useful for working 
with larger groups of type, such as type laid out within columns. These functions enable 
you to set the paragraph indentation and text alignment, change the amount of space 
between paragraphs, set tab marks, and fit type to fill a set width. You can even specify 
where words break in paragraphs, using the hyphenation feature. 

Using the Paragraph palette
You change the formatting of columns and paragraphs using the Paragraph palette.

Paragraph palette 
A. Align Left B. Align Center C. Align Right D. Justify Full Lines E. Justify All Lines F. Left Indent
G. First Line Left Indent H. Right Indent I. Space Before Paragraph

Displaying the Paragraph palette Choose Window > Type > Paragraph.

Changing the palette display size Click the up and down arrows  on a palette’s tab to 
cycle through the display sizes. Alternately, choose Show Options or Hide Options from 
the palette menu.

Editing paragraph values To apply a value to the selected type without moving to the 
next text box in the palette, press Enter or Return. To apply a value and then highlight the 
value just edited, press Shift+Enter or Shift+Return.To apply a value and move to the next 
text box in the palette, press Tab.

A B C D E

IHGF
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Specifying paragraph indentation
Indentation specifies the amount of space between the ends of each line of type and the 
path that contains that type. You can indent from the left or the right side of the path, 
and you can choose additional indentation for the first line of a paragraph. Negative 
indentation moves the type outside the margin. 

Note: The First line left indent and the Left indent on the Paragraph palette also appear on 
the Tab Ruler palette as small triangles. (See “Using the Tab Ruler palette” on page 279.)

Indentation is measured in the units specified in the Type pop-up menu in the Units & 
Undo Preferences dialog box and is selected using the Paragraph palette. 

Indentation affects only the selected paragraph or paragraphs, so you can easily set 
different indentations for paragraphs.

To specify paragraph indentation:

1 Select any type container or type path using a selection tool, or set an insertion point, 
or select a block of type using the type tools.

2 In the Paragraph palette, select the indentation text box you want to change: the left 
indent text box , the right indent text box , or the first line left indent text box .

3 Enter an indentation value.

To create a first line hanging indentation, type a negative value in the First line left indent 
text box.

4 Press Enter, Return, or Tab.

Specifying alignment options
Alignment controls how lines of type are arranged in paragraphs. Each paragraph (or line 
in point type) can be aligned left, right, centered, or justified. 

Justify All Lines justifies all the type and forces the last line in a paragraph to be justified to 
both margins. By default, the last line of a justified paragraph is left aligned with a ragged 
right margin. 

To change alignment options from the Paragraph palette:

1 Do one of the following:

• Select any type container or type path using a selection tool.

• Set an insertion point or select a block of type using the type tools.

2 In the Paragraph palette, click the alignment style you want. 

Specifying hanging punctuation
Hanging punctuation controls whether punctuation marks fall inside or outside the 
margins. Hanging punctuation is controlled by the Hang Punctuation option in the 
Paragraph palette. If hanging punctuation is turned on, the following characters appear 
outside the margins: periods, commas, single-quotation marks, double-quotation marks, 
apostrophes, hyphens, em dashes, en dashes, colons, and semicolons. 

Punctuation hangs when text is aligned right, aligned left, centered, or justified. When a 
punctuation character is followed by an end quotation mark, both characters hang. 
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If you select Hang Punctuation on 2-byte text, punctuation hangs only when there is no 
room to adjust spacing and prevent hanging; otherwise, punctuation does not hang. 
You can ensure that punctuation always hangs by also deselecting the Punctuation Hangs 
Only If Space Unavailable option in the Paragraph palette menu. (See “Using the Kinsoku 
Shori (line breaking) option” on page 276.)

To select hanging punctuation:

1 Select any type container or type path using a selection tool, or set an insertion point, 
or select a block of type using the type tools.

2 If the paragraph options are not visible in the Paragraph palette, choose Show Options 
from the palette menu.

3 Select the Hang Punctuation option.

Specifying spacing options
Spacing options control the word spacing and letterspacing in lines of justified or unjus-
tified type. In unjustified type, you can adjust the word spacing without affecting the 
letterspacing. The Word Spacing and Letter Spacing options apply primarily to justified 
type, although you can also apply spacing to unjustified type. 

Spacing options are always applied to an entire paragraph. To adjust the spacing in a few 
characters but not an entire paragraph, use the Tracking option.

To change spacing in type:

1 Select any type container or type path using a selection tool, or set an insertion point.

2 If the Word Spacing and the Letter Spacing options are not visible in the Paragraph 
palette, choose Show Options from the palette menu.

3 Do one of the following:

• To change the amount of space between words in a line of type, enter minimum, 
desired, and maximum values in the Word Spacing text boxes. (If the text is not justified, 
only the Desired text box is available.) For justified type, the default values for word 
spacing are 100% minimum, 100% desired, and 200% maximum. At 100%, no 
additional space is added between words. 

• To change the amount of space between letters in a line of type, enter minimum, 
desired, and maximum values in the Letter Spacing text boxes. (If the text is not 
justified, only the Desired text box is available.) The default values for letterspacing are 
0% minimum, 0% desired, and 5% maximum. At 0%, no space is added between letters. 

Word spacing and letterspacing are both measured as percentages of the width of a space 
in the selected type size.

Using the Tsume (proportional spacing) option
Most CJK characters are traditionally mono-spaced; that is, each character is the same 
horizontal width (and height when using vertical text) as all other characters. Some fonts, 
however, use built-in proportional spacing to account for differing widths among 
characters. 

You can change the default monospacing to proportional width (and height) spacing for 
text by using the Tsume option in the Character palette.
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You can change monospaced text into proportionally spaced text with the following 
fonts:

• Type 1 CID fonts (Mac OS), which contain the proportional width data.

• Japanese TrueType fonts shipped with KanjiTalk 7.5 and later (Mac OS).

To use proportional spacing between CJK characters:

1 Select the text to which you want to apply proportional spacing.

2 If the multilingual options are not visible in the Character palette, choose Show Multi-
lingual from the palette menu.

3 Select the Tsume option.

Using the Moji Gumi (Japanese layout rules) option
The Moji Gumi option in the Character palette lets you specify the amount of spacing 
placed between CJK characters and punctuation, or between Roman characters and CJK 
characters. By changing the percentage of space between different types of characters, 
the Moji Gumi option eliminates spacing problems that can arise when using a mixture of 
these characters in a single file. 

When the Moji Gumi option is used with the Tsume option, proportional spacing is 
applied first, followed by the Japanese layout rules.

To specify Japanese layout rules:

1 Select the text to which you want to apply layout rules.

2 If the multilingual options are not visible in the Character palette, choose Show Multi-
lingual from the palette menu.

3 Select the Moji Gumi option.

4 To change the spacing between CJK characters and punctuation marks (such as paren-
theses) in the text, enter a spacing percentage, from 0% to 200%, in the CJK/CJK text box.

A value of 100% is standard spacing, a value of 0% eliminates the extra space between 
characters, and a value of 200% doubles the standard spacing.

Text with CJK/CJK setting of 0% compared to text with CJK/ text setting of 200%.
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5 To change the spacing between CJK characters and Roman characters, enter a spacing 
percentage, from 0% to 200%, in the CJK/Roman text box.

Text with CJK/Roman setting of 0% compared to text with CJK/Roman setting of 200%.

Using the Kinsoku Shori (line breaking) option
Where a line breaks in CJK text is generally determined by the boundaries of the text 
bounding box, the size of the characters, and the amount of spacing between the 
characters. In general, a line breaks when there is no more room for the next character. 

Illustrator allows for control of characters that must not end a line, begin a line, or be 
divided over two lines. Selecting the Kinsoku Shori option and by using the options in the 
Kinsoku Shori dialog box, you can control how these characters are handled during line 
breaking, and you can choose which sets of characters to include. For example, you can 
have a line of text compressed to accommodate a punctuation mark (such as an end 
quotation mark), which must remain on the same line as the text it encloses. 

Text without Kinsoku Shori option compare to text with Kinsoku Shori option. 

To specify a character set for breaking lines:

1 If the paragraph options aren’t visible in the Paragraph palette, choose Show Options 
from the palette menu.

2 Select the Kinsoku Shori option. 

3 In the Kinsoku Shori pop-up menu, choose a character set to which to apply line 
breaking rules.

• Hard includes all characters that should not begin or end a line.

• Soft includes a subset of the hard characters. This option is selected by default.
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Characters included in Kinsoku Shori Hard set and Kinsoku Shori Soft set.

Text with Kinsoku Shori Soft set compared to text with Kinsoku Shori Hard set.

Note: With the addition of single-byte characters, the Soft set is consistent with the set 
included in the Kinsoku Shori option of Adobe Illustrator 5.5J; the Hard set is consistent 
with the set of Adobe Illustrator 7.x.

To set line breaking options:

1 If the paragraph options aren’t visible in the Paragraph palette, choose Show Options 
from the palette menu.

2 Choose Kinsoku Shori from the Paragraph palette menu.

3 Select options to apply to the character set selected in the Kinsoku Shori option in the 
Paragraph palette:

• Oikomi Maximum Spacing includes the character on the same line and condenses all 
characters evenly to fit on the line (when text is justified). In the text box, enter a 
maximum value by which to condense text. When the option is unselected, the 

Hard Set

2-byte characters

1-byte characters

Soft Set

2-byte characters

1-byte characters
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character is moved to the next line and characters on the original line are evenly spaced 
to fill the width (or height) of the line. This option is selected by default.

• Don’t Condense Space After Punctuation keeps spacing after a two-byte period uncon-
densed. This option is unselected by default.

• Bunri Kinshi Moji Shori includes the .. , ... , and — characters in the set of characters (Soft 
or Hard) to which line breaking rules are applied. This option is unselected by default. 

• Delete Space between Bunri Kinshi Moji closes up space between the .. , ... , and -- 
characters. This option is unselected by default.

• Hang Punctuation Only If Space Unavailable ensures that text always hangs. This option 
is selected by default.

4 Click OK.

About the Punctuation Hangs Only If Space Unavailable option
When the Hang Punctuation option is selected in the Paragraph palette, the Punctuation 
Hangs Only If Space Unavailable option is available and selected in the Kinsoku Shori 
dialog box. When this option is unselected, text hangs under any circumstance. If you 
want punctuation to hang only when there is no room to adjust spacing and prevent 
hanging, select the Hang Punctuation Only If Space Unavailable option. 

Note: When you open a file created or saved in Illustrator 7.0 and the Punctuation Hangs 
Only If Space Unavailable option is unselected, text in the file is reformatted. 

Working with repeated characters 
You can control how repeated characters in Japanese text are handled using the 
Kurikaeshi Moji Shori option in the Paragraph palette. By default, a repeat character mark 
is substituted for the second character when two identical characters follow one after the 
other in a body of text. When this option is selected, both characters are displayed if they 
are separated by a line break.

Text without Kurikaeshi Moji Shori option compared to text with Kurikaeshi Moji Shori option.

To use repeated character processing:

1 Using any type tool, select a paragraph of text to which you want to apply repeated 
character processing. If no text exists, the setting applies to new text typed. 

2 If the paragraph options aren’t visible in the Paragraph palette, choose Show Options 
from the Paragraph palette menu.

3 Select the Kurikaeshi Moji Shori option.
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Using the Tab Ruler palette
The Tab Ruler palette lets you quickly set left, right, center, and decimal-point tabs in 
horizontal type, and top, bottom, center, and decimal-point tabs in vertical type (up to 15 
tab stops). When you set tabs, a visual tab guide appears in the selected type to help you 
set them, even when the type path is rotated or wrapped. The units of measure for the 
tab ruler are defined by the General units specified in the Units & Undo Preferences dialog 
box (for all files) or by the units specified in the Document Setup dialog box (for the 
current file).

When using the Tab Ruler for vertical type, the Tab Ruler appears in a vertical format. When 
used for horizontal type, the Tab Ruler appears in a horizontal format.

To set tabs in text:

1 Do one of the following:

• Select any type container or type path using a selection tool.

• Set an insertion point or select a range of text using type tools.

2 Choose Window > Type > Tab Ruler.

3 Do one of the following:

• Click the Alignment box (Windows only) at the upper right of the palette to align the 
Tab Ruler with the left margin of the selected text for horizontal type, or with the top 
margin for vertical type.

• Drag the Extend Tab Ruler button at the lower right of the palette to extend the ruler. 

• Select Snap to snap tabs to ruler units as you drag them. You can also Ctrl-drag 
(Windows) or Command-drag (Mac OS) tabs to turn Snap on or off temporarily. 

4 Click the Tab Ruler where you want the tab to appear. The tab position (relative to the 
left margin of the selected horizontal text or the top margin of the vertical text) appears in 
the top center of the palette.

5 Select a type tool, and click to set an insertion point in the text. Then press Tab to move 
the text to the next tab.

To change an existing tab setting:

1 With the Tab Ruler palette open, click a tab mark to highlight it. Click a Tab Style button 
to change the tab style:

• Left-Justified Tab aligns horizontal text to the left, keeping the right margin ragged.

• Center-Justified Tab centers text on the tab mark.

• Right-Justified Tab aligns horizontal text to the right, keeping the left margin ragged.

• Bottom-Justified Tab aligns vertical text to the bottom margin, keeping the top margin 
ragged.

• Decimal-Justified Tab places text in alignment with a decimal point (useful for creating 
columns of numbers).

2 Do any of the following:

• To move a tab, drag it to a new position. As you drag, a line indicates where the tab is 
moving in the text. 
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• To remove default tabs, drag to the right (horizontal text) or toward the bottom 
(vertical text).

• To replace default tabs, drag to the left (horizontal text) or to the top (vertical text).

• To move all tab stops simultaneously to the right/bottom of the selected tab, Shift-drag 
the tab stop. 

• To remove a tab, drag it off the top right or left side of the ruler.

Fitting headline type
Illustrator lets you fit type across the full width of a type path in an object by using the Fit 
Headline command. The Fit Headline command was designed to work with Adobe 
Multiple Master fonts by adjusting the weight of the font and the tracking value when 
distributing type along a path. However, the Fit Headline command also works with other 
fonts by adjusting only the tracking value. (See “Specifying kerning and tracking” on 
page 260.)

If you change the tracking value or the type, be sure to reapply the Fit Headline command.

To fit headline type across a specified area:

1 Enter type in a type container using a type tool  or an area-type tool . 

2 Select the type using any type tool.

3 Choose Type > Fit Headline.

Hyphenating words
The autohyphenation feature automatically hyphenates words where appropriate at the 
ends of lines. You can set the hyphenation parameters in the Paragraph palette. When you 
select the autohyphenation option, you can specify the minimum number of letters 
allowed at the beginning or end of a hyphenated word. You can also limit the number of 
consecutive hyphenated lines.

You can enter a discretionary hyphen to hyphenate a word manually. Illustrator always 
breaks a word at a discretionary hyphen, regardless of the autohyphenation setting. 

You can also specify the hyphenation for a specific word or exclude a word from being 
hyphenated by using the Hyphenation Options command. In addition, you can select the 
language in which the hyphenation exception takes place. 

To enter a discretionary hyphen:

1 Select a type tool, and click where you want to enter the hyphen.

2 Press Shift+Ctrl+hyphen (Windows) or Shift+Command+hyphen (Mac OS).

To set the autohyphenation feature:

1 In the Paragraph palette, click Auto Hyphenate. If the option is not visible, choose Show 
Options from the palette menu. 

2 Choose Hyphenation from the Paragraph palette menu. 

3 In the Hyphenate text boxes, enter the minimum number of letters allowed from the 
beginning and end of a hyphenated word.

4 If desired, enter the maximum number of consecutive hyphenated lines in the Limit 
Consecutive Hyphens To text box. 
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5 Click OK.

To set hyphenation options:

1 Choose Edit > Preferences > Hyphenation (Windows and Mac OS 9) or Illustrator > 
Preferences > Hyphenation (Mac OS X). 

2 If desired, choose the language in which the hyphenation rules apply (to new text 
typed) from the Languages pop-up menu. When you select a different language, the rules 
for hyphenating words change to match that language’s rules. 

You can also change the hyphenation language for just the selected text by using the 
Languages pop-up menu in the Character palette. (If the pop-up menu isn’t visible, choose 
Show Multilingual from the Character palette menu.) Doing so is useful for hyphenating 
multilingual projects easily, such as a brochure with instructions in several languages.

3 Enter the word for which you want to specify hyphenation characteristics. If you enter 
the word with no hyphens inserted, Illustrator never hyphenates the word. If you enter 
the word with one or more hyphens inserted, Illustrator hyphenates the word only at 
those places. 

4 Click Add.

5  To remove a word from the hyphenation list, click the word to select it, and press 
Backspace or Del (Windows) or Delete (Mac OS).

Note: Hyphenation information is saved with the application, and not with the file. 
For example, if you use the file on a different computer that has different hyphenation 
exceptions, your text may hyphenate differently.

Editing text
Once you have selected type, you can use any standard word-processing method to edit 
the text.

You can use the Cut, Copy, Paste, Clear, and Select All commands in the Edit menu to copy 
type from Illustrator to other applications, to bring type from another application into an 
Illustrator file, or to edit type within an Illustrator file. When you use the Copy command to 
copy type to and from other applications, you copy only the characters, not the styles. 

Illustrator also includes commands designed specifically for editing blocks of type. These 
tools enable you to check your spelling, find and replace text, modify capitalization, and 
add typographically correct punctuation marks in your text.

Checking spelling
The Check Spelling command compiles a list of misspelled words in a file and offers a list 
of alternative spellings. If Illustrator has incorrectly identified a word as misspelled, you 
can either skip the word without changing it in the file or add the word to the dictionary 
list. These new words are then added to the custom file AI User Dictionary in the Text 
Filters folder in the Plug-ins folder. You can edit this list of words as well.

Note: The Check Spelling command can be used only with Roman fonts; CJK fonts cannot 
be spell checked with the Check Spelling command.
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To check the spelling in a file:

1 Choose Type > Check Spelling. 

The Check Spelling dialog box displays a list of words not found in the current Adobe 
Illustrator dictionary. 

2 To list separately words that are misspelled in the same way but that are in different 
cases (such as Mispell and mispell), select the Case Sensitive option.

3 To see a list of alternative spellings for a misspelled word, click the word in the 
Misspelled Words list. The first instance of that word is highlighted in your file, and any 
alternative spellings appear in the Suggested Corrections list. 

4 Do one of the following:

• To enter a new spelling for a misspelled word, either click the correct spelling in the 
Suggested Corrections text box or type the corrected spelling in the text box. To 
change the first instance of the misspelled word in the file, click Change or double-click 
the correct word. To change every instance of the selected misspelled word in the file, 
select the correct word, and click Change All. 

• To skip a word without changing it, click Skip. To skip every instance of the word in the 
file, click Skip All. This option removes the word from the Misspelled Words list, but the 
word reappears the next time the file is checked.

• To add the word to your dictionary, click Add to List. To add several words at once, hold 
down Ctrl (Windows) or Shift+Command (Mac OS) while clicking or dragging the 
mouse to select the words. 

5 To edit your current dictionary list, click Edit List and do one of the following: 

• To change a word in the dictionary list, select a word in the list, retype it in the text box, 
and click Change.

• To add a new word, type it in the text box, and click Add.

• To remove a word, select the word, and click Remove.

6 Click Done.

To change language dictionaries in the Spell Checking filter:

1 Choose Type > Check Spelling.

2 Click Language. Locate the language dictionary in the Text Filters folder in the Plug-ins 
folder inside the Adobe Illustrator application folder.

3 Select the language dictionary you want to use, and click Open.

Finding and replacing text
The Find command finds and replaces text strings on paths and within type containers 
while retaining the type style, color, kerning, and other type attributes of the text.

To find and replace text:

1 Choose Type > Find/Change.

2 Enter the text string you want to find and, if desired, the text string with which to 
replace it.
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3 Select one of the following options:

• Whole Word searches only for entire words that match the text in the Find What 
text box.

• Case Sensitive searches only for text strings that exactly match the uppercase and 
lowercase text in the Find What text box.

• Search Backward searches the file in reverse order from the insertion point to the 
beginning of the file.

• Wrap Around searches the entire file, starting from the text selection point to the end of 
the file and then from the beginning of the file to the text selection point.

4 Select one of the following options:

• Find Next searches for the next instance of the text string, without replacing it.

• Change/Find replaces the text string and then searches for the next instance of it.

• Change replaces just the currently found instance of the text string in the file.

• Change All replaces all occurrences of the text string in the file.

5 Click Done.

Changing capitalization
The Change Case command enables you to change text from the current case setting to 
all uppercase, all lowercase, or mixed case (that is, each word beginning with an 
uppercase letter).

Note: The Change Case command only works with 1-byte Roman text. CJK Roman (2-byte) 
text is not affected.

To change the capitalization of selected text:

1 Select a type tool, and select the text to be changed.

2 Choose Type > Change Case.

3 Select Uppercase, Lowercase, or Mixed Case, and click OK.

Using smart punctuation
The Smart Punctuation dialog box searches for keyboard text symbols and replaces them 
with publishing text symbols. It can also report the number of symbols replaced.

Note: Smart punctuation works with OpenType fonts only in Mac OS.

To replace standard keyboard characters with publishing characters:

1 Choose Type > Smart Punctuation. 

2 Select one or more of the following options:

• ff, fi, ffi Ligatures changes any occurrence of the ff, fi, or ffi letter combinations into 
ligatures (that is, a text symbol that combines two or more letters into a single, special 
character). To change to ligatures, you must have the appropriate Adobe Expert font 
installed on your system.

• ff, fl, ffl Ligatures changes any occurrence of the ff, fl, or ffl letter combinations into 
ligatures. To change to ligatures, you must have the appropriate Adobe Expert font 
installed on your system.
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• Smart Quotes  “ ” changes straight keyboard quotation marks " " and ' ' into printer’s 
quotation marks “ ” and ‘ ’.

• Smart Spaces . replaces multiple spaces after a period with a single space.

• En, Em Dashes -- replaces a double keyboard dash -- with an en dash –and to replace a 
triple keyboard dash --- with an em dash —.

• Ellipses . . . replaces three keyboard periods ... with ellipsis points . . .

• Expert Fractions replaces separate characters used to represent fractions with their 
single-character equivalents. To change to expert fractions, you must have the appro-
priate Adobe Expert font installed on your system.

3 Select one of the following options:

• Entire Document searches and replaces text symbols in the entire file.

• Selected Text Only replaces symbols only in selected text.

4 Select Report Results to see a list of the number of symbols replaced.

5 Click OK to search for and replace selected characters.

Using the Glyph Options command (Mac OS only) 
Some Japanese fonts contain information on alternative or historical variants for certain 
characters. You can specify an alternative glyph for an existing kanji using the Glyph 
Options command. When you use Type 1 CID fonts (Mac OS), you can substitute a 
standard character with a variant character belonging to the JIS 78, Expert, and Traditional 
character sets. 

To print files containing alternative characters, the corresponding CID font containing the 
glyphs must be installed on the printer. 

Note: Alternative glyphs revert to standard characters when an Illustrator file is imported 
to Adobe Photoshop, Adobe Premiere, or Adobe After Effects. To save alternative glyph 
information, save the Illustrator file in EPS format (be sure to select Include Document 
Fonts in the EPS Format dialog box), and then import it.

To specify an alternative glyph for the current character set:

1 Using any type tool, select the character to be replaced. 

2 Choose Type > Glyph Options.

3 Select the character set from the scrolling menu in the Glyph Options dialog box, and 
click OK.

Note: To select two characters, Option-click. You cannot apply the Glyph Options 
command to more than two characters at a time.
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Creating Templates for 
Data-Driven Graphics

About data-driven graphics
Data-driven graphics make it possible to produce multiple versions of artwork quickly and 
accurately. Let’s say, for example, that you need to produce 500 different Web banners 
based on the same template. In the past, you had to manually populate the template with 
data (images, text, and so on). With data-driven graphics, you can use a script referencing a 
database to generate the Web banners for you. 

In Illustrator, you can turn any piece of artwork into a template for data-driven graphics. 
All you need to do is define which objects on the artboard are dynamic (changeable) 
using variables. You use variables to change text strings, linked images, graph data, and 
the visibility setting of objects in your artwork. In addition, you can create different sets of 
variable data in order to easily view what your template will look like when it is rendered.

Templates provide a means of collaboration between designers, developers, and 
production staff: 

• If you’re a designer, creating a template gives you control over the dynamic elements of 
your design. When you hand your template over for production, you can be sure that 
only the variable data will change. 

• If you’re a developer, you can code variables and data sets directly into an XML file. The 
designer can then import the variables and data sets into an Illustrator file to create a 
design based on your specifications. 

• If you’re responsible for production, you can use scripts within Illustrator, the Batch 
command, or a Web production tool such as Adobe GoLive 6.0 to render the final 
graphics. You can also use a dynamic imaging server such as Adobe AlterCast™ to 
further automate the rendering process. (See “Using scripts” on page 374 and “Batch 
processing” on page 369.)
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Using the Variables palette
You use the Variables palette to work with variables and data sets. The type and name of 
each variable in the document are listed in the palette. If the variable is bound to an 
object, then the Objects column displays the name of the bound object as it appears in 
the Layers palette. (See “Identifying dynamic objects using XML IDs” on page 289.)

Variables palette 
A. Data set B. Palette menu C. Variable type D. Variable name E. Name of bound object 

Displaying the Variables palette Choose Window > Variables.

Selecting a variable Click a row in the Variables palette.

Using the Variables palette menu Click the triangle  in the top right corner of the 
palette to display the commands used with variables.

Displaying variable options Double-click a variable, or choose Variable Options from 
the Variables palette menu. (See “Editing variables” on page 288.)

Sorting rows in the Variables palette Click the Variables header to sort the rows by 
variable name. Click the Objects header to sort the rows by object name. Click the blank 
header above the Variable Type column to sort the rows by variable type.

Working with variables
In order to create a template for data-driven graphics, you need to define which objects on 
the artboard are dynamic (changeable). You use variables to define the attributes of 
dynamic objects.

About variables
You can create four types of variables in Illustrator: Graph Data, Linked File, Text String, and 
Visibility. A variable’s type indicates which object attributes are changeable. For example, 
you can use a Visibility variable to show or hide any object in your template. You can apply 
variables to the following types of objects: 

Text Use the Text String variable to make text dynamic. 

Linked image Use the Linked File variable to make a linked image dynamic.

Graph Use the Graph Data variable to make graph data dynamic.

B

A

C D E
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All objects Use the Visibility variable to make an object’s visibility dynamic. You can also 
make the visibility of groups and layers dynamic.

Two versions of a Web page based on the same template 
A. Graph Data variable B. Linked File variable C. Text String variable D. Visibility variable

Creating unbound variables
You can create a new variable without binding it to an object attribute. You can also let 
Illustrator create a variable when you make an object dynamic. (See “Binding variables to 
object attributes” on page 287.)

To create an unbound variable:

Click the New Variable button  in the Variables palette, or choose New Variable from the 
Variables palette menu. An unbound variable with no type  appears in the Variables 
palette.

Binding variables to object attributes
Binding a variable to an object attribute makes the object dynamic. The type of object and 
type of variable determines what attributes of the object can change. You can bind a 
Visibility variable to any object to make the object’s state of visibility dynamic. If the object 
is text, a linked image, or a graph, you can also make the object’s content dynamic. 
(See “About variables” on page 286.)

To make the visibility of objects dynamic:

1 Select one or more objects. Use the Layers palette to select all the objects in a layer or 
group. (See “Selecting artwork in layers” on page 221.)

2 Do one of the following:

• If you want to create a new variable, make sure that no variable is selected in the 
Variables palette.

• If you want to bind the object to an existing variable, select that Visibility variable in the 
Variables palette. 
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3 Click the Make Visibility Dynamic button  in the Variables palette, or choose Make 
Visibility Dynamic from the Variables palette menu. 

The Visibility variable  appears in the Variables palette.

To make an object’s content dynamic:

1 Select a linked image, text, or a graph. 

2 Do one of the following:

• If you want to create a new variable that matches the type of the selected object, make 
sure that no variable is selected in the Variables palette.

• If you want to bind the object to an existing variable, select that variable in the Variables 
palette. The variable type must either be unbound, or match that of the selected object. 

3 Click the Make Object Dynamic button  in the Variables palette, or choose Make 
Object Dynamic from the Variables palette menu. 

The Text String variable , the Linked File variable , or the Graph Data variable  appears 
in the Variables palette.

To unbind a variable:

1 Select a variable in the Variables palette.

2 Click the Unbind Variable button  in the Variables palette, or choose Unbind Variable 
from the Variables palette menu. 

Editing variables
You change the name and type of a variable by editing its options. You can also lock all 
variables in a document. Locking variables prevents you from creating variables, deleting 
variables, and editing variable options. However, you can bind and unbind objects to 
locked variables.

You change the name of an object in the Variables palette by editing the object’s 
name in the Layers palette. (See “Setting layer options” on page 216.)

To edit variable options:

1 Do one of the following:

• Double-click the variable in the Variables palette.

• Select the variable in the Variables palette, and choose Variable Options from the 
Variables palette menu.

2 Edit the variable name and type, and click OK.

To lock and unlock variables:

Click the Lock Variables button  or Unlock Variables button  in the Variables palette. 

Deleting variables
Deleting a variable removes it from the Variables palette. If you delete a variable that is 
bound to an object, the object becomes static (unless the object is bound to a variable of a 
different type). 

To delete a variable:

1 Select a variable you want to delete.
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2 Do one of the following:

• Click the Trash button  in the Variables palette, or choose Delete Variable from the 
Variables palette menu. 

• To delete the variable without confirmation, drag it to the Trash button.

Editing dynamic objects
You change the data associated with a variable by editing the object to which it is bound. 
For example, if you’re working with a Visibility variable, you change the object’s state of 
visibility in the Layers palette. Editing dynamic objects lets you create multiple data sets 
for use in the template. (See “Using data sets” on page 290.)

To edit a dynamic object:

1 Select a dynamic object on the artboard. Do one of the following to automatically 
select a dynamic object:

• Alt-click (Windows) or Option-click (Mac OS) a variable in the Variables palette.

• Select a variable in the Variables palette, and choose Select Bound Object from the 
Variables palette menu.

2 Edit the data associated with the object as follows:

• For text, edit the text string on the artboard. (See “Editing text” on page 281.)

• For linked files, replace the image using the Links palette or the File > Place command. 
(See “Replacing linked images” on page 39 and “Placing files” on page 35.)

• For graphs, edit the data in the Graph Data palette. (See “Entering and editing graph 
data” on page 376.)

• For all objects with dynamic visibility, change the state of visibility for the object in the 
Layers palette. (See “Hiding or displaying artwork” on page 224.)

To select all dynamic objects:

Choose Select All Bound Objects from the Variables palette menu.

Identifying dynamic objects using XML IDs
The Variables palette displays the names of dynamic objects as they appear in the Layers 
palette. If you save the template in SVG format for use with other Adobe products, these 
object names must conform to XML naming conventions. For example, XML names must 
begin with a letter, underscore, or colon, and cannot contain spaces.

Illustrator automatically assigns a valid XML ID to every dynamic object you create. The 
Names preference lets you view, edit, and export object names using XML IDs.

To identify dynamic objects using XML IDs:

1 Choose Edit > Preferences > Units & Undo (Windows and Mac OS 9) or Illustrator > 
Preferences > Units & Undo (Mac OS X).

2 Select the XML ID option.
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Using data sets
A data set is a collection of variables and associated data. When you create a data set, 
you capture a snapshot of the dynamic data that is currently displayed on the artboard. 
You can switch between data sets to upload different data into your template.

The name of the current data set is displayed at the top of the Variables palette. If you 
change the value of a variable so that the artboard no longer reflects the data stored in the 
set, the name of the data set is displayed in italic type. You can then create a new data set, 
or you can update the data set to overwrite the saved data with the new data. 

To create a new data set:

1 Create one or more dynamic objects on the artboard. (See “Binding variables to object 
attributes” on page 287.) 

Note: You must create at least one bound variable before you can create a data set.

2 Do one of the following:

• Click the Capture Data Set button  in the Variables palette to create a data set and 
assign the default name to it. 

• Choose Capture Data Set from the Variables palette menu, enter a name for the data 
set, and click OK.

To select a data set:

Do one of the following in the Variables palette:

• Choose a data set from the Data Set pop-up menu.

• Click the Previous Data Set button  or choose Previous Data Set from the Variables 
palette menu, to select the previous set in the list.

• Click the Next Data Set button  or choose Next Data Set from the Variables palette 
menu, to select the next set in the list. 

Note: The Previous Data Set button and the Next Data Set button are disabled when the 
document has only one data set (or no data sets).

To update a data set:

Choose Update Data Set from the Variables palette menu to apply the data on the 
artboard to the current data set.

To rename a data set:

Select the data set you want to rename, and do one of the following:

• Double-click the words Data Set: (to the left of the Data Set text box), enter a new name, 
and click OK.

• Choose Rename Data Set from the Variables palette menu, enter a new name, and 
click OK.

• Edit the text directly in the Data Set text box.

To delete a data set:

1 Select the data set you want to delete.

2 Choose Delete Data Set from the Variables palette menu.
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Loading and saving variable libraries
In a collaborative environment, coordination between team members is essential to the 
success of a project. Take, for example, a company that creates Web sites. The Web 
designer is responsible for the look and feel of the Web site, while the Web developer is 
responsible for the underlying code and scripting. If the designer changes the layout of 
the Web page, those changes must be communicated to the developer. Likewise, if the 
developer needs to add functionality to the Web page, the design may need to be 
updated. 

Variable libraries enable designers and developers to coordinate their work through an 
XML file. For example, a designer can create a template for business cards in Illustrator and 
export variable data as an XML file. The developer can then use the XML file to link 
variables and data sets to a database and write a script to render the final artwork. This 
workflow can also be reversed, where the developer codes the variable and data set 
names in an XML file, and the designer imports the variable libraries into an Illustrator 
document.

To import variables into Illustrator from an XML file:

1 Choose Load Variable Library from the Variables palette menu.

2 Select the XML file from which you want to import variables, and click Open. 

The loaded variables and data sets appear in the Variables palette.

To export variables from Illustrator to an XML file:

1 Choose Save Variable Library from the Variables palette menu.

2 Select the folder where you want to save the file, and enter a name for the file, and 
click Save.

Saving templates
When you define dynamic data in an Illustrator document, you are creating a template for 
data-driven graphics. You can save the template in SVG format for use with other Adobe 
products, such as Adobe Altercast (available only in English) and Adobe GoLive 6.0. 
For example, a GoLive user can place an SVG template in a page layout, bind its variables 
to a database using dynamic links, and then use AlterCast to generate iterations of the 
artwork. Likewise, a developer working with AlterCast can bind the variables in the SVG 
file directly to a database or another data source.

To save a template for use with other Adobe products:

1 Save the artwork in SVG format. (See “Saving artwork in an SVG format” on page 324.)

2 Click Advanced, and select Include Extended Syntax for Variable Data. This option 
includes all information needed for variable substitution in the SVG file.

3 Click OK.
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Preparing Graphics for the Web

About Web graphics
When designing graphics for the Web, you must consider different issues than when 
designing graphics for print. Here are some things to keep in mind: 

Color Color is often a key aspect of artwork. However, the colors you see on your artboard 
aren’t necessarily the colors that will appear in a Web browser. You can prevent dithering 
and other color problems by taking a few precautionary steps when creating Web 
graphics. First, always work in RGB color mode. Second, try to use Web-safe colors. 
(See “Using the Color palette” on page 158 and “Loading colors from other color systems” 
on page 166.) 

File size Creating small graphics files is essential to distributing images on the Web. With 
smaller files, Web servers can store and transmit images more efficiently, and viewers can 
download images more quickly. You can view the size and the estimated download time 
for a Web graphic in the Save for Web dialog box. (See “Using the Save for Web dialog box” 
on page 305.)

File format The format in which you save a Web graphic determines the size and display 
characteristics of the file. In general, Web graphics formats fall into two categories: bitmap 
and vector. The bitmap formats—GIF, JPEG, and PNG—describe artwork as a series of 
colored dots called pixels. Each pixel in a bitmap image has a fixed size and is therefore 
resolution-dependent, meaning that dimensions of the image depend of the resolution of 
the monitor on which it is viewed. The vector formats—SVG and SWF—describe artwork 
mathematically, as a set of geometric objects. Because of this, vector graphics are 
resolution-independent and can be scaled up or down in a Web browser. 

Each Web file format has its own characteristics and uses. JPEG preserves the broad range 
and subtle variations in brightness and hue found in photographs and other continuous-
tone images. GIF and PNG-8 efficiently compress solid areas of color while preserving 
sharp detail, such as that in line art, logos, or illustrations with type. SVG and SWF maintain 
high-quality, vector artwork and produce smaller file sizes than bitmap formats. Both of 
these formats are ideal for creating animation frames and sophisticated Web effects. 

Working in pixel preview mode
When you save artwork in a bitmap format—such as JPEG, GIF, or PNG—Illustrator 
rasterizes the artwork at 72 pixels per inch. You can preview how objects will appear when 
rasterized using pixel preview mode. This is especially helpful when you want to control 
the precise placement, size, and anti-aliasing of objects in a rasterized graphic. 
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To understand how Illustrator divides objects into pixels, open a file that contains vector 
objects, choose View > Pixel Preview, and magnify the artwork so that you can see its 
individual pixels. The placement of pixels is determined by an invisible grid that divides 
the artboard into 1 point (1/72 inch) increments. If you move, add, or transform an object, 
you’ll notice that the object snaps to the pixel grid. As a result, any anti-aliasing along the 
“snapped” edges of the object (usually the left and top edges) disappears. Now deselect 
the View > Snap to Pixel command, and move the object. This time, you’ll be able to 
position the object between the pixel grid. Notice how this affects the anti-aliasing of the 
object. As you can see, making very minor adjustments can affect how the object is 
rasterized.

Vector preview and Pixel Preview

Important: The pixel grid is sensitive to the origin (0,0) of the ruler. Moving the origin of 
the ruler will change how Illustrator rasterizes artwork.

To view artwork in pixel preview mode:

Choose View > Pixel Preview.

To disable or enable snapping in pixel preview mode:

Choose View > Snap to Pixel.

Note: By default, the Snap to Pixel command is enabled when you enter pixel preview 
mode. You must deselect the Snap to Pixel command if you want to position objects 
between the pixel grid. 

Dividing artwork into slices
Web pages can contain many elements—HTML text, bitmap images, and vector graphics, 
to name a few. In Illustrator, you use slices to define the different Web elements in your 
artwork. For example, if your artwork contains a bitmap image that needs to be optimized 
in JPEG format, while the rest of the image is better optimized in GIF format, you can 
isolate the bitmap image using a slice. When you save the artwork as a Web page, you can 
choose to save each slice as an independent file with its own format, settings, and color 
palette. 

Creating slices
There are several ways to create slices in Illustrator:

• Use the Object > Slice > Make command when you want the slice dimensions to match 
the boundary of an element in your artwork. If you move or modify the element, the 
slice area automatically adjusts to encompass the new artwork. Also use this command 
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to create a slice that captures text and basic formatting characteristics from a text 
object. (See “Choosing a slice type and setting slice options” on page 294.)

• Use the slice tool, the Object > Slice > Create from Selection command, or the Object > 
Slice > Create from Guides command when you want the slice dimensions to be 
independent of the underlying artwork. Slices that you create in one of these ways 
appear as items in the Layers palette, and you can move, resize, and delete them in the 
same way as other vector objects.

When you create a slice, Illustrator generates automatic slices to create a valid HTML table 
if you save artwork as a Web page. There are two types of automatic slices: auto slices and 
subslices. Auto slices account for the areas of your artwork that are not already defined by 
slices. Illustrator regenerates auto slices every time you add or edit slices. Subslices indicate 
how overlapping slices will be divided. Although subslices are numbered and display a 
slice symbol, you cannot select them separately from the underlying slice. Illustrator 
regenerates subslices every time you arrange the stacking order of slices. 

To create a slice:

Do one of the following:

• Select one or more objects on the artboard, and choose Object > Slice > Make. 

• Select the slice tool  and drag over the area where you want to create a slice. Shift-
drag to constrain the slice to a square. Alt-drag (Windows) or Option-drag (Mac OS) to 
draw from the center. 

• Select one or more objects on the artboard, and choose Object > Slice > Create from 
Selection.

• Place guides where you want to slice the artwork, and choose Object > Slice > Create 
from Guides. (See “Using guides” on page 94.)

Choosing a slice type and setting slice options
A slice’s type and options determine how the content of the slice will look and function on 
the Web. 

To choose a slice type:

1 Select a slice. (See “Selecting and modifying slices” on page 296.)

2 Choose Object > Slice > Slice Options. For information on setting slice options in the 
Save for Web dialog box, see “Working with slices during optimization” on page 306.

3 Choose a content type from the Slice Type pop-up menu.

• Image if you want the artwork defined by the slice to become a linked image file on the 
resulting Web page. 

• No Image if you want the slice area to contain text or a solid color on the resulting Web 
page. You enter text and HTML formatting tags for No Image content slices in the Slice 
Options dialog box. You cannot view No Image content in Illustrator; you must use a 
Web browser to preview it.
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• HTML Text if you want to capture text and basic formatting characteristics from the text 
object in Illustrator. To edit the text for HTML Text content slices, you must update the 
text in your artwork. 

Important: To create a slice with HTML Text content, select a text object, and then choose 
the Object > Slice > Make command. The HTML Text content type is not available if a slice 
was created using another method. (See “Creating slices” on page 293.)

To set options for Image content slices:

In the Slice Options dialog box, do the following, and click OK:

• Specify the slice name in the Name text box. By default, the slice name is used as the file 
name when you save the Web page. (See “Setting file saving options” on page 318.)

• Specify a URL to make the slice area a hotspot in the resulting Web page. You can enter 
a relative URL, enter a full URL (including http://), or choose a previously created URL 
from the pop-up menu.

• If you specified a URL, specify the frame you want the link to target in the Target text 
box. You can enter the name of a target frame, or choose a standard option from the 
pop-up menu.

• Specify text in the Message text box that will appear in the browser’s status area when 
the mouse is positioned over an image.

• Specify text in the Alt text box that will appear in place of image data in nongraphical 
browser (and will be used by voice-recognition software).

• Choose a color that will appear in the slice area of the resulting Web page from the 
Background pop-up menu. Keep in mind that the selected color will not be displayed in 
Illustrator.

To set options for No Image content slices

In the Slice Options dialog box, do the following, and click OK:

• Specify text that will appear in the slice area of the resulting Web page in the Text 
Displayed in Cell text box. You can format the text using standard HTML tags. 

Be careful not to enter more text than can be displayed in the slice area. If you enter 
too much text, it will extend into neighboring slices and affect the layout of your Web 

page. However, because you cannot view the text on the artboard, this will not be 
apparent until you view the Web page in a Web browser.

• Choose options from the Horiz and Vert pop-up menus to specify the horizontal and 
vertical alignment of the text.

• Choose a color that will appear in the slice area of the resulting Web page from the 
Background pop-up menu. Keep in mind that the selected color will not be displayed in 
Illustrator.

To set options for HTML Text content slices:

In the Slice Options dialog box, do the following, and click OK:

• Choose options from the Horiz and Vert pop-up menus to specify the horizontal and 
vertical alignment of the text.
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• Choose a color that will appear in the slice area of the resulting Web page from the 
Background pop-up menu. Keep in mind that the selected color will not be displayed in 
Illustrator.

The text for HTML Text slices is displayed in the Slice Options dialog box; however, 
you cannot edit it. You can make HTML text editable in the Slice Options dialog box by 

changing the slice type to No Image. This breaks the link with the text object on the 
artboard. To ignore text formatting, enter <unformatted> as the first word in the text 
object.

Viewing slices
You can view slices on the artboard and in the Save for Web dialog box. For information on 
viewing slices in the Save for Web dialog box, see “Working with slices during optimi-
zation” on page 306.

Illustrator numbers slices from left to right and top to bottom, beginning in the upper left 
corner of the artwork. If you change the arrangement or total number of slices, slice 
numbers are updated to reflect the new order. 

Artwork with slices

To show or hide slices:

Choose View > Show Slices or View > Hide Slices.

To set slice preferences:

1 Choose Edit > Preferences > Smart Guides and Slices (Windows and Mac OS 9) or 
Illustrator > Preferences > Smart Guides and Slices (Mac OS X).

2 Select Show Slice Numbers to show slice numbers; deselect Show Slice Numbers to 
hide slice numbers.

3 Select a Line Color option to change the color of slice lines. The color of selected slice 
lines is changed automatically to a contrasting color.

4 Click OK.

Selecting and modifying slices
The method you use to select a slice, as well as the ways you can modify a slice, depend on 
how the slice was created. There are fewer options for modifying slices that were created 
using the Object > Slice > Make command, because these slices are tied to the size and 
position of elements in your artwork. 
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To select a slice:

Do one of the following:

• Select the slice select tool  and click on a slice. Shift-click to select additional slices. 
When working with overlapping slices, click the visible section of an underlying slice to 
select it. 

• To select a slice that was created using the slice tool, the Object > Slice > Create from 
Selection command, or the Object > Slice > Create from Guides command, select the 
corresponding <Slice> item in the Layers palette.

• To select a slice that was created using the Object > Slice > Make command, select the 
corresponding artwork on the artboard. Use the Layers palette to select the artwork if 
the slice is tied to a group or layer. (See “Selecting artwork in layers” on page 221.)

For information on selecting slices in the Save for Web dialog box, see “Working with slices 
during optimization” on page 306.

To move or resize a slice:

1 Select a slice.

2 Do one of the following:

• To move a slice, select the slice select tool, move the pointer inside the slice selection 
border, and drag the slice to a new position. Press Shift to restrict movement to a 
vertical, horizontal, or 45° diagonal line. If the slice was created using the Object > Slice 
> Make command, the corresponding artwork also moves.

• To resize a slice, select the selection tool, and drag a side or a corner handle of the slice. 
You cannot resize a slice that was created using the Object > Slice > Make command.

• To resize or move a slice using numeric coordinates, choose Window > Transform, 
and enter the desired coordinates. (See “Using the Transform palette” on page 121.)

To divide a slice:

1 Select a slice that was created using the slice tool, the Object > Slice > Create from 
Selection command, or the Object > Slice > Create from Guides command. You cannot 
divide a slice that was created using the Object > Slice > Make command.

2 Choose Object > Slice > Divide Slices.

3 In the Divide Slice dialog box, select from the following options:

• Divide Horizontally Into to divide the slice or slices lengthwise.

• Divide Vertically Into to divide the slice or slices width-wise.

4 Define how you want to divide each selected slice, and click OK:

• Enter a value for slices down or slices across to divide each slice evenly into the 
specified number of slices.

• Enter a value for pixels per slice to divide each slice based on the specified number of 
pixels. Any section of a slice that is left over is made into another slice. 
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To duplicate a slice:

Select a slice, and do one of the following:

• Choose Object > Slice > Duplicate Slice. 

• Choose Edit > Copy. To paste the slice into another file, open the destination file, and 
then choose Edit > Paste.

To combine slices:

1 Select the slices you want to combine. You cannot combine slices that were created 
using the Object > Slice > Make command.

2 Choose Object > Slice > Combine Slices.

The resulting slice takes its dimensions and position from the rectangle created by joining 
the outer edges of the combined slices. If the combined slices are not adjacent or are of 
different proportions or alignments, the new slice may overlap other slices.

To change the stacking order of slices:

1 Select a slice.

2 Do one of the following:

• If the slice was created using the slice tool, the Object > Slice > Create from Selection 
command, or the Object > Slice > Create from Guides command, drag the slice to a new 
position in the Layers palette. (See “Changing the stacking order of artwork using the 
Layers palette” on page 222.)

• Choose Object > Arrange, and then choose an option to move the slice forward or 
backward in the stacking order. (See “Moving objects frontward or backward in a stack 
of objects” on page 109.)

To align or distribute slices:

1 Select the slices you want to align or distribute.

2 Choose Window > Align, and click the type of alignment or distribution you want to 
apply to the slices. (See “Aligning and distributing objects vertically and horizontally” on 
page 106.) If the slices were created using the Object > Slice > Make command, the corre-
sponding artwork also moves.

Aligning slices can eliminate unneeded auto slices to generate a smaller, more efficient 
HTML file. 

To lock slices:

Choose View > Lock Slices. 

Locking slices prevents you from making changes accidentally, such as resizing or moving. 
The Lock Slices command does not affect slices that were created using the Object > 
Slice > Make command.

Use the Layers palette to lock individual slices that were created using the slice tool, 
the Object > Slice > Create from Selection command, or the Object > Slice > Create 

from Guides command. (See “Locking artwork” on page 225.)
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Removing slices
You can remove slices by deleting them or by releasing them from the corresponding 
artwork.

To delete a slice:

Do one of the following:

• Select the slice, and press Delete. If the slice was created using the Object > Slice > 
Make command, the corresponding artwork is deleted at the same time. If you want to 
keep the corresponding artwork, release the slice instead of deleting it.

• If the slice was created using the slice tool, the Object > Slice > Create from Selection 
command, or the Object > Slice > Create from Guides command, delete the corre-
sponding slice item in the Layers palette.

To delete all slices:

Choose Object > Slice > Delete All.

To release a slice:

1 Select a slice.

2 Choose Object > Slice > Release.

Creating image maps
Image maps enable you to link one or more areas of an image—called hotspots—to a URL. 
When a user clicks on the hotspot, the Web browser loads the linked file.

The main difference between using image maps and using slices to create links is in how 
the artwork is exported as a Web page. Using image maps keeps the artwork intact as a 
single file, while using slices causes the artwork to be exported in separate files. Another 
difference between image maps and slices is that image maps enable you to link 
polygonal or rectangular areas in your artwork, while slices enable you to link only rectan-
gular areas. If you need to link only rectangular areas, using slices may be preferable to 
using an image map. 

Note: To avoid unexpected results, do not create image map hotspots in slices that 
contain URL links—either the image map links or the slice links may be ignored in some 
browsers.

Rectangle image map compared to polygonal image map
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To create an image map: 

1 Select the object that you want to link to a URL. 

2 Choose Window > Attributes.

3 Choose a shape for the image map:

• None to not designate an image map.

• Rectangle to create a rectangular hotspot around the object. The hotspot boundaries 
are similar to those of the selected object’s bounding box.

• Polygon to create a hotspot that closely follows the outline of the selected object.

4 Enter a relative or full URL in the URL text box, or choose from the list of available URLs. 
If you enter a full URL, be sure to include http:// (for example, enter http://
www.adobe.com, not www.adobe.com). You can verify the URL location by clicking the 
Browser button. 

To increase the number of visible entries in the URL menu:

1 Choose Window > Attributes. 

2 Choose Palette Options from the Attributes palette menu. 

3 Enter a value from 1 to 30 to define how many URL entries you want to be displayed in 
the URL list. 

4 Click OK. 

Creating Web graphics with SVG
You can use the SVG, Scalable Vector Graphics, features in Illustrator to create high-quality, 
interactive Web graphics.

About SVG
Traditional image formats—GIF, JPEG, and PNG—are bitmap formats that describe 
images, using a grid of pixels. The resulting files tend to be bulky, limited to a single (often 
low) resolution, and consume large amounts of bandwidth on the Web. SVG, or Scalable 
Vector Graphics, on the other hand, is a vector format that describes images as shapes, 
paths, text, and filter effects. The resulting files are compact and provide high-quality 
graphics on the Web, in print, and even on resource-constrained, handheld devices. Users 
can magnify their view of an SVG image on-screen without sacrificing sharpness, detail, or 
clarity. In addition, SVG provides superior support for text and colors, which ensures that 
users will see images as they appear on your Illustrator artboard. 

The SVG format is entirely XML-based and offers many advantages to developers and 
users alike. With SVG, you can use XML and JavaScript to create Web graphics that respond 
to user actions with sophisticated effects such as highlighting, tool tips, audio, and 
animation.
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Working with SVG in Illustrator
You can save artwork in SVG format using the Save command and the Save for Web 
command. (See “Saving artwork in an SVG format” on page 324 and “Optimizing images” 
on page 305.) How you set up your artwork in Illustrator will impact the resulting SVG file. 
Keep in mind the following guidelines:

Layers Use layers to add structure to an SVG file. When you save artwork in SVG format, 
each layer is converted to a group (<g>) element. (For example, a layer named Button1 
becomes <g id="Button1> in the SVG file.) Nested layers become SVG nested groups, and 
hidden layers are preserved with the SVG styling property “display:none”. 

Transparency If you want objects on different layers to appear transparent, adjust the 
opacity of each object instead of each layer. If you alter opacity at the layer level, the 
resulting SVG file will not display transparency as it appears in Illustrator. 

Raster effects and mesh objects Raster data is not scalable in the SVG Viewer and 
cannot be edited like other SVG elements. If possible, avoid creating artwork that will be 
rasterized in the SVG file. Gradient meshes and objects that use the Rasterize, Artistic, Blur, 
Brush Strokes, Distort, Pixelate, Sharpen, Sketch, Stylize, Texture, and Video effects are 
rasterized when saved in SVG format. Similarly, styles that include these effects—such as 
Blazing Sun, Cement, and Flames—produce rasterization.

Use SVG filter effects to add graphic effects without causing rasterization. 
(See “Adding SVG filter effects to artwork” on page 301.)

Paths Use symbols and simplify the paths in your artwork to improve SVG performance. 
(See “Simplifying paths” on page 61 and “Working with symbols” on page 71.) Also avoid 
using brushes that produce a lot of path data, such as the Charcoal, Fire Ash, and Scroll 
Pen, if performance is a high priority.

Links Use slices, image maps, and scripts to add links to an SVG file. (See “Choosing a slice 
type and setting slice options” on page 294, “Creating image maps” on page 299, and 
“Adding SVG interactivity to artwork” on page 302.)

Scripts A scripting language, such as JavaScript, opens unlimited functionality to an SVG 
file. Pointer and keyboard movements can invoke scripting functions such as rollover 
effects. Scripts can also use the Document Object Model (DOM) to access and modify the 
SVG file—inserting or deleting SVG elements, for example. (See “Adding SVG interactivity 
to artwork” on page 302.)

For more information on using Illustrator to create SVG files, go to the SVG zone on 
www.adobe.com.

Adding SVG filter effects to artwork
You can use SVG filters to add graphic effects such as drop shadows to your artwork. SVG 
filters differ from their bitmap counterparts in that they are XML-based. In fact, an SVG 
filter is nothing more than a series of XML properties that describe various mathematical 
operations. The resulting effect is rendered to the target object instead of the source 
graphic.

Illustrator provides a set of standard SVG filters. You can use the filter with its default 
properties, edit the XML code to produce custom effects, or write new SVG filters.

Important: An SVG filter effect must be the last effect when an object has multiple effects; 
in other words, it must appear at the bottom of the Appearance palette (just above the 

http://www.adobe.com
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Transparency entry). If other effects follow an SVG filter effect, the SVG output will consist 
of a raster object.

To apply an SVG filter effect:

1 Select one or more objects on the artboard, or target an item in the Layers palette. 
(See “Changing the appearance of artwork using the Layers palette” on page 223.)

2 Choose Effect > SVG Filters> Apply SVG Filter, and do one of the following:

• To apply a filter with its default settings, select a filter in the list, and click OK.

• To apply a filter with custom settings, select a filter, and click the Edit SVG Filter 
button . Edit the default code, and click OK.

• To create and apply a new filter, click the New SVG Filter button . Enter the new code, 
and click OK.

Note: When you apply an SVG filter effect, Illustrator displays a rasterized version of the 
effect on the artboard. You can control the resolution of this preview image by modifying 
the document’s rasterization resolution setting. (See “Specifying raster effects settings” on 
page 239.)

To import SVG filter definitions into a document:

1 Choose Effect > SVG Filter > Import SVG Filter.

2 Select the SVG file you want to import filters from, and click Open.

To delete an SVG filter definition from a document:

Select a filter in the Apply SVG Filters dialog box, and click the Trash button.

To modify Illustrator’s default SVG filters:

Use a text editor to edit the Adobe SVG Filters.svg file in the Plug-ins folder inside the 
Adobe Illustrator application folder. You can modify existing filter definitions, delete filter 
definitions, and add new filter definitions.

Adding SVG interactivity to artwork
You use the SVG Interactivity palette to add interactivity to your artwork when it is 
exported for viewing in a Web browser. For example, by creating an event that triggers a 
JavaScript command, you can quickly create movement on a Web page when the user 
performs an action such as moving a mouse cursor over an object. 

The SVG Interactivity palette also lets you see all the events and JavaScript files associated 
with the current file. 
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To add SVG interactivity features to your artwork, select an object using a selection tool, 
and then add the event and corresponding JavaScript to that object in the SVG Interac-
tivity palette. For example, you could select an object in your artwork and specify that the 
object will move on a Web page when a user clicks on the object in a Web browser.

Object with normal appearance and with glow activated by mouse rollover

To add a JavaScript event to an object:

1 Select an object on the artboard, or target an item in the Layers palette. (See “Changing 
the appearance of artwork using the Layers palette” on page 223.)

2 Choose Window > SVG Interactivity. 

3 In the SVG Interactivity palette, choose an event in the Event pop-up menu:

• onfocusin to trigger the action when the element receives focus, such as selection by 
the pointer.

• onfocusout to trigger the action when the element loses focus, often when another 
element receives focus.

• onactivate to trigger the action with a mouse click or keypress, depending upon the 
SVG element.

• onmousedown to trigger the action when the mouse button is pressed down over an 
element.

• onmouseup to trigger the action when the mouse button is released over an element.

• onclick to trigger the action when the mouse is clicked over an element.

• onmouseover to trigger the action when the pointer is moved onto an element. 

• onmousemove to trigger the action while the pointer is over an element.

• onmouseout to trigger the action when the pointer is moved away from an element.

• onkeydown to trigger the action when a key is pressed down.

• onkeypress to trigger the action while a key is pressed down.

• onkeyup to trigger the action when a key is released.

• onload to trigger the action after the SVG document has been completely read and 
parsed. Use this event to call one-time only initialization functions.

• onerror to trigger the action when an element does not load properly or other error 
occurs.

• onabort to trigger the action when the page loading is stopped before the element is 
completely loaded.
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• onunload to trigger the action when the SVG document is removed from a window or 
frame.

• onzoom to trigger the action when the zoom level is changed for the document.

• onresize to trigger the action when the document view is resized.

• onscroll to trigger the action when the document view is scrolled or panned.

4 In the JavaScript text box, write a JavaScript command that will be triggered by the 
event you selected in step 3.

5 Press Enter to add the entry to the event list. 

To delete a JavaScript event from the SVG Interactivity palette:

1 In the SVG Interactivity palette, click on a JavaScript event to highlight it.

2 Click the Remove Selected Entry button , or choose Delete Event from the SVG Interac-
tivity palette menu.

To list, add, or remove JavaScript events linked to the file:

1 In the SVG Interactivity palette, click the Link JavaScript Files button , or choose 
JavaScript Files from the SVG Interactivity palette menu. 

2 In the JavaScript Files dialog box, select a JavaScript entry. Click Add to browse for 
additional JavaScript files; click Remove to remove the selected JavaScript entry.

Creating Web graphics with SWF
The Macromedia® Flash™ (SWF) file format is a vector-based graphics file format for the 
creation of scalable, compact graphics for the Web. Since the file format is vector-based, 
the artwork maintains its image quality at different resolutions and is ideal for the creation 
of animation frames. In Illustrator, you can create individual animation frames on layers 
and then export the image layers into individual frames for use on a Web site. You can also 
define graphic elements called symbols in your Illustrator file. When exported, each 
symbol is defined only once in the SWF file; therefore, using symbols can greatly reduce 
the size of a animation. (See “Working with symbols” on page 71.)

You can save artwork in SWF format using the Export command and the Save for Web 
command. (See “Exporting artwork in SWF format” on page 327 and “Optimizing images” 
on page 305.) Keep the following in mind when preparing artwork to be saved in SWF 
format:

• To create an animated SWF, place each animation frame on a separate Illustrator layer, 
and choose the AI Layers to SWF Frames option when you export the artwork.

• Transparency effects such as blending modes and opacity masks are not exported into 
the SWF format. If you wish to maintain the appearance of a transparency effect, flatten 
the transparency of the art before exporting to SWF format. (See “Changing the display 
of transparent artwork” on page 193.)

• Using the symbol stainer tool and symbol styler tool results in larger SWF files. 

• Mesh objects and gradients with more than eight stops are rasterized and will appear 
as bitmap-filled shapes. Gradients with fewer than eight stops are exported as 
gradients.
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• Patterns are rasterized into small images the size of the pattern art and tiled to fill 
the art.

• Only rounded caps or joins are supported in SWF format. Beveled or square caps and 
joins are converted to rounded when exported to SWF format.

• Pattern-filled text and pattern-filled strokes are converted to paths and filled with the 
pattern. 

• Although text retains many of its features when exported to SWF format, some infor-
mation is lost. When importing the SWF file into Macromedia Flash, leading, kerning, 
and tracking are not maintained. Instead, the text is broken up into separate records to 
simulate the look of leading. When the SWF file is subsequently played in a Macromedia 
Flash player, the appearance of the leading, kerning, and tracking in the file is 
maintained. If you wish to export text as paths, convert the text to outlines before 
exporting to SWF format, using the Create Outlines command.

Optimizing images
You use the optimization features in Illustrator to preview and save artwork in different 
Web graphics file formats. 

Using the Save for Web dialog box
You use the Save for Web dialog box to select optimization options and preview optimized 
artwork. 

Save for Web dialog box 
A. Toolbox B. Preview pop-up menu C. Optimize pop-up menu D. Zoom text box E. Original 
image F. Optimized image

Displaying the Save for Web dialog box Choose File > Save for Web.
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Previewing images Click a tab at the top of the image area to select a display option: 
Original to view the image with no optimization, Optimized to view the image with the 
current optimization settings applied, 2-Up to view two versions of the image side by side, 
or 4-Up to view four versions of the image side-by-side. 

If the entire artwork is not visible in the Save for Web dialog box, you can use the hand tool 
to bring another area into view. Select the hand tool  (or hold down the spacebar), and 
drag in the view area to pan over the image. You can also use the zoom tool to magnify or 
reduce the view. Select the zoom tool , and click in a view to zoom in; hold down Alt 
(Windows) or Option (Mac OS), and click in a view to zoom out. Alternatively, you can 
specify a magnification level in the Zoom text box at the bottom of the Save for Web 
dialog box.

Selecting a view Click a different pane in the Save for Web dialog box to select a new 
view. If you’re working in 2-Up or 4-Up view, you must select a view before you apply 
optimization settings. A black frame indicates which view is selected.

Viewing annotations The annotation area below each image Save for Web dialog box 
provides valuable optimization information. The annotation for the original image shows 
the file name and file size. The annotation for the optimized image shows the current 
optimization options, the size of the optimized file, and the estimated download time 
using the selected modem speed. You can choose a modem speed in the Preview 
pop-up menu. 

Working with slices during optimization
If your artwork contains multiple slices, you must specify the slices to be optimized. You 
can apply optimization settings to additional slices by linking the slices. Linked slices in 
GIF and PNG-8 format share a color palette and dither pattern to prevent the appearance 
of seams between the slices.

To show or hide slices in the Save for Web dialog box:

Click the Toggle Slices Visibility button .

To select slices in the Save for Web dialog box:

1 Select the slice select tool .

2 Click a slice to select it. Shift-click or Shift-drag to select multiple slices. 

Note: In the Save for Web dialog box, unselected slices are dimmed. This does not affect 
the color of the final image.

To view slice options in the Save for Web dialog box:

Select the slice select tool, and double-click a slice. (See “Choosing a slice type and setting 
slice options” on page 294.) 

To set options for multiple slices, double-click the last slice you select.

To link slices:

1 Select two or more slices that you want to link. 

2 Choose Link Slices from the Optimize pop-up menu . 
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The link icon  appears on the linked slices, and the slice lines and icons are assigned a new 
color to help you identify the slices in the set. 

To unlink slices:

Do one of the following:

• To unlink a slice, select the slice, and then choose Unlink Slice from the Optimize 
pop-up menu.

• To unlink all slices in an image, choose Unlink All Slices from the Optimize pop-up 
menu.

Applying optimization settings
You use the Settings panel in the Save for Web dialog box to set optimization options. 
If you’re working in 4-Up mode, you can repopulate the views to automatically generate 
lower-quality versions of the image based on the selected settings.

To apply optimization settings:

1 Select a view in the Save for Web dialog box to which you want to apply optimization 
settings. If your artwork contains multiple slices, select one or more slices to which you 
want to apply the optimization settings. (See “Using the Save for Web dialog box” on 
page 305.)

2 Do one of the following:

• Choose a named optimization setting from the Settings menu. (See “Saving and 
resetting optimization settings” on page 312.)

• Choose a file format from the File Format menu.

3 Set additional optimization options. The file format you chose in Step 2 determines 
which options are available to you. 

(See “Optimization options for GIF and PNG-8 formats” on page 308, “Optimization 
options for JPEG format” on page 309, “Optimization options for PNG-24 format” on 
page 310, “Optimization options for SWF format” on page 310, “Optimization options for 
SVG format” on page 311.)

To apply optimization settings based on file size:

1 Choose Optimize to File Size from the Optimize pop-up menu . 

2 Choose a Start With option:

• Current Settings to use current optimization settings.

• Auto Select GIF/JPEG to automatically generate a GIF or JPEG file. (Illustrator selects GIF 
or JPEG format, depending on its analysis of colors in the image.)

3 Enter a value for file size, and click OK.

To repopulate optimization settings:

1 Apply optimization settings to a view in 4-Up mode.

2 Choose Repopulate Views from the Optimize pop-up menu. 

The selected view and the original view are not altered during repopulation. 
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Optimization options for GIF and PNG-8 formats
GIF is the standard format for compressing images with flat color and crisp detail, such as 
line art, logos, or illustrations with type. You can lower the size of GIF images by reducing 
the number of colors in the file. Like the GIF format, the PNG-8 format efficiently 
compresses solid areas of color while preserving sharp detail; however, not all Web 
browsers can display PNG-8 files. PNG-8 settings are very similar to the GIF settings. 
(See “About graphic file formats” on page 328.)

Optimization panel for GIF format 
A. File format menu B. Color Reduction Method menu C. Dithering Method menu
D. Optimize menu 

Lossy (GIF only) Specify a Lossy value to allow for lossy compression. Lossy compression 
reduces file size by selectively discarding data—a higher Lossy setting results in more data 
being discarded. You can often apply a Lossy value of 5–10, and sometimes up to 50, 
without degrading the image. File size can often be reduced 5%–40% using the Lossy 
option. 

Note: You cannot use the Lossy option with the Interlaced option or with Noise or Pattern 
Dither algorithms.

Color Reduction Method and Colors Choose a method for generating a color table from 
the Color Reduction Method menu. (See “Generating a color table” on page 314.) Then 
specify the maximum number of colors in the Colors text box. If you choose Web for the 
color reduction method, the Auto option becomes active in the Colors pop-up menu. Use 
the Auto option if you want Illustrator to determine the number of colors in the color table 
based on the frequency of colors in the image.

Note: If the image contains fewer colors than the number specified, the color table will 
contain only the number of colors in the image. 

Dithering Method and Dither Choose a dithering method from the Dithering Method 
menu, and specify the amount of application dithering. Dithering refers to the method of 
simulating colors not available in the color display system of your computer. A higher 
dithering percentage creates the appearance of more colors and more detail in an image, 
but can also increase the file size. For optimal compression, use the lowest percentage of 
dither that provides the color detail you require. Images with primarily solid colors may 
work well with no dither. Images with continuous-tone color (especially color gradients) 
may require dithering to prevent color banding. Choose No dither or select an option in 
the Dithering Method menu:

• Diffusion applies a random pattern that is usually less noticeable than Pattern dither. 
The dither effects are diffused across adjacent pixels.
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• Pattern applies a halftone-like square pattern to simulate any colors not in the color 
table.

• Noise applies a random pattern similar to the Diffusion dither method, but without 
diffusing the pattern across adjacent pixels. No seams appear with the Noise dither 
method. 

Transparency and Matte Select a combination of Transparency and Matte options to 
specify how transparent pixels in the image are optimized:

• To make fully transparent pixels transparent and blend partially transparent pixels with 
a color, select Transparency and select a matte color. 

• To make all pixels with greater than 50% transparency fully transparent and all pixels 
with 50% or less transparency fully opaque, select Transparency and choose None from 
the Matte menu. 

• To fill fully transparent pixels with a color and blend partially transparent pixels with the 
same color, select a matte color and deselect Transparency.

To select a matte color, click the Matte color swatch and select a color in the color picker. 
Alternatively, choose an option from the Matte menu: Eyedropper (to use the color in the 
eyedropper sample box), White, Black, or Other (to use the color picker).

Interlace Select Interlaced to create an image that displays as a low-resolution version in 
a browser while the full image file is downloading. Interlacing can make downloading 
time seem shorter and can assure viewers that downloading is in progress. However, inter-
lacing also increases file size.

Web Snap Specify a tolerance level for shifting colors to the closest Web palette equiva-
lents (and prevent the colors from dithering in a browser). A higher value shifts more 
colors. 

Optimization options for JPEG format
JPEG is the standard format for compressing continuous-tone images such as photo-
graphs. Optimizing an image as a JPEG format relies on lossy compression, which selec-
tively discards data. (See “About graphic file formats” on page 328.)

Optimization panel for JPEG format 
A. File format menu B. Quality Level menu C. Optimize menu

Quality Choose an option from the Quality Level menu, or specify a value in the Quality 
text box. The higher the Quality setting, the more detail the compression algorithm 
preserves. However, using a high Quality setting results in a larger file size than using a low 
Quality setting. View the optimized image at several quality settings to determine the best 
balance of quality and file size.
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Optimized Select Optimized to create an enhanced JPEG with a slightly smaller file size. 
The Optimized JPEG format is recommended for maximum file compression; however, 
some older browsers do not support this feature.

Progressive Select Progressive to create an image that displays progressively in a Web 
browser. The image will display as a series of overlays, enabling viewers to see a low-
resolution version of the image before it downloads completely. The Progressive option 
requires use of the Optimized JPEG format.

Note: Progressive JPEGs require more RAM for viewing, and are not supported by some 
browsers.

Blur Specify the amount of blur to apply to the image. This option applies an effect 
identical to that of the Gaussian Blur filter and allows the file to be compressed more, 
resulting in a smaller file size. A setting of 0.1 to 0.5 is recommended.

ICC Profile Select ICC Profile to preserve the ICC profile of the artwork with the file. 
ICC profiles are used by some browsers for color correction. This option is only available 
after you’ve saved an image with an ICC profile—it is not available for unsaved images. 
(See “Setting up color management” on page 176).

Matte Specify a fill color for pixels that were transparent in the original image:

• Click the Matte color swatch and select a color in the color picker. 

• Choose an option from the Matte menu: Eyedropper (to use the color in the eyedropper 
sample box), White, Black, or Other (to use the color picker). 

Pixels that were fully transparent in the original image are filled the selected color, pixels 
the were partially transparent in the original image are blended with the selected color.

Optimization options for PNG-24 format
PNG-24 is suitable for compressing continuous-tone images; however, it produces much 
larger files than JPEG format. (See “About graphic file formats” on page 328.)

The advantage of using PNG-24 is that it can preserve up to 256 levels of transparency in 
an image. To save an image with multilevel transparency, select Transparency and choose 
None from the Matte menu. For more information on the Interlaced, Transparency, and 
Matte options, see “Optimization options for GIF and PNG-8 formats” on page 308.

Optimization options for SWF format
SWF is a vector-based format that creates scalable, compact graphics. Because SWF is 
vector-based, artwork maintains its image quality at different resolutions and is ideal for 
the creation of animation frames.(See “About graphic file formats” on page 328.)

Optimization panel for SWF format 
A. File format menu B. Export As menu C. Optimize menu
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Read Only Select Read Only to prohibit users from modifying the exported SWF file.

Export As Select AI File to SWF File to export the artwork to a single frame. Select AI 
Layers to SWF Frames to export the artwork on each layer to a separate SWF frame, 
creating an animated SWF.

Note: Select AI File to SWF File to preserve layer clipping masks.

Curve Quality Specify the accuracy of the bezier curves. A low number decreases the 
exported file size with a slight loss of curve quality. A higher number increases the 
accuracy of the bezier curve reproduction, but results in a larger file size.

Frame Rate Specify the rate at which the animation will be played in a Macromedia Flash 
viewer. (This option is only available for AI Layers to SWF Frames.)

Loop Select Loop to cause the animation to loop continuously, rather than play once and 
then stop, when played in a Macromedia Flash viewer. (This option is only available for AI 
Layers to SWF Frames.)

Optimization options for SVG format
SVG uses XML to save high-resolution vector graphics. SVG files can contain sophisticated 
elements, such as gradients, animation, and filter effects. (See “About graphic file formats” 
on page 328.)

Increase the resolution in the Document Raster Effects Settings dialog box to improve 
the appearance of raster effects in SVG files. (See “Specifying raster effects settings” on 

page 239.)

Optimization panel for SVG format 
A. File Format menu B. Font Subsetting menu C. Font Location menu D. Image Location menu
E. CSS Properties menu F. Character Encoding G. Optimize menu

Compressed Select Compressed to create a Compressed SVG (SVGZ) file. 

Font Subsetting Choose an option from the Font Subsetting menu to control which 
fonts are embedded or linked from the SVG file. Choose None from the Subsetting menu if 
you can rely on the necessary fonts being installed on end-user systems. Choose Only 
Glyphs Used (only available when embedding fonts) to only include glyphs for text that 
exists in the current artwork. The other values (Common English, Common English + 
Glyphs Used, Common Roman, Common Roman + Glyphs Used, All Glyphs) are useful 
when the textual content of the SVG file is dynamic (such as server-generated text or user-
interactive text).

Decimals Specify the precision of vector data in the SVG file. You can set a value of 1 to 7 
decimal places. A high value results in a larger file size and increased image quality.
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Font Location Choose Embed Fonts or Link Fonts from the Font Location menu. 
Embedding fonts increases file size but ensures that the fonts will always be available 
(for example, if you distribute the SVG file via email). Linking fonts from an external 
location makes sense if you have several SVG files that share the same fonts. 

Image Location Choose Embed Images or Link Images from the Image Location menu. 
Embedding images increases file size but ensures that rasterized images will always be 
available.

CSS Properties Determines how style attributes are saved in the SVG code. The default 
method, Presentation Attributes, applies properties at the highest point in the hierarchy, 
which allow the most flexibility for specific edits and transformations. The Style Attributes 
method creates the most readable files but may increase the file size. Choose this method 
if the SVG code will be used in transformations—for example, transformations using 
Extensible Stylesheet Language Transformation (XSLT). The Entity References method 
results in faster rendering times and reduced SVG file size. The Style Element method is 
used when sharing files with HTML documents. By selecting Style Element, you can then 
modify the SVG file to move a style element into an external stylesheet file that is also 
referenced by the HTML file—however, the Style Element option also results in slower 
rendering speeds.

Encoding Choose a method from the Encoding menu to determine how characters are 
encoded in the SVG file. UTF (Unicode Transformation Format) encoding is supported by 
all XML processors. (UTF-8 is an 8-bit format; UTF-16 is a 16-bit format.) ISO 8859-1 and 
UTF-16 encoding do not preserve file metadata. (See “Adding metadata to documents” on 
page 46.)

Saving and resetting optimization settings
After you optimize an image, you can return to the artboard without losing your settings. 
When you choose the Save for Web command again, the optimization settings are just as 
you left them. 

You can also save optimization settings as a named set and apply the settings to other 
images. Settings that you save appear in the Settings pop-up menu of the Save for Web 
dialog box, together with the Illustrator predefined named settings. If you edit a named 
set or a predefined set, the Settings menu displays the term “Unnamed.” 

To save the current optimization setting:

Do one of the following:

• To save the settings and close the Save for Web dialog box, click Done.

• To save the settings without closing the Save for Web dialog box, press Alt (Windows) or 
Options (Mac OS), and click Remember.

To reset optimization settings to the last saved version:

Press Alt (Windows) or Options (Mac OS), and click Reset.

To save a named set of optimization settings:

1 With desired settings selected in the Settings panel of the Save for Web dialog box, 
choose Save Settings from the Settings panel menu.
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2 Name the settings, and choose a location where they will be saved. By default, named 
settings are saved in the Presets/Save for Web Settings/Optimize folder inside the Adobe 
Illustrator application folder.

3 Click OK.

To edit a named set of optimization settings:

1 Choose the named set from the Settings pop-up menu.

2 Edit the optimization settings as desired. The Settings menu will display the term 
“Unnamed,” since the settings no longer match a named set.

3 Choose Save Settings from the Settings panel menu, and save the settings with the 
name of the original set.

To delete optimization settings:

1 Choose a named set or predefined set of optimization settings from the Settings pop-
up menu.

2 Choose Delete Settings from the Settings panel menu. 

Changing the pixel dimensions of images
You can use the Image Size palette in the Save for Web dialog box to change the pixel 
dimensions of optimized images.

To change the pixel dimensions of images:

1 Click the Image Size tab in the Save for Web dialog box.

2 To maintain the current proportions of pixel width to pixel height, select Constrain 
Proportions. 

3 Do one or more the following:

• Enter a value in the Width text box to change the image’s width.

• Enter a value in the Height text box to change the image’s height.

• Enter a value in the Percent text box to resize the image by a percent value.

4 To remove jagged edges in the artwork, select the Anti-Alias option.

5 To clip the artwork size to match the document’s Artboard boundary, select the Clip to 
Artboard option. 

Note: Any artwork outside the Artboard boundary will be clipped out of the image if you 
select the Clip to Artboard option. 

6 Click Apply. 

Exporting layers as CSS layers
You can use layers in your artwork to generate CSS layers in the resulting HTML file. A CSS 
layer is an element that has an absolute position and can overlap with other elements in a 
Web page. Exporting CSS layers is useful when you plan to create dynamic effects in your 
Web page.

The Layers palette in the Save for Web dialog box gives you control over which top-level 
layers in your artwork are exported as CSS layers, and whether exported layers are visible 
or hidden.
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To set options for exporting CSS layers:

1 Click the Layers tab in the Save for Web dialog box.

2 Select Export As CSS Layers. 

3 Choose a layer from the Layer pop-up menu, and set the following options as desired:

• Visible to create a visible CSS layer in the resulting HTML file.

• Hidden to create a hidden CSS layer in the resulting HTML file.

• Do Not Export to not export the layer to the resulting HTML file.

Optimizing colors in GIF and PNG-8 images
Decreasing the number of colors in an image is a key factor in optimizing GIF and PNG-8 
images. A reduced range of colors will often preserve good image quality while dramati-
cally reducing the file space required to store extra colors.

Generating a color table
Illustrator generates a color table for GIF and PNG-8 images based on the color options 
you set for optimization. You choose a method for generating the color table from the 
Color Reduction menu and specify the number of colors you want in the color table in the 
Colors text box. (See “Optimization options for GIF and PNG-8 formats” on page 308.) 

You can choose from the following methods for generating color tables:

Perceptual Creates a custom color table by giving priority to colors for which the human 
eye has greater sensitivity. 

Selective Creates a color table similar to the Perceptual color table, but favoring broad 
areas of color and the preservation of Web colors. This color table usually produces images 
with the greatest color integrity. Selective is the default option.

Adaptive Creates a custom color table by sampling colors from the spectrum appearing 
most commonly in the image. For example, an image with only the colors green and blue 
produces a color table made primarily of greens and blues. Most images concentrate 
colors in particular areas of the spectrum. 

Web Uses the standard 216-color color table common to the Windows and Mac OS 8-bit 
(256-color) palettes. This option ensures that no browser dither is applied to colors when 
the image is displayed using 8-bit color. (This palette is also called the Web-safe palette.)

Using the Web palette can create larger files, and is recommended only when avoiding 
browser dither is a high priority. 

Custom Preserves the current perceptual, selective, or adaptive color table as a fixed 
palette that does not update with changes to the image.

Note: Other color tables appear in the menu if you have saved them previously. 

Using the Color Table palette
The Color Table palette in the Save for Web dialog box gives you precise control over 
the colors in optimized GIF and PNG-8 images. With a maximum of 256 colors, you can add 
and delete colors in the color table, shift selected colors to Web-safe colors, and lock 
selected colors to prevent them from being dropped from the palette.
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Using the Color Table palette menu Click the triangle  in the right corner of the Color 
Table palette.

Sorting the color table Choose a sorting command from the Color Table palette menu. 
You can sort colors by hue (neutral colors are assigned a hue of 0 and located with the 
reds), luminance (the lightness or brightness of a color), or popularity, making it easier to 
see an image’s color range and locate particular colors. 

Adding new colors Select the eyedropper tool, and click on a color in the image. (Alter-
natively, click the color selection box, and use the color picker to select a color.) Then, click 
the New Color button , or choose New Color from the Color Table palette menu. A small 
white square with a dark center appears in the lower right corner of the new color, 
indicating that the color is locked. 

Note: If the color table already contains the maximum number of colors (256, or 255 with 
transparency), you cannot add a new color. 

Selecting colors To select a color in the image, select the eyedropper tool , and click a 
color in the image. A white border appears around that color in the Color Table palette. To 
select a color in the Color Table palette, click the color. To select a contiguous group of 
colors, press Shift and click another color. All colors in the rows between the first and 
second selected colors are selected. To select a discontiguous group of colors, press Ctrl 
(Windows) or Command (Mac OS) and click each color that you want to select. 

The Color Table palette menu also provides commands for selecting colors.

Note: The Select All Web-Safe Colors command is not available when the optimized image 
does not contain Web-safe colors; likewise, the Select All Non-Web Safe Colors command is 
not available when the optimized image contains only Web-safe colors.

Editing colors Double-click the color in the Color Table palette to display the default 
color picker, and then select a color. A small plus sign appears in the center of each edited 
color. 

Shifting to Web-safe colors Select the colors you want to shift, and click the Web Shift 
button  in the Color Table palette. (Alternatively, choose Web Shift/Unshift Selected 
Colors from the Color Table palette menu.) A small white diamond appears in the center of 
selected colors that have been Web-shifted (and in all Web-safe colors). Shifting colors 
prevents them from dithering in a browser. 

Once you’ve shifted colors, you can restore them to their original values using commands 
in the Color Table palette menu. Choose Web Shift/Unshift Selected Colors or Unshift All 
Colors. Alternatively, select a Web-shifted color, and click the Web Shift button  to revert 
it. To specify a tolerance for shifting colors, specify a value for Web Snap in the Settings 
panel of the Save for Web dialog box. A higher value shifts more colors. 

Deleting colors Click the Trash button or choose Delete Color from the Color Table 
palette menu. When you delete a color, areas of the optimized image that previously 
included that color are rerendered using the closest color remaining in the palette.

Note: Deleting a color changes the color palette type to Custom to prevent the color from 
being added back to the palette if you reoptimize the image.

Locking and unlocking colors Click the Lock button , or choose Lock/Unlock Selected 
Colors from the Color Table palette menu. A white square with a red center appears in the 
lower right corner of each locked color. Locking colors prevents them from being dropped 
or dithered if you reduce the number of colors in the image. 
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To unlock all colors, choose Unlock All Colors from the Color Table palette menu.

Saving color tables Choose Save Color Table from the Color Table palette menu. By 
default, the color table file is given the extension .act (for Adobe Color Table). 

Loading color tables Choose Load Color Table from the Color Table palette menu. You 
can load a color table from an .act file or a GIF file (to load the file’s embedded color table). 
Once you load a new color table, the colors in the optimized image change to reflect the 
new color table.

Saving optimized images
When you’ve applied a combination of settings that achieve a balance between quality 
and file size, you’re ready to save the optimized image.

To save an optimized image:

1 Select the view with the desired optimization settings in the Save for Web dialog box, 
and click Save.

2 Type a filename, and choose a location for the resulting file or files. 

3 Choose a Save as Type option:

• HTML and Images to generate all files required to use your artwork as a Web page. 
This includes an HTML file and separate image files for the slices in the artwork. The 
HTML file includes code for any links, image maps, and other effects in the document. 

• Images Only to save your artwork with the specified optimization settings. If the 
artwork contains multiple slices, each slice is saved as a separate file.

• HTML Only to generate an HTML file but not save any image files. 

4 To set preferences for saving image files and HTML files, click Output Settings. 
(See “Setting output options” on page 316.)

5 Choose an option for slices from the pop-up menu:

• All Slices to save all slices in the image. 

• Selected Slices to save only the selected slices. If you select this option in conjunction 
with the HTML and Images option, Illustrator generates the HTML code based on the 
outermost bounds of the selected slices, and generates auto slices as needed to create 
a complete HTML table.

Note: You must select the desired slices before starting this procedure. 

6 Click Save.

Setting output options
When you save an optimized image as a Web page, you can specify how HTML files are 
formatted, how files are named, how slices are named, and how background images are 
handled. You set these options in the Output Settings dialog box. 

Using the Output Settings dialog box
The Output Settings dialog box contains four sets of options: HTML, Background, Saving 
Files, and Slices. You can save your output settings and apply them to other files.
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Displaying the Output Settings dialog box In the Save for Web dialog box, choose Edit 
Output Settings from the Optimize menu. Alternately, click Output Settings in the Save 
Optimized As dialog box when you save an optimized image.

Switching to a different set of options Choose an options set from the pop-up menu 
below the Settings menu. Alternately, click Next to display the next set in the menu list; 
click Prev to display the previous set.

Saving output settings In the Save for Web dialog box, choose Edit Output Settings 
from the Optimize menu. Set the options as desired, and click Save. Type a filename, 
choose a location for the saved file, and click Save. 

Loading output settings In the Save for Web dialog box, choose Edit Output Settings 
from the Optimize menu. Click Load, select a *.iros file, and click Open.

Setting HTML output options
You can set the following options in the HTML set:

Tags Case Specifies the capitalization for tags. 

Attribs Case Specifies the capitalization for attributes.

Setting tags and attributes to all uppercase helps the code stand out in the file.

Indent Specifies a method for indenting lines of code: using the authoring application’s 
tab settings, using a specified number of spaces, or using no indentation.

Line Endings Specifies a platform for line ending compatibility.

Always Quote Attributes Places quotation marks around all tag attributes. Placing 
quotation marks around attributes is required for compatibility with certain early 
browsers and for strict HTML compliance. However, always quoting attributes is not 
recommended. Quotation marks are used when necessary to comply with most browsers, 
even if this option is deselected.

Include Comments Adds explanatory comments to the HTML code.

Include GoLive Code Reformats code in the style used by Adobe GoLive. Select this 
option if you plan to reoptimize slices in GoLive.

Generate CSS Generates a Cascading Style Sheet, rather than an HTML table. 

Referenced Specifies how slice positions are referenced in the HTML file when using CSS:

• By ID to position each slice using styles that are referenced by a unique ID.

• Inline to include style elements in the declaration of the block element <DIV> tag. 

• By Class to position each slice using classes that are referenced by a unique ID.

Generate Table Aligns slices using an HTML table, rather than a Cascading Style Sheet. 

Empty Cells Specifies how empty slices are converted to table cells. Select GIF, IMG W&H 
to use a one-pixel GIF with width and height values specified on the IMG tag. Select GIF, TD 
W&H to use a one-pixel GIF with width and height values specified on the TD tag. Select 
NoWrap, TD W&H to place a nonstandard NoWrap attribute on the table data and also 
place width and height values specified on the TD tags.

TD W&H Specifies when to include width and height attributes for table data: Always, 
Never, or Auto (the recommended setting).
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Spacer Cells Specifies when to add one row and one column of empty spacer cells 
around the generated table: Always, Never, or Auto (the recommended setting). Adding 
spacer cells is necessary with table layouts in which slice boundaries do not align, to 
prevent the table from breaking apart in some browsers.

Image Map Type Specifies what type of image map is created:

• Client-Side to include all required code for the image map in the image’s HTML file.

• NCSA Server-Side to create a separate .map file in addition to the HTML file, using NCSA 
specifications.

• CERN Server-Side to create a separate .map file in addition to the HTML file, using CERN 
specifications.

• Client & NCSA to create both a client-side and server-side compatible image map, using 
NCSA specifications.

• Client & CERN to create both a client-side and server-side compatible image map, using 
CERN specifications.

Note: Contact your Internet service provider to find out whether to use NCSA or CERN 
specification for server-side image maps.

Image Map Placement Specifies the location of the image map declaration (the <MAP> 
tag) in the HTML file:

• Top to place the image map declaration at the top of the HTML body section. 

• Body to place the image map declaration above the <IMG SRC> tag for the associated 
slice.

• Bottom to place the image map declaration at the bottom of the HTML body section. 

Setting background options
You can set the following options in the Background set:

View As Select Image if you want the Web page to display an image or a solid color as a 
background behind the current image. Select Background if you want the Web page to 
display the optimized image as a tiled background.

Image Enter the location of an image file, or click Choose and select an image. The file 
you specify will be tiled behind the optimized image on the Web page.

Color Click the Color box, and choose a background color using the color picker, or 
choose an option from the pop-up menu.

Setting file saving options
You set the following options in the Saving Files set:

File Naming Choose elements from the pop-up menus or enter text into the fields to be 
combined into the default names for all files. Elements include document name, slice 
name, rollover state, trigger slice, file creation date, slice number, punctuation, and file 
extension. Some options are relevant only if the file contains slices or rollover states.

The fields let you change the order and formatting of the filename parts (for example, 
letting you indicate rollover state by an abbreviation instead of the full word).

File Name Compatibility Select one or multiple options to make the filename 
compatible with Windows (permits longer filenames), Macintosh, and UNIX operating 
systems.
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Copy Background Image When Saving Preserves a background image that has been 
specified in the Background preferences set. 

Put Images In Folder Specifies a folder name where optimized images are saved 
(available only with documents containing multiple slices).

Include Copyright Includes copyright information with the image. (See “Adding 
metadata to documents” on page 46.)

Setting slice naming preferences
You specify the default naming pattern for slices in the Slices set. Choose elements from 
the pop-up menus or enter text into the fields to be combined into the default names for 
all slices. Elements include document name, the word slice, numbers or letters designating 
slices or rollover states, slice creation date, punctuation, or none.
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Saving and Exporting

About saving and exporting artwork
When you save or export artwork, Illustrator writes the artwork data to a file. The structure 
of the data depends on the file format that you select. There are four basic file formats—
AI, PDF, EPS, and SVG—that store vector data in such a way that it can be reopened and 
edited in Illustrator. There are also a variety of non-native formats that let you export data 
for use outside of Illustrator. Keep in mind that when you choose a non-native format, 
Illustrator will not be able to retrieve all of the data if you reopen the file in Illustrator. 
For this reason, it is recommended that you save artwork in AI, PDF, EPS, or SVG format 
until you are finished creating it, and then export the artwork to the desired format.

You can use the following methods to save and export artwork:

• Choose File > Save to save artwork to its current AI, PDF, EPS, SVG, or SVGZ file. If you 
haven’t previously saved the artwork, or if the current file is not an AI, PDF, EPS, or SVG 
file, the Save command functions in the same way as the Save As command. 

• Choose File > Save As to save artwork to a different AI, PDF, EPS, SVG, or SVGZ. In the 
Save As dialog box, select a location for the file, enter a filename, choose a format from 
the Save as Type (Windows) or Format (Mac OS) pop-up menu, and click Save. 

• Choose File > Save a Copy to save an identical copy of the artwork while leaving the 
original file as the active file. In the Save a Copy dialog box, select a location for the file, 
enter a filename, choose a format from the Save as Type (Windows) or Format (Mac OS) 
pop-up menu, and click Save.

• Choose File > Export to export artwork using a non-native format. In the Export dialog 
box, select a location for the file, enter a filename, choose a format from the Save as 
Type (Windows) or Format (Mac OS) pop-up menu, and click Export. If the format you 
want to use is not available, install the format’s plug-in module. (See “Using plug-in 
modules” on page 18.)

• Choose File > Save for Web to optimize artwork for Web display using the JPEG, GIF, 
PNG, SVG, and SWF formats. (See “Optimizing images” on page 305.)

• Use the Clipboard and the drag-and-drop feature to export selected portions of 
artwork. (See “Using the Clipboard to copy artwork” on page 104, and “Using the drag-
and-drop feature to copy artwork” on page 105.)

For more information on specific file formats, see “About graphic file formats” on 
page 328.

Saving artwork in Illustrator format
When you save artwork in Illustrator format, you can choose which version of Illustrator 
you want the file to be compatible with. You can also set a variety of options that control 
how data is saved in the file.
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To save artwork in Illustrator format: 

1 Save the artwork as described in “About saving and exporting artwork” on page 320. 
Choose Illustrator (AI) as the file format.

2 In the Illustrator Native Format Options dialog box, select the Adobe Illustrator version 
with which you want your file to be compatible. Keep in mind that certain features, such as 
gradients, layers, and transparency, may not be supported by earlier versions of the 
Illustrator file format. 

3 Set additional options, and click OK:

Create PDF Compatible File Saves a PDF representation of the document in the 
Illustrator file. Select this option if you want the Illustrator file to be compatible with other 
Adobe applications. (This option is available only for Illustrator 10.0 format.)

Use Compression Compresses PDF data in the Illustrator file. Using compression 
increases the time required to save the document, so deselect this option if you’re experi-
encing very slow (8 to 15 minute) save times. (This option is available only for Illustrator 
10.0 format when the Create PDF Compatible File option is selected.)

Embed All Fonts Embeds all fonts that are used in the artwork. This ensures that the 
original font is used for display and printing on computers that do not have the font 
installed. (Selecting the Embed Fonts option increases the size of the saved file.)

Subset Fonts Specifies when to embed fonts based on how many of the font’s characters 
are used in the document. For instance, if a font contains a thousand characters but the 
document only uses 10 of those characters, you may decide that embedding the font is 
not worth the extra file size.

Embed ICC Profile Creates a color-managed document. (See “Embedding profiles in 
saved documents” on page 186.)

Include Linked Files Embeds files that are linked to the artwork.

Use Japanese File Format Saves the artwork as a Japanese language file that is 
compatible with Illustrator versions 3, 4, or 5. (This option is not available for later 
Illustrator versions.)

Transparency Determines what happens to transparent objects when you choose a 
version of Illustrator format earlier than 9.0. Select Preserve Paths to discard transparency 
effects and reset transparent artwork to 100 percent opacity. Select Preserve Appearance 
option to maintain the appearance of transparency by flattening transparent areas of the 
artwork. If your artwork contains complex, overlapping areas and you require high-
resolution output, click Cancel and specify rasterization settings before continuing. 
(See “Printing and saving transparent artwork” on page 336.)

Saving artwork in EPS format
Virtually all page layout, word-processing, and graphic applications accept imported or 
placed EPS files. The EPS format preserves many of the graphic elements you can create 
with Adobe Illustrator, which means that EPS files can be reopened and edited as 
Illustrator files.
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To save artwork in EPS format:

1 Save the artwork as described in “About saving and exporting artwork” on page 320. 
Choose Illustrator EPS (EPS) as the file format.

2 In the EPS Format Options dialog box, select the Adobe Illustrator version with which 
you want your file to be compatible. Select Version 9.0 or later to preserve transparency, 
text, and spot colors in the artwork if the file is placed in another application (such as 
Adobe InDesign or QuarkXPress). 

Note: Selecting Version 8.0 or earlier will result in text being converted to outlines, spot 
colors being converted to process colors, and transparency being discarded or flattened 
(depending on the Transparency option you select).

3 Set additional options, and click OK:

Preview options Determine the characteristics of the preview image that is saved in the 
file. The preview image is displayed in applications that cannot display EPS artwork 
directly. If you don’t want to create a preview image, choose None from the Format menu. 
Otherwise, select a black-and-white or color format.

If you select TIFF (8-bit Color) format, select a background option for the preview image: 
Transparent to produce a transparent background or Opaque to produce a solid 
background. (Select Opaque if the EPS document will be used in a Microsoft Office 
application.)

Include Linked Files Embeds files that are linked to the artwork.

Include Document Thumbnails Creates a thumbnail image of the artwork that is 
displayed in the Illustrator Open and Place dialog boxes.

Include Document Fonts Includes all fonts that are used in the artwork. This ensures that 
the original font is used for display and printing on computers that do not have the font 
installed. (Selecting the Embed Fonts option increases the size of the saved file. You 
cannot embed protected Japanese fonts.) 

Use Japanese File Format Saves the artwork as a Japanese language file that is 
compatible with Illustrator versions 3, 4, or 5. (This option is not available for later 
Illustrator versions.)

CMYK PostScript Allows RGB color documents to be printed from applications that do 
not support RGB output. When the EPS file is reopened in Illustrator, the RGB colors are 
preserved.

PostScript Determines what level of Postscript is used to save the artwork. (See “About 
graphic file formats” on page 328.)

Transparency Determines what happens to transparent objects when you choose a 
version of Illustrator format earlier than 9.0. Select Preserve Paths to discard transparency 
effects and reset transparent artwork to 100 percent opacity. Select Preserve Appearance 
option to maintain the appearance of transparency by flattening transparent areas of the 
artwork. If your artwork contains complex, overlapping areas and you require high-
resolution output, click Cancel and specify rasterization settings before continuing. 
(See “Printing and saving transparent artwork” on page 336.)
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Saving artwork in Adobe PDF format
Many page layout, word-processing, and graphic applications accept imported or placed 
PDF files. You can use the Preserve Illustrator Editing Capabilities option to preserve all 
Illustrator data, which means that PDF files can be reopened and edited as Illustrator files.

To save artwork in Adobe PDF format:

1 Save the artwork as described in “About saving and exporting artwork” on page 320. 
Choose Adobe PDF (PDF) as the file format.

2 In the Adobe PDF Format Options dialog box, choose an Options Set:

• Default for artwork that will be printed.

• Screen Optimized for artwork that will be displayed on the Web. This option produces a 
smaller file and automatically converts the artwork to RGB color mode.

3 If you’re satisfied with the default settings, click OK to save the artwork. Otherwise, set 
additional options, and then click OK. 

The options for saving PDF files are divided into two categories: General and Compression. 
Selecting different options causes the name of the Options Set to change to Custom.

To set General options:

Choose General from the pop-up menu below the Options Set box pop-up menu, and set 
the desired options:

File Compatibility Determines which version of Adobe Acrobat the resulting file is 
compatible with. Acrobat 5.0 format preserves transparency, text, and spot colors in the 
artwork; however, not all applications support this data. Select Preserve Illustrator Editing 
Capabilities if you want to reopen and edit the PDF file in Adobe Illustrator.

Embed All Fonts Includes all fonts that are used in the artwork. This ensures that the 
original font is used for display and printing on computers that do not have the font 
installed. Selecting the Embed All Fonts option increases the size of the saved file. 

Note: You cannot embed protected Japanese fonts.

Subset Fonts Specifies when to embed fonts based on how many of the font’s characters 
are used in the document. For instance, if a font contains a thousand characters but the 
document only uses 10 of those characters, you may decide that embedding the font is 
not worth the extra file size.

Embed ICC Profile Creates a color-managed document. (See “Embedding profiles in 
saved documents” on page 186.)

Generate Thumbnails Creates a thumbnail image of artwork that is displayed in the 
Illustrator Open or Place dialog boxes.

To set Compression options:

1 Choose Compression from the pop-up menu below the Options Set pop-up menu. 
The dialog box is divided into three panels, each of which provides options for 
compressing and resampling bitmap images in your artwork. 
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2 Set the desired options in each panel of the dialog box:

Average Downsampling Determines if the artwork is downsampled. Downsampling 
reduces the resolution of the image to the specified pixels per inch. If you plan to print the 
PDF file at high resolution, do not use downsampling. If you plan to use the PDF file on the 
Web, using downsampling allows for higher compression.

Compression and Quality Determine the type and amount of compression that is used. 
The Automatic option automatically sets the best possible compression and quality for 
the artwork contained in the file. For most files, this option produces satisfactory results. 

ZIP compression works well on images with large areas of single colors or repeating 
patterns and for black-and-white images that contain repeating patterns. Illustrator 
provides 4-bit and 8-bit ZIP compression options. If you use 4-bit ZIP compression with 
4-bit images, or 8-bit ZIP compression with 4-bit or 8-bit images, the ZIP method is 
lossless; that is, data is not removed to reduce file size and so image quality is not affected. 
Using 4-bit ZIP compression with 8-bit data can affect the quality, however, because data 
is lost. 

JPEG compression is suitable for grayscale or color images. JPEG compression is lossy, 
which means that it removes image data and may reduce image quality; however, it 
attempts to reduce file size with a minimum loss of information. Because JPEG 
compression eliminates data, it can achieve much smaller files sizes than ZIP compression.

CCITT and Run Length compression are only available for monochrome bitmap images. 
CCITT (Consultative Committee on International Telegraphy and Telephony) compression 
is appropriate for black-and-white images and any images scanned with an image depth 
of 1 bit. Group 4 is a general-purpose method that produces good compression for most 
monochromatic images. Group 3, used by most fax machines, compresses monochro-
matic bitmaps one row at a time. Run Length compression produces the best results for 
images that contain large areas of solid black or white. 

Compress Text and Line Art Applies ZIP compression to all text and line art in the file. 

Saving artwork in an SVG format
SVG is a vector format that produces high-quality, interactive Web graphics. (See “Creating 
Web graphics with SVG” on page 300.) There are two versions of the SVG formats: SVG and 
Compressed SVG (SVGZ). SVGZ can reduce file sizes by 50% to 80%; however, you cannot 
edit SVGZ files using a text editor.

When you export artwork in an SVG format, mesh objects are rasterized. In addition, 
images in the artwork that have no alpha channel are converted to the JPEG format. 
Images with an alpha channel are converted to the PNG format.

To save artwork in an SVG format: 

1 If the artwork contains any SVG filter effects, select each item to which an SVG filter 
effects has been applied, and move the filter effect to the bottom of the Appearance 
palette (just above the Transparency entry). (See “Adding SVG filter effects to artwork” on 
page 301.)

2 Save the artwork as described in “About saving and exporting artwork” on page 320. 
Choose SVG (SVG) or SVG Compressed (SVGZ) as the file format.
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3 In the SVG Options dialog box, set the desired options:

• Font Subsetting to control which fonts are embedded or linked from the exported SVG 
file. Choose None from the Subsetting menu if you can rely on the necessary fonts 
being installed on end-user systems. Choose Only Glyphs Used (only available when 
embedding fonts) to include only glyphs for text that exists in the current artwork. 
The other values (Common English, Common English + Glyphs Used, Common Roman, 
Common Roman + Glyphs Used, All Glyphs) are useful when the textual content of the 
SVG file is dynamic (such as server-generated text or user-interactive text).

• Font Location to determine whether the subset fonts are embedded directly in the file 
or linked to the exported fonts from the original Illustrator file. Embedding fonts 
increases file size but ensures that the fonts will always be available. For example, 
embed fonts if you plan to distribute the SVG file via e-mail. Saving the fonts in an 
external location makes sense if you have several SVG files that share the same fonts. 

• Image Location to determine whether raster images are embedded directly in the file or 
linked to the exported JPEG or PNG images from the original Illustrator file. Embedding 
images increases file size but ensures that rasterized images will always be available. 

• Preserve Illustrator Editing Capabilities to preserve Illustrator-specific data in the SVG 
file. Select this option if you plan to reopen and edit the SVG file in Illustrator.

4 Click OK to save the artwork, or click Advanced to set additional options:

CSS Properties Determines how style attributes are saved in the SVG code. The default 
method, Presentation Attributes, applies properties at the highest point in the hierarchy, 
which allow the most flexibility for specific edits and transformations. The Style Attributes 
method creates the most readable files but may increase the file size. Choose this method 
if the SVG code will be used in transformations—for example, transformations using 
Extensible Stylesheet Language Transformation (XSLT). The Style Attributes <Entity Refer-
ences> method results in faster rendering times and reduced SVG file size. The Style 
Elements method is used when sharing files with HTML documents. By selecting Style 
Elements, you can then modify the SVG file to move a style element into an external 
stylesheet file that is also referenced by the HTML file—however, the Style Elements 
option also results in slower rendering speeds.

Decimal Places Specifies the precision of vector data in the SVG file. You can set a value 
of 1 to 7 decimal places. A high value results in a larger file size and increased image 
quality.

Encoding Determines how characters are encoded in the SVG file. UTF (Unicode Transfor-
mation Format) encoding is supported by all XML processors. (UTF-8 is an 8-bit format; 
UTF-16 is a 16-bit format.) ISO 8859-1 and UTF-16 encoding do not preserve file metadata. 
(See “Adding metadata to documents” on page 46.)

Optimize for Adobe SVG Viewer Maintains the highest level of Illustrator data while still 
allowing the SVG file to be manually edited. Select this option to take advantage of faster 
rendering for features such as SVG filter effects.

Include Extended Syntax for Variable Data Includes all information needed for variable 
substitution in the SVG file. (See “Saving templates” on page 291.)

Include Slicing Data Includes slice locations and optimization settings.

Include File Info Includes file metadata in the SVG file. This option is available only when 
UTF-8 encoding is selected. (See “Adding metadata to documents” on page 46.)
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Exporting artwork in Photoshop format
Exporting to the Photoshop file format retains layers, masks, transparency, compound 
shapes, slices, image maps, and editable type when possible. This makes is easy to share 
artwork between Illustrator and Photoshop. 

If your artwork contains data that cannot be exported to Photoshop file format, Illustrator 
preserves the appearance of the artwork by merging the layers in the document or by 
rasterizing the artwork. As a result, there may be times when layers, sublayers, compound 
shapes, editable text, slices, or image maps are not preserved in the Photoshop file, even 
though you selected the appropriate export option.

To save artwork in Photoshop format: 

1 Export the artwork as described in “About saving and exporting artwork” on page 320. 
Choose Photoshop (PSD) as the file format.

2 In the Photoshop Options dialog box, set the export parameters, and click OK:

Color Model Determines the color model of the exported file. (See “Color modes and 
models” on page 152.)

Note: Exporting a CMYK document as RGB, or vice versa, may cause unexpected changes 
in the appearance of transparent areas, especially those that include blending modes.

Resolution Determines the resolution of the exported file. (See “About resolution in 
bitmap images” on page 26.)

Anti-alias Removes jagged edges in the artwork by supersampling it. Deselecting this 
option helps maintain the hard edges of line art when it is rasterized.

Write Layers Exports each Illustrator top-level layer as a separate Photoshop layer if 
doing so does not compromise the appearance of the artwork. Nested layers are flattened 
into the top-level layer during export, unless the Write Nested Layers option is also 
selected. If Write Layers is deselected, all layers are flattened into a single Photoshop layer.

Note: If the objects inside a layer have blending modes other than Normal applied to 
them, Illustrator may not be able to export the layer. To avoid this problem, isolate the 
blending modes. (See “Isolating blending modes” on page 197.) If this does not produce 
the desired results, try applying the blending mode to the layer instead of to the individual 
objects.

Write Nested Layers Writes each top-level sublayer to a separate Photoshop layer if 
doing so does not compromise the appearance of the artwork. Top-level layers become 
Photoshop layer sets. This option is only available if the Write Layers option is also 
selected. If more than 100 Photoshop layers result, an alert reminds you that Photoshop 
5.5 and earlier will not be able to open the document.

Write Compound Shapes Creates a Photoshop shape layer for each compound shape in 
a top-level layer if doing so does not compromise the appearance of the artwork. To write 
compound shapes with solid strokes, change the Join type to Round. (See “Using the 
Stroke palette” on page 159.)

Note: Illustrator cannot export compound shapes that have styles, dashed strokes, and 
brushes applied to them. 
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Editable Text Exports horizontal and vertical point type in a top-level layer to editable 
Photoshop type if doing so does not compromise the appearance of the artwork. 

Note: Illustrator cannot export area type and type on a path to Photoshop as editable 
text. 

Include Hidden Layers Exports hidden layers in the artwork to hidden Photoshop layers. 

Write Slices Exports slices in the artwork to Photoshop slices if doing so does not 
compromise the appearance of the artwork.

Write Image Maps Exports image maps in the artwork to Photoshop image maps if 
doing so does not compromise the appearance of the artwork.

Embed ICC Profile Creates a color-managed document. (See “Embedding profiles in 
saved documents” on page 186.)

Exporting artwork in SWF format
SWF is a vector format that produces high-quality, animated Web graphics. (See “Creating 
Web graphics with SWF” on page 304.) 

To export artwork in SWF format:

1 Export the artwork as described in “About saving and exporting artwork” on page 320. 
Choose Macromedia Flash (SWF) as the file format.

2 In the Macromedia Flash (SWF) Format Options dialog box, select an Export As option:

• AI File to SWF File to export the artwork to a single frame. Select this option to preserve 
layer clipping masks.

• AI Layers to SWF Frames to export the artwork on each layer to a separate SWF frame, 
creating an animated SWF.

• AI Layers to SWF Files to export the artwork on each layer to a separate SWF file. The 
result is multiple SWF files, each containing a single frame with the artwork from a 
single Illustrator layer.

3 Set additional options, and click OK:

Frame Rate Specifies the rate at which the animation will be played in a Macromedia 
Flash viewer. (This option is only available for AI Layers to SWF Frames.)

Looping Causes the animation to loop continuously, rather than play once and then stop, 
when played in a Macromedia Flash viewer. (This option is only available for AI Layers to 
SWF Frames.)

Generate HTML Generates HTML code for the SWF file, including its width and height. 
You can use this code to easily include the SWF file in a Web page. The HTML file is saved to 
the same location as the SWF file.

Read Only Prohibits users from modifying the exported SWF file.

Clip to Artboard Size Exports the entire artboard (and any artwork within the artboard 
borders) to the SWF file. Any artwork outside the artboard borders will be clipped off. 

Curve Quality Determines the accuracy of the bezier curves. A low number decreases 
the exported file size with a slight loss of curve quality. A higher number increases the 
accuracy of the bezier curve reproduction, but results in a larger file size.
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Image Format Determines how the artwork is compressed. Lossless compression 
maintains the highest image quality but creates a large SWF file. Lossy (JPEG) compression 
creates a smaller SWF file but adds artifacts to the image. Select Lossless if you intend to 
continue to work on the file (or files) in Macromedia Flash; select Lossy if you’re exporting 
the final SWF file.

JPEG Quality Specifies the amount of detail in the exported image. The higher the 
quality, the larger the file size. (This option is only available if you choose Lossy 
compression.)

Method Specifies the type of JPEG compression that is used. Baseline (Standard) applies 
the standard type of compression, while Baseline Optimized applies additional optimi-
zation. (These options are only available if you choose Lossy compression.)

Resolution Adjusts the screen resolution for bitmap images. Resolution for exported 
SWF files can be 72 to 2400 pixels per inch (ppi). Higher resolution values result in better 
image quality but larger file sizes.

About graphic file formats
Adobe Illustrator can import and export many common file formats. Graphic file formats 
are distinguished by the way they represent graphic information. Graphic information can 
be represented as either vector drawings or bitmap images. Some graphic file formats 
contain only vector drawings or only bitmap images, but many can include both in the 
same file.

AutoCAD Drawing (DWG) and AutoCAD Interchange File (DXF) formats DWG is the 
standard file format for saving vector graphics created in AutoCADƒ. DXF is a drawing 
interchange format for exporting AutoCAD drawings to or importing drawings from other 
applications. The DXF format is a tagged data representation of all the information 
contained in an AutoCAD drawing file. 

Note: By default, white strokes or fills in Illustrator artwork is exported to the DWG and 
DXF formats as black strokes or fills. 

Bitmap (BMP) format BMP is the standard Windows bitmap image format on Windows-
compatible computers. When saving an image in this format, you can specify either 
Microsoft Windows or OS/2® format, but your choice is limited to 24-bit depth for the 
image. 

Computer Graphics Metafile (CGM) format CGM is a vector-based file format for the 
exchange of two-dimensional graphical data. The metafile format is primarily for the 
exchange of graphical images, including complex engineering or architectural images and 
complex illustrations. CGM is not the primary choice for text-based artwork. 

Encapsulated PostScript (EPS) format The EPS file format is used to transfer PostScript 
language artwork between applications and is supported by most illustration and page-
layout programs. Typically, EPS files represent single illustrations or tables that are placed 
onto a host page, but an EPS file can also represent a complete page. Because EPS files are 
based on the PostScript language, they can contain both vector and bitmap graphics. 
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In addition to the PostScript language representation of the graphics to be placed, 
many EPS files contain a bitmap preview of the graphic that the application can display. 
EPS files intended to be used by Macintosh applications, for example, can contain PICT or 
TIFF images for screen preview; those intended for use by Windows applications contain 
either TIFF or Windows Metafile bitmap images.

Not all applications that create EPS files create preview images, however. When you place 
an EPS file without a preview image, Illustrator displays a box with an “X” to represent the 
EPS artwork. For more information on importing and exporting EPS files in Illustrator, 
see “Opening and placing artwork” on page 33 and “Managing linked and embedded 
images” on page 37.

Enhanced Meta File (EMF) format The Enhanced Meta File format is widely used by 
Windows applications as an intermediate format for exchanging vector graphics data. 
Illustrator may rasterize some vector data when exporting artwork to EMF format.

Filmstrip format (FLM) The Filmstrip (FLM) format is an image-editing format used 
primarily by the Adobe Premiere and Adobe Photoshop applications. FLM organizes 
images into a long vertical strip containing numbered frames as well as the Society of 
Motion Picture and Television Engineers (SMPTE) time code. 

Macromedia Flash format (SWF) The Macromedia Flash format is a version of the 
Macromedia Flash Player vector-based graphics format for interactive, animated Web 
graphics. You can export artwork to the Macromedia Flash format for use in Web design, 
and view the artwork in any browser equipped with the Macromedia Flash Player. 

GIF format Graphics Interchange Format (GIF) is the file format commonly used to 
display indexed-color graphics and images over the World Wide Web. GIF is an LZW-
compressed format designed to minimize file size and electronic transfer time. The GIF 
format supports binary transparency by allowing one of the indexed colors to be fully 
transparent. GIF does not support partial opacity as found in an alpha channel. 

JPEG format Joint Photographic Experts Group (JPEG) format is commonly used to 
display photographs and other continuous-tone images over the World Wide Web. JPEG 
compresses file size by selectively discarding data. Because of this, JPEG compression is 
referred to as lossy. JPEG format does not support transparency.

Note: Artifacts, such as wave-like patterns or blocky areas of banding, are added to a file 
each time you save the file as a JPEG. You should always save JPEG files from the original 
image, not from a previously saved JPEG.

A JPEG image is automatically decompressed when opened. A higher level of compression 
results in lower image quality, and a lower level of compression results in better image 
quality. In most cases, the Maximum quality option produces a result indistinguishable 
from the original. 

PCX format PCX format, established by Z-Soft® for its PC Paintbrush® software, is 
commonly used by IBM PC-compatible computers. Most PC software supports version 5 of 
the PCX format. Version 3 files do not support a custom color palette. For this reason, 
when you open a version 3 PCX file in Illustrator, the palette is ignored and a standard VGA 
color palette is used instead. 

Portable Document Format (PDF) The PDF format is used by Adobe Acrobat, Adobe’s 
electronic publishing software for Mac OS, Windows, and UNIX. You can view PDF files 
using the Acrobat Reader software included on your Adobe Illustrator CD.
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PDF can represent both vector and bitmap graphics and can also contain electronic 
document search and navigation features. PDF files, for example, can contain hypertext 
links and an electronic table of contents. Because Illustrator can open a PDF file, you can 
use the vector artwork or bitmap images from any PDF file in an Illustrator file.

Macintosh PICT format (PIC) The PICT format is widely used among Macintosh graphics 
and page-layout applications as an intermediary file format for transferring files between 
applications. The PICT format is especially effective at compressing images that contain 
large areas of solid color. 

PNG format Developed as a patent-free alternative to GIF, Portable Network Graphics 
(PNG) format is used for lossless compression and for display of images on the World Wide 
Web. Unlike GIF, PNG supports 24-bit images and produces background transparency 
without jagged edges; however, some Web browsers do not support PNG images. 

PostScript file format (PS) PostScript is a page description language that is built into 
many desktop printers and virtually all high-end printing systems. Because it is built into 
so many printers, most Mac OS, Windows, and UNIX applications can create PostScript files 
for printing. You cannot save PostScript files directly from Illustrator. However, if you’re 
using a PostScript printer, you can use the Print to File option (Windows) or the File option 
in the Destination pop-up menu (Mac OS) in the Print dialog box to create a PostScript file.

Note: For best results, Adobe recommends that you create PostScript files with the Apple 
LaserWriter 8 or Adobe PostScript printer driver. 

The first version of the PostScript file format, PostScript LanguageLevel 1, represents both 
grayscale vector graphics and grayscale bitmap images. The second version, PostScript 
LanguageLevel 2, represents color as well as grayscale vector and bitmap images, and 
supports RGB, CYMK, and CIE-based color models for both vector and bitmap graphics. 
(Some PostScript LanguageLevel 1 files also represent color with extensions to the 
PostScript language that were generalized in PostScript LanguageLevel 2.) PostScript 
LanguageLevel 3 provides additional functionality to LanguageLevel 2, including the 
ability to print mesh objects when printing to a PostScript® 3™ printer. Since printing to 
PostScript LanguageLevel 1 and LanguageLevel 2 devices converts gradient mesh objects 
to bitmap images, it is preferable to print artwork that contains gradient mesh objects to a 
PostScript 3 printer.

Note: PostScript LanguageLevel 1 is not supported for export to EPS or printing in the 
current version of Illustrator. However, LanguageLevel 1 export is supported for Illustrator 
8.0 and lower EPS formats.

PIXAR format (PXR) The PIXAR format is designed specifically for high-end graphics 
applications, such as those used for rendering three-dimensional images and animation. 

Scalable Vector Graphics (SVG) and Scalable Vector Graphics Compressed (SVGZ) 
formats The Scalable Vector Graphics formats are a World Wide Web Consortium (W3C) 
specification for a standard, two-dimensional vector graphics language for the Web. SVG 
works well with HTML and JavaScript, giving Web designers creative control in designing 
an interactive and dynamic Web experience. (See “About SVG” on page 300.)

You can reduce file sizes by 50% to 80% using SVGZ format. However, because SVGZ is a 
binary format, you cannot use a text editor to edit SVGZ files.

Note: The SVG plug-in is normally installed with Illustrator. If you need to find the plug-in 
separately, go to the SVG zone on www.adobe.com to download it.

http://www.adobe.com
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Targa (TGA) format The TGA format is designed for use on systems that use the 
Truevision® video board. If you are saving artwork in this format, you have the option of 
choosing the resolution and color depth you want.

Tagged-Image File Format (TIFF) TIFF is used to exchange files between applications 
and computer platforms. TIFF is a flexible bitmap image format that is supported by 
virtually all paint, image-editing, and page-layout applications. Also, virtually all desktop 
scanners can produce TIFF images.

TIFF supports RGB, CMYK, and grayscale color models. It also supports LZW compression, 
a lossless compression method that does not discard detail from the image.

When you export Illustrator artwork in TIFF, you can choose an RGB, CMYK, or grayscale 
color model and define the image resolution. To compress the file to a smaller size 
automatically, click the LZW Compression option.

Windows Meta File (WMF) format The Windows Meta File format is an intermediate 
exchange format for 16-bit Windows applications. WMF format is supported by almost all 
Windows drawing and layout programs. It has limited vector graphics support, and 
wherever possible EMF format should be used in place of WMF format.
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Printing

About printing
Whether you are providing multicolored artwork to an outside service bureau or just 
sending a quick draft of a drawing to an inkjet or laser printer, knowing a few basics about 
printing will make the print job go more smoothly and help ensure that the finished 
artwork appears as intended.

Types of printing When you print a file, the Adobe Illustrator program sends it to a 
printing device, either to be printed directly onto paper, to a digital printing press, or to be 
converted to a positive or negative image on film. In the latter case, the film can then be 
used to create a master plate for printing by a mechanical press.

Types of images The simplest types of images, such as a page of text, use only one color 
in one level of gray. A more complex image is one whose color tones vary within the 
image. This type of image is known as a continuous-tone image. A scanned photograph is 
an example of a continuous-tone image.

Halftoning To create the illusion of continuous tone when printed, images are broken 
down into a series of dots. This process is called halftoning. Varying the sizes and densities 
of the dots in a halftone screen creates the optical illusion of variations of gray or 
continuous color in the image. 

Color separation Artwork that will be commercially reproduced and that contains more 
than a single color must be printed on separate master plates, one for each color. This 
process is called color separation.

Getting detail The detail in a printed image results from a combination of resolution and 
screen frequency. The higher an output device’s resolution, the finer (higher) a screen 
ruling you can use. (See “Specifying the halftone screen ruling” on page 358.) 

Transparency If the artwork contains transparency, it will be flattened according to 
settings in the Document Setup dialog box. Using the Quality/Speed slider, you can affect 
the ratio of rasterized versus vector images in the printed artwork. (See “Printing and 
saving transparent artwork” on page 336.)

Printing artwork and composites
You can choose from a set of standard printing options in Adobe Illustrator for any type of 
artwork you print. These printing options appear in the Print Setup > Properties dialog box 
(Windows) or Page Setup (Mac OS) dialog box. You can then print the artwork using the 
Print dialog box. 

If you are making color separations, you can print a color or grayscale composite proof to 
check your work. A composite image can help you to design and proof your artwork 
before printing final (and costly) separations. When Illustrator prints a composite, it prints 
all of the colors used in the file on one plate. 
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Any overprinting options that you have selected in the document will print correctly on a 
composite, unless you have chosen the Ignore Overprinting in Composite Output option 
in the Print dialog box. You should also remember that, as with color monitors, color 
printers vary greatly in color reproduction quality; thus, composites from a color printer 
never substitute for proofs made by the print shop.

To select printing options:

1 Choose File > Print Setup (Windows) or File > Page Setup (Mac OS). 

2 Do one of the following: 

• In Windows, click Properties. 

• In Mac OS, select Page Attributes or PostScript Options from the pop-up menu.

3 Do one of the following:

• In Windows, select the options you want in the Properties dialog box, and click OK.

• In Mac OS, select the options you want from the selected pop-up menu, and click OK. 

To print a file:

1 Choose File > Print.

The number of pages that Illustrator prints is determined by the View options selected in 
the Artboard panel of the Document Setup dialog box. If the Single Full Page option in the 
Document Setup dialog box is selected, a single page prints. If any other View option is 
selected, for example, the Tile Full Pages option, you can specify a page or a range of 
pages to print by entering beginning and ending page numbers in the From and To 
text boxes. 

2 Indicate which pages you want printed. 

3 Choose from the following options in the Print dialog box (Windows) or choose Adobe 
Illustrator 10.0 from the pop-up menu (Mac OS) and set the advanced printing options:

• PostScript. If your printer driver and printer support PostScript Level 2 or 
LanguageLevel 3, you can select one of these options. These options enable you to 
optimize printing of mesh objects or other complex artwork. (See “Printing mesh 
objects” on page 341.)

• Output. Select Composite to print a single composite color image or Separate to print a 
separation. The Separate option only becomes available after you have set the 
separation options in the Separation Setup dialog box.

• Data. This option for printing bitmap images to PostScript printers is available only in 
Mac OS. Select Binary to decrease the amount of data and therefore to speed up the 
printing of bitmap images, or ASCII to make the data usable on a wider variety of 
printers and networks. 

• Bitmap Printing. This option for non-PostScript printers is available only in Windows. 
Select Bitmap Printing when printing documents that contain complex objects (such as 
objects with smooth shading or gradients) on a low-resolution printer. The image is 
sent to the printer as a bitmap image; although the print speed may be diminished, the 
possibility of error messages is reduced.

• Ignore Overprinting in Composite Output. This option specifies that any Overprint Fill 
or Overprint Stroke settings you have set in the Attribute palette do not appear on the 
composite. With this option selected, overprinting in composites occurs as in Adobe 
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Illustrator 8 or earlier. Deselecting this option results in simulating the appearance of 
printing to separations.

• Force Fonts to Download. This option temporarily downloads fonts from the computer 
to the printer. 

Note: If double-byte fonts print diagonally and do not show the correct typeface, the fonts 
are not stored on your printer. Forcing the fonts to download allows you to print them 
(with reduced print quality). For better print quality, install the fonts on the printer.

4 Click OK (Windows) or Print (Mac OS).

By default, Adobe Illustrator prints all visible layers. To print an individual layer, 
see “Making artwork nonprintable” on page 225.

Important: Adobe Illustrator does not support PDF Writer format; if you attempt to print 
to PDF Writer you may experience delays or errors in printing.

Using color management when printing
When you print a color-managed RGB or CMYK document, you can specify additional 
color management options to keep color consistent in the printer output. For example, 
suppose that your document currently contains a profile tailored for prepress output, 
but you want to proof the document colors on a desktop printer. In the Print dialog box, 
you can convert the document’s colors to the color space of the desktop printer; the 
printer profile will be used instead of the current document profile when printing. Because 
various RGB profiles are available in the Print dialog box, you can send color data as RGB 
values to printers.

When printing to a PostScript printer, you also have the option of using PostScript color 
management. In this workflow, Illustrator sends the document’s color data along with the 
document profile directly to the PostScript printer and lets the printer convert the 
document to the printer color space. The exact results of the color conversion can vary 
among printers. To use PostScript color management, you must have a printer that uses 
PostScript Level 2 or later; it is not necessary to install an ICC profile for the printer on 
your system.

Note: PostScript color management is not recommended when printing files that contain 
transparency.

For information on profiles and color-managed workflows, see “About color 
management” on page 174.

To color-manage a document while printing:

1 Choose File > Print.

2 Under Print Space, choose an option for Profile:

• To print using the document’s current color profile, choose Same As Source. No conver-
sions will be performed on the colors of the document when it is printed.

• To print using a different destination profile, choose that profile from the list.

• To print to a PostScript printer and have colors managed at the level of the printer, 
choose PostScript Color Management.
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3 For Intent, choose the rendering intent to use when converting colors to the desti-
nation profile space. For more information, see “Specifying a rendering intent” on 
page 184.

Setting crop marks and trim marks
Crop marks define where the artwork is trimmed after it is printed. You can place crop 
marks directly into your artwork using the Object > Crop Marks > Make command. If you 
select Japanese Crop Marks in the General Preferences dialog box, any crop marks you 
create in your file will appear as Japanese-style crop marks.

Like crop marks, trim marks also define where a printed image should be trimmed; 
however, you use trim marks to create multiple marks inside your artwork. The Trim Marks 
filter creates trim marks based on an imaginary rectangle drawn around the imageable 
area of the object.

Illustrator does not recognize trim marks created with the Trim Marks filter as special 
objects when creating color separations. As a result, trim marks do not affect the printing 
bounding box around the artwork. Trim marks are useful, therefore, when you want to 
create several sets of marks around objects on a page—for example, when you are 
creating a sheet of business cards to be printed.

To set crop marks directly in the artwork:

1 Draw a rectangle to define the boundaries of where you want the crop marks to appear. 
(It doesn’t matter if the rectangle is filled or stroked.)

2 Select the rectangle.

3 Choose Object > Crop Marks > Make. If you have selected a rectangle as the border, the 
crop marks replace the selected rectangle. If no rectangle has been selected, crop marks 
are placed at the corners of the artboard.

Once you’ve set crop marks, you cannot directly select or edit them. To indirectly edit crop 
marks, you can choose Object > Crop Marks > Release, edit the rectangle that defines the 
crop marks boundary, and then remake them using the Object > Crop Marks > Make 
command. If you want to delete the existing crop marks, you can use the Object > Crop 
Marks > Release command. 

You can use the Make Crop Marks command without first creating and selecting a 
rectangle to define the boundaries of the crop marks. The crop marks are set at the 

outer corners of the document.

If you plan to separate a color Illustrator file, you should first set crop marks in the artwork. 
If you don’t set crop marks, by default Illustrator sets them around the bounding box of all 
objects in the artwork.

For more information on setting crop marks in color separations, see “Step 4: Set the 
printing bounding box and place crop marks around the image to be separated” on 
page 354.

To eliminate crop marks:

Choose Object > Crop Marks > Release. The original rectangle reappears to define the 
bounding area of your artwork. The rectangle may then be deleted or moved. 
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To specify Japanese crop marks:

1 Choose Edit > Preferences > General (Windows and Mac OS 9) or Illustrator > 
Preferences > General (Mac OS X). 

2 Select Japanese Crop Marks, and then click OK. 

To create trim marks around an object:

Select the object, and choose Filter > Create > Trim Marks.

Trim marks created with the Trim Marks filter do not replace crop marks created with the 
Color Separation Setup dialog box or with the Object > Crop Marks > Make command. 

Printing and saving transparent artwork
When your artwork contains transparency, Illustrator performs a process called flattening 
before printing or saving the artwork. During flattening, Illustrator looks for areas where 
transparent objects overlap other objects and isolates these areas by dividing the artwork 
into components. Illustrator then analyses each component to determine if the artwork 
can be represented using vector data or if the artwork must be rasterized.

In most cases, the flattening process produces excellent results. However, if your artwork 
contains complex, overlapping areas and you require high-resolution output, you can 
control the degree to which artwork is rasterized. 

To specify rasterization settings for high-resolution output:

1 Choose File > Document Setup.

2 Choose Transparency from the pop-up menu at the top of the dialog box, do the 
following, and click OK:

• Specify a Raster/Vector balance. The higher the setting, the less rasterization is 
performed on artwork. Select the highest setting to represent as much artwork as 
possible using vector data; select the lowest setting to rasterize all the artwork.

• Specify an output resolution for rasterized artwork (except for mesh objects). In most 
cases, 300 is sufficient. The path output resolution affects the precision of intersections 
when flattening. (See “Changing the path output resolution” on page 337.)

• Select Convert All Text to Outlines to ensure that the width of text stays consistent 
during flattening. Enabling this option, however, will cause small fonts to appear 
slightly thicker.

• Select Convert All Strokes to Outlines Strokes to ensure that the width of strokes stays 
consistent during flattening. Enabling this option, however, will cause thin strokes to 
appear slightly thicker.

• Select Clip Complex Regions to ensure that the boundaries between vector artwork 
and rasterized artwork fall along object paths. Selecting this option reduces stitching 
artifacts that result when part of an object is flattened while another part of the object 
remains in vector form. However, selecting this option may result in paths that are too 
complex for the printer to handle.

• Select Preserve Overprints When Possible if you are printing separations and the 
document contains overprinted objects. Selecting this option generally preserves 
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overprint for objects that are not involved in transparency and therefore improves 
performance.

Important: Illustrator always flattens overprinted objects when printing a composite, 
regardless of how you set the Preserve Overprint When Possible option. 

3 If your artwork contains raster-based effects (effects applied using the Effect menu), 
choose Effect > Rasterize > Document Raster Effects Settings. Select High (300ppi) for 
Resolution, and click OK. (See “Specifying raster effects settings” on page 239.)

For more information on transparency, flattening, and high-resolution output, 
see www.adobe.com. 

Changing the path output resolution
Curves in artwork are defined by the PostScript interpreter as small line segments; 
and the smaller the line segments, the more accurate the curve. However, when small line 
segments are used to draw a curve, the total number of line segments increases, thereby 
increasing the complexity of the curve. If a curve is too complex for a PostScript interpreter 
to rasterize, a PostScript error can result, and the curve won’t print. 

The output resolution determines the flatness of the curve: A lower output resolution 
results in greater flatness, and thus longer and fewer line segments. Using a lower output 
resolution creates a less accurate curve, but improves printing performance.

Adobe Illustrator prints fastest and best by using a default output resolution setting of 800 
dots per inch (dpi). However, in some cases, you might want to decrease the output 
resolution—for example, if you draw a very long curved path that won’t print due to a 
limit-check error, if printing is slow, or if objects are not being printed at an adequate 
resolution. To avoid or correct the limit-check error, you can split long paths, as described 
in “Splitting paths to print large, complex shapes” on page 341, or you can set the output 
resolution for the document to a lower value. 

To change the output resolution: 

1 Choose File > Document Setup, and choose Printing and Export from the pop-up menu 
at the top of the dialog box.

2 Enter a value in the Output Resolution text box. Recommended values are between 
100 dpi and 300 dpi for printing at 300 dpi, and between 800 and 2400 dpi for printing at 
2400 dpi. The limits are 100 and 9600 dpi.

3 Click OK.

Printing gradients, mesh objects, and color blends
Files with gradients, gradient mesh objects, or color blends can be difficult for some 
printers to print smoothly (without discrete bands of color) or at all. There are ways to 
improve the printed results of gradients, mesh objects, and color blends on such printers. 
You can also improve the way that transparencies are printed. 

Follow these general guidelines:

• Use a blend that changes at least 50% between two or more process color components.

http://www.adobe.com
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• Use shorter blends. The optimum length depends on the colors in your blend, but try to 
keep blends shorter than 7.5 inches. (See “Calculating the maximum blend length 
based on the color change” on page 339.)

• Use lighter colors or make dark blends short. Banding is most likely to occur between 
very dark colors and white. 

• Use an appropriate line screen that retains 256 levels of gray. 

• When the document contains complex artwork, transparencies, gradients, mesh 
objects, or blends, make sure that you have selected the right resolution and Quality/
Speed settings in the Document Setup dialog box. (See “Printing and saving trans-
parent artwork” on page 336.)

Ensuring your resolution/line screen produces 256 grays
In printing your file, you may find that the resolution of your printer, when combined with 
the chosen line screen, allows fewer than 256 levels of gray. A higher screen frequency 
decreases the levels of gray available to the printer. (For example, if you are printing at a 
resolution of 2400 dpi, using a line screen higher than 150 results in fewer than 256 levels 
of gray.)

The following table lists the maximum line screens you can use with printers to maintain 
all 256 levels of gray:

Final Imagesetter 
Resolution

Maximum Line 
Screen to Use

300 19

400 25

600 38

900 56

1000 63

1270 79

1446 90

1524 95

1693 106

2000 125

2400 150

2540 159

3000 188

3252 203

3600 225

4000 250
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Calculating the maximum blend length based on the color 
change
Adobe Illustrator calculates the number of steps in a gradient based on the percentage of 
change between the colors in the gradient. The number of steps, in turn, determines the 
maximum length of the blend before banding occurs. 

The gradient’s number of steps and maximum length assume that you are printing the file 
with a line screen and resolution that produce 256 levels of gray.

To determine the maximum blend length based on the color change:

1 Select the measure tool , and click the beginning point and the endpoint of the 
gradient.

2 Note the distance displayed in the Info palette on a piece of paper. This distance repre-
sents the length of the gradient or color blend.

3 Calculate the number of steps in the blend using this formula:

Number of steps = 256 (number of grays) X Percentage change in color

To figure out the percentage change in color, subtract the lower color value from the 
higher color value. For example, a blend between 20% black and 100% black is an 80%—
or 0.8—change in color. 

When blending process colors, use the largest change between the colors. For instance, 
a blend from 20% cyan, 30% magenta, 80% yellow, and 60% black to 20% cyan, 90% 
magenta, 70% yellow, and 40% black indicates a 60% change, because the greatest 
change occurs in magenta, from 30% to 90%.

4 Using the number of steps calculated in step 3, see if the length of the gradient is larger 
than that indicated in the chart. If it is, reduce the length of the gradient or change the 
colors.

Number of Steps 
Adobe Illustrator 
Recommends

Maximum Blend Length

Points Inches Cms

10 21.6 .3 .762

20 43.2 .6 1.524

30 64.8 .9 2.286

40 86.4 1.2 3.048

50 108.0 1.5 3.810

60 129.6 1.8 4.572

70 151.2 2.1 5.334

80 172.8 2.4 6.096

90 194.4 2.7 6.858

100 216.0 3.0 7.620

110 237.6 3.3 8.382
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Using the Compatible Gradient and Gradient Mesh Printing 
option
Some printers have difficulty printing gradients and gradient mesh objects. For example, 
gradients may print with a banding effect on older PostScript Level 2 devices. In addition, 
gradient mesh objects may print incorrectly to some PostScript 3 devices. The Compatible 
Gradient and Gradient Mesh Printing option enables such printers to print your files by 
converting the objects to JPEG format. 

Important: Use this option only with files that contain gradients and gradient mesh 
objects that will be printed on devices that have difficulty printing such files. This option 
can slow printing on printers that don’t have problems with gradients.

To improve gradient printing:

1 Choose File > Document Setup. Then choose Printing & Export from the pop-up menu 
at the top left of the Document Setup dialog box.

2 Select the Compatible Gradient and Gradient Mesh Printing option. Click OK.

120 259.2 3.6 9.144

130 280.8 3.9 9.906

140 302.4 4.2 10.668

150 324.0 4.5 11.430

160 345.6 4.8 12.192

170 367.2 5.1 12.954

180 388.8 5.4 13.716

190 410.4 5.7 14.478

200 432.0 6.0 15.240

210 453.6 6.3 16.002

220 475.2 6.6 16.764

230 496.8 6.9 17.526

240 518.4 7.2 18.288

250 540.0 7.5 19.050

256 553.0 7.7 19.507

Number of Steps 
Adobe Illustrator 
Recommends

Maximum Blend Length

Points Inches Cms
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Printing mesh objects
Since all but the most complex mesh objects are printed as vector objects when printing 
to a PostScript Level 3 printer, you can usually optimize printing results by printing to a 
Level 3 printer. However, when printing transparent mesh objects, or when printing to a 
Level 2 printer, the mesh objects are written both as a vector object as well as a JPEG 
image. The resolution of the JPEG image is determined by the Mesh setting in the 
Document Setup dialog box. (See “Printing and saving transparent artwork” on page 336.) 

Note: Even if you are printing to a Level 3 printer, printing may be delayed if the PostScript 
field in the Print dialog box is set to Level 2. Therefore, when printing to a Level 3 printer 
only, you can optimize the speed by setting the PostScript field to Level 3.

Improving gradient printing on low-resolution printers
When a gradient fill is applied to an object, Illustrator uses the printer’s default screen. 
If you turn off the printer’s default screen in the Printing & Export panel of the Document 
Setup dialog box, Illustrator uses Adobe screens to enhance the output of gradients when 
printing to low-resolution printers (600 dpi and less) that support fewer than 256 gray 
levels. On some low-resolution printers, turning off the Use Printer’s Default Screen option 
may improve the output quality of gradients, gradient meshes, and raster images.

Note: Do not turn off Use Printer’s Default Screen if you want to use a printer override 
(EPSF Riders) file.

To turn off the printer’s default screen, with low-resolution printers:

1 Choose File > Document Setup. Then choose Printing & Export from the pop-up menu 
at the top left of the Document Setup dialog box.

2 Deselect Use Printer’s Default Screen, and click OK.

Splitting paths to print large, complex shapes
If you are printing Adobe Illustrator files containing overly long or complicated paths, 
the file may not print and you may receive limit-check error messages from your printer. 
To simplify paths, you can split long, complex paths into two or more separate paths using 
Split Long Paths in the Printing & Export panel of the Document Setup dialog box. 

When Split Long Paths is selected, the Adobe Illustrator program checks whether a closed 
path is too long to print whenever you save or print an image. If the path length exceeds 
what the printer’s memory can handle, Illustrator breaks the closed path into pieces 
represented on-screen by lines through the path. These lines appear only in Outline view; 
they do not preview or print. The image previews and prints as if the paths were joined.

Keep the following in mind when using Split Long Paths: 

• It’s a good idea to save a copy of your original artwork before splitting paths. That way, 
you still have the original, unsplit file to work with if needed. 

• Illustrator treats split paths in the artwork as separate objects. To change your artwork 
once paths are split, you must either work with the separate shapes or rejoin the paths 
to work with the image as a single shape. 

• Split Long Paths has no effect on stroked paths or compound paths. When you use Split 
Long Paths on an object that is both filled and stroked, the object is split into two 
objects.
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To split long paths:

1 Choose File > Document Setup. Then choose Printing & Export from the pop-up menu 
at the top left of the Document Setup dialog box.

2 Select Split Long Paths, and click OK. Illustrator splits paths as needed when you print or 
save the file.

To split a stroked path:

Split the path with the scissors tool.

To split a compound path:

1 Choose Object > Compound Paths > Release to remove the compound path.

2 Break the path into pieces using the scissors tool.

3 Redefine the pieces as compound paths. 

To split a mask:

1 Choose Object > Clipping Mask > Release to remove the mask.

2 Break the path into pieces using the scissors tool.

3 Redefine the pieces as masks. 

To rejoin a split path:

1 Delete any extra lines created with Split Long Paths by selecting the lines and pressing 
Delete.

2 Select all of the split paths that made up the original object.

3 Choose Window > Pathfinder and click the Add to Shape Area button in the Pathfinder 
palette. The path is rejoined, with an anchor point placed at each intersection where a split 
path was reconnected.

Using a printer override (EPSF Riders) file
The EPSF Riders file sets the screen frequency, angle, spot function, and flatness for all files, 
or adds an annotation or an error handler message to all files. The settings you specify in 
the EPSF Riders file override any settings you specified using the Separation Setup dialog 
box. Before you can create an EPSF Riders file, you must move the EPSF Riders plug-in into 
the Plug-ins folder.

The Make Riders filter creates an Adobe Illustrator EPSF Riders file. The EPSF Riders file 
contains PostScript code that, when added to an Adobe Illustrator file, overrides how a file 
prints. The Delete Riders filter removes the EPSF Riders file from your system. Only one file, 
named EPSF Riders, is created when you choose the Make Riders filter. You cannot create 
multiple Riders files, and you must not change the name of the EPSF Riders file. 

To use the EPSF Riders plug-in:

1 Move the Riders plug-in into the Plug-ins folder. The Riders plug-in is located in the 
Riders Folder, within the Utilities folder.

2 Once you have moved the Riders plug-in to the Plug-ins folder, quit Illustrator and then 
restart the program. Restarting the program acknowledges the presence of the Riders 
plug-in the Plug-ins folder. 
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Once the Riders plug-in is in your directory or Plug-ins folder and you have created an 
EPSF Riders file, all files saved or printed from Illustrator are affected. To remove the EPSF 
Riders information from your files, you can either delete the Adobe Illustrator EPSF Riders 
file or move it out of the Plug-ins folder, and then resave all the files that contain the 
embedded Riders information. 

To create an EPSF Riders file:

1 Choose Filter > Other > Make Riders.

Note: If you haven’t moved the Riders plug-in into the Plug-ins folder, the Other category 
does not appear in the Filter menu. If necessary, follow the steps in the previous section to 
move the Riders plug-in into the correct location. 

2 Do any of the following:

• Choose a screen frequency, or line screen, to designate the number of rows of halftone 
dots per inch when printing. The screen frequency value must be between 1 and 999.

• Choose a screen angle to determine the angle at which the rows of halftone dots print. 
(The default setting for black-and-white printing, 45 degrees, is intended to make the 
dot rows less conspicuous to the eye.) The screen angle value must be between 0 
and 360.

• Choose a spot function to determine the halftone dot’s shape. Choose Import from the 
Spot Function pop-up menu to select and import a spot function.

Important: An imported spot function must be in PostScript language, correctly 
formatted. Importing an incorrectly formatted spot function can make a file unprintable. 
See the Spot Function Template file, located in the Utilities/Riders folder.

• Choose a flatness setting to simplify complex paths. The Riders flatness setting must be 
between 0.2 and 200 and is applied to all curves in an Illustrator file. 

Note: The Riders flatness setting overrides the output resolution setting and is not recom-
mended in most cases. (See “Changing the path output resolution” on page 337.)

• Choose Setup from the Annotation pop-up menu, and enter an annotation of up to 
254 characters. The annotation appears at the bottom left corner of the printed page.

• Choose Error Handler to print error information on the page if a PostScript error occurs. 
If you are using the Adobe PSPrinter™ or the LaserWriter 8.0 or later printer driver, turn 
on the printer driver’s error handling instead of the Riders’ error handler.

3 When you have selected the options you want, click Make.

Important: Do not rename the EPSF Riders file. (The name Adobe Illustrator EPSF Riders is 
selected by default.) If you change the name, Illustrator ignores the file. 

4 Save the EPSF Riders file in the Plug-ins folder.

To delete the Riders file:

1 Choose Filter > Other > Delete Rider. 

2 Select the Adobe Illustrator EPSF Riders file.

3 Click Delete.

To move a Riders file:

1 Locate the EPSF Riders file in the Plug-ins folder. 
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2 Move the EPSF Riders file out of the Plug-ins folder. You can move it anywhere, but you 
may want to move it into the Illustrator folder.

3 Quit Adobe Illustrator, then restart the program, and resave all the files that contain 
embedded Riders information. 

File data and annotating objects
The Document Info palette lists general file information and object characteristics, 
as well as the number and names of styles, custom colors, patterns, gradients, fonts, 
and placed art. 

You can use the Note text box in the Attributes dialog box to annotate an object so that it 
can easily be located in the PostScript file with a text editor. This feature can help service 
bureaus or other professionals trying to troubleshoot printing problems.

To use the Document Info palette:

1 If you want information on a particular set of objects, select the objects.

2 Choose Window > Document Info. To view information on only the selected object, 
select Selection Only in the pop-up menu of the palette.

3 Choose from the information screens listed in the Show Info For pop-up menu: 
Document, Objects, Styles, Brushes, Spot Color Objects, Pattern Objects, Gradient Objects, 
Fonts, Linked Images, Embedded Images, and Font Details.

4 To save a copy of the file information as a text file, click Save. 

To annotate an object: 

1 Select the object you want to annotate. 

2 Choose Window > Attributes. 

3 Choose Show Note from the Attributes palette menu; then type the annotation. 

You can enter up to 240 characters in the Note text box. For example, you can enter a short 
description of the object, the creation date, and the name of the creator of the artwork.
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Producing Color Separations

About separations
To produce high-quality separations, it helps to be familiar with the basics of printing, 
including line screens, resolution, process colors, and spot colors.

It is also recommended that you work closely with the print shop that will produce your 
separations, consulting its experts before beginning each job and during the process.

To reproduce color and continuous-tone images, printers usually separate artwork into 
four plates—one plate for each of the cyan, magenta, yellow, and black portions of the 
image. When inked with the appropriate color and printed in register with one another, 
these colors combine to reproduce the original artwork. The process of dividing the image 
into two or more colors is called color separating, and the films from which the plates are 
created are called the separations. 

Outputting to CMYK 
Artwork is separated into CMYK output when you’re preparing an image to be printed 
using the process colors cyan (C), magenta (M), yellow (Y), and black (K). (The letter K is 
used for black to avoid confusion, because B might also stand for blue.) 

Outputting spot colors
You can use custom inks, called spot colors, in addition to or in place of process colors. 
Because a spot color is printed on its own plate, spot colors can often reduce the 
complexity and cost of printing artwork. 

For example, instead of using the four process colors to reproduce artwork consisting of 
black text and bluish-green line drawings, you could use two spot colors—one of black 
and one representing that exact shade of green. In addition, you can use spot color inks to 
produce colors not reproducible by CMYK inks, such as fluorescent and metallic colors.

You can use the Color palette to display the CMYK equivalent of a spot color.

Outputting registration colors
If you want to print a color on all plates in the printing process, including spot color plates, 
you can convert it into a registration color. Registration color is typically used for crop 
marks and trim marks. (See “Setting crop marks and trim marks” on page 335.)

To output registration color:

1 Select the object on which you want to apply registration color.

2 Choose Window > Show Swatches.

3 In the Swatches palette, click the Registration color swatch , located in the first row of 
swatches. The selected objects are converted into registration color objects. 
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4 To change the on-screen appearance of the registration color from the default black, 
use the Color palette.

Note: The color you specify will be used for representing registration-colored objects on 
the screen. These objects will always print as gray on composites and as an equal tint of all 
inks in separations.

Step 1: Calibrate your monitor and check colors in your 
artwork 
Printed colors may not match the colors that were displayed on your monitor. For 
example, an object that looked red on-screen before may now look orange. At this point, 
you need to correct any color problems in your artwork. You also should verify that your 
monitor has been color-calibrated, as described in “Producing Consistent Color” on 
page 174.

If your artwork is color managed, you can preview how the color will appear when repro-
duced on a particular output device. (See “Soft-proofing colors” on page 185.)

Types of colors you can use, and how they are separated
You can paint artwork with process colors, spot colors, or a combination of both. For infor-
mation on your color choices, see “Adding, duplicating, and deleting swatches” on 
page 162 and “Loading colors from other color systems” on page 166.

Printing gradients as separations
A gradient that contains process colors will be separated onto the process plates. 
A gradient that contains two tints of the same spot color will be separated on a single spot 
color plate. To create a gradient that separates on one piece of film between a spot color 
and white, create a gradient fill between the spot color and a 0% tint of the color. 

Note: If you create a gradient between two spot colors, you should assign different screen 
angles to those spot colors in the Separation Setup dialog box. This is because if two spot 
colors have the same screen angle, they will overprint each other. If you’re not sure what 
the angles should be, consult your print shop. (See “Specifying the halftone screen ruling” 
on page 358.)

Step 2: Select overprint options for overlapping colors
If you have not changed the transparency of your artwork with the Transparency palette, 
the fills and strokes in the artwork will appear opaque because the top color knocks out, 
or cuts out, the area underneath. You can prevent knockout by using the Overprint option 
in the Attributes palette to make the topmost overlapping printing ink appear transparent 
in relation to the underlying ink. 

Note: The degree of transparency in printing depends on the ink, paper, and printing 
method used. Consult your print shop to determine how these variables will affect your 
final artwork.

You can see the effects of overprinting by using the Overprint Preview command. When 
the Overprint Preview mode is on, you can see an approximation of how overlapping 
colors will print. (See “Viewing how colors will overprint” on page 15.) 
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You can also set overprinting features using the Overprint Fill or Overprint Stroke options 
in the Attributes palette, as described below. You can also use the Multiply blending mode 
in the Transparency palette (see “About blending modes” on page 196), or the Hard Mix 
command (see “Using the Hard Mix and Soft Mix effects” on page 171). 

After you have set your overprinting options, you should use the Overprint Preview mode 
to see an approximation of how the overprinting colors will print. However, it is important 
that you carefully check overprinted colors on separated artwork using integral or overlay 
proofs.

Colors knocked out by default and Overprint option in the Attributes palette selected

The Filter > Colors > Overprint Black command allows you to set black fill or black stroked 
lines to overprint (or, alternatively, to remove overprinting commands from black fill or 
black stroked lines).

You may want to overprint in the following situations:

• Overprint 100% black lines against a color background when the illustration style 
allows.

• Overprint when the artwork does not share common ink colors and you want to create 
a trap or overlaid ink effects. When overprinting process color mixes or custom colors 
that do not share common ink colors, the overprint color is added to the background 
color. For example, if you print a fill of 100% magenta over a fill of 100% cyan, the 
overlapping fills appear violet, not magenta.

To set overprinting on objects:

1 Select the object or objects that you want to overprint. 

Overprint fills 
A. Cyan (bottom) B. Magenta (middle) C. Yellow (top)

2 Choose Window > Show Attributes.

3 Select Overprint Fill.

S  T  A  R  F  I  S  H S  T  A  R  F  I  S  H
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If you use the Overprint option on a 100% black stroke or fill, the black ink may not be 
opaque enough to prevent the underlying ink colors from showing through. To eliminate 
the show-through problem, use a four-color (rich) black instead of a 100% black. Consult 
with your print shop about the exact percentages of color to add to the black.

Appearance of artwork on monitor and printed artwork

To set or remove overprinting from black lines:

1 Select the objects to have overprinting added or removed. You can set overprinting for 
custom colors whose process equivalents contain specific percentages of black or for 
process colors that include black.

2 Choose Filter > Colors > Overprint Black. 

3 In the dialog box, choose Add Black to add overprinting or Remove Black to remove 
overprinting commands. 

4 Enter the percentage of black to indicate which objects have overprinting added or 
removed. For example, enter 80% to select only objects containing 80% black.

5 Choose any of the following options:

• Fill, Stroke, or both options to apply overprinting to filled paths, stroked paths, or both 
types of paths.

• Include Blacks with CMY to apply overprinting to paths painted with cyan, magenta, or 
yellow if the path also contains black at the specified percentage.

• Include Spot Blacks to apply overprinting to custom colors whose process equivalents 
include black at the specified percentage.

Note: If you are overprinting a spot color that contains process colors as well as the 
specified percentage of black, it is necessary to choose both the Include Blacks with CMY 
option and the Include Spot Blacks option. 

6 Click OK.

Step 3: Create a trap to compensate for misregistration on 
press
Misregistration can cause gaps between colors on the final output when colors printed 
from separate plates overlap or adjoin one another. To compensate for potential gaps 
between colors in artwork, print shops use a technique called trapping to create a small 
area of overlap (called a trap) between two adjoining colors.



Using Help | Contents | Index Back 349  

Adobe Illustrator Help Producing Color Separations 

Using Help | Contents | Index Back 349  

You can use a separate, dedicated trapping program to create traps automatically, or you 
can use Illustrator to create traps manually.

Artwork without trap and with trap

Appropriate and inappropriate artwork for Trap command 

About traps
When overlapping painted objects share a common color, trapping may be unnecessary if 
the color that is common to both objects creates an automatic trap. For example, if two 
overlapping objects contain cyan as part of their CMYK values, any gap between them is 
covered by the cyan content of the object underneath.

Note: When artwork does contain common ink colors, overprinting does not occur on the 
shared plate. 

There are two types of trap: a spread, in which a lighter object overlaps a darker 
background and seems to expand into the background; and a choke, in which a lighter 
background overlaps a darker object that falls within the background and seems to 
squeeze or reduce the object. 

Spread: Object overlaps background. Choke: Background overlaps object.

You can create both spreads and chokes in the Adobe Illustrator program. 

It is generally best to scale your graphic to its final size before adding a trap. Once you 
create a trap for an object, the amount of trapping increases or decreases if you scale the 
object. For example, if you create a graphic that has a 0.5-point trap and scale it to five 
times its original size, the result is a 2.5-point trap for the enlarged graphic. 

S  T  A  R  F  I  S  H S  T  A  R  F  I  S  H
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Trapping with tints
When trapping two light-colored objects, the trap line may show through the darker of 
the two colors, resulting in an unsightly dark border. For example, if you trap a light yellow 
object into a light blue object, a bright green border is visible where the trap is created.

To prevent the trap line from showing through, you can specify a tint of the trapping color 
(in this example, the yellow color) to create a more pleasing effect. Check with your print 
shop to find out what percentage of tint is most appropriate given the type of press, inks, 
paper stock, and so on being used.

Trapping type
Trapping type can present special problems. Avoid applying mixed process colors or tints 
of process colors to type at small point sizes, because any misregistration can make the 
text difficult to read. Likewise, trapping type at small point sizes can result in hard-to-read 
type. As with tint reduction, check with your print shop before trapping such type. For 
example, if you are printing black type on a colored background, simply overprinting the 
type onto the background may be enough. 

To trap type, you can add the stroke below the fill in the Appearance palette, and set the 
stroke to overprint (or set it to Multiply blending mode).

Using the Trap command
The Trap command creates traps for simple objects by identifying the lighter artwork—
whether it’s the object or the background—and overprinting (trapping) it into the darker 
artwork.

Note: The Trap command is only available when you are working on CMYK documents.

Function of Trap command 
A. Area of overprint B. Area of knockout C. Background color D. Foreground color

You can apply the Trap command as a Pathfinder command or as an effect. For more infor-
mation on effects, see “Using effects” on page 235. For instructions on using the Stroke 
palette to create a trap with strokes on individual objects, see “Trapping by overprinting” 
on page 352.

A B

C D
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In some cases, the top and bottom objects may have similar color densities so that one 
color is not obviously darker than the other. In this case, the Trap command determines 
the trap based on slight differences in color; if the trap specified by the Trap dialog box is 
not satisfactory, you can use the Reverse Trap option to switch the way in which the Trap 
command traps the two objects.

Light object and dark background: Trap command creates spread. Dark object and light 
background: Trap command creates choke.

To create a trap using the Trap command:

1 Select two or more objects, choose Window > Show Pathfinder, and select Trap from 
the palette’s pop-out menu. 

2 In the Thickness text box, enter a stroke width of between 0.01 and 5000 points. Check 
with your print shop to determine what value to use.

3 Enter a value in the Height/Width% text box to specify the trap on horizontal lines as a 
percentage of the trap on vertical lines. 

Specifying different horizontal and vertical trap values lets you compensate for on-press 
irregularities, such as paper stretch. Contact your print shop for help in determining this 
value. The default value of 100% results in the same trap width on horizontal lines and on 
vertical lines. 

To increase the trap thickness on horizontal lines without changing the vertical trap, set 
the Height/Width value to greater than 100%. To decrease the trap thickness on horizontal 
lines without changing the vertical trap, set the Height/Width value to less than 100%.

Height/Width set to 50% and 200%

4 Enter a Tint Reduction value to change the tint of the trap. The default value is 40%.
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The Tint Reduction value reduces the values of the lighter color being trapped; the darker 
color values remain at 100%. The Tint Reduction value also affects the values of custom 
colors.

With tint reduction value of 100%, trap contains 100% of lighter color. With tint reduction value of 
50%, trap contains 50% of lighter color.

5 Select additional trapping options as required:

• Traps with Process Color if you want to convert spot color traps to equivalent process 
colors. This option creates an object of the lighter of the spot colors and overprints it. 

• Reverse Traps to trap darker colors into lighter colors. This option does not work with 
rich black—that is, black that contains additional CMY inks.

6 Click OK to create a trap on the selected objects. Click Defaults to return to the default 
trapping values.

Trapping by overprinting
For more precise control of trapping and for trapping complex objects, you can create the 
effect of a trap by stroking an object and setting the stroke to overprint.

To create a spread or choke by overprinting:

1 Select the topmost object of the two objects that must trap into each other.

2 In the Stroke box in the toolbox or the Color palette, do one of the following:

• Create a spread by entering the same color values for the Stroke as appear in the Fill 
option. You can change the stroke’s color values by selecting the stroke and then 
adjusting its color values in the Color palette. This method enlarges the object by 
stroking its boundaries with the same color as the object’s fill.

Object stroked with 1-point stroke of fill color 
A. Stroke creates spread trap B. Fill creates knockout C. Area of trap D. Area of knockout

• Create a choke by entering the same color values for the Stroke as appear in the lighter 
background (again, using the Color palette); the Stroke and Fill values will differ. This 
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method reduces the darker object by stroking its boundaries with the lighter 
background color.

3 Choose Window > Show Stroke.

Object stroked with 1-point stroke of background color 
A. Stroke creates choke trap B. Fill creates knockout C. Area of trap D. Area of knockout

4 In the Stroke palette, in the Weight text box enter a stroke width of between 0.6 and 
2.0 points. 

A stroke weight of 0.6 point creates a trap of 0.3 point. A stroke weight of 2.0 points 
creates a trap of 1.0 point. Check with your print shop to determine what value to use.

5 Choose Window > Show Attributes. 

6 Select Overprint Stroke. 

In a spread, the lighter object traps into (overprints) the darker background. In a choke, 
overprinting the stroke causes the lighter background to trap into the darker object.

To trap a line:

1 Select the line to be trapped. 

2 In the Stroke box in the toolbox or the Color palette, assign the stroke a color of white.

3 In the Stroke palette, select the desired line weight.

4 Copy the line, and choose Edit > Paste in Front. The copy is used to create a trap.

5 In the Stroke box in the toolbox or the Color palette, stroke the copy with the desired 
color. 

6 In the Stroke palette, choose a line weight that is wider than the bottom line.

7 Choose Window > Show Attributes.
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8 Select Overprint Stroke for the top line.

Copy of stroke used for spread trap 
A. Top stroke creates spread trap B. Bottom stroke creates knockout C. Area of knockout
D. Area of trap

To trap a portion of an object: 

1 Draw a line along the edge or edges that you want to trap. If the object is complex, use 
the direct-selection tool  to select the edges, copy it, and choose Edit > Paste in Front to 
paste the copy directly on top of the original.

Drop shadow with a trap. The line drawn at the intersection of two shapes creates a trap.

2 In the Stroke box in the toolbox or the Color palette, select a color value for the Stroke 
to create either a spread or a choke.

If you are uncertain about what type of trap is appropriate, see “About traps” on page 349.

3 Choose Window > Show Attributes.

4 Select Overprint Stroke.

Step 4: Set the printing bounding box and place crop 
marks around the image to be separated
You can place crop marks around the image to be separated, either directly on the artwork 
or in the separations. Crop marks indicate the image area. 

Keep these points in mind when creating crop marks for color separations:

• If you are setting crop marks in the original artwork and want the artwork to contain a 
bleed (a margin added to the image so that it can be trimmed after printing), make sure 
that you extend the artwork past the crop marks to accommodate the bleed. 
(See “Specifying the bleed area” on page 362.)

• If you plan to separate several small pieces of artwork in the same file, you can create a 
set of trim marks for each piece of artwork. You might want more than one set, for 
example, if the file contains several business cards that you plan to separate. To create 
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more than one set of trim marks, draw them in the artwork or use the Trim Marks filter. 
See “Setting crop marks and trim marks” on page 335. 

Specifying the printing bounding box in the separation
The printing bounding box is represented as a gray rectangle surrounding the artwork in 
the Separation Setup preview window. The bounding box sets the position of the crop 
marks on your separations and defines the printable boundaries of the artwork, as well as 
nonprintable boundaries such as direction lines. 

You can define the printing bounding box either by using the Object > Crop Marks > Make 
command, or by using the Separations Setup dialog box to set the bounding box at the 
artwork boundaries. You can also modify the current bounding box dimensions in the 
Separations Setup dialog box.

The numbers in the Margins text boxes show where the image lies within the page. These 
numbers measure the distance from the 0,0 point in the imageable area to the edges of 
the bounding box. The 0,0 point is in its default position at the bottom left corner of the 
page boundary.

If you select a different page size, the margin numbers change as Illustrator calculates the 
distance of the bounding box from the edge of a new page size. 

Note: The Margins numbers for a given page size (such as Letter) may vary by PPD file. This 
is because printers and imagesetters may differ in how they define the size of an 
imageable area.

To specify the printing bounding box using crop marks:

1 Do one of the following:

• Draw a rectangle to define a customized printing bounding box, and then select the 
rectangle.

• Choose Edit > Deselect All to set the printing bounding box around the artboard.

2 Choose Object > Crop Marks > Make. 

To define the printing bounding box boundary using the Separation Setup 
dialog box:

1 Do not set any crop marks in the document, or remove existing crop marks by choosing 
Objects > Crop Marks > Release. If the existing crop marks were created using a rectangle, 
delete that rectangle.

2 Choose File > Separation Setup. The printing bounding box is placed by default as 
tightly as possible around all the artwork.

To modify the existing printing bounding box:

1 In the Separation Setup dialog box, do one of the following:

• Enter values in the Left, Right, Top, and Bottom margin text boxes. Press Tab to go to the 
next text box.

• Drag any of the size handles in the preview.

• Select Revert to cancel any changes and revert to the previous bounding box settings.

2 Specify another separation option, or click OK.
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Specifying printer’s marks
When you prepare artwork for printing, a number of marks are needed for the printer to 
register the artwork elements precisely and verify correct color. These marks include 
elements such as crop marks, registration marks, star targets, calibration bars, and labels. 
The Separation Setup dialog box enables you to add these marks to your separations. 

Printer’s marks 
A. Star target B. Label (film only) C. Registration marks D. Black overprint color bar
E. Crop mark F. Gradient tint bar G. Progressive color bar

In Illustrator, the printer’s marks are either turned on or turned off. You cannot choose 
individual marks to be placed around the artwork. The Use Printer’s Marks option adds the 
following marks to the separations:

Registration marks and star targets Illustrator places around your artwork two types of 
marks that the print shop uses to align the separations: registration marks and star targets. 
Registration marks are the most commonly used marks in printing, because they are easy 
to line up accurately. Star targets are harder than registration marks to align, but they are 
extremely accurate.

Labels Illustrator labels the film with the name of the file, the line screen used, the screen 
angle for the separation, and the color of each particular plate. These labels appear at the 
tops of the images. 

Crop marks Illustrator places crop marks at the edges of the printing bounding box. If the 
Japanese Crop Marks option is selected in the General Preferences dialog box, a double 
set of crop marks is displayed. 

To include printer’s marks on the separations:

1 In the Separation Setup dialog box, select Use Printer’s Marks.

2 Specify another separation option, or click OK.

Step 5: Set separation options
Setting up a separation involves choosing the separation options and then printing or 
saving the file.

C�

M�

Y�

CM�

MY�

CY�

CMY�

K

clownfish.ai      177lpi   45o   1

cyan magenta yellow black

B CA

D E F G



Using Help | Contents | Index Back 357  

Adobe Illustrator Help Producing Color Separations 

Using Help | Contents | Index Back 357  

Preparing a file for separation includes specifying which printer settings and halftone 
screen ruling to use and whether the separation should be a positive or negative image. 
In addition, you can specify a bleed around the artwork.

The separation settings you choose for a file are saved with the separated file. If you open 
a file that has never been separated in Illustrator, the program returns to the default 
settings.

To choose separation options:

1 Choose one of the following options:

• File > Separation Setup.

• File > Print, and then click Separation Setup in the Print dialog box. 

2 Select the PPD file that corresponds to your printer or imagesetter, as described in 
“Selecting a PPD file.” Choose options as described in the rest of that section.

3 Click OK or Print.

Selecting a PPD file
To define the output device for the separation, you select the PostScript Printer Descrip-
tions (PPD) file that corresponds to your PostScript printer or imagesetter. (You cannot 
separate to a non-PostScript device.) 

A PPD file contains information about your output device, including its resolution, 
available page sizes, line screen rulings, and screen angles. Loading the file displays the 
different settings for the output device, in the Separation Setup dialog box.

To select a PPD file:

1 Choose File > Separation Setup. In the Separation Setup dialog box, click Open PPD. 

2 Locate the System folder in the Windows folder (Windows) or the Printer Descriptions 
folder in the Extensions folder within the System Folder (Mac OS).

3 Select a PPD file that corresponds to the output device you use to print your separa-
tions. The filenames correspond to the printer or imagesetter name and model and have a 
.ppd file extension (Windows). 

4 Click Open. The name of the PPD file you selected appears in the dialog box. The name 
of the currently selected printer appears in the title of the dialog box.

5 Choose other separation options as described in the following sections, or click OK.

Specifying which layers to separate
The Layer pop-up menu lets you specify which layers to include in the separation.

To specify which layers to separate:

1 In the Separation Setup dialog box under Options, choose one of the following options 
from the Separate menu:

• Printable, Visible Layers to separate only layers that are both printable and visible. These 
correspond to the layers that print when creating a composite proof.

• Visible Layers to separate only the visible layers.

• All Layers to separate all layers.

2 Specify another separation option, or click OK.



Using Help | Contents | Index Back 358  

Adobe Illustrator Help Producing Color Separations 

Using Help | Contents | Index Back 358  

Specifying which colors to create separations for
In the Separation Setup dialog box, each separation is labeled with the color name that 
Illustrator assigned it. If an icon of a printer  appears next to the color name, Illustrator 
creates a separation for the color. 

To specify whether to create a separation for a color:

1 Do one of the following:

• By default, Illustrator creates a separation for each CMYK color in the art. To create a 
separation, make sure the printer icon is displayed next to the color name in the 
Separation Setup dialog box. 

• To choose not to create a separation, click the printer icon next to the color’s name. 
The printer icon disappears, and no separation is created. 

Separating spot colors as process colors
You can separate spot colors or named colors as equivalent CMYK process colors in the 
Separation Setup dialog box. When spot colors or named CMYK colors are converted to 
their process color equivalents, they are printed as separations rather than on a single 
plate. 

To separate all spot colors as process colors:

In the Separation Setup dialog box, click Convert to Process. (This option is on by default.)

A four-color process icon  appears next to all the spot colors in the artwork. 

To separate individual spot colors as process colors:

1 In the Separation Setup dialog box, deselect Convert to Process.

2 Click the printer icon next to the spot color in the list of colors. A four-color process icon 
appears. 

3 For each spot color you want to convert to a process color, click the printer icon next to 
its name in the list of colors. 

4 Specify another separation option, or click OK.

Specifying the halftone screen ruling
The Halftone menu displays one or more sets of line screens (lines per inch, or lpi) and 
resolutions (dots per inch, or dpi) available on the printer or imagesetter that prints the 
color separations.

A high line-screen ruling (for example, 150 lpi) spaces the dots used to create an image 
closely together to create a finely rendered image on the press; a low screen ruling (60 lpi 
to 85 lpi) spaces the dots farther apart to create a coarser image. The size of the dots is also 
determined by the line screen. A high line-screen ruling uses small dots; a low screen 
ruling uses large dots. The most important factor in choosing a line-screen ruling is the 
type of printing press your job uses. Ask your print shop how fine a line screen its press can 
hold, and make your choices accordingly.
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The PPD files for high-resolution imagesetters offer a wide range of possible line-screen 
rulings paired with various imagesetter resolutions. The PPD files for lower-resolution 
printers typically have only a few choices for line screens, and they are coarser screens of 
between 53 lpi and 85 lpi. The coarser screens, however, give optimum results on lower-
resolution printers. Using a finer screen of 100 lpi, for example, actually decreases the 
quality of your image when a low-resolution printer is used for final output. 

To specify a halftone screen ruling and resolution:

1 In the Separation Setup dialog box, choose one of the following options:

• To select one of the preset halftone screen ruling and printer resolution combinations, 
choose an option from the Halftone pop-up menu.

• To specify a custom halftone screen ruling, select the plate to be customized and then 
enter the lpi value in the Frequency text box and a screen angle value in the Angle 
text box.

Note: The default angles and frequencies are determined by the selected PPD file. Be sure 
to check with your print shop for the preferred frequency and angle before creating your 
own halftone screens.

2 Specify another separation option, or click OK.

Specifying the page size and orientation
Adobe Illustrator normally uses the page size default in the PPD file for the selected 
printer. However, you can change the page size to any of the sizes listed in the PPD file as 
well as specify portrait (vertical) or landscape (horizontal) orientation. Page sizes are listed 
by familiar names (such as Letter) and by dimensions in points. The dimensions shown in 
parentheses after the page size are the limits of the imageable area. The imageable area is 
the total page size less any unprintable border used by the printer or imagesetter. Most 
laser printers cannot print to the exact edge of a page.

If you select a different page size (for example, change from letter to legal), the artwork is 
rescaled in the preview window. This is because the preview window displays the entire 
imageable area of the selected page; when the page size is changed, the preview window 
automatically rescales to include the imageable area.

Note: The imageable area may vary by PPD file, even for the same page size (for example, 
Letter), because different printers and imagesetters define the sizes of their imageable 
areas differently.

Make sure that your page size is large enough to contain your artwork as well as crop 
marks, registration marks, and other necessary printing information. To conserve image-
setter film or paper, however, select the smallest page size that accommodates your 
artwork and necessary printing information.

To specify a page size:

1 In the Separation Setup dialog box, choose an option from the Page Size pop-up menu.

2 Specify another separation option, or click OK.

To specify the orientation of the page:

1 In the Separation Setup dialog box, choose Portrait or Landscape from the Orientation 
pop-up menu.
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2 Specify another separation option, or click OK.

Specifying a custom page size
You can specify a custom page size using the Custom Page Size option in the Page Size 
pop-up menu. This option is available only if you are using a printer that accommodates 
various page sizes, such as a high-resolution imagesetter. The PPD file for a laser printer, for 
example, does not provide this option.

The largest custom page size you can specify depends on the maximum imageable 
area of your imagesetter. Consult the documentation on your specific printer for more 
information.

To specify a custom page size:

1 In the Separation Setup dialog box, choose Custom from the Page Size pop-up menu.

2 Do one of the following:

• To specify the smallest page size needed for your artwork and printer’s marks, click OK 
to accept the default values.

• To specify a page size larger than the default, enter a new width and height in the Width 
and Height fields. Be sure to increase the values; decreasing the default values may clip 
your artwork.

• If desired, change the placement of the page by entering a value in the Offset field. 

In the first illustration, the page placement is off; in the second illustration, Offset shifts the 
pages to the left. 

Page placement 
A. Film B. Page C. Offset

The Offset value specifies the amount of space along the right side of the imageable area. 
For example, entering a value of 30 points in the Offset option moves your page 30 points 
to the left. 

• To rotate your page 90 degrees, select Transverse and click OK. 

A B C
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If your imagesetter can accommodate the longest side of your imageable area, you can 
conserve a considerable amount of film or paper by using Transverse in conjunction with 
Offset. Compare the following examples of an image printed by Adobe Illustrator with 
Transverse on and off. 

Transverse off and film saved with Transverse on 
A. Offset value B. Film saved

When both Offset and Transverse are selected, Offset controls the amount of space 
between the separations. 

Specifying the emulsion
Emulsion refers to the photosensitive layer on a piece of film or paper. Up (Right Reading) 
means that type in the image is readable (that is, “right reading”) when the photosensitive 
layer is facing you. Down (Right Reading) means that type is readable when the photo
sensitive layer is facing away from you. Normally, images printed on paper are printed Up 
(Right Reading), whereas images printed on film are often printed Down (Right Reading). 
Check with your print shop to determine which emulsion direction it prefers.

To tell whether you are looking at the emulsion side or the nonemulsion side (also referred 
to as the base), examine the final film under bright light. One side appears shinier than the 
other. The dull side is the emulsion side; the shiny side is the base.

To specify the emulsion:

1 In the Separation Setup dialog box, choose Up (Right Reading) or Down (Right Reading) 
from the Emulsion pop-up menu. The image flips.

2 Specify another separation option, or click OK.

Specifying the image type
The image options determine the image exposure: negative or positive. Typically, print 
shops require negative film in the United States and positive film in Europe and Japan. 
If you are unsure about which image type to use, consult your print shop. 

To specify the image type:

1 In the Separation Setup dialog box, choose Positive or Negative from the Image 
pop-up menu.

2 Specify another separation option, or click OK.
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Overprinting black in the separation
It can be cheaper and easier to have the print shop overprint black on the press. You can 
choose whether to overprint black when printing or saving selected separations. 

See “Step 2: Select overprint options for overlapping colors” on page 346.

To overprint black in the separation:

1 Under Options in the Separation Setup dialog box, select Overprint Black.

Note: The Overprint Black option works only for objects that have the color black applied 
through values in the K channel. It does not work for objects that appear black because of 
their transparency settings or styles.

2 Specify another separation option, or click OK.

Specifying the bleed area
Bleed is the amount of artwork that falls outside of the printing bounding box, or outside 
the crop marks and trim marks. You can include bleed in your artwork as a margin of 
error—to ensure that the ink is still printed to the edge of the page after the page is 
trimmed or to ensure that an image can be stripped into a keyline in a document. Once 
you create the artwork that extends into the bleed, you can use Illustrator to specify the 
extent of the bleed.

Changing the bleed moves the crop marks farther from or closer to the image; the crop 
marks still define the same size printing bounding box, however.

To specify bleed:

1 Under Options in the Separation Setup dialog box, enter an amount in the Bleed 
text box.

By default, Illustrator applies a bleed of 18 points. This means that the artwork extends 
18 points beyond the crop marks on your film. The maximum bleed you can set is 
72 points; the minimum bleed is 0 points.

The size of the bleed you use depends on its purpose. A press bleed (that is, an image that 
bleeds off the edge of the printed sheet) should be at least 18 points. If the bleed is to 
ensure that an image fits a keyline, it needs to be no more than 2 or 3 points. Your print 
shop can advise you on the size of the bleed necessary for your particular job. 

2 Specify another separation option, or click OK.

Step 6: Print and save separations
When you have completed setting up the separations, you are ready to print or save your 
separations. 

Note: The printer or imagesetter you plan to use to print separations must match the PPD 
file you specified when setting up the separations. If the output device and PPD file don’t 
match, you will receive a warning message.

Saving the file saves the separation setup, the PPD information, and any color conversions 
you have specified in the Separation Setup dialog box.
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To print the separations you selected:

1 Select the separations you want to print, as described in “Specifying which layers to 
separate” on page 357. (For information about placing crop marks with the Separation 
Setup dialog box, see “Setting crop marks and trim marks” on page 335 and “Specifying 
printer’s marks” on page 356.)

2 Choose File > Print, or return to the Print dialog box if it is still open.

3 Choose any print options.

4 Choose a method for selecting the Separate output option:

• On Windows, choose Separate from the Output pop-up menu.

• On Mac OS, choose Adobe Illustrator 10 from the Options pop-up menu. Then choose 
Separate from the Output pop-up menu.

5 Make sure Print to File is deselected, and click OK (Windows) or select Printer from the 
Destination pop-up menu and click Print (Mac OS).

To save the separations you selected as a PostScript file:

1 Select the separations you want to save, as described in “Specifying which layers to 
separate” on page 357.

2 Choose File > Print, or return to the Print dialog box if it is still open.

3 Choose any print options.

4 Choose a method for selecting the Separate output option:

• Choose Separate from the Output pop-up menu (Windows).

• Choose Adobe Illustrator 10 from the Options pop-up menu. Then choose Separate 
from the Output pop-up menu (Mac OS).

5 Select the Print to File option (Windows) or choose File from the Destination pop-up 
menu (Mac OS).

6 Do one of the following:

• Click OK and enter a filename in the Print to File dialog box. Then click OK 
again (Windows).

• Accept the default filename or enter another name for the separation and click 
Print (Mac OS).
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Automating Tasks

About automating tasks using actions and scripts
Graphic design is a field characterized by creativity, but aspects of the actual work of illus-
tration and page layout are anything but creative. When you think about the work that 
you do, chances are good you’ll find that you spend most of your time doing the same or 
similar production tasks, over and over again. In fact, you’ll probably notice that the time 
you spend placing and replacing images, correcting errors, and preparing files for printing 
and Web display often reduces the time you have available for doing creative work.

Automating tasks provides an answer to this dilemma. Using actions and scripts, you can 
automate many of the boring, repetitive tasks you have to do, leaving more time to 
concentrate on the creative aspects of your work. An action is a series of tasks that are 
recorded while using the Illustrator application—menu commands, tool options, object 
selection, and so on. When you play an action, Illustrator performs all of the recorded tasks 
for you. A script is a series of commands that tells your computer to perform a sequence of 
operations. These operations may involve only Illustrator, or they may involve other appli-
cations, such as word processing, spreadsheet, and database management programs.

Illustrator provides prerecorded actions and scripts to assist you in performing common 
tasks. Prerecorded actions are installed as a default set in the Actions palette when you 
install the Illustrator application; default scripts appear in the File > Scripts submenu. 

Using the Actions palette
You use the Actions palette to record, play, edit, and delete actions. It also lets you save, 
load, and replace action sets. 

Actions palette 
A. Toggles item on or off B. Toggles modal control on or off C. Set D. Action E. Recorded 
command F. Stop playing/recording G. Begin recording H. Play current selection I. Create new 
set J. Create new action K. Delete selection

Displaying the Actions palette Choose Window > Actions.

Expanding and collapsing sets and commands Click the triangle to the left of the set or 
command in the Actions palette.
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Displaying actions as buttons Choose Button Mode from the Actions palette menu. 
Choose Button Mode again to return to list view.

Note: You cannot expand and collapse sets and commands when the Actions palette is in 
Button mode.

Creating and recording actions
When you create an action, Illustrator records the commands (including any specified 
values), palettes, and tools you use, in the order you use them.

The following guidelines can help you in designing actions:

• Most, but not all, commands can be recorded. However, you can allow for commands 
that cannot be recorded. (See “Inserting nonrecordable commands” on page 367.)

• Nonrecordable commands include those that change your view of the screen 
(including most commands in the View menu), commands that display or hide palettes, 
and commands in the Effect menu. Also, tools such as the gradient and mesh tools, 
eyedropper, paint bucket, and scissors are not recordable.

• When recording an action, keep in mind that playback results depend on such variables 
as the current fill and stroke colors, and on file and program settings. 

Because Illustrator executes the commands as you record them, it’s a good idea to 
record a complicated action using a copy of a file, and then play the action on the 

original.

• Until you specifically save a set of actions with the Save Actions command, actions are 
automatically saved in the preferences file. For information on this file, see “Setting 
preferences” on page 20.

To create a new action:

1 Open a file.

2 In the Actions palette, click the New Action button , or choose New Action from the 
palette menu.

3 Enter a name for the action.

4 If the Actions palette contains multiple sets of actions, choose the set to which you 
want to add the action. (See “Organizing sets of actions” on page 373.)

5 If desired, set one or both of the following options:

• Assign a keyboard shortcut to the action. You can choose any combination of a 
Function key, the Ctrl key (Windows) or Command key (Mac OS), and the Shift key (for 
example, Ctrl+Shift+F3).

Note: If you assign an action the same shortcut that is used for a command, the shortcut 
will apply the action rather than the command.

• Assign a color for display in Button Mode.

6 Click Record. The Begin Recording button in the Actions palette turns red.

Pressing Alt (Windows) or Option (Mac OS) and clicking the Create New Action button 
creates an action and begins recording.
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7 To guard against mistakes, record the File > Save a Copy command at the beginning of 
the action.

8 Choose commands as you want them recorded. 

If the command you choose opens a dialog box, clicking OK records the command and 
clicking Cancel does not record it. If a chosen command is not recorded, it must be 
inserted in the action. (See “Inserting nonrecordable commands” on page 367.)

Note: You cannot record setting optimization options for multiple slices in the Save for 
Web dialog box. Set the slice optimization options before you start recording the action, 
then press Alt (Windows) or Option (Mac OS) and click Remember in the Save for Web 
dialog box. When you record the action, Illustrator will remember the settings.

9 Stop recording by clicking the Stop Playing/Recording button.

10 If you want to keep the action for use in future work sessions, save the action. 
(See “Organizing sets of actions” on page 373.)

Recording paths
The Insert Selected Path command lets you record a path as part of an action. When 
played back, the entire path is reproduced as part of the action.

To record a path:

1 Start recording an action.

2 Select a path.

3 Choose Insert Select Path from the Actions palette menu.

Selecting an object during an action
The Select Object command lets you select a particular object during the course of an 
action. You identify the object to be selected using the Note text box in the Attributes 
palette. The Select Object function is useful for choosing a particular object during an 
action on which to perform commands, use palettes, or make selections in dialog boxes. 
For example, you could pick a specific ellipse in the artwork on which to perform transfor-
mation effects such as scale or rotate, change stroke characteristics using the Stroke 
palette, or apply colors with the Color palette. 

To name an object for use during an action:

1 Select the object to be used in the action.

2 Choose Window > Attributes.

3 Choose Show Note from the pop-up menu in the Attributes palette.

4 Type a name for the object in the Note text box. The object now can be used in an 
action sequence.

To select an object during an action:

1 Record an action, as described in “Creating and recording actions” on page 365, up to 
the point where the object is to be selected.

2 Choose Select Object from the pop-up menu in the Actions palette.

3 Enter the object name in the Set Selection dialog box. (The name should match the 
object name entered in the Note text box of the Attributes dialog box.)
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4 Set the following options in the Set Selection dialog box:

• Select Case Sensitive to select only objects that exactly match the uppercase or 
lowercase words in their Note text.

• Select Whole Word to select only objects whose names match every word listed in the 
Note text box associated with the object.

5 Click OK and continue recording the actions.

Inserting nonrecordable commands
The painting tools, tool options, effects, view commands, and preferences cannot be 
recorded. However, many commands that cannot be recorded can be inserted into an 
action using the Insert Menu Item command. 

An inserted command is not executed until the action is played. No values for the 
command are recorded in the action, so the file remains unchanged when the command 
is inserted. If the command has a dialog box, the dialog box appears during playback, and 
the action pauses until you click OK or Cancel. You can insert a command when recording 
an action or after it has been recorded.

To insert a menu item in an action:

1 Choose where to insert the menu item in the Actions palette:

• Select an action’s name to insert the item at the end of the action.

• Select a command to insert the item after the command. 

2 Choose Insert Menu Item from the Actions palette menu.

3 Do one of the following:

• Choose a command from its menu.

• Enter a command in the Insert Menu Item dialog box. If you don’t know the full name of 
the command, enter part of it and click Find. You can also use the Tab key to find the 
command.

4 Click OK.

Inserting stops
You may want to include a stop in your action so that you can perform a task that cannot 
be recorded. Once you’ve performed the task, you can then continue by clicking the Play 
Current Selection button in the Actions palette. 

You can also display a short message when the action reaches the stop. For example, you 
can remind yourself what you need to do before continuing with the action. A Continue 
button can be included in the message box. This way you can check for a certain condition 
in the file (for example, a selection) and continue if nothing needs to be done. You can 
insert a stop when recording an action or after it has been recorded.

To insert a stop:

1 Choose where to insert the stop in the Actions palette:

• Select an action’s name to insert the stop at the end of the action.

• Select a command to insert the stop after the command. 

2 Choose Insert Stop from the Actions palette menu.
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3 Type the message you want to appear. 

4 If you want the option to continue the action without stopping, select Allow Continue.

5 Click OK. 

Setting modal controls and excluding commands
After recording an action, you can insert a modal control. This lets you pause a command 
to display its dialog box and specify different values, and to manipulate a modal tool to 
apply new settings. (A modal tool requires pressing Enter or Return to apply its effect.)

If you do not use a modal control, Illustrator runs the command using the values specified 
when you first recorded the action (and the dialog box does not appear). 

You can also exclude commands that you don’t want to include as part of a recorded 
action or that you don’t want to play when running the action.

To set a modal control:

1 Make sure that the Actions palette is in list view. (If necessary, deselect Button Mode in 
the Actions palette menu.) 

2 Do one of the following:

• Click the column to the left of the command name to display the dialog box icon. Click 
again to remove the modal control.

• To turn on or disable modal controls for all commands in an action or set, click the 
column to the left of the action or set name.

To exclude or include a command:

Do one of the following: 

• Click to clear the check mark to the left of the command name. Click again to include 
the command.

• To exclude or include all commands in an action or set, click the check box to the left of 
the action or set name.

• To exclude or include all commands except the selected command, Alt-click (Windows) 
or Option-click (Mac OS) the command.

Playing actions
When you play an action, Illustrator executes the series of commands as you recorded 
them. But you can begin with any command, exclude commands, or play a single 
command in an action. If you have inserted a modal control in your action, you can specify 
values in a dialog box or reapply a modal tool (any tool that requires you to press Enter or 
Return to apply it) when the action pauses. (See “Setting modal controls and excluding 
commands” on page 368.)

In button view, clicking a button executes the entire action—though commands previ-
ously excluded are not executed. 

To play an action or set on a single file:

1 Open the file.
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2 Specify what to play:

• To play a set of actions, select the set name.

• To play a single action, select the action name.

• To play only part of an action, select the command from which you want the action 
to start.

3 To exclude or include a command within an action from playing, click the check box to 
the left of the action name. 

4 Click the Play Current Selection button in the Actions palette or choose Play from the 
pop-up menu.

To play a single command in an action:

1 Select the command you want to play.

2 Do one of the following:

• Ctrl-click (Windows) or Command-click (Mac OS) the Play Current Selection button in 
the Actions palette.

• Hold down Ctrl (Windows) or Command (Mac OS), and double-click the command.

Slowing actions during playback
Sometimes a long, complicated action does not play properly, but it is difficult to tell 
where the problem occurs. The Playback Options command gives you three speeds at 
which to play actions, so that you can watch each command as it is carried out.

To specify how fast actions should play:

1 Choose Playback Options from the Actions palette pop-up menu.

2 Specify a speed:

• Accelerated to play the action at normal speed (the default).

• Step by Step to complete each command and redraw the image before going on to the 
next command in the action.

• Pause and enter the amount of time Illustrator should pause between carrying out each 
command in the action.

3 Click OK.

Batch processing
The Batch command lets you play an action on a folder of files and subfolders. You can also 
use the Batch command to populate a template with different sets of data. (See “About 
data-driven graphics” on page 285.)

When batch processing files, you can leave all the files open, close and save the changes to 
the original files, or save modified versions of the files to a new location (leaving the 
originals unchanged). If you are saving the processed files to a new location, you may 
want to create a new folder for the processed files before starting the batch.

To batch process files:

1 Choose Batch from the Actions palette menu.
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2 For Set, choose the desired set.

3 For Action, choose the desired action.

4 For Source, choose an option:

• Folder to play an action on files (including subfolders) already stored on your computer. 
Click Choose to specify a folder. Select Override Action “Open” Commands to open the 
files from the specified folder. (Any Open commands recorded as part of the original 
action are ignored.) Select Include All Subdirectories to process all files and folders 
within the specified folder.

• Data Sets to play an action once for each data set in the current file. (See “Using data 
sets” on page 290 and “Loading and saving variable libraries” on page 291.)

5 For Destination, choose an option:

• None to leave the files open without saving changes (unless the action included a Save 
command).

• Save and Close to save the files in their current location. This option is only available if 
you chose Folder for Source.

• Folder to save the altered files to another location. Click Choose to specify the desti-
nation folder. This option is only available if you chose Folder for Source.

Saving files using the Batch command options always saves the files in the same 
format as the original files. To create a batch process that saves files in a new format, 

record the Save As or Save a Copy command, followed by the Close command, as part of 
your original action. Then choose None for the Destination when setting up the batch 
process.

6 If the action contains any save or export commands, set override options:

• Override Action “Save” Commands to save the processed files in the specified desti-
nation folder and not to a location recorded in the action. Click Choose to specify the 
destination folder.

• Override Action “Export” Commands to export the processed files to the specified desti-
nation folder and not to a location recorded in the action. Click Choose to specify the 
destination folder. 

7 If you chose Data Sets for Source, select option for generating file names when 
overriding save and export commands:

• File + Number to generate the file name by taking the original document’s file name, 
removing any extension, and then appending a three digit number corresponding to 
the data set. 

• File + Data Set Name to generate the file name by taking the original document’s file 
name, removing any extension, and then appending an underscore and the name of 
the data set. 

• Data Set Name to generate the file name by taking the name of the data set. 

8 For Errors, choose an option:

• Stop for Errors to suspend the batch process until you confirm the error message.
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• Log Errors to File to record each error in the file without stopping the batch process. If 
errors are logged to this file, a message appears after files are processed, alerting you to 
review the error file. If you select this option, click Save As, and name the error file. 

To batch process using multiple actions, create a new action, and record the Batch 
command for each action you want to use. This technique also lets you process 

multiple folders in a single batch. To batch process multiple folders, create aliases within a 
folder to the other folders you want to process.

Editing actions
You can edit actions in the following ways:

• Rearrange actions, or rearrange commands within an action and their order of 
execution. 

• Add commands to an action.

• Record new commands or new values for actions with dialog boxes.

• Change action options such as the action name, button color, and shortcut key. 

• Duplicate actions and commands. This helps you experiment with changing an action 
without losing the original version, and for creating an action based on an existing one.

• Delete actions and commands.

• Reset the actions to the default list.

To move an action to a different set:

In the Actions palette, drag the action to a different set. When the highlighted line appears 
in the desired position, release the mouse button.

To rearrange commands within an action:

In the Actions palette, drag the command to its new location within the same action. 
When the highlighted line appears in the desired position, release the mouse button.

To record additional commands:

1 Do one of the following:

• Select the action name to insert the new command at the end of the action.

• Select a command in the action to insert the command after it.

2 Click the Begin Recording button on the Actions palette.

3 Record the additional commands.

4 Click the Stop Playing/Recording button to stop recording.

Note: You can also insert nonrecordable commands or drag commands from other 
actions. (See “Inserting nonrecordable commands” on page 367.)

To record an action again:

1 Select an action and choose Record Again from the Actions palette menu.

2 If a modal tool appears, do one of the following:

• Use the tool differently, and press Enter or Return to change the tool’s effect.
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• Press Enter or Return to retain the same settings.

3 If a dialog box appears, do one of the following:

• Change the values and click OK to record them.

• Click Cancel to retain the same values. 

To record a single command again:

1 Select an object of the same type for which you want to rerecord the action. 
For example, if a command is only available for vector objects, then you must have a 
vector object selected when you rerecord.

2 In the Actions palette, double-click the command. 

3 Enter the new values, and click OK.

To change action options:

1 Do one of the following:

• Double-click the action name.

• Select the action, and choose Action Options from the Actions palette menu.

2 If desired, type a new name for the action, choose a color for the action button, assign a 
Function key and select the Shift or Ctrl key (Windows) or the Command key (Mac OS) to 
combine with the function key for an action shortcut.

3 Click OK.

To duplicate a set, action, or command:

Do one of the following:

• Select a single set, action, or command. You can Shift-click or Ctrl-click (Windows) or 
Command-click (Mac OS) to select multiple items. Then choose Duplicate from the 
Actions palette menu. The copied sets appear at the bottom of the Actions palette. 
The copied commands or actions appear after the original command or action.

• Drag an action or command to the Create New Action button at the bottom of the 
Actions palette, or drag a set to the Create New Set button at the bottom of the Actions 
palette. The copied action appears at the bottom of the Actions palette. The copied 
command appears after the original command. The copied set appears after the 
original set.

To delete a set, action, or command:

1 In the Actions palette, select the set, action, or command you want to delete. You can 
Shift-click, or Ctrl-click (Windows) or Command-click (Mac OS) to select multiple 
commands within an action.

2 Do one of the following:

• Click the Delete button on the Actions palette. Click OK to delete the action or 
command.

• Drag the selection to the Delete button on the Actions palette.

• Choose Delete from the Actions palette menu.
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To delete all actions:

Choose Clear Actions from the Actions palette menu. Click OK to delete all the actions.

To delete a selected action or command automatically, Alt-click (Windows) or 
Option-click (Mac OS) the Delete Selection button.

To reset actions to the default set:

1 Choose Reset Actions from the Actions palette menu.

2 Click Append to add the set of default actions to the current actions in the Actions 
palette, or OK to replace the current actions in the Actions palette with the default set.

Organizing sets of actions
To help you organize your actions, you can create sets in which to place them and save the 
sets to disk. You can organize sets of actions for different types of work—for example, print 
publishing and online publishing—and transfer sets to other computers. You can save 
only the entire contents of the selected set in the Actions palette, not individual actions.

Note: Unsaved actions are automatically saved to the preferences file. If this preferences 
file is lost or removed, any unsaved actions you may have created will be lost. Be sure to 
use the Save Actions command in the Actions palette to save your actions to a separate 
actions file so you can load them later, and to keep them safe.

Replacing a saved set of actions replaces all existing actions. Loading a saved set adds to 
existing actions, with new ones appearing at the bottom of the Actions palette.

To create a new set for actions:

1 In the Actions palette, do one of the following:

• Choose New Set from the pop-up menu.

• Click the Create New Set button at the bottom of the Actions palette.

2 Enter the name of the set and click OK.

To rename a set of actions:

1 In the Actions palette, do one of the following:

• Double-click the name of the set in the Actions palette.

• Select the name of the set and choose Set Options from the pop-up menu.

2 Enter the name of the set, and click OK.

To save a set of actions:

1 Select a set.

2 Choose Save Actions from the Actions palette menu.

3 Type a name for the set, choose a location, and click Save. The default actions set is 
saved in the Presets/Action Sets folder within the Adobe Illustrator application folder.

To replace all actions in the Actions palette with a new set of actions:

1 Choose Replace Actions from the Actions palette menu.

2 Locate and select an actions file.
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3 Click Open.

Important: Using the Replace Actions command will replace all sets of actions in the 
current document. Before using the Replace Actions command, you should make sure that 
you have already saved a copy of your current set of actions using the Save Actions 
command.

To load a set of actions:

1 Choose Load Actions from the Actions palette menu.

2 Locate and select the actions file.

3 Click Open.

Using scripts
When you execute a script, your computer performs a sequence of operations. These 
operations may involve only Illustrator, or they may involve other applications, such as 
word processing, spreadsheet, and database management programs. Illustrator ships with 
a standard set of scripts, but you can also add new scripts. 

If you’re familiar with the JavaScript, AppleScript (Mac OS), or Visual Basic programming 
languages, you can create scripts for use in Illustrator. (See the scripting documentation 
on the Illustrator CD.) Illustrator recognizes the following types of scripts: JavaScript files 
(text files with the .js extension), AppleScript files and OSA scripts (compiled scripts or 
applets with the .scpt extension), Visual Basic scripts (executable files with the .exe 
extension), and VB Scripts (text files with the .vbs extension).

To execute a script:

Do one of the following:

• Choose File > Scripts, and choose a script from the submenu. 

• Choose File > Scripts > Browse, and navigate to the script you want to execute. 

To install a script:

Copy the script to your computer’s hard disk. 

If you place the script in the Presets/Scripts folder inside the Adobe Illustrator application 
folder, the script will appear in the File > Scripts submenu. If you place the script in another 
location on your hard disk, you can execute the script in Illustrator using the File > 
Scripts > Browse command.

Note: If you edit a script while the Illustrator application is open, you must save your 
changes for the changes to take effect. If you place a script in the Scripts folder while the 
Illustrator application is running, you must relaunch Illustrator for the script to appear in 
the Scripts menu.
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Using Graphs

About graphs
Adobe Illustrator graph tools let you create nine different graph types:

Column The default graph type. It compares one or more sets of values by using 
rectangles whose lengths are proportional to the values.

Stacked column Similar to a column graph, but stacks the columns on top of one 
another, instead of side by side. This graph type is useful for showing the relationship of 
parts to the total.

Bar Similar to a column graph, but positions the rectangles horizontally instead of 
vertically.

Stacked bar Similar to a stacked column graph, but stacks the bars horizontally instead 
of vertically.

Line Uses points to represent one or more sets of values, with a different line joining the 
points in each set. This type of graph is often used to show the trend of one or more 
subjects over a period of time.

Area Similar to a line graph, but emphasizes totals as well as changes in values. 

Scatter Plots data points as paired sets of coordinates along the x and y axes. Scatter 
graphs are useful for identifying patterns or trends in data. They also can indicate whether 
variables affect one another. 

Pie A circular graph whose wedges represent the relative percentages of the values 
compared.

Radar Compares sets of values at given points in time or in particular categories, and is 
displayed in a circular format. This type of graph is also called a web graph. 

For a gallery demonstrating the use of graph tools, see “Toolbox overview (4 of 5)” on 
page 10. 

Working with graphs
Once you create a graph, you can customize it by using colors and designs, and you can 
select options for the type. Each time you change the graph data, the graph is updated. 
However, certain graph options—such as font size and column markers—revert to their 
defaults if you change the graph data.

Graphs are created as grouped objects. You can select elements of a graph with the direct-
selection and group-selection tools, and you can change the elements. However, if you 
ungroup a graph, you cannot change the graph’s type or modify the graph’s data. 
(See “Selecting parts of a graph” on page 388.)
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To create a graph:

1 Do one of the following:

• To create a graph using the current settings, select a graph tool .

• To set graph options before creating the graph, double-click a graph tool. In the Graph 
Type dialog box, select options and click OK. (See “Selecting graph options” on 
page 381.)

2 Create the graph:

• Drag diagonally from the corner where you want the graph to begin to the opposite 
corner. Hold down Alt (Windows) or Option (Mac OS) to drag from the center of the 
graph.

• Click the graph tool in the artwork where you want to create the graph, and then 
specify the dimensions for the graph in the Graph dialog box. Hold down Alt (Windows) 
or Option (Mac OS) to specify a point as the center of the graph. By default, the Graph 
dialog box displays the dimensions of the most recently drawn graph. Dimensions are 
displayed in the units of measure specified in the Edit > Preferences > Units & Undo 
dialog box (Windows and Mac OS 9) or Illustrator > Preferences > Units & Undo dialog 
box (Mac OS X).

3 Enter the graph data. (See “Entering graph data” on page 376.)

Entering and editing graph data
You can enter data in a graph in three ways: by typing it into the graph data dialog box, 
by importing data from another file, or by pasting data from another program or from 
another graph. Regardless of the method you use, you can edit the data once it has been 
entered.

Entering graph data
Note the following about graph data:

• You must select an entire graph before you can change its data.

• You can enter data in up to 32,767 rows by 32,767 columns, as memory permits.

• Graph data cannot contain nonnumerical characters other than decimal points (.) 
or decimal commas; if it does, the data is not plotted. For example, you would enter 
245000, not 245,000. However, you can enter nonnumerical characters in labels, 
as described later in this section.

To enter data manually:

1 Create a graph using the procedure described in “Working with graphs” on page 375. 
Make sure that the graph is selected.
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2 If the graph data dialog box is not already open, choose Object > Graph > Data.

Graph data dialog box 
A. Entry line B. Import data C. Transpose row/column D. Switch x/y E. Cell style F. Revert  
G. Apply H. Row I. Column J. Cell

At the top of a work sheet is the entry line for entering data. You enter labels and then data 
that correspond to the labels. Each label or value you enter is placed into a separate cell. 
A cell is the intersection of a row and a column. 

Labels are words or numbers that describe two things: categories, whose data is entered in 
rows; and legends, whose data is entered in columns. In the final graph, legends appear as 
boxes that you can place above or to the right of a graph.

3 Enter labels and data for the particular graph type, according to the guidelines in 
“Entering labels and data for particular graph types” on page 378. Also see “Selecting 
graph options” on page 381.

Usually, you enter a label in at least the first row and the first column of the work sheet. 
Follow these guidelines:

• To create category labels for the horizontal (x) axis, enter the labels in the first column. 
(Do not enter a label in the first cell if you are also creating legend names for the vertical 
(y) axis.)

• To create legend labels for the vertical (y) axis, enter the labels in the first row. (Do not 
enter a legend label in the first cell of the row if you are also creating labels for the 
horizontal (x) axis.)

• To create labels consisting only of numbers, enclose the numbers in straight quotation 
marks (that is, not “curly” quotation marks). For example, to use the year 1996 as a label, 
enter "1996"; to use quotation marks around a number label, use text quotation marks 
within another set of straight quotation marks—for example "“1996”". If a label 
includes both text and numbers, you do not need to use quotation marks.

• To create line breaks in legends or labels, use the vertical bar key to separate lines. 
For example, enter Total|subscriptions|1996 to produce the following graph label:

Total 
subscriptions 
1996

4 Continue entering data in the work sheet, choosing one of the following methods to 
move to another cell:

• Press Tab to enter the data and select the next cell in the same row.

• Press Enter or Return to enter the data and select the next cell in the same column.

A B C D E F G

JI

H
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• Use the arrow keys to move from cell to cell.

• Click any cell.

5 To correct a mistake or to change how data is entered in the graph data dialog box, 
do one of the following:

• If you accidentally enter graph data backward (that is, in rows instead of columns, 
or vice versa), click the Transpose button  to switch the columns and rows of data. 
(See “Adjusting graphs” on page 380.)

• To switch the x and y axes of a scatter graph, click the Switch X/Y button . 

6 To adjust the cell column width to display more or fewer digits, click the Cell Style 
button  and enter a new value in the Cell Style dialog box. 

7 When you finish entering data in the work sheet, do one of the following:

• Click the Apply button  to keep the graph data dialog box open and apply the data to 
the graph.

• Click the close box to close the graph data dialog box and apply the data to the graph.

• Click the Revert button  to return data to its state when you last applied it to the 
graph.

Entering labels and data for particular graph types
Labels can be words that describe columns of data, or they can be years, months, or days 
for comparing data over time. 

Follow these additional guidelines for entering data for the selected graph type:

Column and stacked column graphs Enter numbers along the vertical (y) axis; enter 
labels for the data along the horizontal (x) axis. 

Bar and stacked bar graphs Enter numbers along the horizontal (x) axis; enter labels for 
the data along the vertical (y) axis. 

Column, stacked column, bar, and stacked bar graphs The height of the column or the 
length of the bar corresponds to the amount being compared. For column or bar graphs, 
you can combine positive and negative values; negative values appear as columns 
extending below the horizontal axis. For stacked column graphs, numbers must be all 
positive or all negative.

Line graphs Enter numbers representing quantities along the y axis; enter numbers 
representing time along the x axis. Each column of data corresponds to one line in the line 
graph. You can combine positive and negative values in a line graph. 

Area graphs Plot at least two rows of data; values must be all positive or all negative. 
Each row of data entered corresponds to a filled area on the area graph. Area graphs add 
each column’s values to the previous column’s totals. Therefore, even if area graphs and 
line graphs contain the same data, they appear substantially different. 

Scatter graphs Enter y axis data in the first column and x axis in the second column. 
A scatter graph differs from the other kinds of graphs, because both axes measure values; 
there are no categories. If the first column contains labels, it is ignored, and the second 
column produces values for the y coordinates.



Using Help | Contents | Index Back 379  

Adobe Illustrator Help Using Graphs 

Using Help | Contents | Index Back 379  

Pie graphs Plot only one row of data, either all positive or all negative values. If you plot 
additional rows of data, a separate pie graph is created for each additional row. You cannot 
combine positive and negative values. The size of the individual pie graphs is proportional 
to the total of each graph’s data.

Radar graphs Enter labels for the axes in the first column and a set of numbers in each 
successive column. Each label results in a separate axis; unlike other graphs, a radar graph 
can have more than two axes per graph. Each number is plotted on an axis and connected 
to the others in the same axis to create a “web.” (See “Selecting graph options” on 
page 381.)

Importing data from another application
If you first save data files as text in other applications, you can import the data files into 
Adobe Illustrator. In the text files, each cell must be separated by a tab, and each row must 
be separated by a carriage return. 

You can cut and paste data from a spreadsheet application such as Lotus® 1-2-3 or 
Microsoft Excel using your computer’s cut and paste procedures. 

The data can only contain decimal points or decimal commas; otherwise, the data is not 
plotted. For example, enter 732000, not 732,000.

To import data from another application:

1 Create a graph. Make sure that the graph is selected.

2 If the graph data dialog box is not already open, choose Object > Graph > Data.

3 Click the cell that will be the top left cell of the data that you import.

4 Click the Import Data button . 

5 Open the file that you want to import. The data is imported and entered into the work 
sheet in the graph data dialog box.

6 Click the Apply button . The graph is updated with the imported data.

To copy and paste data from another application:

1 Open the application and file containing the data you want to copy, select the data, 
and choose Edit > Copy to copy the data to the Clipboard.

2 Open the Adobe Illustrator program.

3 Create a graph. Make sure that the graph is selected.

4 If the graph data dialog box is not already open, choose Object > Graph > Data.

5 Click the cell that will be the top left cell of the data you paste.

6 Choose Edit > Paste. The data is pasted into the cells in the graph data dialog box.

7 Click the Apply button . The graph is updated with the pasted data.

Editing existing data
You can edit data you entered in the graph data dialog box. The Cut and Copy commands 
move data to the Clipboard; the Paste command moves data from the Clipboard into a 
work sheet. The Clear command erases the entire selection, either within the text or as a 
set of cells. The Delete key functions as both a Delete key and a Backspace key for a 
single cell. 
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To edit existing data:

1 Click the cell you want to edit. The cell is highlighted, and the cell’s data is shown in the 
entry line.

2 Do one of the following for editing data:

• Enter a value in the selected text box.

• Click in the entry line. Type new information.

• Press Delete to delete an entire cell entry.

• Use the Cut, Copy, Paste, or Clear command in the Edit menu to edit the data. You can 
cut and paste any cell or group of cells to another selected cell or group of cells.

3 Click the Apply button .

Adjusting graphs
You can transpose data, switch the x and y axes in scatter graphs, and adjust the cell 
column width and decimal precision. To adjust data, use the graph data dialog box. 

To transpose rows and columns of data:

1 Choose Object > Graph > Data.

2 Click the Transpose button . Labels and data that were listed across the top row are 
now listed along the left column. When the categories and legends are reversed, all the 
data is transposed accordingly.

To switch the x and y axes in a scatter graph:

1 Choose Object > Graph > Data.

2 Click the Switch X/Y button  to reverse the data columns.

To adjust a column width manually:

1 In the graph data dialog box, position the pointer at the edge of the column you want 
to adjust. The pointer changes to a double arrow.

2 Drag the handle to the desired position.

To reset the column width, you must drag the column width again; you cannot use the Cell 
Style dialog box. If you drag the column width to zero, the column reverts to the column 
width set in the Cell Style dialog box.

To change the width of columns you have not previously changed manually:

1 Click the Cell Style button  in the graph data dialog box. 

2 Enter a value between 0 and 20 in the Column Width text box. Click OK. 

Changing the value in the Column Width text box changes the width of the columns in the 
graph data dialog box only; it has no effect on the width of columns in the graph.

To adjust decimal precision:

1 Click the Cell Style button in the graph data dialog box.
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2 Enter a value between 0 and 10 in the Number of Decimals text box. The default is 2. 
This means that if you enter the number 4, it appears in the graph data dialog box as 4.00; 
if you enter the number 1.55823 with the Number of Decimals text box set to 2, the cell 
displays 1.56. Click OK.

Selecting graph options
Here are additional options that are available, depending on the graph type selected. 

Note: Area graphs have no unique options. 

To select graph type options:

1 If you want to change an existing graph, select the entire graph.

2 Choose Object > Graph > Type, or double-click the graph tool.

3 Choose Graph Options from the pop-up menu at the top left of the Graph Type 
dialog box.

4 Select options for the selected graph type, as described in the following sections.

Selecting column and stacked column options
Column Width and Cluster Width values can range from 1% to 1000%. These values allow 
space between columns and between clusters. A value of 100% moves both columns and 
clusters flush against each other. A value above 100% causes the columns and clusters to 
overlap one another. 

Column and stacked column graph options are the same. They include the following:

• Column Width, by default, is 90%.

• Cluster Width is the total width of all columns in a cluster. A cluster is a group of columns 
corresponding to a row of data in the work sheet. The default cluster width is 80%. 
If you are using stacked column graphs exclusively, it is recommended that you set the 
cluster width to 100% and use only the Column Width option to adjust the width.

Selecting bar and stacked bar options
Bar Width and Cluster Width values can range from 1% to 1000%. These values allow space 
between bars and between clusters. A value of 100% moves both bars and clusters flush 
against each other. A value above 100% causes the bars and clusters to overlap one 
another. 

Bar and stacked bar graph options are the same. They include the following:

• Bar Width, by default, is 90%.

• Cluster Width is the total width of all bars in a cluster. A cluster is a group of bars that 
correspond to a row of data in the work sheet. The default cluster width is 80%. If you 
are using stacked bar graphs exclusively, it is recommended that you set the cluster 
width to 100% and use only the Bar Width option to adjust the width.

Selecting line graph options
The following graph type options let you choose how to display line graphs: 

• Mark Data Points places square markers at each data point. 
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• Connect Data Points draws lines that connect the data points and makes it easier to see 
relationships between data. 

• Edge-to-Edge Lines draws lines that extend across the graph, from left to right along 
the horizontal (x) axis.

• Draw Filled Lines becomes available when you select Connect Data Points. Draw Filled 
Lines creates a wider line according to the value you enter in the Line Width text box, 
and it fills the line with paint according to the specifications for that series of data. 

Selecting scatter graph options
The graph type options for scatter graphs are the same as those for line graphs, except 
that the Edge-to-Edge Lines option is not available. The default options for scatter graphs 
are Mark Data Points and Connect Data Points.

Selecting pie graph options
The following legend options let you choose how to display legends with pie graphs:

• Standard Legend places column labels outside the graph; this is the default. Use this 
option when you combine pie graphs with other kinds of graphs.

• Legends in Wedges inserts labels into the corresponding wedges. 

• No Legend omits legends entirely. 

Percentages and legends are painted black by default. If a pie wedge with a dark 
background obscures a legend, repaint the dark background. Use the group-selection tool 
to select the dark pie wedges, and paint the wedges using the Color palette or Swatches 
palette.

The following position options let you choose how to display multiple pie graphs:

• Ratio sizes the graphs proportionally.

• Even makes all the pie graphs the same diameter.

• Stacked stacks each pie graph on top of the other, and each graph is sized 
proportionally.

The following sort options let you choose which element is displayed first, proceeding 
clockwise from the top of the pie graph:

• All sorts the wedges of the selected pie graph from largest to smallest value.

• First sorts the wedges of the selected pie graphs so that the largest value in the first 
graph will be placed in the first wedge, and the rest will sort from largest to smallest. 
All other graphs will follow the order of the wedges in the first graph.

• None sorts the wedges of the selected pie graphs in the order in which you entered 
values.

Selecting radar graph options
The graph type options for radar graphs are the same as those for line graphs. The default 
options for radar graphs are Mark Data Points and Connect Data Points.
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Specifying the value axis position
You can specify whether to have the value axis (typically the y axis) displayed on the left 
side, the right side, or both sides of the graph. You can have the same axis displayed on 
both sides, or, if you want different scales to appear on either side, you can select specific 
data to apply to one side or another. It is important to keep the following in mind when 
specifying value axes to the right or left side of the graph:

• If you select the entire graph and then select the On Both Sides option, both sides will 
show the same axis scale.

• If you want to have different scales on the right side versus the left side, you must assign 
data columns to the appropriate side of the graph. For example, if you want the left side 
of a graph to show Meters and the right side Feet, you need to select the data to show 
in Feet and specifically assign it to On Right Side to have the right side of the graph 
show the desired scale in Feet. 

• There are no value axis options for pie graphs.

(See “Combining different graph types” on page 387.)

To specify the axis position:

1 In the Graph Type dialog box, choose one of the following options from the Value Axis 
pop-up menu:

• For column, stacked column, line, or area graphs, choose On Left Side, On Right Side, 
or On Both Sides. 

• For scatter graphs, choose On Left Side or On Both Sides.

• For bar and stacked bar graphs, choose On Bottom Side, On Top Side, or On Both Sides.

Note: If you select On Both Sides without assigning data to a specific side, the scales on 
the axes will be identical on both sides of the graph.

• For Radar graphs, choose On All Sides.

2 Click OK.

To specify different scales for axes on both sides:

1 Select a graph that has labels for both axes, and make sure that the legend is showing. 
(See “Entering labels and data for particular graph types” on page 378.)

2 Choose Object > Graph > Type, or double-click the graph tool.

3 In the Graph Type dialog box, choose On Both Sides from the Value Axis pop-up menu.

4 Choose Left Axis from the Graph Options pop-up menu, and make the desired changes 
to the Left Axis values.

5 Choose Right Axis from the Graph Options pop-up menu, and make the desired 
changes to the Right Axis values.

6 Click OK, and then deselect the graph.

7 Use the group-selection tool  to select a set of data and its legend box or legend line.

8 Double-click the graph tool to open the Graph Type dialog box.

9 Choose On Right Side from the Value Axis pop-up menu.
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10 Choose Value Axis from the Graph Options pop-up menu, reenter the changes you 
want to make to the right axis values, and then click OK.

Note: Once you have created a graph with a separate right and left axis, you cannot 
adjust the axis values. To change the axis values, you must change the graph back to a left 
side-only value axis.

To set the graph so that all data can be read on two different scales:

1 Assign some data columns to one scale and the rest of the data columns to the 
other scale.

2 Set the minimum and maximum on the two axes to be equivalent as described in 
“Setting axis tick mark and label options” on page 384. For example, for a graph in which 
one axis displays a Celsius scale and the other a Fahrenheit scale, you can set the Celsius 
scale to 0 (minimum) and 32 (maximum), and set the Fahrenheit scale to 32 (minimum) 
and 122 (maximum). All the data in the graph can then be read accurately on either scale.

Setting axis tick mark and label options
You can add tick marks to show units of measurement in a graph, and you can add infor-
mation to labels including units of measurement such as “$.” 

Tick marks are the lines placed perpendicular to the axes to show the units of 
measurement. They can be used either horizontally or vertically or both to set categories 
apart in a line graph, for example, or to separate categories in a column or scatter graph.

You may need to change axis attributes such as tick marks or labels when a single graph 
contains more than one graph type. (See “Combining different graph types” on page 387.)

To set tick mark and label options:

1 Choose an axis from pop-up menu in the top left of the Graph Type dialog box:

• Value Axis to set options for the axis that displays the graph’s unit of measurement. 
The y axis is the value axis for column, stacked column, line, and area graphs. The x axis 
is the value axis for bar and stacked column graphs. 

Note: The Value Axis option is not available when a graph is set to display value axes on 
both sides. (See “Specifying the value axis position” on page 383.)

• Left Axis, Right Axis, Bottom Axis, or Top Axis to set options for a specific axis when a 
graph is set to display value axes on both sides.

• Category Axis to set options for the axis that defines the graph’s categories. The x axis is 
the category axis for column, stacked column, line, and area graphs. The y axis is the 
category axis for bar and stacked column graphs. The Category Axis option is not 
available for scatter, pie, and radar graphs.

2 For value axes, left axes, right axes, bottom axes, or top axes, select Override Calculated 
Values to manually calculate the placement of tick marks. Either accept the values set 
when you created the graph or enter a minimum value, a maximum value, and the 
number of divisions between labels.

3 Choose a tick mark length from the Length pop-up menu.

4 Specify how many tick marks to draw in the Draw Tick Marks Per Division text box. 
To prevent numbers from appearing on an axis, enter 0.
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5 For category axes, select Draw Tick Marks Between Labels to draw tick marks on either 
side of the labels or columns, or deselect the option to center tick marks over the labels 
or columns.

6 For value axes, left axes, right axes, bottom axes, or top axes, enter characters in the 
Prefix or Suffix text box to add more information before (Prefix) or after (Suffix) values, 
such as a dollar sign before a number, or the word units, or a percent sign after the values. 

7 Click OK.

Graph with vertical tick lines

Adding visual emphasis to graphs
You can refine the look of a graph using visual aids, including drop shadows, adding 
legends at the top of the graph, or overlapping the columns in a bar graph. 

To add a drop shadow:

In the Graph Type dialog box, select Add Drop Shadow and click OK.

Graph with drop shadows

To display legends across the top of a graph:

1 In the Graph Type dialog box, select Add Legend Across Top.
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2 Click OK. By default, legends are displayed to the right of the graph. You can choose to 
display them horizontally across the top of the graph.

Graph with default legends compared to graph with legends across top.

To make columns or bars of data overlap:

1 When creating a stacked column or stacked bar graph, in the Graph Type dialog box 
enter a value in the Column Width or Bar Width text box greater than 100%. 

2 Select First Column in Front, and click OK.

Graph with overlapping columns

To specify the order in which columns overlap:

1 In the Graph Type dialog box, to place the first row or column of data in the work sheet 
frontmost in the graph, select First Row in Front or First Column in Front (the default). You 
must always select this option for an area graph; if you do not, some areas may not appear. 

2 Click OK.

Changing graph types
Once you create a graph, you can change to another graph type to illustrate the data more 
effectively by using the Graph Type dialog box.

To change the graph type of an individual series of data, use the group-selection tool to 
select the data series. Be sure to include the legend in the selection. (See “Combining 
different graph types” on page 387.)

Note: Once graph objects are painted with gradients, changing graph types can cause 
unexpected results. To prevent undesirable results, either do not apply gradients until the 
graph is finished, or use the direct-selection tool to select gradient-painted objects and 
paint those objects with a process color; then reapply the original gradients.
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To change graph types:

1 Select the graph.

2 Choose Object > Graph > Type, or double-click the graph tool.

3 Choose Graph Options from the pop-up menu at the top left of the Graph Type 
dialog box.

4 Click the desired graph type. The options for the particular type of graph you selected 
appear in the bottom half of the dialog box. 

5 Click the desired graph options and click OK.

Combining different graph types
You can combine different graph types in one graph. For example, you may want one set 
of data to appear as a column graph and other sets of data to appear as a line graph. 
You can combine any type of graph with any other, with the exception of scatter graphs. 
Scatter graphs cannot be combined with any other graph type.

Graph with both columns and lines

If a graph uses more than one graph type, you may want one set of data along the right 
axis and the other set of data along the left axis. In this way, each axis measures different 
data. For information on assigning data to different sides of the graph, see “Specifying the 
value axis position” on page 383 and “Setting axis tick mark and label options” on 
page 384.

Note: To create two axes for a graph with different scales, you need to assign data to the 
left side (or the bottom side) and different data to the right side (or the top side) using the 
Value Axis menu in the Graph Type dialog box. If you select the entire graph and the On 
Both Sides option, both axes will display identical scale values.

If you use stacked column graphs with other graph types, be sure to use the same axis for 
all sets of data that are represented by stacked column graphs. If some sets of data use the 
right axis while other sets of data use the left axis, the column heights may be misleading 
or may overlap.

To combine different graph types:

1 Use the group-selection tool  to select a set of data and its legend box or legend line. 
(See “Selecting parts of a graph” on page 388.) Once you select the series, you can then 
change the graph type in the Graph Type dialog box.

2 Choose Object > Graph > Type, or double-click the graph tool.
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3 Select the graph type and options you want. (See “Selecting graph options” on 
page 381.)

4 Apply the selected data to an axis by selecting On Right Side, On Left Side, On Top Side, 
or on Bottom Side from the Value Axis pop-up menu and click OK.

5 Use the group-selection tool  again to select a different set of data on which to apply a 
different graph type, and which will be assigned to a different axis. 

6 Perform steps 2 through 4 again on the new data, creating a different graph type and 
assigning the data to the opposite axis, and then click OK.

Exporting graph designs to other files
You can create a custom startup file that contains the graph designs you use most 
frequently. The graph designs contained in the startup file then appear in the graph 
design list in the Graph Design dialog box and are available in every new Adobe Illustrator 
file you create. (See “Creating a custom startup file” on page 168.)

Customizing a graph
You can customize a graph in numerous ways. You can change the colors of shading; 
change the typeface and type style; and move, reflect, shear, rotate, or scale any or all of 
the graph. You can use customized column and marker designs. You can also use styles to 
apply transparency, gradients, blends, brush strokes, and other effects to graphs.

About graph elements
It is essential to keep in mind when you customize a graph that a graph is a grouped 
object that is related to its data. Never ungroup the graph; if you do, you cannot change 
the graph. To edit a graph, you select the parts you want to edit without ungrouping the 
graph, using either the direct-selection tool or the group-selection tool. 

It is also important to understand how elements of a graph are related. The entire graph 
with its legends is one group. All the sets of data are a subgroup of the graph; in turn, each 
set of data with its legend box is a subgroup of all the sets of data. Each value is a 
subgroup of its set of data, and so on. Never ungroup or regroup objects that are within 
the group.

You can see the hierarchy of grouping within a graph by creating a column graph with two 
or more columns of data. The first column in the first cluster of columns is grouped with 
the first column in the next cluster of columns. In addition, the group of the first columns 
is grouped with the first legend.

Selecting parts of a graph 
If you want to select some objects in a graph and send them to the back or front of other 
objects, it’s important that you send only objects that represent an entire set of data or 
individual numbers. You can select individual columns, lines, pie wedges, or series and 
move them to the front or back. Do not, however, select and move individual category 
labels, individual legend labels, individual axis tick lines, individual axis tick labels, or 
vertical or horizontal axis lines. 
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If you want to move a set of data in a line graph in front or in back of another set of data, 
you must select the entire set of data, including the legend. Selecting just the data points 
is not sufficient.

To select an entire data set in a graph:

1 Select the group-selection tool .

2 Click the legend of the columns you want (for example, Group A). 

3 Without moving the group-selection tool pointer from the legend, click again. All of the 
columns grouped with the legend are selected.

You can also select a group by clicking one of its parts, clicking again to select columns 
grouped with it, and clicking a third time to select the legend.

Each click adds another layer of grouped objects to the selection, beginning with the next 
group up in the hierarchy. You can click as many times as the number of groups to add to a 
selection.

To deselect part of a selected group:

1 Select the direct-selection tool .

2 Hold down Shift, and click to deselect the object.

To change part of the type in a graph:

1 Select the group-selection tool .

2 Click once to select the baseline of the type you want to change; click twice to select all 
of the type.

3 Choose Window > Type > Character or Window > Type > Paragraph.

4 Set the type attributes you want to change. Changes you make apply only to the 
selected type.

About graph designs
You can create and apply custom markers or columns to represent data in graphs. Graph 
designs can be a simple drawing, logo, or other symbol representing values in a graph, 
such as a bicycle; they can also be complex objects that contain patterns, guide objects, 
and type. You can reuse graph designs and edit them to make a new design. 

Using a graph design is different from painting a column with a pattern. Graph designs are 
scaled so that the design fits within the column. Once the design is used in the graph, 
the design can be selected and modified.

You can apply a graph design in a column or stacked column graph, or in a bar or stacked 
bar graph. You can also use a graph design to replace markers in a line or scatter graph.

You can create the following types of graph designs:

• A vertically scaled design is stretched or compressed vertically. Its width does not 
change.
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• A uniformly scaled design is scaled both vertically and horizontally. The horizontal 
spacing of the designs is not adjusted for the different widths.

Vertically scaled graph design compared to uniformly scaled graph design

• A repeating design stacks a design to fill the columns. You can specify the value that 
each design represents, as well as whether you want to chop or scale designs that 
represent fractions.

Repeating graph with chopped design compared to repeating graph with scaled design

• A sliding design is similar to a vertically scaled design, except that you can specify where 
in the design to stretch or compress it. For example, if you were using a person to 
represent data, you might stretch or compress only the body, but not the person’s head. 
Using the Vertically Scaled option would scale the entire person. 

Sliding graph design

When you use a graph design with a column or bar graph, you scale the design vertically 
or horizontally, repeat the design, or slide the design with the columns or bars.
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You can also rotate the design in the Graph Column dialog legend box. By default, the 
design is rotated to appear horizontal in the legend box. You can turn this option off so 
that the design appears vertically in the legend box. 

Rotated graph design compared to unrotated design

Creating a graph design
Creating a graph design is similar to creating a pattern. (For design ideas that you might 
use when creating graphs, see “Creating and working with patterns” on page 206.)

When you create a design or use a design in a file, the design is saved. To use that design 
in another file, either open the file in which you created the design or use the Window > 
Swatch Libraries > Other Library command and choose the file whose designs you want 
to import. (When the designs are imported, you will see the colors, gradients, and patterns 
in the new file, but the actual graph designs will only be visible in the Graph Design 
dialog box.)

To create a graph design:

1 Create a rectangle as the backmost object in the design. The rectangle represents the 
boundary of the graph design.

2 Paint the rectangle as desired, or fill and stroke it with None so that it is invisible.

Copy and paste the smallest column in your graph to use it as the bounding rectangle 
for your design.

3 Create the design using any of the drawing tools, or position an existing design in front 
of the rectangle.

4 To display column totals with the graph design, skip to that procedure later in this 
section.

5 Using the selection tool , select the entire design, including the rectangle.

6 Choose Object > Group to group the design.

7 Choose Object > Graph > Design.

8 Click New Design. A preview of the selected design appears.

Graph Design dialog box

A A
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Only the portion of the design that fits inside the backmost rectangle appears, but the 
whole design appears when used in the graph.

9 Click Rename. Name the design, and click OK. Then click OK again.

10 To apply the design to a graph, see “Applying graph designs to a graph” on page 393.

To create a sliding graph design:

1 Create a rectangle as the backmost object in the design. This rectangle is the boundary 
for the graph design.

2 Create the design using one of the drawing tools, or place an existing design in front of 
the rectangle.

3 Use the pen tool  to draw a horizontal line to define where the design is stretched or 
compressed.

4 Select all parts of the design, including the horizontal line.

5 Choose Object > Group.

6 Use the direct-selection tool  or group-selection tool  to select the horizontal line. 
Be sure to select only the horizontal line.

7 Choose View > Guides > Make Guides.

8 Choose View > Guides > Lock Guides to remove the check mark next to Lock so you can 
unlock the guides. Move the design around to make sure that the guide moves with the 
design.

9 Use the selection tool  to select the whole design. 

10 Choose Object > Graph > Design.

11 Click New Design. You see a small preview of the selected design.

12 Click Rename. Name the design, and click OK. Then click OK again.

To display column totals with the graph design:

1 Create the graph design.

2 Select the type tool . Position the pointer at a point where you want the value to 
appear, near or in the rectangle that defines the design. 

For example, you can place the value in, above, below, to the left, or to the right of the 
design.

3 Click and type a percent sign (%) followed by two digits from 0 to 9. The digits control 
how the data is displayed.

The first digit determines how many places appear before the decimal point. For example, 
if your total was 122, a digit of 3 would display 122. If you enter 0 for the first digit, the 
program adds the number of places necessary for the value. 

The second digit determines how many places appear after the decimal point. Zeros are 
added as necessary, and values are rounded up or down as necessary. You can vary these 
numbers, depending on how many digits you need. 

4 To change the type attributes, choose Window > Type > Character, specify the 
attributes you want, and close the palette. 

5 To align the decimal points, choose Window > Type > Paragraph and select Right 
Alignment.



Using Help | Contents | Index Back 393  

Adobe Illustrator Help Using Graphs 

Using Help | Contents | Index Back 393  

6 Using the selection tool , select the entire design, including the rectangle and 
any type.

7 Choose Object > Group to group the design.

8 Choose Object > Graph > Design.

9 Click New Design. You see a preview of the selected design.

10 Click Rename. Name the design, and click OK. Then click OK again.

Sliding graph design with data totals

Applying graph designs to a graph
Once you have created a graph design, you can apply it either as a column in a column 
graph, as a bar in a bar graph, or as a marker in a line or scatter graph.

To use a graph design in a column graph or bar graph:

1 Use the group-selection tool  to select the columns or bars you want to fill with the 
design, or select the entire graph.

2 Choose Object > Graph > Column.

3 Select a column design type, as described in “About graph designs” on page 389.

If you choose the Repeating Column Type, enter a value in the Each Design Represents 
text box for what each design represents. Also select whether to chop or scale any 
fractions of the design in the For Fractions pop-up menu. Chop Design cuts off a fraction 
of the top design as necessary; Scale Design scales the last design to fit in the column.

4 Select the design you want to use; you see a preview of the selected design. Click OK.

To create a marker design:

1 Start by copying a marker rectangle from the graph, and using the rectangle as the 
backmost object, to set the marker size.

2 Make the marker artwork the size you want it to be in the graph, even if it’s larger than 
the marker rectangle you copied.

3 Once you’ve got the marker design the way you want it, select the design, then choose 
Object > Graph > Design, and click New Design. 

4 Click the Rename button, enter a new name for the design, and click OK.

To use a marker design in a line or scatter graph:

1 Use the direct-selection tool  to select the markers and the legends in the graph that 
you want to replace with a design. Do not select any lines. 

2 Choose Object > Graph > Marker. Select a design, and click OK.
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The design is scaled so that the backmost rectangle in the design is the same size as the 
default square marker on the line or scatter graph.

Line graph with marker designs

Reusing a graph design
You can reuse a graph design that you created and edit it to make a new design. If you 
have the original artwork, you can alter it and then rename the design using the Graph 
Design dialog box. (See “Creating a graph design” on page 391.)

If you don’t have the original artwork defined as a graph design, you can retrieve the 
original by pasting the graph design into your artwork.

To paste an existing graph design into your artwork:

1 Choose Select > Deselect to deselect all of the artwork.

2 Choose Object > Graph > Design.

3 Select the graph design that you want to paste into your artwork, and click Paste 
Design.

4 Click OK. The graph design is pasted into your artwork. You can now edit it and define it 
as a new graph design.
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Macintosh Shortcuts

Selecting and moving
 

*Press  to constrain movement to 45° angles (except ).

 Command  Option  Shift  Key

Painting and transforming

Result Action

, , or  (last used) Any tool (except selection tools) +  

   or  (last used)  + Ctrl + Tab

    –click tool

Adds to a selection , ,  or  + 

Subtracts from a selection , , or  + 

Adds to lasso selection ,  +  + drag

Subtracts from a lasso selection ,  +  + drag

Constrains to follow mesh line  +  –drag mesh point

Moves selection in user defined 
increments

    

Moves selection in 10x user defined 
increments

 +     

Locks all deselected artwork  +  +  + 2

Result Action

  

Samples color from an image or 
intermediate color from gradient

 +  

Samples style and appends appearance of 
currently selected item

 +  +  –click

Sets origin point and opens dialog box , , , or  +  –click

Duplicates and transforms selection , , , or  +  –drag
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 Command  Option  Shift  Key

Shapes

 Command  Option  Shift  Key

Transforms patterns (independent of 
object)

, , , , or  + ~ –drag

Rotates selection  –click and then drag anywhere outside 
of bounding box

Skews selection (after mouse down only)  +  –drag handles (  +  +  –drag 
handles to skew from center)

Changes perspective (after mouse down 
only)

 +  +  +  –drag corner handle

Resizes selection proportionately  or  +  –drag bounding box handle

Resizes selection from center  or  +  –drag bounding box handle

Result Action

Sets starting point and opens dialog box Shape tools + click

Constrains proportion , , , , or  +  –drag

Constrains orientation , , , , , or  +  –drag

Repositions object while it is being drawn , , , , , , , , , , or  + 
spacebar–drag while drawing

Changes to minimum/maximum radius  +   

Maintains inner radius  +  –drag

Creates continuous duplicates with 
mouse movement

, , , , , , , , , or  + ~ –drag

Adds/subtracts spiral coils, horizontal grid 
lines, concentric grid circles, corner radius, 
sides, star points, or rays/rings

, , , , , , or   +   

Adds/subtracts coils while increasing 
spiral length

 +  –drag

Changes decay  +  –drag

Draws line segment, arc, spiral, grid, polar 
grid, rectangle, rounded rectangle, ellipse, 
polygon, or star from center

, , , , , , , , , or  +  –drag 
(  +  –drag to constrain from center)
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Path Editing

 Command  Option  Shift  Key

Viewing

Result Action

 (convert-anchor-point tool)  +  

   

  + 

Edits existing path  –drag (while drawing over or near 
selected path)

Closes path over start point Click start point with the pen

 (smooth tool)  +  

Moves anchor point and handles while 
drawing

 + spacebar

Creates closed path while drawing  or  +  –drag

Connects path to end of another path  +  –drag

Cuts along straight line  +  

Cuts at 45°/90° increments  +  + 

Moves mesh point along path  +  –drag mesh point

Adds mesh point using existing object 
color

 +  –click path

Removes mesh point  +  –click mesh point

Turns shape mode buttons into Pathfinder 
commands

 + Shape mode

Result Action

Fits imageable area in window Double-click 

100% magnification Double-click  

 spacebar (when not in text focus) 

 + spacebar

 +  + spacebar or  + 

Adjusts zoom marquee position Drag ; then press spacebar and continue 
dragging



Using Help | Contents | Index Back 398  

Adobe Illustrator Help Macintosh Shortcuts 

Using Help | Contents | Index Back 398  

 Command  Option  Shift  Key

Type

*Amount is set in Edit > Preferences > Type & Auto Tracing.

**Press Shift to select or extend existing selection.

 Command  Option  Shift  Key

Hides unselected artwork  +  +  + 3

Converts between horizontal and vertical 
guide

 –drag guide

Releases guide  +  + –double-click guide

Result Action

Aligns left, right, or center  +  + L, R, or C

Justifies  +  + J

Inserts soft return  + Return

Highlights kerning  +  + K

Resets horizontal scale to 100%  +  + X

Resets tracking/kerning to 0  +  + Q

Increases/decreases point size*  +  + > or <

Increases/decreases leading*  +   

Sets leading to the font size Double-click the leading icon  in the 
Character palette

Increases/decreases kerning/tracking*  + 

Increases/decreases baseline shift*  +  + 

Selects word, paragraph Double-click word, triple-click word

Moves pointer left/right one word or up/
down one paragraph

 +  or **

Switches between type and vertical type, 
area type and vertical area-type, and path 
type and vertical path-type tools

 

Switches between area type and type, 
path type and area type, and vertical path-
type and vertical area-type tools

 + click 
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Windows Shortcuts

Selecting and moving
 

*Press  to constrain movement to 45° angles (except ).

 Shift  Key

Painting and transforming

Result Action

, , or  (last used) Any tool (except selection tools) + Ctrl 

   or  (last used) Ctrl + Tab

   Alt –click tool

Adds to a selection , ,  or  + 

Subtracts from a selection , , or + 

Adds to lasso selection ,  +  + drag

Subtracts from a lasso selection  ,  + Alt + drag

Constrains to follow mesh line  +  –drag mesh point

Moves selection in user defined 
increments

    

Moves selection in 10x user defined 
increments

 +     

Locks all deselected artwork Ctrl + Alt +  + 2

Result Action

  Alt

Samples color from an image or 
intermediate color from gradient

 +  

Samples style and appends appearance of 
currently selected item

 + Alt +  –click

Sets origin point and opens dialog box , , , or  + Alt –click

Duplicates and transforms selection , , , or  + Alt –drag
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 Shift  Key

Shapes

 Shift  Key

Transforms patterns (independent of 
object)

, , , , or  + ~ –drag

Rotates selection  –click and then drag anywhere outside 
of bounding box

Skews selection (after mouse down only)  + Ctrl –drag handles (  + Alt + Ctrl–
drag handles to skew from center)

Changes perspective (after mouse down 
only)

 + Ctrl + Alt +  –drag corner handle

Resizes selection proportionately  or  +  –drag bounding box handle

Resizes selection from center  or  + Alt –drag bounding box handle

Result Action

Sets starting point and opens dialog box Shape tools + click

Constrains proportion , , , , or  +  –drag

Constrains orientation , , , , , or  +  –drag

Repositions object while it is being drawn , , , , , , , , , , or  + 
spacebar–drag while drawing

Changes to minimum/maximum radius  +   

Maintains inner radius  + Ctrl –drag

Creates continuous duplication with 
mouse movement

, , , , , , , , , or  + ~ –drag

Adds/subtracts spiral coils, horizontal grid 
lines, concentric grid circles, corner radius, 
sides, star points, or rays/rings

, , , , , , or  +   

Adds/subtracts coils while increasing 
spiral length

 + Alt –drag

Changes decay  + Ctrl –drag

Draws line segment, arc, spiral, grid, polar 
grid, rectangle, rounded rectangle, ellipse, 
polygon, or star from center

, , , , , , , , , or  + Alt –drag 
(Alt +  –drag to constrain from center)
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Path Editing

 Shift  Key

Viewing

Result Action

 (convert-anchor-point tool)  + Alt 

  Alt 

  + Alt

Edits existing path  –drag (while drawing over or near 
selected path)

Closes path over start point Click start point with the pen

 (smooth tool)  + Alt 

Moves anchor point and handles while 
drawing

 + spacebar

Creates closed path while drawing  or  + Alt –drag

Connects path to end of another path  + Ctrl –drag

Cuts along straight line  + Alt 

Cuts at 45°/90° increments  + Alt + 

Moves mesh point along path  +  –drag mesh point

Adds mesh point using existing object 
color

 +  –click path

Removes mesh point  + Alt –click mesh point

Turns shape mode buttons into Pathfinder 
commands

Alt + Shape mode

Result Action

Fits imageable area in window Double-click 

100% magnification Double-click  

 spacebar (when not in text focus) 

Ctrl + spacebar

Ctrl + Alt + spacebar or  + Alt

Adjusts zoom marquee position Drag ; then press spacebar and continue 
dragging
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 Shift  Key

Type

*Amount is set in Edit > Preferences > Type & Auto Tracing.

**Press Shift to select or extend existing selection.

 Shift  Key

Hides unselected artwork Ctrl + Alt +  + 3

Converts between horizontal and vertical 
guide

Alt –drag guide

Releases guide Ctrl +  –double-click guide

Result Action

Aligns left, right, or center Ctrl +  + L, R, or C

Justifies Ctrl +  + J

Inserts soft return  + Return

Highlights kerning Ctrl + Alt + K

Resets horizontal scale to 100% Ctrl +  + X

Resets tracking/kerning to 0 Ctrl + Alt + Q

Increases/decreases point size* Ctrl +  + > or <

Increases/decreases leading* Alt +   

Sets leading to the font size Double-click the leading icon  in the 
Character palette

Increases/decreases kerning/tracking* Alt +     

Increases/decreases baseline shift* Alt +  +   

Selects word, paragraph Double-click word, triple-click word

Moves pointer left/right one word or up/
down one paragraph

Ctrl +   or   **

Switches between type and vertical type, 
area type and vertical area-type, and path 
type and vertical path-type tools

 

Switches between area type and type, 
path type and area type, and vertical 
path-type and vertical area-type tools

Alt + click 
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Legal Notices

Copyright
© 2001 Adobe Systems Incorporated. All rights reserved. 

Adobe® Illustrator® 10 User Guide for Windows® and Macintosh

If this guide is distributed with software that includes an end user agreement, this guide, as well as the software described in it, is furnished 
under license and may be used or copied only in accordance with the terms of such license. Except as permitted by any such license, no part of 
this guide may be reproduced, stored in a retrieval system, or transmitted, in any form or by any means, electronic, mechanical, recording, or 
otherwise, without the prior written permission of Adobe Systems Incorporated. Please note that the content in this guide is protected under 
copyright law even if it is not distributed with software that includes an end user license agreement. 

The content of this guide is furnished for informational use only, is subject to change without notice, and should not be construed as a 
commitment by Adobe Systems Incorporated. Adobe Systems Incorporated assumes no responsibility or liability for any errors or inaccuracies 
that may appear in the informational content contained in this guide. Please remember that existing artwork or images that you may want to 
include in your project may be protected under copyright law. The unauthorized incorporation of such material into your new work could be a 
violation of the rights of the copyright owner. Please be sure to obtain any permission required from the copyright owner. Any references to 
company names in sample templates are for demonstration purposes only and are not intended to refer to any actual organization.

Adobe, the Adobe logo, Acrobat, Acrobat Reader, Adobe Certified Training Provider, Adobe Certified Expert, Adobe Dimensions, Adobe 
Gamma, Adobe Image Library, Adobe Premiere, Adobe Press, Adobe Type Manager, After Effects, AlterCast, Classroom in a Book, FrameMaker, 
GoLive, Illustrator, InDesign, LiveMotion, Minion, Myriad, PageMaker, Photoshop, PostScript, PostScript 3, Streamline, Type Reunion are either 
registered trademarks or trademarks of Adobe Systems Incorporated in the United States and/or other countries. Microsoft, OpenType, 
Windows, and Windows NT are registered trademarks of Microsoft Corporation in the U.S and/or other countries. Apple, Macintosh, Power 
Macintosh, QuickTime, and TrueType are trademarks of Apple Computer, Inc. registered in the U.S. and other countries. QuickTime and the 
QuickTime logo are trademarks used under license. Helvetica and Times are trademarks of Linotype-Hell AG and/or its subsidiaries. IBM and 
OS/2 are registered trademarks of International Business Machines Corporation. Kodak is a registered trademark and Photo CD is a trademark 
of Eastman Kodak Company. UNIX is a registered trademark in the United States and other countries, licensed exclusively through X/Open 
Company, Ltd. Pentium is a registered trademark of Intel Corporation. Macromedia and Flash are trademarks or registered trademarks of 
Macromedia, Inc. in the United States and/or other countries. Sun is a trademark or registered trademark of Sun Microsystems, Inc. in the 
United States and other countries. All other trademarks are the property of their respective owners.

PANTONE® Colors displayed in the software application or in the user documentation may not match PANTONE-identified standards. Consult 
current PANTONE Color Publications for accurate color. PANTONE® and other Pantone, Inc. trademarks are property of Pantone, Inc. © Pantone, 
Inc. 2001. Pantone, Inc. is the copyright owner of color data and/or software which are licensed to Adobe Systems Incorporated to distribute 
for use only in combination with Adobe Illustrator. PANTONE Color Data and/or Software shall not be copied onto another disk or into memory 
unless as part of the execution of Adobe Illustrator software. ImageStream Graphics and Presentation Filters copyright 1991–1996 Inso Corpo-
ration. All rights reserved. International Correct Spell Concise Correction software, version 8.1, licensed from Inso Corporation. Copyright 1986-
1994, Inso Corporation, Microlytics, Inc., Xerox Corp. All rights reserved worldwide.

Portions copyright © Eastman Kodak Company, 2000 and used under license. All rights reserved. Protected by U.S. Patents U.S. 4,837,613; 
5,831,632; 5,870,091; and 5,943,063; patents pending. Contains an implementation of the LZW algorithm licensed under U.S. Patent 4,558,302. 
Adobe Systems Incorporated, 345 Park Avenue, San Jose, California 95110, USA.

Notice to U.S. Government End Users. The Software and Documentation are “Commercial Items,” as that term is defined at 48 C.F.R. §2.101, 
consisting of “Commercial Computer Software” and “Commercial Computer Software Documentation,” as such terms are used in 48 C.F.R. 
§12.212 or 48 C.F.R. §227.7202, as applicable. Consistent with 48 C.F.R. §12.212 or 48 C.F.R. §§227.7202-1 through 227.7202-4, as applicable, 
the Commercial Computer Software and Commercial Computer Software Documentation are being licensed to U.S. Government end users (a) 
only as Commercial Items and (b) with only those rights as are granted to all other end users pursuant to the terms and conditions herein. 
Unpublished-rights reserved under the copyright laws of the United States. Adobe Systems Incorporated, 345 Park Avenue, San Jose, CA 
95110-2704, USA. For U.S. Government End Users, Adobe agrees to comply with all applicable equal opportunity laws including, if appropriate, 
the provisions of Executive Order 11246, as amended, Section 402 of the Vietnam Era Veterans Readjustment Assistance Act of 1974 
(38 USC 4212), and Section 503 of the Rehabilitation Act of 1973, as amended, and the regulations at 41 CFR Parts 60-1 through 60-60, 60-250, 
and 60-741. The affirmative action clause and regulations contained in the preceding sentence shall be incorporated by reference.
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Index

A
About Plug-ins command 239

Absolute Colorimetric rendering intent 184

Accented Edges command 243

actions

editing and deleting 371

excluding and including commands 368

inserting modal controls and stops 367, 368

nonrecordable 365

playing 365, 368

recording 365

recording paths 366

resetting 373

saving 365

sets of 373

Actions palette 364

Actual Size command 16

Adaptive color table 314

Adaptive palette 314

Add Anchor Points command 57

Add Arrowheads filter 132

Add New Fill command 230

Add New Stroke command 230

add-anchor-point tool 6, 57

Adjust Colors filter 172

adjusting

axis of reflection 118

corners of rounded rectangles 63

paths 49, 56, 60, 80

type scale 261

Adobe Certification program 23

Adobe Dimensions 104

Adobe Gamma command 190

Adobe Gamma utility 188

Adobe Gamma wizard 190

Adobe Online 22

Adobe PDF file format 323

Adobe Photoshop. See Photoshop

Adobe Premiere 104

Adobe Streamline 90, 104

Adobe Web site 19, 21

AI file format 320

AI File to SWF File option 311

AI Layers to SWF Frames option 311

aligning objects 106

See also Align palette

options 106

using guides and grids 94

using Smart Guides 96

aligning type

along a path 253

in paragraphs 273

alignment point. See center point of objects

All on Same Layer command 101

alternative glyphs (characters) 284

anchor points 47

adding 50, 56, 57

adjusting 59

averaging 62

changing type 58

corner 47

deleting 56

drawing and 50

removing extra 61

selected and unselected 98

smooth 47, 58

Angle menu 96

angle of constraint 107

angle of rotation 12, 108

Angle option, for gradients 201

Angled Strokes command 244

angles
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for rotating objects 114

for shearing 119

Smart Guide 96

animation

frames in SWF format 327

releasing artwork to layers 217

annotating

files 343

objects 344

appearance attributes

about 228

displaying 229

Layers palette and 223

modifying 230

removing 230

Appearance palette 228

arc segments 67

arc tool 7

area graph 375

area graph tool 10

area type 252

area-type tool 6

Arrange command 109

Arrange Icons command 14

arrowheads, adding to lines 132

Art brushes 79, 84

artboard 16, 28, 29

See also page size

showing and hiding 29

Artistic filters and effects 242

artwork

masking 149

tracing 89

ASCII option 333

Ask When Modified option 38

Assign Profile command 186

attributes. See appearance attributes, stroke 
attributes

Auto Hyphenate option 280

auto trace tool 11, 89, 90

AutoCAD files 328

Auto-Kerning option 261

Auto-Leading option 259

Automatically option 37

Average command 62

axes, rotation of 108

axis of reflection 118

axis options in graphs 383

B
banding in blends and gradients 339

bar graph 375

bar graph tool 10

Bas Relief command 245

base (non-emulsion side) 361

base color 196

baseline

leading 259

selecting type from 255

shifting 261

Batch command 369

bending. See Scribble and Tweak filter and 
Distort filters and effects

bevel join 160

Binary option 333

bitmap images 25, 237

applying filters 239

colorizing 238

defined 26, 105

dimming 220

loading 241

rasterizing 237

speeding printing of 333

texturizing 241

Bitmap Printing option 333

bleed 357, 362

Blend Front to Back command 137

Blend Horizontally command 137

blend tool 11

Blend Vertically command 137

blending

banding in blends 339

blend color 196

blend length, maximum 339

blending modes 101, 196
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printing issues 337

shapes 133

Blending Mode command 101

bloat tool 9, 125

Blur filters and effects 243

BMP file format 328

bounding box

moving and transforming objects with 99

in patterns 206

preferences 99

printing 30

resetting angle after transformation 120

resizing and 58

rotating objects with 114

scaling objects with 116

in separations 355

showing or hiding 99

Bounds option 40

Break Link to Style command 234

breaking. See Expand Compound Shape 
command, Release command, Release 
Compound Shape command

brightness 152

Bring Forward command 109

Bring to Front command 109

browser dithering 315

Brush Libraries

creating 89

displaying names of 88

importing brushes from 88

Brush Libraries command 88

Brush Strokes command 89, 101

Brush Strokes filters and effects 243

brush strokes, selecting 101

brushes 79

Art 84

Calligraphic 79

Pattern 85

Scatter 83

Brushes palette 88

brushes, creating and modifying

changing key color 87

changing options 88

changing preferences for all 80

colorizing 86

converting to masked objects 81

previewing effects 82

removing from path 81

tips for using 89

brushes, managing

adding to palette 82

deleting from palette 82

displaying brushes 81

displaying pattern names 12

duplicating 81

importing from Brush Libraries 88

moving in palette 81

selecting unused 81

Button Mode command 365

C
Calligraphic brushes 79

capitalization, changing 283

Cascade command 14

center point of objects 63, 64

centered ellipses and rectangles, drawing 63

CGM file format 328

Chalk & Charcoal command 245

Change Case command 283

Character palette 256

characters

auto-kerning 261

changing type units 258, 262

direction 265

displaying options in Character palette 272

font 257

hidden 255

kerning and tracking 260

size 258

style 257

Charcoal command 245

Check In command 43

Check Out command 43

Check Spelling command 281

choke 349
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chroma 152

Chrome command 245

circles, drawing 63, 64

See also ellipses, drawing

CJK text

divided note option 266

line breaking options 276

proportional spacing option 274

Classroom in a Book 23

Cleanup command 254

Clear Appearance command 230

Clear Guides command 95

Clip option 195

Clip to Artboard option in Web-optimized 
images 313

Clip to Bounding Box option 40

Clipboard, importing and exporting artwork 
with 104

Clipping Mask command 149, 150

clipping masks 149, 195, 226

Close command 14

closed paths

drawing 49, 51, 53, 80

splitting 61

CMM. See color management engine

CMYK

color mode, selecting color in 170

color mode, selecting for new documents 28

color model 153, 154

converting to 238, 239

icon 160

output 345

CMYK PostScript 322

CMYK Startup file 161, 168

Collect in New Layer command 218

color blends, printing 337

Color Burn mode 197

Color button 157

Color Dodge mode 197

Color folder for Windows profiles 188

color gamuts 154

Color Halftone command 244

color management

black point compensation 184

characterizing and calibrating monitors 189

color spaces in 174

policies 178, 181

predefined settings 177

printing options 334

profiles. See profiles

rendering intents 184

saving and loading custom settings 185

saving and loading settings 185

setting up 176

soft-proofing 185

viewing environment 176

working spaces 178, 180

color management engine 175, 183

Color mode 197

color models 152

color modes

selecting color in 153, 169

selecting for new documents 28

Color option 95

Color palette 158

Color Picker 169

color profiles. See profiles

Color Settings command 177, 180

color slider 169

color spaces 154, 174

color tables

Adaptive palette for GIF 314

generating 314

Perceptual palette for GIF 314

color transitions, quality of 27

color values 12, 169

color wheel 152

Colored Pencil command 242

colors

base 196

complementary 153

device-independent 174

global and nonglobal process 155, 156, 163

PANTONE 167

selecting by color system numbers 167
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selecting objects by same 101

soft-proofing 185

spot 155, 163

subtractive 153

Web-safe and non-Web-safe 169, 170, 292

colors, adding to document

adding swatches from other documents 165

importing from desktop 171

loading from other color matching systems 
166

colors, applying

to 1-bit images 238

by dragging and dropping 159

to gradient fills 201

to a mesh 205

painting with 156

to symbol instances 77

colors, changing

adjusting and converting with filters 172

for brushes 86

globally 163

inverting 173

merging swatches 165

saturating and desaturating 173

Web-shifting 315

colors, printing

color composites 333

mixing overlapping colors 171

nonprintable colors 154, 170

Column command (graphs) 393

column graph 375, 381

column graph tool 10

Combine Slices command 298

combining. See compound paths

commands

in actions 368

keyboard shortcuts for 19

Compatible Gradient and Gradient Mesh 
Printing option 340

complementary colors 153

Composite option 333

Compound Path command 142

compound paths 141, 145

converting type into 267

Layers palette and 223

releasing 144, 145, 146

Compound Paths command 145, 342

compound shapes 141

exporting to Photoshop 326

Layers palette and 223

compression

Adobe PDF format 323

GIF format 329

Illustrator format 321

JPEF format 329

PNG format 330

Computer Graphics Metafile format 328

conserving paper and film 359, 361

Constant option (ink pen) 139

Constrain Angle option 102, 108

Construction Guides option 96

Conté Crayon command 246

context-sensitive menus 13, 113

Continue button 367

continuous-tone images 332

Convert filters 172

Convert Photoshop Layers to Objects option 
34

Convert to Process command 358

Convert to Process option 201

Convert to Shape commands 127

convert-anchor-point tool 6, 58

converting strokes to filled objects 148

Copy command 103

copying

between applications 102, 105

by dragging 103

in a circular pattern. See Transform Again 
command

paint attributes 170

by pasting 103

and placing precisely 104

type attributes 263

CorelDRAW, importing from 32

corner points 47, 58

corner radius value 64
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corners, rounding 127

correcting mistakes 91

Craquelure command 246

Create Mesh command 204

Create Outlines command 267

Crop command 147

crop marks 335, 354, 356

eliminating 335

Japanese 335

setting 335, 362

Crop Marks command 335

cropping artwork. See masks

cross hair 48

Crosshatch command 244

Crystallize command 245

crystallize tool 9, 125

current tool, displaying 17

Cursor Key option 103

cursors, precision 4, 48

curve handles. See direction points

curves

See also drawing

adjusting 59

drawing 52, 54

smoothing 50

custom colors 167

converting to process colors 358

in gradients 201

tables of 314

custom startup files 168

Cut command 103

Cutout command 242

cutting

with knife tool 149

with scissors tool 61, 89

with Slice command 149

See also Clipping Mask command

D
Dark Strokes command 244

Darken mode 197

Dash and gap settings. See Stroke palette

dashed lines, creating 160

dashes, replacing in text 284

Data command 377

data-driven graphics, rendering with Batch 
command 369

decimal precision in graphs 380

default actions 373

De-Interlace command 247

Delete Brush command 82

Delete Empty Text Paths option 254

Delete Riders filter 342

Delete Style command 234

delete-anchor-point tool 6, 57

deleting

actions 372

brush attributes 81

brushes 82

brushes from paths 81

empty text paths 254

objects 107

Density option (ink pen) 138

Deselect All command 100, 101

Deselect command 51

deselecting objects 101

designs, graph 391

device-independent color 174

dictionaries, changing 282

Difference mode 197

Diffuse Glow command 244

Direction Handles command 101

direction handles, selecting 101

direction lines 51, 54, 56, 58

direction points 51, 98

direct-lasso tool 98, 111

direct-select lasso tool 6

direct-selection tool 6, 97, 111

activating temporarily 58

adjusting paths with 56, 58, 59

Disable Auto Add/Delete option 57

discretionary hyphens, entering 280

Dispersion option (ink pen) 138

displaying

documents 27
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distance, measuring 12, 93

Distort filters and effects 126, 244

distorting

objects 120, 126

Distribute Objects option 106

Distribute Spacing option 106

distributing objects 106

See also transforming objects

dithering, browser 315

Divide & Outline Will Remove Unpainted 
Artwork option 141

Divide Slices command 297

Document Info command 344

Document Raster Effects Settings dialog box 
239

Document Setup command 18, 29, 30, 333

Document Setup dialog box

flattening settings 336

Show Images In Outline option 220

dots per inch (dpi) 27, 358

Download from Server command 43

Downloadables command 22

drag and drop 105, 159

drawing

adjusting segments 56, 59

changing point types 58

with cross hair 48

mixing straight and curved segments 54

open and closed paths 48

with pen tool 50

with pencil tool 48

shapes 62

drawing objects

arc segments 67

curved segments 52

ellipses and circles 63, 64

line segments 67

polygons 64

rectangles and squares 63, 64

rounded rectangles 63

spirals 68

stars 64

Drop Shadow command 130

Dry Brush command 242

Duplicate Brush command 82

Duplicate Slice command 298

Duplicate Style command 233

Duplicate Swatch command 162

duplicating

brushes 81

objects 99

type 263

DWG file format 328

DXF file format 32, 328

E
edges, feathering and softening 131

Edit Contents command 123

Edit Envelope command 123

Edit Original option 41

Edit Selected Paths option 50

Edit Selection command 102

Edit Views command 14

effects 228

Artistic 242

Blur 243

Brush Strokes 243

Distort 244

Outline Type 267

Pixelate 244

Sharpen 245

Sketch 245

Stylize 246

Texture 246

Video 247

effects, working with

applying 235

changing objects and paths 126

compared to filters 239

editing 230

Layers palette and 223

removing 230

SVG and 301

Ellipse command 127

ellipse tool 7, 62, 63
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ellipses, drawing 63, 64

ellipsis (symbol), in text 284

em space, in text 260

Embed Image command 39

embedded objects 37

emulsion 361

en and em dashes, in text 284

endpoints

joining 62

in open paths 47

engraved effects. See Pen and Ink filter

Envelope Distort command 123

envelopes 122

creating 123

editing 123

expanding 124

Layers palette and 223

mesh and 123

options for 124

releasing 124

removing from objects 124

EPS file format 321

placing files 36

printing embedded 37

problems with spot colors and transparent 
artwork 155

EPSF Riders file 342

erase tool 8, 50

Error Handler option 343

Exclude command 147

Exclusion mode 197

Exit command 28

Expand Appearance command 81

Expand command

converting fills and strokes to objects 214

converting to regular objects 214

creating mesh object from gradients 204

envelopes and 124

expanding complex objects 214

Expand Compound Shape command 145

Expand Stroke. See Outline Stroke command

Expert Fractions option 284

Export command 320

exporting

artwork in Photoshop format 326

artwork in SWF format 327

artwork in other formats 328

to Clipboard 104

graph designs 388

and saving artwork 320

text files 268

eyedropper tool 11, 170

changing paint attributes 171

copying type with 263

importing color with 171

painting with 171

F
Feather command 131

feathering edges 131

File Dimensions option 40

file formats

Adobe PDF 323

EPS 321

Illustrator 320

importing into Illustrator 32

Photoshop 326

SVG and SVGZ 324

SWF 327

Web 292

File Info command 46

files

batch-processing 369

managed 42

options for saving 318

sizes for Web graphics 292

Fill button 157

Fill Color command 101

filled objects, selecting 100

fills 156

See also patterns

applying effects to 236

for masks 151

film

base 361
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conserving 359, 361

Film Grain command 242

Filmstrip file format 329

filters

Artistic 242

Blur 243

Brush Strokes 243

Distort 244

Pixelate 244

Sharpen 245

Sketch 245

Stylize 246

Texture 246

Video 247

filters, working with

applying 240

changing objects and paths 126

choosing last used 240

compared to effects 239

improving performance 242

installing 239

plug-ins 239

Find Font command 258

finding and replacing

fonts 258

text 282

Fit Headline command 280

Fit In Window command 16

Flare Options 66

flare tool 8

flares

drawing 65

editing 66

expanding 66

Flash file format 304, 327

flatness, of paths 343

Flatten Artwork command 218

Flatten Photoshop Layers to a Single Image 
option 35

flattening, settings for 336

Flip Horizontal command 121

Flip Vertical command 121

FLM file format 329

FOCOLTONE colors 167

fonts 257

Adobe Expert 283

choosing 257

creating ligatures 283

embedding 321, 322, 323

finding and replacing 258

monospaced and proportional 274

OpenType 267

single master and multiple master 255

Type 1 255

Type 1 CID 275

Force Fonts to Download option 334

four-color process printing 153

fractions 284

Free Distort command 126

Free Distort filter. See free transform tool

free memory (RAM) 17

free transform tool 9, 120

defined 113

distorting objects 120

reflecting objects 117

rotating objects 114

scaling objects 116

shearing objects 119

freeform paths

See also pencil tool

changing 49

drawing 48

freehand tool. See pencil tool

FreeHand, importing from 32

Fresco command 241, 242

full screen mode 13

G
Gamma utility 189

gamuts 154

gap, setting for auto trace 90

Gaussian Blur command 243

General preferences 21

geometric patterns 208

GIF file format 329
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and Adaptive palette 314

custom color table 314

and Perceptual palette 314

selecting a color table 314

Web Snap slider 315

Web-safe color table 314

Glass command 241, 244

global colors 163

global process color 163

Glowing Edges command 246

Glyph Options command 284

Go to Link command 38

GoLive, saving HTML files for 317

gradient bar 201

Gradient button 157, 200

Gradient command 200

gradient fill. See gradients

gradient mesh tool. See mesh tool

gradient meshes

See also meshes

optimizing printing 341

SVG and 301

Gradient palette 200

gradient stops 201

gradient tool 11, 202

gradients 200

applying across multiple objects 202

applying color to 200, 201

converting to objects 214

creating 200

displaying names of 12

in graph objects 386

importing 166

linear and radial 201

modifying 201

printing 201, 337, 346

Grain command 241, 247

Graph dialog box 376

graph tool 10, 376

graphic file formats 32

Graphic Pen command 246

Graphic Style command 101

graphs

adding drop shadows 385

adjusting 378, 380

axis labels 377

categories in 377

cells in 377

labels in 377, 378

legends in 377, 386

line 381

options for 381

painted with gradient fills 386

selecting parts of 388

using numbers as category labels 377

graphs, data for

adding 376

decimal precision in 380

editing 379

importing 376, 379

transposing 378, 380

work sheet for entering 377

graphs, designs for 389

exporting 388

repeating 390

sliding 390

uniformly scaled 390

vertically scaled 389

graphs, types of 375

changing 387

combining 387

line 375

gray levels for printing 338

grayscale 154, 238, 239

greeking 272

grid tool 7

Gridline Every option 95

grids 69, 70, 95

Grids in Back option 95

Group command 110

grouped objects

graphs as 388

hiding and showing 112

Layers palette and 223
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locking and unlocking 112

moving 109

nesting 110

selecting 110

stacking 111

group-selection tool 6, 97

guide objects

converting objects to 95

See also guides

guides 94

hiding and showing 95

preferences 95

Smart Guides 96

Guides & Grid command 95

gutters, changing 271

H
Halftone Pattern command 246

halftone screens 27, 358

halftoning 332

halo, flares and 65

hand tool 12, 14

Hang Punctuation option 278

hanging punctuation 273, 278

Hard Light mode 196

Hard Mix effect 171

hatch style 139, 140

headline type, fitting 280

hidden characters 255

Hide Artboard command 29

Hide Bounding Box command 99

Hide Center Point option 64

Hide command 112

Hide Page Tiling command 30

Hide Rulers command 91

Hide Selection command 112

Hide Slices command 296

hiding

center point of object 64

objects 112

horizontal scale, adjusting 261

horizontal type 252

aligning along path 253

entering 250

entering along path 252

entering in objects 252

HSB

color mode, selecting color in 170

color model 152

HTML output settings 317

hue 152

Hue mode 197

hyphenation 280

I
I-beam pointer 250

ICC profiles 175, 188

Ignore Overprinting in Composite Output 
option 333

Illustrator

importing images from 31

preferences file 20

vector graphics 25, 26

Illustrator file format 320

image maps 299

assigning to an object 300

exporting to Photoshop 327

imageable area 27, 359

images

importing 31, 36

moving 17

negative or positive 361

previewing 18

resolution 26

imagesetters 29

importing

alternative glyphs (characters) 284

artwork 31

brushes 88

colors 166

Illustrator files 31

paths 104

text files 104, 268

indenting paragraphs 273
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Info palette 12, 93

Ink Outlines command 244

ink tool. See Pen and Ink command

Inner Glow command 130

Insert Menu Item command 367

Insert Select Path command 366

Intent option for destination color space 335

Interactive drop shadow tool 130

Interlace option

for GIF and PNG-8 309

Intersect command 147

Inverse command 101

Invert Colors command 173

Invert Mask option 195

Isolate Blending command 197

J
Japanese crop marks 335

Japanese file format 321, 322

Japanese fonts, alternative characters in 284

Japanese layout rules (Moji Gumi option) 275

Join command 62

joining

brush paths 89

endpoints and paths 62

JPEG file format 329

justifying lines 273

K
kerning

auto 261

changing 260

key color, changing 87

keyboard shortcuts 19

Keyboard Shortcuts command 19

Kinsoku Shori (line breaking) options 276, 277

knife tool 12, 149

Knockout Group option 191, 199

knockouts 191, 199

Kumi Moji option 266

Kurikaeshi Moji Shori option 278

L
labels, for separations 356

labels, graph axis 384

landscape (horizontal) orientation 359

language dictionaries, changing 282

lasso tool 6, 97, 110

Layer Options dialog box 216

Color option 220

Dim Images To option 220

Lock option 225

Name option 216

Preview option 220

Print option 225

Show option 225

Template option 225, 227

layers 215

adding and deleting 216, 219

for color separations 357

merging and flattening 218

moving between Illustrator and Photoshop 
227, 326

options for 216

pasting artwork between 110, 223

releasing and collecting items 217, 218

selecting 215

SVG and 301

template 220, 226

Layers palette, contents

clipping sets 226

color square 219, 221, 222

compound paths and shapes in 223

envelopes in 223

expanding and collapsing layers in 215

groups in 223

hierarchy of 222

Pathfinder paths in 223

row size 216

thumbnails in 216

Layers palette, using 215, 216

changing view of artwork 220

dimming bitmap images 220

displaying 215
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duplicating items in 224

locating items in 221

locking artwork 225

moving items in 222

printing and 225

selecting artwork 221

showing and hiding artwork 224

targeting items in 223

leading

auto 259

changing 259

legends, in graphs 386

letterforms, changing 267

levels of gray 338

Library Open command 140

Library Save As command 140

ligatures, using 283

Lighten mode 197

limit-check error 337, 341

line attributes. See stroke attributes

line breaking in CJK text 276

Line Color preference 296

line graph 375, 381

line graph tool 10

line screen 343

maximum 338

printer 358

line segments 67

line tool 7

line trap, creating 353

line weight. See stroke weight

linear gradients 201

Linear option (ink pen) 139

lines

See also paths

adding arrowheads 132

dashed 160

drawing 48, 50, 51, 54

selecting 98

trapping 353

wavy and Zig Zag 131

lines per inch (lpi) 27

Link Blocks command 270

linking 37

EPS or PDF files 36

images 37

objects 37

type blocks 270

type containers 269

Links command 38

Links palette 38, 39

liquify tools 125

Load Texture command 241

loading

bitmap images and textures 241

output settings 316

Locate Object command 221

Lock command 112

Lock Guides command 95

locking

masks 151

objects 112, 225

Log Errors to File option 371

lowercase and uppercase, changing 283

Luminosity mode 197

M
Mac OS X preferences file 20

Macintosh Drag Manager 105

magic wand tool 6, 98, 101

magnifying and reducing views 15

Make command (clipping mask) 150

Make Compound Shape command 142

Make Guides command 95

Make Riders command 343

Make Slice command 294

Make with Mesh command 123

Make with Top Object command 123

Make with Warp command 123

Make Wrap command 271

managed files

checking in and checking out 43

creating 44

opening 42
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uploading changes to 44

Manually option 38

Marker command 393

marquee 16, 98

masks 138

adding fill and stroke 151

creating 150

locking and unlocking 151

opacity 194

selecting 101

splitting 342

using outlined type as 267

Masks command 101

mathematical operations in text boxes 92

measure tool 11, 93

measuring using Info palette 12

memory and printing 341

Merge command 147

Merge Selected command 218

Merge Styles command 233

Merge Swatches option 165

mesh lines 202

mesh objects 202

mesh patches 203

mesh points 202

mesh tool 11, 203

meshes 123

adding color to 205

creating 202

envelope and 123

improving printing of 340

transforming and editing 204

Mezzotint command 245

Minus Back command 147

misregistration 348

missing fonts 268

mistakes, correcting 91

miter join 159

mixed symbol set 74

MM Design palette 256

modal controls, using with actions 368

models. See color models

modes. See color modes

Moji Gumi (Japanese layout rules) option 275

monitors

calibrating 188, 189

characterizing 189

profiles for 188

resolution 26

size 26

monospaced fonts, changing to proportional 
274

Mosaic Tiles command 247

mosaics, creating 247

Move command 104

Move option 106

moving

brushes 81

direction lines and points 51

moving objects 31, 103

with arrow keys 103

between Illustrator and Photoshop 103

between layers 109

with bounding box 99

by dragging and pasting 103

with free transform tool 104

to front or back 109

grouped 106, 109

with Smart Guides 97

specified distance and direction 104

while drawing 63

Multiply mode 196

N
named optimization settings 312, 313

Navigator palette 16

negative and positive film 361

Neon Glow command 242

New Action command 365

New Art Has Basic Appearance command 230

New Brush command 82, 85

New command 28

New Layer command 216

New Style command 233
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New Sublayer command 216

New Symbol button 71

New Symbol command 71

New View command 14

New Window command 14

None button 157

None swatch 160

Non-Global option 163

nonimageable area 28

nonprintable colors 170

nonrecordable actions 365

Non-Uniform Scaling option 116

non-Web-safe colors 170

Normal mode 196

Note Paper command 246

NTSC Colors command 247

numeric values for specifying colors 169

O
Object Highlighting option 96

Object Mosaic command 247

Object Mosaic filter 247

objects

converting to guide objects 95

converting to rectangles and ellipses 127

entering type in 252

masking 199

resetting bounding box 120

selecting and deselecting 97, 100, 101

Smart Guides and 97

wrapping type around 271

objects, creating 145

by combining paths 145

by combining shapes 141

by drawing shapes 62

by duplicating 99

holes in compound paths 145

knocking out shapes 199

by offsetting 107

objects, displaying 112

masking 149

showing and hiding center point 63, 64

objects, managing

deleting 107

grouping and ungrouping 110

locking and unlocking 112

removing brush attributes from 81

reordering 109

stacking order 109

objects, modifying 141

changing appearance with filters and effects 
126

reflecting 117

reshaping 60, 122

rotating 114

scaling 99, 116

shearing 119

smoothing 61

transforming 113, 120

twisting 129

objects, moving

aligning and distributing 106

between Illustrator and Photoshop 102, 103

with bounding box 99

by cutting and pasting 102

while drawing 63

with selection tool 99

by snapping 103

Ocean Ripple command 244

Offset option 360, 361

Offset Path command 107

OLE 105

online publishing, colors and 155

Online Settings preferencse 22

Only Web Colors option 169

opacity 191

changing 193

creating 191

selecting objects with same 101

Opacity and Mask Define Knockout Shape 
option 199

Opacity command 101

opacity masks

clipping 195

creating 194
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inverting 195

Open command 28, 33, 34, 36

Open from Workgroup command 42

open paths

joining brush 89

joining endpoints and paths 62

Open Recent Files command 34

opening

files 33

Illustrator files 31

palettes 4

OpenType fonts 267

Optimize to File Size option 307

optimizing

based on file size 307

named settings for 312

Options of Selected Object command 88

order. See Arrange command

Other Library command 88, 166

Outer Glow command 130

Outline command 15, 147

Outline Object command 267

Outline Others command 220

Outline Stroke command 148

Outline view 15, 220

outlining objects. See strokes

out-of-gamut colors 154, 158, 170

output options. See Document Setup 
command 29

output resolution 337

Output Settings dialog box

file saving options 318

HTML options 317

loading output settings 316

saving options 316

slice naming options 319

ovals, drawing. See ellipses, drawing

Overlay mode 196

Overprint Black command 347, 348

Overprint Black option 362

Overprint Fill option 347

Overprint Preview command 15, 347

overprinting

black 362

on composite proofs 333

options for 346

previewing 347

trapping by 352, 353, 354

P
page boundaries 30, 31

Page Setup dialog box 332

page size 29, 359

page tool 12, 31

paint

copying attributes of 170

setting attributes of 156

paint bucket tool 11, 170, 171

copying type with 263

using with a mesh 206

Paint Daubs command 243

Paint Style command 101

paintbrush tool 8, 79

adjusting path with 80

setting preferences for 80

painting order. See stacking order

painting type 263

Palette Knife command 243

palettes

using 4, 5

PANTONE color 167

paper stretch 351

Paragraph palette 256, 272

paragraphs

aligning type in 273

indenting 273

indenting first line of 273

Paste command 103

Paste in Back command 103, 109

Paste in Front command 103, 109

Paste Remembers Layers command 223

Paste Remembers Layers option 110

pasting artwork between layers 223

Patchwork command 247

path guides for text 271
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Path Simplify command 61

Pathfinder

commands, repeating last 141

effects 142

Layers palette and 223

Pathfinder buttons 142

Pathfinder palette 142

paths 47

anchor points in 47

artwork dropped in Photoshop as 105

closed 49, 51, 80

endpoints in 47

freeform 48

masking 149

recording 366

segments in 47

paths, drawing

closed paths with paintbrush tool 80

closed paths with pencil tool 49

closing paths 51, 53

connecting open paths 57

curved segments 52

extending paths 57

with pen tool 50

with pencil tool 48

paths, modifying

adjusting segments 56, 59

blending 135

erasing 50

with filters and effects 126

joining and splitting 61, 62, 89, 341, 342

with pencil tool 48

removing brushes from 81

with reshape tool 60

reversing 146

simplifying 61

smoothing 49

paths, using with type

changing objects to type paths 252

converting type to paths 267

deleting type paths 254

entering type on paths 253

fitting headline type across paths 280

path-type tool 7, 252, 253

pattern bounding box 206

Pattern brushes 79, 85

pattern tile 206

patterns 206, 207

creating brushes with 79

geometric 208

importing 166

irregular 209

modifying 212

moving 213

printing 344

tiling 213

transforming 213

PCX file format 329

PDF file format 323

PDF files

opening in Illustrator 33

placing 36

PDF Writer 334

Pen and Ink filters 137, 248

pen tool 6, 50

See also curves

adjusting paths with 56

measuring coordinates with 12

pencil tool 8, 48

See also freeform paths

adjusting paths with 49

setting preferences for 50

Perceptual color table 314

Perceptual palette, using with GIF 314

Perceptual rendering intent 184

performance, improving 242

Persistent command 167

Photo CD 32

Photo Crosshatch command 248

Photocopy command 246

Photoshop

compatible file formats 32

copying objects into Illustrator 102

dragging Illustrator files into 105, 106
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dragging objects into Illustrator 106

Photoshop file format 326

PICT file format 330

picture clipping 105

pie graph 375, 382

pie graph tool 11

PIXAR file format 32, 330

pixel dimensions 26, 313

Pixel Preview command 15, 293

Pixelate filters and effects 244

pixelation 27

pixels 26

pixels per inch (ppi) 26

pixels, resolution and 26

Place command 33, 36

Place Symbol Instance button 72

Place Symbol Instance command 72

Placement Options 39

placing

EPS or PDF files 36

images 17

text 268

Plaster command 246

Plastic Wrap command 243

Playback Options command 369

plug-ins 18, 239

Plug-ins Preferences command 18

PNG file format 330

PNG-8

Custom color table 314

selecting a color table 314

Web Snap slider 315

Web-safe color table 314

point of origin 113, 115

pointer

changing to cross hair 48

changing to precision pointer 4

Pointillize command 245

points

 See also anchor points

changing 58

for ruler 92

polar grid tool 7

polar grids 69, 70

polygon tool 8, 64

portrait (vertical) orientation 359

positive and negative film 361

positive image 361

Poster Edges command 243

PostScript Color Management option 334

PostScript file format 330

PostScript Printer description files. See PPD 
files

PPD files 357, 359

and page size 359

selecting 357

preference options

Constrain Angle 102, 108

Corner Radius 64

Disable Auto Add/Delete 57

Japanese Crop Marks 336

Keyboard Increment 103

Paste Remembers Layers 110

Plug-ins 18

Scale Strokes and Effects 117

Smart Guides 96

Transform Pattern Tiles 102

Use Area Select 100

Use Precise Cursors 48

preferences

general 21

grids and guides 95

hyphenation 281

paintbrush tool 80

pencil and smooth tools 50

ruler and type units 92, 262

scaling objects 115

transparency 193

undo levels 91

workgroup 45

Preferences command 20

Preserve menu 39

preset warp shape 123

Preview All Layers command 220

Preview command 15
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Preview view 220

previewing 15, 82

Print command 333

printable area. See tiling pages

printable colors 170

printer resolution 27

printer’s marks 356

printer’s quote marks 284

printing 332

embedded EPS images 37

file and error information 343, 344

gradients 337

making artwork nonprintable 225

memory and path splitting 341

options in Page Setup dialog box 332

patterns 344

PDF Writer support 334

tiling 30

transparent artwork 336

printing, color and grayscale

color blends 337

color management options 334

four-color 153

gradients as separations 346

grayscale printers 242

separations 362

process color icon 160

process colors 154, 155, 156

editing 163

printing 153

profiles 175

adding or updating 187

displaying in status bar 17

embedding in output 186

for JPEG optimization 310

for printing 334

guidelines for monitors 189

obtaining 187

reassigning 186

storage location 188

updating 188

Progressive option, for JPEG 310

Proof Colors command 185

Proof Setup commands 185

properties

line and arc segments 67

polar grids 70

rectangular grids 69

proportional spacing (Tsume) 274

Proportions (Fill) option 39

Proportions (Fit) option 39

PSD file format 326

publishing text symbols 283

Pucker & Bloat filter 127

pucker tool 9, 125

punctuation

hanging 273, 278

smart 283

PXR file format 330

Q
Quality option, for JPEG 309

Quit command 28

quotation marks

changing 283

Smart Quotes 284

R
radar graph tool 11

radar graphs 375, 382

Radial Blur command 243

radial gradients 201

Random option 106

Random option (ink pen) 139

rasterization during printing and saving 336

Rasterize command 238

rasterizing 105

settings for 239

vector graphics 237

rays, flares and 65

Rectangle command 127

rectangle tool 7, 62, 63

rectangles, drawing 63

centered 63
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squares 63, 64

rectangles, text 251, 270

rectangular grids 69

Redefine option 73

Redo command 91

Reduce to Basic Appearance command 230

Reflect command 118

Reflect option (ink pen) 139

reflecting objects 117

by specifying axis 118

with free transform tool 117

with reflect tool 8, 117

Registration color 160

registration marks 356

Relative Colorimetric rendering intent 184

Release command 144, 145, 146, 299

Release command (clipping mask) 150

Release Compound Shape command 144

Release Guides command 95

Release to Layers command 217

releasing compound paths 144, 145, 146

Remove Brush Strokes command 81

removing overlap. See Unite command

rendering intents 175, 184

Repeated Character Processing option 278

repeating last command 121, 141

Replace Link command 39

Replace Spine option 136

Replace Symbol button and option 73

Repopulate Views command 307

Reselect command 101, 164

Reset Actions command 373

Reset With Mesh command 123

Reset With Warp command 123

reshape tool 9, 60

reshaping objects and paths 60

resizing

See also scaling objects

palettes 5

resolution 26

of gradients 337

of path output 337

rasterization settings 336

specifying in separations 359

restoring files 91

resulting color, in blending modes 196

Reticulation command 246

Reverse Front to Back command 137

Reverse Order command 222

Reverse Spine command 136

Reverse Traps option 351, 352

reversing paths 146

Revert command 91

RGB

color mode, converting to 238, 239

color mode, selecting colors numerically in 
169, 170

color mode, selecting for new file 28

color model 152, 169

RGB icon 160

RGB startup file 161, 168

Riders file 342

right alignment 273

right reading 361

rings, flares and 65

Rotate command 114, 116

rotate tool 8, 114

rotating objects 114

with bounding box 114

with free transform tool 114

individually in a group 115

with rotate tool 114

by specifying angle 114

x and y axes 107

Rotation option (ink pen) 138

rotation, angle of 12, 108

Rough Pastels command 241, 243

Rough Pastels filter 241

Roughen filter 128

Round Corners filter 127

round joins, setting 160

Rounded Rectangle command 127

rounded rectangles, drawing 63

adjusting corners 63

centered 63
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rounded-rectangle tool 7, 62, 63

rounding corners 127

Rows & Columns command 270

rows in text

changing gutter size 271

changing height 271

rulers 91

changing units 92

ruler guides 94

ruler origin 93

showing and hiding 91

S
Same As Source option 334

Same Blending Mode command 101

Same Fill & Stroke command 101

Same Fill Color command 101, 164

Same Opacity command 101

Same Stroke Color command 164

Same Stroke Weight command 164

Same Style command 164

Saturate command 173

saturation 152

Saturation mode 197

Saturation rendering intent 184

Save commands 320

Save for Web command 305

saving

artwork in Adobe PDF format 323

artwork in EPS format 321

artwork in Illustrator format 320

artwork in SVG format 324

batch-processed files 370

and exporting artwork 320

optimized images 318

transparent artwork 336

Scale option (ink pen) 138

Scale Stroke Weight option 121

Scale Strokes and Effects option 117

scale tool 8, 116

scaling objects 99, 115

with bounding box 116

with free transform tool 116

individually in a group 117

with scale tool 116

setting preferences 115

specifying scale factors 116

scallop tool 9, 125

Scatter brushes 79

scatter graph 375, 382

scatter graph tool 10

scissors tool 11, 61, 89

scratch area 28

screen angle 343

screen frequency

choosing 343

image resolution and 27

Screen mode 196

Scribble and Tweak command 129

scripts 364

executing 374

installing 374

segments 47, 52

drawing 54

editing 59

selecting 98

Select Again command 164

Select All command 100

Select All Unused command 161

selecting

anchor points and segments 97, 98

artwork using Layers palette 221

brush strokes 101

masks 101

paths 97

same symbol instance 101

type 254

selecting objects 97

all objects 100

all unselected objects 101

entire objects or lines 98

filled objects 100

grouped objects 97, 110

multiple objects 100
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with same attributes 101

with same color, stroke weight, stroke color, 
opacity, or blending mode 98

selection marquee 98

selection tools 6, 59, 97, 110

selections

adding and removing 98

copying between applications 105

Selective color table 314

self-intersecting path 146

Send Backward command 109

Send to Back command 109

Send to Current Layer command 222

Separation Setup option 357

separations 345

color 332

controlling space between 361

converting spot colors to process colors 358

printing 362

problems with spot colors and transparent 
artwork 155

saving 362

setting options for 356

set, of symbol instances 73

Settings menu 312

settings, online 22

shade stepping 130

shadows. See drop shadows

Shape Modes buttons 142

shapes

converting to rectangles and ellipses 127

drawing circles 62

drawing ellipses 62

drawing polygons 64

drawing rectangles 62

drawing rounded rectangles 62

drawing spirals 68

drawing squares 62

drawing stars 64

reshaping 60

Sharpen filter and effect 245

shear tool 8, 119

shearing objects 119

by specifying angle and axis 119

with free transform tool 119

with shear tool 119

shortcuts, keyboard 19

Show Align command 106

Show All command 112

Show Artboard command 29

Show Bounding Box command 99

Show Center Point option 64

Show Color command 157

Show Grid command 95

Show Guides command 95

Show Hidden Characters command 255

Show Images in Outline option 18, 37

Show Info command 12

Show Magic Wand command 101

Show Options command 106

Show Page Tiling command 30

Show Rulers command 91, 94

Show Slice Numbers preference 296

Show Slices command 296

Show Stroke command 159

Show Tool Tips option 21

Show Transform command 121

showing

center point of objects 64

hidden characters 255

pointer or cross hair 48

simple path 142

Simplify command 61

Simulate Paper option 193

Single Full Page option 30, 93

single master fonts 255

Size command 258

size, measuring 12

Sketch filters and effects 245

skewing. See shearing objects

Slice command 149

slice select tool 11

slice tool 11

slices 293

compared to image maps 299
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creating 293

exporting to Photoshop 327

naming pattern, setting 319

preferences 296

saving in SVG format 325

working with 296

Smart Guides 96

choosing a point 96

creating, moving, and transforming objects 
97

preferences for 96

turning on and off 96

working with 97

Smart Guides command 96

Smart Punctuation command 283

Smart Quotes option 284

Smart Spaces option 284

Smooth Color option, in blends 135

smooth points 47, 58

smooth tool 8, 50

smoothing paths or strokes 49, 61

Smudge Stick command 243

Snap to Grid command 95

Snap to Pixel command 293

Snap to Point command 103

Snapping Tolerance option 96

Soft Light mode 196

Soft Mix effect 172

softening edges 131

soft-proofing colors 185

Sort by Kind command 40

Sort by Names command 40

Sort by Status command 40

space between objects 106

Spatter command 244

Specified Distance option 135

Specified Steps option 135

spelling, checking 281

spiral tool 7, 68

Split Long Paths option 341

splitting paths

with filled and stroked objects 341

to print complex shapes 341

with scissors tool 61, 89

splitting. See Release command

Sponge command 243

spot color icon 160

spot colors 155, 156

and blended objects 133

editing swatches 163

problems exporting with overlapping 
transparent artwork 155

Spot Function Template file 343

Sprayed Strokes command 244

spread trap 349

squares, drawing 63, 64

stacked bar graph tool 10

stacked bar graphs 375, 381

stacked column graph tool 10

stacked column graphs 375, 381

stacked objects

grouping 111

moving forward or backward 109

stacking order 109, 222

Stained Glass command 247

Stamp command 246

standard screen mode 13

star targets 356

star tool 8, 64

startup files 161, 168

creating 388

creating customized 168

status bar 17

straight lines, drawing 51

Stray Points command 101

stray points, selecting 101

stroke attributes

See also Stroke palette

Bevel Join 160

Dashed Lines 160

Miter Join 159

Round Join 160

setting

Stroke Weight 159

Stroke button 157

stroke color, selecting by same 101
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Stroke palette

See also stroke attributes

displaying 159

using 159

stroke weight

preserving while scaling objects 117

selecting by same 101

setting 159

Stroke Weight command 101

strokes

adding to masks 151

adjusting with paintbrush tool 80

adjusting with pencil tool 49

applying effects to 236

converting to filled objects 148

erasing 50

setting attributes for 159

smoothing 49

Style option 95

styles 228

applying 231

applying to symbol instances 78

creating 232

deleting 234

importing 234

Layers palette and 223

modifying 232

selecting objects with same 101

style libraries 234

unlinking 234

Styles palette 231

Stylize filter and effect 246

Subdivisions option 95

sublayers

creating 216

subscripts and superscripts 261

subtractive colors 153

Sumi-e command 244

SVG file format 300

adding interactivity to artwork 302

and SVGZ file format 324

filter effects and 301

Illustrator and 301

optimization options for 311

scripting for 302

SVG Interactivity palette 302

swatch libraries

creating persistent palettes 167

loading colors from other files 166

moving swatches to Swatches palette 166

selecting by color system number 167

swatches 156

displaying 161

loading into Illustrator 166

merging 165

modifying 162

sorting 161

Swatches palette 160, 165

SWF file format

creating graphics in 304

exporting in 327

symbol instance sets 73

adding to 75

creating 75

deleting from 76

symbol instances 73

adding 75

adjusting color and transparency 77, 78

adjusting size and density 76

applying styles to 78

changing stacking order 76

duplicating 72

expanding 76

modifying and redefining 73

placing 72

rotating 77

selecting same 101

symbol screener tool 10, 78

symbol scruncher tool 9, 76

symbol shifter tool 9, 76

symbol sizer tool 10, 76

symbol spinner tool 10, 77

symbol sprayer tool 9, 75

symbol stainer tool 10, 77
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symbol styler tool 10, 78

symbolism tools 73

symbols 71

creating 71

duplicating 72

modifying 73

redefining 73

selecting 72

SVG and 301

Symbols palette 71

Symmetric option (ink pen) 139

T
Tab Ruler palette 279

tabs, setting 279

targeting layers 223

text

capitalization of 283

editing 281

exporting 268

finding and replacing 282

hyphenating 280

importing 268

orientation of 265

overflow 269

replacing symbols 283

selecting 254

text boxes, mathematical operations in 92

text columns, changing width of 271

Text Label Hints option 96

Text Objects command 101

text objects, selecting 101

Text Orientation command 266

Texture filters and effects 241, 246

Texturizer command 247

Thickness option (ink pen) 138

thumbnails

in EPS file 322

in PDF file 323

tick marks, in graphs 384

TIFF file format 331

Tile command 14

Tile Full Pages option 30, 93

Tile Imageable Areas option 30

tiling pages 29

time and date, displaying current 17

Tint Reduction value 351

tints

creating and changing globally 163

displaying names 12

tips for using brushes 87, 89

tolerances, for tools 50

toolbox 4

tools

See also individual tool names

changing pointer to cross hair 48

keyboard shortcuts for 19

setting preferences for 50, 80

Tools command 4

Torn Edges command 246

Toyo colors 167

tracing artwork 89

tracking, changing 260

Transform Again command 121

Transform Both command 122

Transform Each command 106, 115, 117

Transform Object Only command 121

Transform palette 121

See also aligning objects

Transform Pattern Only command 121

Transform Pattern Tiles option 102, 214

Transform Tools option 96, 97

transformation tools 113

transforming objects 99, 113

distorting 120

reflecting 117

repeating transformations 121

resetting bounding box 120

rotating 114

scaling 115

shearing 119

transforming type 264

Transforms option 39

transparency 191
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changing 192, 193

creating knockouts 198

exporting in Flash format 304

printing 192, 336, 337

saving 321, 322, 336

setting preferences and values 193

SVG and 301

symbol instances 78

targeting layers 193

using grouped objects 191

transparency grid 192

Transparency palette 192

transposing data in graphs 380

Transverse option 360

Trap command 351

trapping 348

compensating for paper stretch 351

creating traps 348

horizontal and vertical trap values 351

by overprinting 352

reverse traps 352

with similar color densities 351

with tints 350

type 350

Traps with Process Color option 352

Trim command 147

Trim Marks filter 335, 355

TrueType fonts 267

TRUMATCH colors 167

Tsume (proportional spacing) option 274

twirl tool 9, 125

Twist command 129

twist tool 8, 129

twisting objects 129

type 250

area type 250

as a graphic object 267

as a mask 267

hinting in outline fonts 267

horizontal and vertical 250

selecting 254, 255

trapping 350

vector graphics and 25

Type & Auto Tracing command 262

Type 1 fonts 255, 267

type in columns and objects 268

changing column layout 271

creating rows and columns 270

entering 251

linking and unlinking blocks and containers 
268, 269, 270

wrapping around graphic objects 271

entering 252

type paths

creating 250, 252

deleting 254

entering type on 253

moving type along 253

selecting 264

type tools 6, 250

type, entering

anywhere in work area 250

on horizontal or vertical paths 252, 253

in objects 252

in rectangles 251

at specific point 250

typing text in file 250

type, managing

changing type units 262

displaying and hiding hidden characters 
255

displaying palettes and options 256, 272

exporting to Photoshop 327

greeking 272

type, modifying

changing to ligatures 283

finding and replacing fonts 258

painting 263

transforming 264

using alternative characters 284

using Expert Fractions option 284

type, paragraph layout

aligning 273

headline fitting 280

indenting first line 273
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indenting paragraphs 273

justifying 273

setting paragraph attributes 272

setting tabs 279

using Tab Ruler palette 279

type, punctuation and spaces in

discretionary hyphens 280

ellipses 284

em spaces 260

en and em dashes 284

hanging punctuation 273

hyphens 280

smart punctuation 283

Smart Quotes 284

Smart Spaces 284

type, setting attributes 256

baseline shift 261

copying attributes 263

fonts 257

kerning 260

leading 259

size 258

spacing 274

styles 257

subscript and superscript 261

tracking 260

U
Underpainting command 243

Undo command 91

undo levels 91

Ungroup command 110

ungrouping objects 110

unit of measure 92

allowed 92

converting 92

Unite button 342

Units option 92

units, type 258, 262

Unlink Blocks command 270

Unlock All command 112

unlocking

masks 151

objects 112

unnamed colors 156

Unsharp Mask command 245

Unshift All Colors command 315

Update Link command 39

updating links 37

Upload to Server command 44

uppercase and lowercase, changing 283

URL, assigning to object 299

Use Area Select option 100, 102

Use Page Setup option 29

Use Precise Cursors option 4, 48

Use Preview Bounds option 122

Use Print Setup option 29

V
variable pen. See Calligraphic brushes

variables, saving in SVG format 291, 325

vector graphics 25, 237

vectors 25

vertical area-type tool 7

vertical path-type tool 7

vertical scale, adjusting 261

vertical type

entering along path 252

entering at specific point 250

entering in objects 252

vertical type tool 7

Video filters and effects 247

view

actual size 16

enlarging 15

moving 14

reducing 15

setting up 13

View Artboard Only command 16

view box 17

viewing 13

artwork in color or as paths 15

entire document 16

overprinting of colors 15



Using Help | Contents | Index Back 431  

Adobe Illustrator Help Index 

Using Help | Contents | Index Back 431  

A  B  C  D  E  F  G  H   I   J  K  L  M  N  O  P  Q  R  S  T  U  V  W  X  Y  Z

placed images 17

W
Wari-Chu (divided note) option 266

warp shape, envelopes and 123

warp tool 9, 125

Water Paper command 246

Watercolor command 243

wavy lines, creating 131

web graph 375

Web graphics

designing 292

GoLive integration 317

Web Shift button 315

Web Shift/Unshift Selected Colors command 
315

Web site for Adobe 22

Web Snap slider 315

WebDAV servers, about 41

Web-safe colors

recognizing non-Web-safe colors 170

RGB 158

table of 314

Web-shifted colors 315

windows

arranging multiple 14

opening new 14

setting up 13

workflow management

checking files in and out 43

downloading managed files 42

uploading changes 44

workgroup management 41

adding files to 44

preferences for 45

working spaces

defined 178

specifying 180

wrapping type 271

wrinkle tool 9, 125

X
x and y axes, rotating and constraining 107

x and y coordinates, measuring 12

Z
zero origin, specifying 93

Zig Zag filter 131

Zoom commands 15

zoom tool 12, 15
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